Subject: Re: [Idr] WG adoption of draft-farrel-idr-bgp-ls-registry-02.txt

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 1 Nov 2019 22:16:43 -0000

Hello chairs, WG,

I may have taken my eye off the IDR list for a while, but it seems to me that my draft is languishing.

Did the WG last call complete? Did we decide to adopt or discard?

Thanks,

Adrian

From: Susan Hares <[email-masked]> 
Sent: 09 August 2019 16:15
To: [email-masked]; 'Ketan Talaulikar (ketant)' <[email-masked]>; 'John Scudder' <jgs=[email-masked]>
Cc: [email-masked]
Subject: RE: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Adrian and WG: 

<WG chair hat on> 

Ketan and his co-authors have been carefully working RFC7752bis 

prior to adopting in the WG.  However, given the comments to the list – 

I would like to make sure the WG is not rushed to address all known 

Issues in RFC752. 

We can usually send through registry drafts quickly. 

The WG can progress both drafts in parallel. 

<Chair hat off> 

<wg member hat on>  

I suggest we put both drafts as one of our 

Key milestones for IDR. 

<wg member hat off> 

Cheers, Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, August 8, 2019 7:50 AM
To: 'Ketan Talaulikar (ketant)'; 'John Scudder'
Cc: [email-masked] <mailto:[email-masked]> ; 'Hares Susan'
Subject: Re: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Hi Ketan,

Yes.

We’re assuming that 7752bis will take a while to progress through the working group (I might be wrong) while we could advance draft-farrel-idr-bgp-ls-registry pretty fast.

If I’m wrong we should simply roll my draft into 7752bis and be done.

If I’m right:

*        My draft runs to completion

*        7752bis needs to obsolete 7752 and the RFC that my draft will become, and the IANA section has to be updated to reflect what the registry will say at that time.

Best,

Adrian

From: Ketan Talaulikar (ketant) <[email-masked] <mailto:[email-masked]> > 
Sent: 08 August 2019 11:47
To: John Scudder <jgs=[email-masked] <mailto:jgs=[email-masked]> >; Adrian Farrel <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]> ; Hares Susan <[email-masked] <mailto:[email-masked]> >
Subject: RE: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Hi All,

I obviously support this “easing of process overhead” for BGP-LS code point allocations. Apologies for not responding earlier.

Adrian, can you please also let know if the same text needs to be also updated in draft-ketant-idr-rfc7752bis which is also up for WG adoption and would result in obsoleting RFC7752?

Thanks,

Ketan

From: Idr <[email-masked] <mailto:[email-masked]> > On Behalf Of John Scudder
Sent: 06 August 2019 02:57
To: Adrian Farrel <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]> ; Hares Susan <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Well obviously I (with my “working group member” rubber mask and fright wig) kind of want them but I was holding off on saying so because that's kind of obvious.  

To reiterate for others’ benefit why I think this is worthwhile vs. early allocation:

- It reflects the author’s original intent, for whatever that’s worth. (The WG’s current intent is more important.)

- It provides the minimum of red tape, less even than early allocation.

- Because the number space is large, resolving the tension between red tape and the risk of something silly being allocated in favor of permissiveness is OK.

- Let’s not forget there’s still at least two humans in the loop (the Designated Expert and IANA).

That said, if the WG can’t generate enough enthusiasm to say “yes please” then I won’t cry, although I also won’t (with “WG co-chair” spangled epaulets and cravat on) feel as sympathetic next time someone tells me it’s too hard to get a code point.

—John

On Aug 5, 2019, at 11:28 AM, Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Hi WG,

I just want to rattle the bars of the cage a bit, here.

John (reliably) informs me that he had a number of conversations about the BGP-LS registries and their allocation policies: people (it seems) wanted more-relaxed rules.

It is possible that the advocates are the authors of the set of drafts that have just been pushed forward for “early allocation” and so no one cares any more.

Or it is possible that everyone is too busy.

Or, perhaps, no one wants these changes.

Thanks,

Adrian

From: Idr < <mailto:[email-masked]> [email-masked]> On Behalf Of Susan Hares
Sent: 27 July 2019 01:37
To:  <mailto:[email-masked]> [email-masked]
Subject: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

This begins a 2 week WG adoption call for draft-farrel-idr-bgp-ls-registry-02.txt.

Let the discussion begin and in midst of your comments please remember to include "support" or "no support".

Adrian enjoy the discussion.

Cheerily  Sue

Sent via the Samsung Galaxy S7 edge, an AT&T 4G LTE smartphone

_______________________________________________
Idr mailing list
 <mailto:[email-masked]> [email-masked]
 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_idr&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=m2Z21XyyBWfE7-JRpCBMd9mW5AU5UenqFDS0r2Wjmi0&s=n3RyYdF5g5JgzuEcUrayd07c_83FTSigaOWGlLpIku0&e=> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_idr&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=m2Z21XyyBWfE7-JRpCBMd9mW5AU5UenqFDS0r2Wjmi0&s=n3RyYdF5g5JgzuEcUrayd07c_83FTSigaOWGlLpIku0&e=

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 1 Nov 2019 19:16:06 -0400

Adrian: 

This one dropped through an open gap in the IDR calls.   I got a medium amount of response for adoption.   I will start a call indicating the chairs intend to adopt later this evening.   Please plan to attend IDR for first session. 

Thanks! 

Sue 

From: Adrian Farrel [mailto:[email-masked]] 
Sent: Friday, November 1, 2019 6:17 PM
To: 'Susan Hares'; 'John Scudder'
Cc: [email-masked]
Subject: RE: [Idr] WG adoption of draft-farrel-idr-bgp-ls-registry-02.txt

Hello chairs, WG,

Thanks,

Adrian

Adrian and WG: 

<WG chair hat on> 

Issues in RFC752. 

<Chair hat off> 

<wg member hat on>  

Key milestones for IDR. 

<wg member hat off> 

Cheers, Sue 

Cc: [email-masked]; 'Hares Susan'

Hi Ketan,

Yes.

If I’m right:

·        My draft runs to completion

·        7752bis needs to obsolete 7752 and the RFC that my draft will become, and the IANA section has to be updated to reflect what the registry will say at that time.

Best,

Adrian

From: Ketan Talaulikar (ketant) <[email-masked]> 
Sent: 08 August 2019 11:47
To: John Scudder <jgs=[email-masked]>; Adrian Farrel <[email-masked]>
Cc: [email-masked]; Hares Susan <[email-masked]>
Subject: RE: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Hi All,

Thanks,

Ketan

From: Idr <[email-masked]> On Behalf Of John Scudder
Sent: 06 August 2019 02:57
To: Adrian Farrel <[email-masked]>
Cc: [email-masked]; Hares Susan <[email-masked]>
Subject: Re: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

—John

On Aug 5, 2019, at 11:28 AM, Adrian Farrel <[email-masked]> wrote:

Hi WG,

Thanks,

Adrian

 

Cheerily  Sue

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 1 Nov 2019 23:50:43 +0000

FWIW – I support adoption…
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Friday, November 1, 2019 at 7:16 PM
To: Adrian Farrel <[email-masked]>, 'John Scudder' <jgs=[email-masked]>
Cc: IDR List <[email-masked]>
Subject: Re: [Idr] WG adoption of draft-farrel-idr-bgp-ls-registry-02.txt

Adrian:

Thanks!

Sue

Hello chairs, WG,

Thanks,
Adrian

Adrian and WG:

<WG chair hat on>

<wg member hat on>

Cheers, Sue

Cc: [email-masked]<mailto:[email-masked]>; 'Hares Susan'

Hi Ketan,

Yes.

If I’m right:
•        My draft runs to completion
•        7752bis needs to obsolete 7752 and the RFC that my draft will become, and the IANA section has to be updated to reflect what the registry will say at that time.

Best,
Adrian

From: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>
Sent: 08 August 2019 11:47
To: John Scudder <jgs=[email-masked]<mailto:jgs=[email-masked]>>; Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Hares Susan <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Hi All,

Thanks,
Ketan

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of John Scudder
Sent: 06 August 2019 02:57
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Hares Susan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

—John

On Aug 5, 2019, at 11:28 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

Hi WG,

Thanks,
Adrian

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Susan Hares
Sent: 27 July 2019 01:37
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Cheerily  Sue

Sent via the Samsung Galaxy S7 edge, an AT&T 4G LTE smartphone
_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_idr&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=m2Z21XyyBWfE7-JRpCBMd9mW5AU5UenqFDS0r2Wjmi0&s=n3RyYdF5g5JgzuEcUrayd07c_83FTSigaOWGlLpIku0&e=

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sat, 2 Nov 2019 06:09:44 +0000

+1 (and I had indicated the same during the adoption call as well)

From: Idr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: 02 November 2019 05:21
To: Susan Hares <[email-masked]>; [email-masked]; 'John Scudder' <jgs=[email-masked]>
Cc: [email-masked]
Subject: Re: [Idr] WG adoption of draft-farrel-idr-bgp-ls-registry-02.txt

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Friday, November 1, 2019 at 7:16 PM
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>, 'John Scudder' <jgs=[email-masked]<mailto:jgs=[email-masked]>>
Cc: IDR List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] WG adoption of draft-farrel-idr-bgp-ls-registry-02.txt

Adrian:

Thanks!

Sue

Cc: [email-masked]<mailto:[email-masked]>

Hello chairs, WG,

Thanks,
Adrian

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Sent: 09 August 2019 16:15
To: [email-masked]<mailto:[email-masked]>; 'Ketan Talaulikar (ketant)' <[email-masked]<mailto:[email-masked]>>; 'John Scudder' <jgs=[email-masked]<mailto:jgs=[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Idr] WG adoption of draft-farrell-idr-bgp-ls-registry-02.txt

Adrian and WG:

<WG chair hat on>

<wg member hat on>

Cheers, Sue

Hi Ketan,

Yes.

If I’m right:

Best,
Adrian

Hi All,

Thanks,
Ketan

—John

Hi WG,

Thanks,
Adrian

Cheerily  Sue

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 2 Nov 2019 13:47:51 +0100

Not sure if I reacted back then, I support the adoption.

Regards,
Jeff

> On Nov 1, 2019, at 23:17, Adrian Farrel <[email-masked]> wrote:
> 
> 
> Hello chairs, WG,
>  
> From: Idr <[email-masked]> On Behalf Of Susan Hares
> Sent: 27 July 2019 01:37
> To: [email-masked]
> [email-masked]
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr