Subject: [Idr] draft-ietf-idr-tunnel-encaps

From: <[email-masked]>
Date: Tue, 26 Nov 2019 15:38:00 +0000

Hi authors,
Cc'ing John and Alvaro as the document has left IDR WG.

TL;DR: I think that you should remove "an "IPv6 SID (Segment Identifier)" TLV,"

https://tools.ietf.org/html/draft-ietf-idr-tunnel-encaps-14#section-3.7 says:

   [I-D.ietf-idr-bgp-prefix-sid] defines a BGP Path attribute known as
   the "Prefix-SID Attribute".  This attribute is defined to contain a
   sequence of one or more TLVs, where each TLV is either a "Label-
   Index" TLV, an "IPv6 SID (Segment Identifier)" TLV, or an "Originator
   SRGB (Source Routing Global Block)" TLV.

Actually latest version of [I-D.ietf-idr-bgp-prefix-sid] has removed the support for "IPv6 SID (Segment Identifier)" TLV

The value 2 previously corresponded to the IPv6 SID TLV which was

   specified in previous versions of this document.  It was removed and

   usage of the BGP Prefix-SID for Segment Routing over the IPv6

   dataplane [I-D.ietf-spring-segment-routing<https://tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27#ref-I-D.ietf-spring-segment-routing>] has been deferred to

   future specifications.
https://tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27#section-7

Best regards,
--Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 26 Nov 2019 11:06:54 -0500

On November 26, 2019 at 10:38:01 AM, [email-masked] wrote:

Hi!

> Cc’ing John and Alvaro as the document has left IDR WG.

I haven't reached this document yet, so any changes are ok as long as there is WG consensus.  John (as Chair and Shepherd) can take care of that.

> TL;DR: I think that you should remove “an "IPv6 SID (Segment Identifier)" 
> TLV,”

FWIW, the proposal makes sense to me.

Thanks for catching that early. :-)

Alvaro.

---

From: John Scudder <[email-masked]>
Date: Tue, 26 Nov 2019 16:13:54 +0000

So we would remove Section 3.7 plus the few references to it elsewhere in the document? That seems fine, thanks for catching this. We also get to eliminate a normative reference dependency. :-)

IDR WG, if anyone has an objection, please raise it — but it seems like an open-and-shut case.

Thanks,

—John

On Nov 26, 2019, at 10:38 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi authors,

TL;DR: I think that you should remove “an "IPv6 SID (Segment Identifier)" TLV,”

https://tools.ietf.org/html/draft-ietf-idr-tunnel-encaps-14#section-3.7<https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-idr-tunnel-encaps-14*section-3.7__;Iw!8WoA6RjC81c!VsJ456XB1LS-76ORABaTDwi2kEMtkvSglVu1GBspWDKTjkG7UKKk9Dn1oAQ_sg$> says:

   dataplane [I-D.ietf-spring-segment-routing<https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27*ref-I-D.ietf-spring-segment-routing__;Iw!8WoA6RjC81c!VsJ456XB1LS-76ORABaTDwi2kEMtkvSglVu1GBspWDKTjkG7UKKk9DkVu8hmCg$>] has been deferred to

   future specifications.

https://tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27#section-7<https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27*section-7__;Iw!8WoA6RjC81c!VsJ456XB1LS-76ORABaTDwi2kEMtkvSglVu1GBspWDKTjkG7UKKk9DlPf85KuQ$>

Best regards,
--Bruno

---

From: <[email-masked]>
Date: Tue, 26 Nov 2019 16:30:16 +0000

I was trying to suggest a smaller change, more specifically the following change:

OLD : each TLV is either a "Label-
   Index" TLV, an "IPv6 SID (Segment Identifier)" TLV, or an "Originator
   SRGB (Source Routing Global Block)" TLV.

NEW: each TLV is either a "Label-
   Index" TLV, or an "Originator
   SRGB (Source Routing Global Block)" TLV.

I could not find other reference to SRv6 SID or dependency on SRv6 so that simple change looks a priori safe.

However I have not re-read the whole draft, so I’m just raising the issue for the authors to fix.

Thanks,
--Bruno

From: John Scudder [mailto:[email-masked]]
Sent: Tuesday, November 26, 2019 5:14 PM
To: DECRAENE Bruno TGI/OLN
Cc: [email-masked]; idr wg; Alvaro Retana
Subject: Re: draft-ietf-idr-tunnel-encaps

Thanks,

—John

Hi authors,

https://tools.ietf.org/html/draft-ietf-idr-tunnel-encaps-14#section-3.7<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-idr-tunnel-encaps-14*section-3.7__;Iw!8WoA6RjC81c!VsJ456XB1LS-76ORABaTDwi2kEMtkvSglVu1GBspWDKTjkG7UKKk9Dn1oAQ_sg$> says:

   dataplane [I-D.ietf-spring-segment-routing<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27*ref-I-D.ietf-spring-segment-routing__;Iw!8WoA6RjC81c!VsJ456XB1LS-76ORABaTDwi2kEMtkvSglVu1GBspWDKTjkG7UKKk9DkVu8hmCg$>] has been deferred to

   future specifications.
https://tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27#section-7<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-ietf-idr-bgp-prefix-sid-27*section-7__;Iw!8WoA6RjC81c!VsJ456XB1LS-76ORABaTDwi2kEMtkvSglVu1GBspWDKTjkG7UKKk9DlPf85KuQ$>

Best regards,
--Bruno

---

From: John Scudder <[email-masked]>
Date: Tue, 26 Nov 2019 18:56:05 +0000

Got it, thanks.

On Nov 26, 2019, at 11:30 AM, [email-masked]<mailto:[email-masked]> wrote:

I defer to the authors to reply further.

Thanks,

—John

---

From: Keyur Patel <[email-masked]>
Date: Tue, 26 Nov 2019 23:41:44 +0000

Good catch.  Will remove the text and send out an updated version if there are no further comments/objections from the wg.

Regards,
Keyur

On Nov 26, 2019, at 8:14 AM, John Scudder <[email-masked]> wrote:

Thanks,

—John

Hi authors,

   future specifications.

Best regards,
--Bruno