Subject: [Idr] draft-chan-idr-bgp-lu2-00.txt

From: Robert Raszuk <[email-masked]>
Date: Mon, 4 Nov 2019 18:30:01 +0100

Hi Louis,

Can you elaborate on the intended meaning of encoding a VPN label in your
draft as part of the transport encoding ?

           The following is an example

           PE1----ABR1-----ABR2-----PE2

           PE1 will send the following labels with a color 100 path

           [2001 13001 801 16], where

           2001 - SR label to reach ABR1

           13001 - Binding-SID label to reach ABR2. Underlying tunnel
type is RSVP-TE

           801 - Binding-SID label to reach PE2. Underlying tunnel type is SR-TE
*           16 - a VPN label*

*           ^^^^^^^^^^^^^^^^*

Many thx,

Robert.

---

From: Louis Chan <[email-masked]>
Date: Sat, 9 Nov 2019 05:19:18 +0000

Hi,

I will attend IETF meeting in Singapore.
Would I be granted a chance to present on the proposed draft?
If yes, which date and time slot should I expect?

Rgds
Louis

From: Robert Raszuk <[email-masked]>
Sent: Tuesday, November 5, 2019 2:55 AM
To: Louis Chan <[email-masked]>
Cc: idr@ietf. org <[email-masked]>
Subject: Re: draft-chan-idr-bgp-lu2-00.txt

Louis,

My point is that VPN label should never be carried in BGP-LU - it does not belong there in transport layer.

It is fine to carry a color for it and do the mapping at PEs or ASBRs option B, but not the value.

Thx,
R.

On Mon, Nov 4, 2019 at 7:46 PM Louis Chan <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert,

The VPN label is just an example for the service. Here it might be a L3VPN.
Subsequent session of the draft indicates there would be a mapping between a VPN service prefix and the transport tunnel (i.e. label stack) via color.

/Louis

From: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, November 5, 2019 1:30 AM
To: Louis Chan <[email-masked]<mailto:[email-masked]>>
Cc: idr@ietf. org <[email-masked]<mailto:[email-masked]>>
Subject: draft-chan-idr-bgp-lu2-00.txt

Hi Louis,

Can you elaborate on the intended meaning of encoding a VPN label in your draft as part of the transport encoding ?

           13001 - Binding-SID label to reach ABR2. Underlying tunnel type is RSVP-TE

           16 - a VPN label

           ^^^^^^^^^^^^^^^^

Many thx,

Robert.