Subject: [Idr] BGP autodiscovery design team

From: John Scudder <[email-masked]>
Date: Wed, 4 Dec 2019 19:33:12 +0000

Hi All,

I realized this morning that although we announced in the last meeting that we’re forming this design team, we never announced it on the list. This is to correct that mistake. Here’s the text of the slide we presented at the meeting (https://datatracker.ietf.org/meeting/106/materials/slides-106-idr-sessa-auto-discovery-design-team-chairs-00):

---
Autodiscovery

• Clear interest in WG to work on this topic.
• No clear consensus on a specific approach.
• Proposals (four of them) progressively closer semantically, seems likely convergence can happen. 
• But, important differences remain.
	• At least: transport (L2, L3), liveness, security, maybe multihop.
• Chairs propose to charter a design team to close on a single proposal, by next meeting.
	• Might build on one of the existing drafts, might be a new draft, up to the design team.
	• Emphasis on pragmatism, OK to limit applicability (for example, to a single administrative domain). 
• Questions? Comments? Volunteers?
—

We are in the process of forming the team and hope to announce it soon. We have many good volunteers already but if you didn’t know and do want to volunteer, please contact Sue and me. 

Note that the design team will not make any binding decisions: as with all WG work, the WG has the final word, so any output of the DT will serve as input to the WG as a whole. (So even if you aren’t part of the DT, that doesn’t mean you won’t have a chance to be part of the process.)

Thanks,

—John

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 4 Dec 2019 12:42:39 -0800

John,

Thanks for sending out!
Count me in as a volunteer

Cheers,
Jeff
On Dec 4, 2019, 11:33 AM -0800, John Scudder <jgs=[email-masked]>, wrote:
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 4 Dec 2019 20:45:38 +0000

I volunteer as well.
Acee

From: Idr <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Date: Wednesday, December 4, 2019 at 3:43 PM
To: IDR List <[email-masked]>, John Scudder <jgs=[email-masked]>
Subject: Re: [Idr] BGP autodiscovery design team

John,

Thanks for sending out!

Cheers,
Jeff

Hi All,

---
Autodiscovery

Thanks,

—John

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 4 Dec 2019 21:54:02 +0100

Hi John,

When this was announced I asked if this design team scope is to work on
discovering your BGP peers in DC space or also in WAN and IX environments.

As you know I have been focusing on the latter for a number of years and I
can share that discovering p2p eBGP peers requires a very different
solutions as compared with discovering your iBGP peers or IX members.

So please kindly clarify the scope of this effort here.

Just stating BGP autodiscovery IMHO is too broad at this point. Likewise
working on the DC space and declaring we are done with BGP autodiscovery
all together would not be in the best interest of the protocol.

I suggest that this effort be called BGP DC or p2p autodiscovery.

Many thx,
Robert.

On Wed, Dec 4, 2019 at 8:33 PM John Scudder <jgs=
[email-masked]> wrote:

> Hi All,
>
> I realized this morning that although we announced in the last meeting
> that we’re forming this design team, we never announced it on the list.
> This is to correct that mistake. Here’s the text of the slide we presented
> at the meeting (
> https://datatracker.ietf.org/meeting/106/materials/slides-106-idr-sessa-auto-discovery-design-team-chairs-00
> ):
>
> ---
> Autodiscovery
>
> We are in the process of forming the team and hope to announce it soon. We
> have many good volunteers already but if you didn’t know and do want to
> volunteer, please contact Sue and me.
>
> Note that the design team will not make any binding decisions: as with all
> WG work, the WG has the final word, so any output of the DT will serve as
> input to the WG as a whole. (So even if you aren’t part of the DT, that
> doesn’t mean you won’t have a chance to be part of the process.)
>
> Thanks,
>
> —John

---

From: Keyur Patel <[email-masked]>
Date: Wed, 4 Dec 2019 21:06:50 +0000

+1. I will volunteer as well.

Regards,
Keyur

From: Idr <[email-masked]> on behalf of "Acee Lindem (acee)" <[email-masked]>
Date: Wednesday, December 4, 2019 at 12:46 PM
To: Jeff Tantsura <[email-masked]>, idr wg <[email-masked]>, John Scudder <jgs=[email-masked]>
Subject: Re: [Idr] BGP autodiscovery design team

I volunteer as well.
Acee

John,

Thanks for sending out!

Cheers,
Jeff

Hi All,

---
Autodiscovery

Thanks,

—John

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 5 Dec 2019 03:26:00 +0000

Hi John, 

I'd like to volunteer as well. Thanks.

Best regards,
Jie

> -----Original Message-----
> From: Idr [mailto:[email-masked]] On Behalf Of John Scudder
> Sent: Thursday, December 5, 2019 3:33 AM
> To: idr wg <[email-masked]>
> Subject: [Idr] BGP autodiscovery design team
> 
> Hi All,
> 
> I realized this morning that although we announced in the last meeting that
> we’re forming this design team, we never announced it on the list. This is to
> correct that mistake. Here’s the text of the slide we presented at the meeting
> (https://datatracker.ietf.org/meeting/106/materials/slides-106-idr-sessa-auto-
> discovery-design-team-chairs-00):
> 
> ---
> Autodiscovery
> 
> Note that the design team will not make any binding decisions: as with all WG
> work, the WG has the final word, so any output of the DT will serve as input to
> the WG as a whole. (So even if you aren’t part of the DT, that doesn’t mean
> you won’t have a chance to be part of the process.)
> 
> Thanks,
> 
> —John

---

From: "Liubing (Remy)" <[email-masked]>
Date: Thu, 5 Dec 2019 03:37:11 +0000

Please count me in as a volunteer.

Best regards.
Remy

> Sent: Thursday, December 05, 2019 3:33 AM
> correct that mistake. Here’s the text of the slide we presented at the
> meeting (https://datatracker.ietf.org/meeting/106/materials/slides-106-idr-
> sessa-auto-discovery-design-team-chairs-00):
> 
> ---
> Autodiscovery
> 
> We are in the process of forming the team and hope to announce it soon.
> We have many good volunteers already but if you didn’t know and do want
> to volunteer, please contact Sue and me.
> 
> work, the WG has the final word, so any output of the DT will serve as input
> to the WG as a whole. (So even if you aren’t part of the DT, that doesn’t
> mean you won’t have a chance to be part of the process.)
> 
> Thanks,
> 
> —John

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 5 Dec 2019 03:42:45 +0000

Linda Dunbar

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of John Scudder
Sent: Wednesday, December 04, 2019 1:33 PM
To: idr wg <[email-masked]>
Subject: [Idr] BGP autodiscovery design team

Hi All,

I realized this morning that although we announced in the last meeting that we’re forming this design team, we never announced it on the list. This is to correct that mistake. Here’s the text of the slide we presented at the meeting (https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F106%2Fmaterials%2Fslides-106-idr-sessa-auto-discovery-design-team-chairs-00&amp;data=02%7C01%7Clinda.dunbar%40futurewei.com%7Ccb4deb0980e4416aa56808d778f0d481%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637110848094360298&amp;sdata=PdBKa46JwY86swFIpjOLt2Hw%2F7OMr1SzJXSZt3AaA%2F0%3D&amp;reserved=0):

---
Autodiscovery

Thanks,

—John
_______________________________________________
Idr mailing list
[email-masked]
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fidr&amp;data=02%7C01%7Clinda.dunbar%40futurewei.com%7Ccb4deb0980e4416aa56808d778f0d481%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637110848094360298&amp;sdata=I4JDeIZP6wnbz1jfVc%2B712et7sp2FrTGAEbOgRy%2BlYA%3D&amp;reserved=0

---

From: "徐小虎(义先)" <[email-masked]>
Date: Thu, 05 Dec 2019 11:44:23 +0800

Hi John,

I volunteer as well.

Best regards,
Xiaohu

------------------------------------------------------------------
From:John Scudder <jgs=[email-masked]>
Send Time:2019年12月5日(星期四) 03:33
To:idr wg <[email-masked]>
Subject:[Idr] BGP autodiscovery design team

Hi All,

---
Autodiscovery

Thanks,

—John

---

From: Andrew Alston <[email-masked]>
Date: Thu, 5 Dec 2019 05:34:56 +0000

I’d be happy to volunteer on this on as well

Thanks

Andrew

From: Idr <[email-masked]> On Behalf Of Keyur Patel
Sent: Thursday, 5 December 2019 00:07
To: Acee Lindem (acee) <[email-masked]>; Jeff Tantsura <[email-masked]>; idr wg <[email-masked]>; John Scudder <jgs=[email-masked]>
Subject: Re: [Idr] BGP autodiscovery design team

Regards,
Keyur

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 4, 2019 at 12:46 PM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, idr wg <[email-masked]<mailto:[email-masked]>>, John Scudder <jgs=[email-masked]<mailto:jgs=[email-masked]>>
Subject: Re: [Idr] BGP autodiscovery design team

I volunteer as well.
Acee

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 4, 2019 at 3:43 PM
To: IDR List <[email-masked]<mailto:[email-masked]>>, John Scudder <jgs=[email-masked]<mailto:jgs=[email-masked]>>
Subject: Re: [Idr] BGP autodiscovery design team

John,

Thanks for sending out!

Cheers,
Jeff
On Dec 4, 2019, 11:33 AM -0800, John Scudder <jgs=[email-masked]<mailto:jgs=[email-masked]>>, wrote:

Hi All,

I realized this morning that although we announced in the last meeting that we’re forming this design team, we never announced it on the list. This is to correct that mistake. Here’s the text of the slide we presented at the meeting (https://datatracker.ietf.org/meeting/106/materials/slides-106-idr-sessa-auto-discovery-design-team-chairs-00<https://datatracker.ietf.org/meeting/106/materials/slides-106-idr-sessa-auto-discovery-design-team-chairs-00>:

---
Autodiscovery

Thanks,

—John
_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr<https://www.ietf.org/mailman/listinfo/idr>

---

From: Srihari Sangli <[email-masked]>
Date: Thu, 5 Dec 2019 06:32:26 +0000

I volunteer too.

srihari…

On 05/12/19, 2:16 AM Idr on behalf of Acee Lindem (acee) from [email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]> said >

I volunteer as well.
Acee

John,

Thanks for sending out!

Cheers,
Jeff

Hi All,

---
Autodiscovery

Thanks,

—John

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 5 Dec 2019 06:35:20 +0000

Hi John/Sue,

I would like to volunteer for this design team.

Thanks,
Ketan

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of John Scudder
Sent: 05 December 2019 01:03
To: idr wg <[email-masked]>
Subject: [Idr] BGP autodiscovery design team

Hi All,

---
Autodiscovery

Thanks,

—John

---

From: Gaurav Dawra <[email-masked]>
Date: Wed, 4 Dec 2019 22:43:09 -0800

Hi,

I can help out as well.

Gaurav

Sent from my iPhone

> On Dec 4, 2019, at 10:35 PM, Ketan Talaulikar (ketant) <[email-masked]> wrote:
> 
> Hi John/Sue,
>

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 5 Dec 2019 13:37:33 +0000

John,

	I will volunteer..

Thanks,
	Jim Uttaro

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of John Scudder
Sent: Wednesday, December 04, 2019 2:33 PM
To: idr wg <[email-masked]>
Subject: [Idr] BGP autodiscovery design team

Hi All,

I realized this morning that although we announced in the last meeting that we’re forming this design team, we never announced it on the list. This is to correct that mistake. Here’s the text of the slide we presented at the meeting (https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_106_materials_slides-2D106-2Didr-2Dsessa-2Dauto-2Ddiscovery-2Ddesign-2Dteam-2Dchairs-2D00&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=dG2-03-tyhUbG27cjuFdt-jsfgFF_8A-dFihGn-nFI0&s=yF77pRYHLHrhNMWJ4TyN-UVmN-i40VpwIar7weBlAc0&e= ):

---
Autodiscovery

Thanks,

—John
_______________________________________________
Idr mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_idr&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=dG2-03-tyhUbG27cjuFdt-jsfgFF_8A-dFihGn-nFI0&s=cA59-Zf6r-MteAyvmlqkl0f2EYXRG02RQ1nD-B8QyrU&e=

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 5 Dec 2019 13:46:36 +0000

I agree with Roberts’ point. Prior to crafting or selecting a draft as the basis for a proposal the design team should clearly articulate the scope, use cases and requirements that need to be addressed. IMO stating that in an informational RFC is a good way to ensure that all stakeholders are in agreement as to what the eventual specification/draft addresses, and as important does not address. When creating EVPN we first crafted an informational RFC https://tools.ietf.org/html/rfc7209 that specified Active/Active Multi-homing, flooding and multicast optimization etc… which formed the basis for the RFC 7432. This focused the design team on realizing the requirements articulated there.

Thanks,
              Jim Uttaro

From: Idr <[email-masked]> On Behalf Of Robert Raszuk
Sent: Wednesday, December 04, 2019 3:54 PM
To: John Scudder <jgs=[email-masked]>
Cc: idr wg <[email-masked]>
Subject: Re: [Idr] BGP autodiscovery design team

Hi John,

When this was announced I asked if this design team scope is to work on discovering your BGP peers in DC space or also in WAN and IX environments.

As you know I have been focusing on the latter for a number of years and I can share that discovering p2p eBGP peers requires a very different solutions as compared with discovering your iBGP peers or IX members.

Just stating BGP autodiscovery IMHO is too broad at this point. Likewise working on the DC space and declaring we are done with BGP autodiscovery all together would not be in the best interest of the protocol.

Many thx,
Robert.

On Wed, Dec 4, 2019 at 8:33 PM John Scudder <jgs=[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

I realized this morning that although we announced in the last meeting that we’re forming this design team, we never announced it on the list. This is to correct that mistake. Here’s the text of the slide we presented at the meeting (https://datatracker.ietf.org/meeting/106/materials/slides-106-idr-sessa-auto-discovery-design-team-chairs-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_106_materials_slides-2D106-2Didr-2Dsessa-2Dauto-2Ddiscovery-2Ddesign-2Dteam-2Dchairs-2D00&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=fVHdhiXAwpQtI-gjRcy7vUIUsv7lmxXPQdekhxRFxpU&s=hRYdRgxBmq6M5xfdod7VModMkFWQt7prrfS13VIi-HM&e=>):

---
Autodiscovery

Thanks,

—John
_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_idr&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=fVHdhiXAwpQtI-gjRcy7vUIUsv7lmxXPQdekhxRFxpU&s=Q4w0NSDbOUxxDr2dU-9kQv7p-XJOym4Oelnb9nTkzqI&e=>

---

From: Job Snijders <[email-masked]>
Date: Thu, 5 Dec 2019 14:50:01 +0100

On Thu, Dec 5, 2019 at 14:46 UTTARO, JAMES <[email-masked]> wrote:

> *I agree with Roberts’ point. Prior to crafting or selecting a draft as
> the basis for a proposal the design team should clearly articulate the
> scope, use cases and requirements that need to be addressed. IMO stating
> that in an informational RFC is a good way to ensure that all stakeholders
> are in agreement as to what the eventual specification/draft addresses, and
> as important does not address. When creating EVPN we first crafted an
> informational RFC https://tools.ietf.org/html/rfc7209
> <https://tools.ietf.org/html/rfc7209> that specified Active/Active
> Multi-homing, flooding and multicast optimization etc… which formed the
> basis for the RFC 7432. This focused the design team on realizing the
> requirements articulated there.*
>

I think the above is good feedback.

Also, it appears the entire working groep is interested to be part of the
design team. Perhaps the design team’s mailing list should be [email-masked]?
:-)

Kind regards,

Job

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 5 Dec 2019 14:58:43 +0100

Hi Job,

>  Perhaps the design team’s mailing list should be [email-masked]

Indeed !

I do not understand why there is any need for "design team" if required
functionality is about one of the core protocol functionality. What are we
trying to achieve - if someone on IDR is not interested given mail thread
can be easily moved to trash.

Hi Jim,

Many thx for your opinion. Very much appreciated here.

Also as we see from some proposals the core DC auto peering (also called by
some as "autodiscovery") can be done with the assistance of existing L2
protocols. So I think the fundamental first question is if this work even
belongs to IDR.

Thx,
R.

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 5 Dec 2019 17:15:36 -0500

Publicly echoing my private responses, I'm willing to be on the design team.

-- Jeff

> On Dec 4, 2019, at 2:33 PM, John Scudder <jgs=[email-masked]> wrote:
> 
> Hi All,
>

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 5 Dec 2019 23:20:30 +0100

John,

>  We are in the process of forming the team and hope to announce it soon.
We have many good
> volunteers already but if you didn’t know and do want to volunteer,
please contact Sue and me.

If such design team for unscoped "BGP autodiscovery" work gets formed
please add my name to the volunteer list.

Thank you,
Robert

---

From: Randy Bush <[email-masked]>
Date: Thu, 05 Dec 2019 14:43:15 -0800

> I agree with Roberts’ point. Prior to crafting or selecting a draft as
> scope, use cases and requirements that need to be addressed. IMO
> stating that in an informational RFC is a good way to ensure that all
> stakeholders are in agreement as to what the eventual
> specification/draft addresses, and as important does not address.

while i am tempted to agree with you, i see it from a different vector.

imiho, if we agreed to constrain solutions to the absolute minimal
mechanism, we might be able to cover a significant subset of clos, ibgp,
inter-provider, and ixp.

if we do not constrain to the minimial mechanism, we will make a complex
and disgusting mess of boiling the ocean on {pick any one of the above}.

i think it was tony hoare who said something such as

   there are two kinds of standards,
     - the intersection of what everybody *must* have
     - the union of what everybody thinks they could want

randy

---

From: Job Snijders <[email-masked]>
Date: Thu, 5 Dec 2019 23:55:00 +0100

>      - the intersection of what everybody *must* have

I would be interested to help achieve exactly the above.

Hopefully we can manage that in a way that doesn’t harm internet routing
from a security perspective. :-)

Kind regards,

Job

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 6 Dec 2019 00:24:51 +0100

> mechanism, we might be able to cover a significant subset of clos,
> ibgp, inter-provider, and ixp.

We have a very different set of possible tools and solutions to setup BGP
peering in Clos fabric as compared with BGP neighbor discovery for IBGP
mesh or IXP.

With that perhaps we could consider if for nothing else then for simplicity
to separate those two quite orthogonal tasks.

As noted for the latter we do have a pretty mature candidate solution on
the table. For the former I think there is a lot of experience we could
leverage from IGPs.

I am not aware that there is a requirement to automate
Inter-provider peering in any dimension.

Many thx.
Robert.

---

From: Warren Kumari <[email-masked]>
Date: Thu, 5 Dec 2019 21:11:01 -0500

> Publicly echoing my private responses, I'm willing to be on the design

As am I (if the chairs will have me!)

W

> We have many good volunteers already but if you didn’t know and do want to
> > Note that the design team will not make any binding decisions: as with
> all WG work, the WG has the final word, so any output of the DT will serve
> as input to the WG as a whole. (So even if you aren’t part of the DT, that
-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: John Scudder <[email-masked]>
Date: Fri, 6 Dec 2019 19:28:56 +0000

On Dec 5, 2019, at 8:50 AM, Job Snijders <[email-masked]<mailto:[email-masked]>> wrote:

Also, it appears the entire working groep is interested to be part of the design team. Perhaps the design team’s mailing list should be [email-masked]<mailto:[email-masked]>? :-)

I realize this was intended in jest (or at least there’s a smiley) but kidding aside, the IESG statement on design teams covers all the points I would if I tried to write a serious response. https://ietf.org/about/groups/iesg/statements/design-teams/

Regards,

—John