Subject: Re: [Idr] Securing BGP sessions (Issue#41)

From: Qin Wu <[email-masked]>
Date: Mon, 16 Dec 2019 00:50:09 +0000

To the question of IPsec, and whether we should support it or not, as I said, I will let Jeff comment. But what kind of documentation are you hoping for? Isn’t it just a question of giving IKE the parameters it needs to setup a IPsec tunnel? If we decide to support it, i2nsf WG has been working on an IKE model, as I just learnt, complete with re-keying,

[Qin] Mahesh, I believe you are referring to KARP working group instead of I2NSF working group.
which with a few changes could be used by the BGP model.

Cheers.

On Dec 13, 2019, at 10:47 AM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mahesh,

On 12/10/19, 8:41 PM, "Mahesh Jethanandani" <[email-masked]<mailto:[email-masked]>> wrote:

On Dec 10, 2019, at 5:29 PM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mahesh,

On 12/10/19, 8:19 PM, "Mahesh Jethanandani" <[email-masked]<mailto:[email-masked]>> wrote:

  Hi Acee,

On Dec 10, 2019, at 5:10 PM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mahesh,
I assume by IPsec, you mean transport mode IPsec.

  Yes. The assumption is that the underlying transport is secured using IPsec, and the model provides (if needed) key parameters needed to kick off the IKE to setup the SA in IPsec.

  HTH.

Well it doesn't help at all.... Normally, the usage of IPsec (AH, ESP, algorithms, key exchange, etc.) would be specified in some document. For example, IPsec usage by OSPFv3 is specified in RFC 4552. Granted, it is a lot simpler for BGP than OSPFv3 since BGP is strictly P2P but specification would still seem to necessary.

   You are right. It should be some document. That document in my mind is the YANG model for IPsec/IKE, something we need to ask the SEC ADs about. You would agree that what needs to be defined is not BGP specific, and therefore does not belong in the BGP model.

   Much like TCP-AO and TCP-MD5 I expect this other document to define a grouping that the BGP model imports and uses to define what is needed to setup IPsec.

Actually I disagree with you - TCP MD5 and TCP-AO are more than adequately documented.

  MD5 - https://datatracker.ietf.org/doc/rfc2385/
  TCP-AO - https://datatracker.ietf.org/doc/rfc5925/

It is only IPsec transport mode that isn't described. Also, I don't know of anyone who supports this so I'm wondering why it is in the discussion for this version of the BGP YANG model.

Thanks,
Acee

   Cheers.

Thanks,
Acee

For IPsec protection of BGP, where are the details specified?
Thanks,
Acee

On 12/10/19, 7:35 PM, "Idr on behalf of Mahesh Jethanandani" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

 This is the second thread in the list of issues that were discussed in IETF 106 w.r.t. to BGP YANG model. This particular thread is to discuss the issue of defining how BGP sessions are going to be secured.

 As stated in Singapore, the model is being defined to secure BGP sessions using
 - TCP AO
 - TCP MD5
 - IPSec

 In case there was a question of why MD5, it is because there are existing implementations that are choosing to stay with MD5, regardless of the issues that have been raised about MD5. The model therefore has to support such implementations.

 The model will use the ietf-key-chain model’s (RFC 8177) key-chain-ref to refer to an instance of the key chain. By doing that it will make use of the key rollover capability defined in that model, and for static key configuration by setting the end time to infinite in the key chain. The BGP model will leave the case of IPSec as TBD for now, and fill it when/if the IPSec YANG model is defined.

 Questions/Concerns?

 Mahesh Jethanandani
 [email-masked]<mailto:[email-masked]>

 _______________________________________________
 Idr mailing list
 [email-masked]<mailto:[email-masked]>
 https://www.ietf.org/mailman/listinfo/idr

  Mahesh Jethanandani
  [email-masked]<mailto:[email-masked]>

   Mahesh Jethanandani
   [email-masked]<mailto:[email-masked]>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 16 Dec 2019 10:43:41 -0800

Hi Qin

> On Dec 15, 2019, at 4:50 PM, Qin Wu <[email-masked]> wrote:
> 

No, I am referring to i2nsf group. KARP concluded quite some time ago, and the document are not active anymore. For i2nsf, I am referring to this specific document and this particular section.

https://tools.ietf.org/html/draft-ietf-i2nsf-sdn-ipsec-flow-protection-07#appendix-B <https://tools.ietf.org/html/draft-ietf-i2nsf-sdn-ipsec-flow-protection-07#appendix-B>

Thanks.

Mahesh Jethanandani
[email-masked]