Subject: Re: [Idr] Regarding Color Extended Communities Reserved bits (draft-ietf-idr-tunnel-encaps)

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 5 Mar 2020 05:29:55 +0000

Hi Alvaro,

I would like to point out that (as it stands today), we have included the request for the creation of this registry at https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-08#section-6.7

I would like to reconfirm that your proposal was for the draft-ietf-idr-tunnel-encaps to simply create the registry and for the draft-ietf-idr-segment-routing-te-policy to then request assignment for the bits that it has defined.

I would wait to hear from the authors of draft-ietf-idr-tunnel-encaps on how they would like to proceed on this and then we can accordingly update draft-ietf-idr-segment-routing-te-policy as necessary.

Thanks,
Ketan

-----Original Message-----
From: Alvaro Retana <[email-masked]> 
Sent: 19 February 2020 04:07
To: Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]
Cc: idr wg <[email-masked]>; [email-masked]
Subject: Re: [Idr] Regarding Color Extended Communities Reserved bits (draft-ietf-idr-tunnel-encaps)

On November 14, 2019 at 3:28:51 AM, Ketan Talaulikar wrote:

Ketan:

Hi!

I'm in the process of reviewing draft-ietf-idr-tunnel-encaps, so I ran into this message.

> The Color Extended Communities is specified in
> https://tools.ietf.org/html/draft-ietf-idr-tunnel-encaps-14#section-4.
> 3 and in it we have a RESERVED field. Now two bits in this field are 
> specified by
> https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-0
> 7#section- 3. However, we don't have an IANA registry for this 
> field/bits and neither is one requested by either of these drafts.
>
> I am wondering in which draft we should make the IANA request for this 
> field and if done in the BGP SRTE draft, would it end up updating the 
> Tunnel Encaps draft?
>
> Any suggestion on how to proceed with this? With so many other drafts 
> leveraging tunnel encaps, my concern is that we should not end up with 
> a collision.

I would prefer it if this registry was defined in draft-ietf-idr-tunnel-encaps.  I'll add a note in my review about it.

Thanks!!

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 5 Mar 2020 13:46:58 +0000

On March 5, 2020 at 12:30:24 AM, Ketan Talaulikar wrote:

Ketan:

Hi!

> I would like to point out that (as it stands today), we have included the
> request for the creation of this registry at
> https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-08#section-6.7
>
> I would like to reconfirm that your proposal was for the
> draft-ietf-idr-tunnel-encaps to simply create the registry and for the
> draft-ietf-idr-segment-routing-te-policy to then request assignment for the
> bits that it has defined.

Correct.

I also put a note in my review of draft-ietf-idr-tunnel-encaps about it.

https://mailarchive.ietf.org/arch/msg/idr/S1nyz1sewA_Xqf63W_vz8c4L8Z0/

Alvaro.