Subject: [Idr] Alissa Cooper's Discuss on draft-ietf-idr-rfc5575bis-22: (with DISCUSS)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Wed, 22 Apr 2020 06:46:14 -0700

Alissa Cooper has entered the following ballot position for
draft-ietf-idr-rfc5575bis-22: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-idr-rfc5575bis/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Apologies as this may be a really silly question, but isn't it possible for
traffic-rate-bytes and traffic-rate-packets to interfere with each other? That
is, if by mistake a flow specification shows up containing both actions and
they contradict each other (e.g., 0 bytes but 1M packets), how is that
situation supposed to be handled?

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 22 Apr 2020 06:53:04 -0700

On April 22, 2020 at 9:46:15 AM, Alissa Cooper wrote:

Alissa:

Hi!

> traffic-rate-bytes and traffic-rate-packets to interfere with each other?
> That is, if by mistake a flow specification shows up containing both actions
> and they contradict each other (e.g., 0 bytes but 1M packets), how is that

See §7.7.  It is left to the implementation to decide which filtering
action to use.

Alvaro.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 22 Apr 2020 10:02:57 -0400

Hi Alvaro,

> On Apr 22, 2020, at 9:53 AM, Alvaro Retana <[email-masked]> wrote:
> 

Right, but 7.1 and 7.2 say that traffic-rate-bytes and traffic-rate-packets don’t interfere with each other (or any other filtering actions specified), so presumably 7.7 does not apply? 

Alissa

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Apr 2020 11:52:23 -0400

Alissa and Alvaro: 

Alissa discuss is correct.   

My solution to fix this is to provide the following revisions: 

Section 7.1: 
Old/
   Interferes with: No other BGP Flow Specification Traffic Filtering
   Action in this document.
/
  New/
   Interferes with:  May interfere with the traffic-rate-packets (see section 7.2).
   Policy may allow both filtering by traffic-rate-packets and traffic-rate-bytes. 
   If policy does not allow this, these two actions will conflict.  
/  
Section 7.2 
Old/
   Interferes with: No other BGP Flow Specification Traffic Filtering
   Action in this document.
/
   Interferes with: May interfere with the  traffic-rate-bytes (see section  7.1) 
   Policy may allow both filtering by traffic-rate-packets and traffic-rate-bytes. 
   If policy does not allow this, these two actions will conflict.      
/

If this fix  is acceptable to both of you, please let me know.  We will re-spin the draft. 

Sue Hares 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Alissa Cooper
Sent: Wednesday, April 22, 2020 10:03 AM
To: Alvaro Retana
Cc: [email-masked]; [email-masked]; [email-masked]; IESG
Subject: Re: [Idr] Alissa Cooper's Discuss on draft-ietf-idr-rfc5575bis-22: (with DISCUSS)

Hi Alvaro,

>> Apologies as this may be a really silly question, but isn't it 
>> possible for traffic-rate-bytes and traffic-rate-packets to interfere with each other?
>> That is, if by mistake a flow specification shows up containing both 
>> actions and they contradict each other (e.g., 0 bytes but 1M 
>> packets), how is that situation supposed to be handled?
> 

Alissa

> Alvaro.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 22 Apr 2020 11:56:27 -0400

Works for me. Thanks.
Alissa

> On Apr 22, 2020, at 11:52 AM, Susan Hares <[email-masked]> wrote:
> 
> Alissa and Alvaro: 
>

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 22 Apr 2020 09:31:27 -0700

Works for me too.

Thanks!

Alvaro.

On April 22, 2020 at 11:56:33 AM, Alissa Cooper ([email-masked]) wrote:

Works for me. Thanks.
Alissa

> Subject: Re: [Idr] Alissa Cooper's Discuss on
draft-ietf-idr-rfc5575bis-22: (with DISCUSS)
> Right, but 7.1 and 7.2 say that traffic-rate-bytes and
traffic-rate-packets don’t interfere with each other (or any other
filtering actions specified), so presumably 7.7 does not apply?

---

From: Christoph Loibl <[email-masked]>
Date: Wed, 22 Apr 2020 20:11:10 +0200

Hi everyone.

Thanks for bringing this up. I remember that we had a very similar discussion about this before. Since both is possible at the same time I think that the changes suggested below are reasonable. It seems that this has consensus and I will take care of the update tomorrow.

Cheers Christoph.

-- 
Christoph Loibl
[email-masked] | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

> On 22.04.2020, at 18:31, Alvaro Retana <[email-masked]> wrote:
> 
> Works for me too.
> 
> Thanks!
> 
> Alvaro.
> 
> On April 22, 2020 at 11:56:33 AM, Alissa Cooper ([email-masked] <mailto:[email-masked]>) wrote:
> 
>> Works for me. Thanks. 
>> Alissa 
>> 
>> > On Apr 22, 2020, at 11:52 AM, Susan Hares <[email-masked] <mailto:[email-masked]>> wrote: 
>> >  
>> > Alissa and Alvaro:  
>> >  
>> > From: Idr [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Alissa Cooper 
>> > Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; IESG 
>> >> On Apr 22, 2020, at 9:53 AM, Alvaro Retana <[email-masked] <mailto:[email-masked]>> wrote: 
>> >>  
>> > [email-masked] <mailto:[email-masked]> 
>> > https://www.ietf.org/mailman/listinfo/idr <https://www.ietf.org/mailman/listinfo/idr> 
>> >  
>>