Subject: [Idr] Measurements on Regular, Extended, and Large Communities

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Fri, 24 Apr 2020 13:14:28 +0000

Please see measurements below on Regular, Extended (EC), and Large Communities (LC).
Analysis is based on data from many newer Routeviews collectors. 
** Question: Any insights why we don't see any ECs at all? **
OTOH, we do see good numbers of LCs even though there is no IANA registry for them yet.
Distribution of path lengths in updates with Communities/LCs is also shown below.

Sriram

P.S. Thank you to Lilia Hannachi (NIST) for the detailed analysis.

*********************************************************************
Community ANALYSIS (Collector : napafrica 2020-04-02:00)
*********************************************************************
# Updates = 479381 (Total)
# COMMUNITY = 329323 (68%)
  (AS path length distribution = 2:11504  3:114361  4:120531  5:49992  6:17917  7:3974  8:1623  9:584  10:130  11:268  12:62  13:2)
# LARGE_COMMUNITY = 49515 (10%)
  (AS path length distribution = 2:4004  3:22893  4:16388  5:4966  6:864  7:313  8:42  10:22  11:1)
# EXTENDED COMMUNITIES = 0 (0%)

*********************************************************************
Community ANALYSIS (Collector : amsix 2020-04-02:08)
*********************************************************************
# Updates = 395487 (Total)
# COMMUNITY = 115900 (29%)
  (AS path length distribution = 2:6038  3:28532  4:42006  5:23086  6:7958  7:2333  8:425  9:98  10:90  11:45  12:19  13:6)
# LARGE_COMMUNITY = 11530 (2%)
  (AS path length distribution = 2:1321  3:4583  4:3871  5:1467  6:214  7:55  8:15  9:4)
# EXTENDED COMMUNITIES = 0 (0%)

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 24 Apr 2020 14:50:25 +0100

> ** Question: Any insights why we don't see any ECs at all? **

possibilities:

- there are many types of EC and router config grammar is implemented 
inconsistently across different platforms, and there's no guarantee that 
the grammar is capable of expressing anything other than the commoner types

- they can't handle asn32:asn32, so there's no compelling reason to 
prefer them over rfc1997 communities.

- the more common EC types already have specific meanings, e.g. RT/SOO/etc

I've never seen them in the wild used for generic purposes.  It's always 
rfc1997, or more recently LC.

Nick

---

From: Colin Petrie <[email-masked]>
Date: Mon, 27 Apr 2020 20:42:39 +0200

If you are analysing Route-Views table dumps (and not updates) then you 
won't see ECs because Quagga/FRR only dumps selected attributes into the 
MRT files [0]. ECs are not on the list of dumped attributes. LCs were 
added to the list as part of the LC implementation patch.

RIPE's RIS implementation records all the received attributes opaquely 
so you will see ECs in there. They are also present within the 
route-views updates files (as these are dumped raw by Quagga).

Cheers,
Colin

[0]: bgp_dump_routes_attr():
https://github.com/FRRouting/frr/blob/master/bgpd/bgp_attr.c#L4146

On 24-04-2020 15:50, Nick Hilliard wrote:
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Wed, 29 Apr 2020 23:04:58 +0000

Thanks Nick and Colin. Insights you shared are helpful.

>added to the list as part of the LC implementation patch.

Our analysis sees LCs in both Quagga and FRR RouteViews collectors in RIBs and Updates.
We don't see ECs at all in any of these cases.
Some Quagga collectors show LCs in RIB (e.g., route-views3) and others don't (e.g., route-views2).

>route-views updates files (as these are dumped raw by Quagga).

Our measurements show LCs in RIPE-RIS but no ECs. 
Yep, we don't see ECs (in RIBs or Updates) in RIPE-RIS or Routeviews.
May be Nick is right about lack of compelling reason to use EC.
Examples (RIPE-RIS):
*********************************************************************
Community ANALYSIS (Collector : rrc00 2020-04-25:02)
*********************************************************************
# Updates = 366516 (Total)
# COMMUNITY = 293050 (79%)
AS path length distribution =    2: 1480 (0%)    3: 7177 (2%)    4: 20212 (6%)    5: 23894 (8%)    6: 17841 (6%)    7: 8023 (2%)    8: 2317 (0%)    9: 539 (0%)    10: 197 (0%)    11: 150 (0%)    12: 102 (0%)    13: 32 (0%)    14: 12 (0%)
# LARGE_COMMUNITY = 222778 (60%)
AS path length distribution =    2: 534 (0%)    3: 5066 (2%)    4: 18288 (8%)    5: 75891 (34%)    6: 76389 (34%)    7: 33773 (15%)    8: 9108 (4%)    9: 2151 (0%)    10: 833 (0%)    11: 247 (0%)    12: 232 (0%)    13: 54 (0%)    14: 6 (0%)    16: 1 (0%)
# EXTENDED COMMUNITIES = 0 (0%)

*********************************************************************
Community ANALYSIS (Collector : rrc15 2020-04-25:02)
*********************************************************************
# Updates = 115386 (Total)
# COMMUNITY = 92189 (79%)
AS path length distribution =    1: 67 (0%)    2: 5996 (6%)    3: 23925 (25%)    4: 26179 (28%)    5: 16973 (18%)    6: 10503 (11%)    7: 4418 (4%)    8: 1153 (1%)    9: 305 (0%)    10: 79 (0%)    11: 55 (0%)    12: 38 (0%)    13: 19 (0%)    14: 6 (0%)
# LARGE_COMMUNITY = 2555 (2%)
AS path length distribution =    2: 89 (3%)    3: 1312 (51%)    4: 609 (23%)    5: 429 (16%)    6: 104 (4%)    7: 9 (0%)    8: 3 (0%)
# EXTENDED COMMUNITIES = 0 (0%)

Sriram