Subject: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Fri, 24 Apr 2020 06:50:23 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-idr-rfc5575bis-23: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-idr-rfc5575bis/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for the work put into this document. The document is clear, easy to
read (I appreciated the given examples).

Alas, due to overload of work, I had only a quick browse through the document
with specific focus points and found nothing EXCEPT why having two different
documents ? One for IPv4 (with the core elements of the protocol) and one for
IPv6 (with only the IPv6 specifics)... I am more than surprized to say the
least... hence my DISCUSS...

This blocking DISCUSS can easily be fixed: e.g., with a RFC Editor note to make
a cluster of this document and draft-ietf-idr-flow-spec-v6 so that they are
published together with adjacent RFC numbers. Merging the two documents would
be preferred but I understand that this is more work (albeit a missed
opportunity).

Please find below a couple on non-blocking COMMENTs.

I hope that this helps to improve the document,

Regards,

-éric

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I also second Erik K.'s comment on non-TCP/UDP ports.

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Apr 2020 09:58:15 -0400

Eric:

We have a rule in IDR to not submit this for publication until we have 2 implementations.   
We do not have 2 vendors who will indicate the v6 support is deployed.  

The original document (RFC5575) did not have v6, and the IESG asked the IDR group to work on the v6 draft. 
The same authors have a v6 version of text in WG LC.   We've call for implementation reports and receive none on the v6. 

If you would like to help us find v6 with Flow-specification deployments, we would be happy to forward the v6 version to the IESG. 
Our long term game-plan was one document with v4 and v6 support. 

Sue Hares 
(author and IDR co-chair)

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Éric Vyncke via Datatracker
Sent: Friday, April 24, 2020 9:50 AM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thank you for the work put into this document. The document is clear, easy to read (I appreciated the given examples).

Alas, due to overload of work, I had only a quick browse through the document with specific focus points and found nothing EXCEPT why having two different documents ? One for IPv4 (with the core elements of the protocol) and one for
IPv6 (with only the IPv6 specifics)... I am more than surprized to say the least... hence my DISCUSS...

This blocking DISCUSS can easily be fixed: e.g., with a RFC Editor note to make a cluster of this document and draft-ietf-idr-flow-spec-v6 so that they are published together with adjacent RFC numbers. Merging the two documents would be preferred but I understand that this is more work (albeit a missed opportunity).

Regards,

-éric

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Apr 2020 10:27:50 -0400

Eric:

[author hat on] 
My co-authors remind me that we have three manuals which indicate 4 implementations (2 Cisco, 1 Huawei,  1 Arbor Networks), and it is possible we have missed other flow specifications.  
Cisco:
https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_bgp/configuration/xe-16/irg-xe-16-book/C3PL-BGP-Flowspec-Client.html

Arbor Networks Netscout 
https://archive.nanog.org/sites/default/files/wed.general.trafficdiversion.serodio.10.pdf

Huawei: 
https://support.huawei.com/enterprise/en/doc/EDOC1100028534?section=j034&topicName=configuring-dynamic-bgp-ipv6-flow-specification
[Author hat off] 

[WG co-chair hat on] 
Our usual checking involves getting the interoperability details which the IDR chairs (in my WG co-chair hat) has not received.  So, the bottom line is that this in process - but it is behind the v4.   

The WG also has draft-ietf-idr-bgp-flowspec-oid-11.txt (for intra-AS work) that updates the RFC5575bis has past WG LC. Large networks have deployed this as well, and wished it rolled into RFC5575bis.   

The WG desired to get something out the door to correct the inaccuracies in RFC5575bis.    
[WG co-chair hat on] 
 
We are glad to take instruction from the IESG regarding these drafts.  

Sue Hares 

-----Original Message-----
From: Susan Hares [mailto:[email-masked]] 
Sent: Friday, April 24, 2020 9:58 AM
To: 'Éric Vyncke'; 'The IESG'
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

Eric:

Sue Hares 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Éric Vyncke via Datatracker
Sent: Friday, April 24, 2020 9:50 AM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

Regards,

-éric

---

From: Alvaro Retana <[email-masked]>
Date: Fri, 24 Apr 2020 10:41:16 -0700

Eric:

Hi!

I appreciate all your hard work on making sure that IPv6 is always considered.

However, I disagree with your request.

(1) IPv6 has been considered. The WG has completed the work on FlowSpec for
    IPv6 — it is just waiting for implementation reports. [Sue already updated
    the tracking page. [1]]

(2) By requiring joint publication, you are effectively overturning the WG
    consensus to clean rfc5575 up and leave new functionality to new
    documents. As Sue already mentioned, the IPv6 functionality is not the
    only document that depends on this base — so we would be delaying
    that publication too (because of the Normative reference).

(3) This document already contains a reference to the IPv6 document. That will
    be more effective than requiring adjacent RFC numbers. It is not always
    the case where documents in the same cluster receive adjacent RFC numbers.

(4) This request is not aligned with the DISCUSS Criteria [2].

Having said all that, I am willing to prioritize my review of the IPv6
document (when the WG requests publication), and would not oppose a
request to the RFC Editor for expedited processing in order to get an
RFC number assigned before rfc5575bis is published.  I think this is
reasonable considering the time it may take the document to reach
AUTH48.

Thanks!

Alvaro.

[1] https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-flow-spec-v6%20implementations

[2] https://www.ietf.org/about/groups/iesg/statements/iesg-discuss-criteria/

On April 24, 2020 at 9:50:24 AM, Éric Vyncke via Datatracker
([email-masked](mailto:[email-masked])) wrote:

> This blocking DISCUSS can easily be fixed: e.g., with a RFC Editor note to
> make a cluster of this document and draft-ietf-idr-flow-spec-v6 so that they
> are published together with adjacent RFC numbers. Merging the two documents
> would be preferred but I understand that this is more work (albeit a missed
> opportunity).

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 24 Apr 2020 21:46:06 +0000

Sue,

Thank you for the added pieces of information.

I can only respect the decision of the IDR WG to mandate 2 implementations before requesting publication. Impressive.

Nice to see that there are more than 1 IPv6 implementation of FlowSpec (I obviously knew about one). Thanks to your co-authors to have identified those implementations.

This should advance the v6 document within the WG and towards publication.

Let me check with the routing AD how we can proceed (per Alvaro's email) on opportunity to clear my DISCUSS and why not having consecutive RFC numbers.

Regards

-éric

-----Original Message-----
From: Susan Hares <[email-masked]>
Date: Friday, 24 April 2020 at 16:28
To: Eric Vyncke <[email-masked]>, 'The IESG' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

    Eric:

    [author hat on] 

    Arbor Networks Netscout 

    Huawei: 

    [WG co-chair hat on] 

    Sue Hares 

    -----Original Message-----
    From: Susan Hares [mailto:[email-masked]] 
    Sent: Friday, April 24, 2020 9:58 AM
    To: 'Éric Vyncke'; 'The IESG'
    Cc: [email-masked]; [email-masked]; [email-masked]
    Subject: RE: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

    Eric:

    Sue Hares 

    -----Original Message-----
    From: Idr [mailto:[email-masked]] On Behalf Of Éric Vyncke via Datatracker
    Sent: Friday, April 24, 2020 9:50 AM
    To: The IESG
    Cc: [email-masked]; [email-masked]; [email-masked]
    Subject: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

    Regards,

    -éric

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Apr 2020 18:32:02 -0400

Eric: 

I will leave you to discuss the flow-specification v6 work with Alvaro. 

For my co-authors and the IDR-WG, we will move this process as fast as possible. 

Sue 

-----Original Message-----
From: Eric Vyncke (evyncke) [mailto:[email-masked]] 
Sent: Friday, April 24, 2020 5:46 PM
To: Susan Hares; 'The IESG'
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

Sue,

Regards

-éric

-----Original Message-----
From: Susan Hares <[email-masked]>
Date: Friday, 24 April 2020 at 16:28
To: Eric Vyncke <[email-masked]>, 'The IESG' <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

    Eric:

    [author hat on] 

    Arbor Networks Netscout 

    Huawei: 

    [WG co-chair hat on] 

    Sue Hares 

    -----Original Message-----
    From: Susan Hares [mailto:[email-masked]] 
    Sent: Friday, April 24, 2020 9:58 AM
    To: 'Éric Vyncke'; 'The IESG'
    Cc: [email-masked]; [email-masked]; [email-masked]
    Subject: RE: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

    Eric:

    Sue Hares 

    -----Original Message-----
    From: Idr [mailto:[email-masked]] On Behalf Of Éric Vyncke via Datatracker
    Sent: Friday, April 24, 2020 9:50 AM
    To: The IESG
    Cc: [email-masked]; [email-masked]; [email-masked]
    Subject: [Idr] Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

    Regards,

    -éric

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 27 Apr 2020 14:11:18 +0000

Alvaro,

Thank you for your detailed reply. About your point 1), Sue has indeed updated the implementation wiki page and, if I understand correctly the IDR processes, this should allow the WGLC & publication of the IPv6 document. 

With this new element, do you (and the WG chairs) believe that making a cluster is doable ? Else, I am trusting you as responsible AD and the chairs to expedite the IPv6 document processing (including 'jumping the RFCE queue') to have them published roughly at the same time. This is indeed very similar to a formal cluster.

If we agree on the above (expedite processing for IPv6 document and/or cluster) then I am clearing my DISCUSS.

Regards

-éric

PS: still wondering why this situation arise in 2020 :-O

-----Original Message-----
From: Alvaro Retana <[email-masked]>
Date: Friday, 24 April 2020 at 19:41
To: Éric Vyncke via Datatracker <[email-masked]>, Eric Vyncke <[email-masked]>, The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Jie Dong <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Éric Vyncke's Discuss on draft-ietf-idr-rfc5575bis-23: (with DISCUSS and COMMENT)

    Eric:

    Hi!

    Thanks!

    Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 27 Apr 2020 15:12:25 +0000

On April 27, 2020 at 10:11:21 AM, Eric Vyncke wrote:

Eric:

> Thank you for your detailed reply. About your point 1), Sue has indeed
> updated the implementation wiki page and, if I understand correctly the IDR
> processes, this should allow the WGLC & publication of the IPv6 document.

WGLC is already done, it concluded last week.  In general, idr runs
the WGLC and then waits for implementations.

Right now the Shepherd is working on the write up, which should
include finalizing the implementation report.

> With this new element, do you (and the WG chairs) believe that making a
> cluster is doable ? Else, I am trusting you as responsible AD and the chairs
> to expedite the IPv6 document processing (including 'jumping the RFCE queue')
> to have them published roughly at the same time. This is indeed very similar
> to a formal cluster.

Because there's other work depending on rfc5575bis, I rather not hold
up its publication beyond the normal process.  I don't expect
significant issues with draft-ietf-idr-flow-spec-v6, but I also prefer
for them not to share their fate.

As I mentioned, once the WG asks for publication, I'll prioritize its
review.  I can also ask the IESG to approve expedited processing once
the IPv6 document is approved.

Take care!

Alvaro.