Subject: [Idr] [idr]Question about draft-ietf-idr-segment-routing-te-policy

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Wed, 29 Apr 2020 11:25:05 +0000

Hi Authors,

  About the draft draft-ietf-idr-segment-routing-te-policy-08,  Section  2.1. SR Policy SAFI and NLRI

Before the draft 08 version, it says:
   o  NLRI Length: 1 octet of length expressed in bits as defined in
      [RFC4760].

Now in draft 08 version, it says:
   o  NLRI Length: 1 octet of length expressed in bits as defined in
      [RFC4760<https://tools.ietf.org/html/rfc4760>].  When AFI = 1 value MUST be 12 and when AFI = 2 value
      MUST be 24.

I think the last sentence is conflict with before. If we use bits for length, when AFI = 1 the value is 96 and when AFI = 2, the value is 192.
And now some implementation already use the bits for length.

  So is this a clerical error or is it based on other considerations?

Regards,
Haibo

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 29 Apr 2020 16:28:35 +0000

Hi Haibo,

Thanks for catching this error. Since the value is in bits, it should be 96 and 192 respectively as you mentioned.

Will fix this in the next/upcoming draft update.

Thanks,
Ketan

From: Wanghaibo (Rainsword) <[email-masked]>
Sent: 29 April 2020 16:55
To: [email-masked]
Cc: [email-masked]
Subject: [idr]Question about draft-ietf-idr-segment-routing-te-policy

Hi Authors,

Regards,
Haibo