Subject: [Idr] Question about draft-hujun-idr-bgp-ipsec-02 ( was RE: 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

From: Linda Dunbar <[email-masked]>
Date: Fri, 3 Apr 2020 20:24:09 +0000

Jun,

Need a few clarify questions for your draft.

  1.  Does  draft-hujun-idr-bgp-ipsec-02 assume that IKEv2 still running between IPsec peers?

  1.  Does receiving the IPsec BGP UPDATE triggers a node to start the  IKEv2 with the speaker without any configuration from the administer? If Node B can only establish IPsec IKEv2 with another node C, does it matter if the Node B receives or not receives the BGP update from the C?
  2.  How does the BGP UPDATE ease the IPsec configuration? Does  it ease the configuration on the BGP UPDATE speaker? Or does it ease the configuration of the receiver?
  3.  How to differentiate  Public Routing Instances?
If the payload packet within the IPsec tunnel are simple IP forwarding, is there still "Private Routing Instances"?

  1.  On Page 3, the draft states that only "Local Tunnel Endpoint address, Public Routing Instance and CHILD SA traffic selector address range" are advertised by the BGP.
Is the Local Tunnel Endpoint address same as the LOOPBACK address of the node? Or can be a specific Ingress or egress port of the node sending out the BGP UPDATE?

Thank you very much.

Linda Dunbar

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Monday, March 30, 2020 7:07 AM
To: 'IDR List' <[email-masked]>
Subject: [Idr] 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

This begins a 2 week WG adoption call for  two drafts BGP provisioned IPSEC infrastructure

1) draft-hujun-idr-bgp-ipsec-02.txt:
BGP Provisioned IPSEC Tunnel Configuration

https://datatracker.ietf.org/doc/draft-hujun-idr-bgp-ipsec/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hujun-idr-bgp-ipsec%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdb1e68b21c294ff7e40f08d7d4a2e5e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637211668440594288&sdata=HRHfVUUOy0a1ofnIzfTM4zsBqzZCGEhyMEopPdtEdyI%3D&reserved=0>

2) draft-hujun-idr-bgp-ipsec-transport-mode-00.txt:
BGP Provisioned IPsec Transport Mode Protected Tunnel Configuration

https://datatracker.ietf.org/doc/draft-hujun-idr-bgp-ipsec-transport-mode/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hujun-idr-bgp-ipsec-transport-mode%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cdb1e68b21c294ff7e40f08d7d4a2e5e4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637211668440604245&sdata=XROXZN5YTy5GQEToYyAkFNHx71%2B%2FXnln1QJjMzeRQ6I%3D&reserved=0>

These drafts were presented at IETF 104 and IETF 105.
At IETF 105, there was a detailed discussion on the security issues.
After IETF 105, the author modified his draft to take care of the
Issues mentioned.

Discussion during the WG Adoption should examine:
1) Has this draft addressed the necessary security issues to
    be adopted as IDR WG draft?

2) Is this useful generic IPSEC functionality for networks?

   The EVPN related to IPSEC continues in BESS.
   This draft is considered here as a general feature.

3) Are there any deployments of this draft?

Stay safe and healthy... Sue

---

From: "Hu, Jun (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 9 Apr 2020 00:13:00 +0000

Sorry for replying late, Pls see my answer in line

From: Idr <[email-masked]> On Behalf Of Linda Dunbar
Sent: Friday, April 3, 2020 1:24 PM
To: Susan Hares <[email-masked]>; 'IDR List' <[email-masked]>
Subject: [Idr] Question about draft-hujun-idr-bgp-ipsec-02 ( was RE: 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

Jun,

[Hu Jun] yes

  1.  Does receiving the IPsec BGP UPDATE triggers a node to start the  IKEv2 with the speaker without any configuration from the administer? If Node B can only establish IPsec IKEv2 with another node C, does it matter if the Node B receives or not receives the BGP update from the C?
[Hu Jun] it is up to the implementation, there are two options:

           *   create the tunnel upon receiving BGP update
           *   create tunnel only when router need to forward a packet to a destination that need to be reached via IPsec tunnel
either way works

  1.  How does the BGP UPDATE ease the IPsec configuration? Does  it ease the configuration on the BGP UPDATE speaker? Or does it ease the configuration of the receiver?
[Hu Jun] think of a simple case, where there are 3 routers: A , B and C, A has subnet S behind it that require IPsec protection, if B or C need to forward a packet to S, it must be over an IPsec tunnel; so traditionally, you would configure two tunnels on A: A->B and A->C, then you would also need to configure a tunnel B->A on B and a tunnel C->A on C, so in total, there are 4x tunnel configuration on 3 routers; but now with my draft, you just need to configure A to advertise a BGP update for S which include ipsec config, there is no per-tunnel configuration on A, B or C.

  1.  How to differentiate  Public Routing Instances?
If the payload packet within the IPsec tunnel are simple IP forwarding, is there still "Private Routing Instances"?
[Hu Jun] the concept of public and private routing instance is to separate trust network from un-trusted network; Typically, for security reason, you want to separate trusted network from un-trusted network by using different routing instance,  for example, internet is un-trusted network, while an enterprise intranet is trusted network, they are different routing instance;  then an payload packet from the intranet is encapsulated into an IPsec tunnel, the result ESP tunnel packet is forwarded via internet.
But public routing instance could same as private routing instance if you have good reason to do so, there is nothing in protocol level prevent that
On Page 3, the draft states that only "Local Tunnel Endpoint address, Public Routing Instance and CHILD SA traffic selector address range" are advertised by the BGP.
Is the Local Tunnel Endpoint address same as the LOOPBACK address of the node? Or can be a specific Ingress or egress port of the node sending out the BGP UPDATE?
[Hu Jun] this total up to the operator, both loopback or a physical interface address could be used, but typically a loopback address is prefer for stable reason

Thank you very much.

Linda Dunbar

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Susan Hares
Sent: Monday, March 30, 2020 7:07 AM
To: 'IDR List' <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

These drafts were presented at IETF 104 and IETF 105..
At IETF 105, there was a detailed discussion on the security issues.
After IETF 105, the author modified his draft to take care of the
Issues mentioned.

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 9 Apr 2020 16:46:49 +0000

Jun,

your Section 2.3 IPsec Configuration Tag Sub-TLV has  Certificate trust-anchor: CA-1 and Certificate trust-anchor: CA-2

Why need two Trust Anchors (CA-1 & CA-2)?
What are expected actions for a node receiving this information?  If the receiver has different trust anchor, should the receiver do more validation?

What are the expected actions for receiver upon receiving the  local/remote Traffic selector protocol, local/remote Traffic selector port range?

For your example, what if the subnet S behind A only needs to be encrypted to B, but not to C because A<->C has VPN connected. What should C do with the received IPsec UPDATE? For a network with hundreds of nodes, what do they do with the received UPDATE?

a simple case, where there are 3 routers: A , B and C, A has subnet S behind it that require IPsec protection, if B or C need to forward a packet to S, it must be over an IPsec tunnel;

Thank you,

Linda Dunbar

From: Hu, Jun (Nokia - US/Mountain View) <[email-masked]>
Sent: Wednesday, April 8, 2020 7:13 PM
To: Linda Dunbar <[email-masked]>; Susan Hares <[email-masked]>; 'IDR List' <[email-masked]>
Subject: RE: [Idr] Question about draft-hujun-idr-bgp-ipsec-02 ( was RE: 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Linda Dunbar
Sent: Friday, April 3, 2020 1:24 PM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>; 'IDR List' <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Question about draft-hujun-idr-bgp-ipsec-02 ( was RE: 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

Jun,

Thank you very much.

Linda Dunbar

https://datatracker.ietf.org/doc/draft-hujun-idr-bgp-ipsec/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hujun-idr-bgp-ipsec%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C867befd7c8f14a9f2b9708d7dc1ac510%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637219879863935674&sdata=SwzXzkVYOO80URTGX2HtZip%2Fm%2B03GqA1mNcQSuUPwWs%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-hujun-idr-bgp-ipsec-transport-mode/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hujun-idr-bgp-ipsec-transport-mode%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C867befd7c8f14a9f2b9708d7dc1ac510%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637219879863945672&sdata=KUP1Cd05vEX6ZfJlzbA8gROpgktmvT1WeWS2ifaAA%2Bw%3D&reserved=0>

---

From: "Hu, Jun (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 9 Apr 2020 17:26:17 +0000

Pls see my comments in line

From: Linda Dunbar <[email-masked]>
Sent: Thursday, April 9, 2020 9:47 AM
To: Hu, Jun (Nokia - US/Mountain View) <[email-masked]>; Susan Hares <[email-masked]>; 'IDR List' <[email-masked]>
Subject: RE: [Idr] Question about draft-hujun-idr-bgp-ipsec-02 ( was RE: 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

Jun,

Why need two Trust Anchors (CA-1 & CA-2)?
[Hu Jun] this is just an example to show IPsec configuration tag could be mapped to different configs; for example, lets say you have two subnets belongs to two type of services, each has different trust-anchor;
What are expected actions for a node receiving this information?  If the receiver has different trust anchor, should the receiver do more validation?

[Hu Jun] the IPsec configuration tag represents a set of IPsec configuration for receiver to use for creating the IPsec tunnel; for example router B received a BGP update for subnet S, which contains an IPsec config tag value T1, and T1 is mapping to a set of IPsec config include trust-anchor CA-1,  B then need to use a certificate issued by CA-1 as its credential for IPsec tunnel authentication
What are the expected actions for receiver upon receiving the  local/remote Traffic selector protocol, local/remote Traffic selector port range?
[Hu Jun] same as above, these are all required Ipse config that receiver need to use for creating IPsec tunnel to reach the subnet S

a simple case, where there are 3 routers: A , B and C, A has subnet S behind it that require IPsec protection, if B or C need to forward a packet to S, it must be over an IPsec tunnel;
[Hu Jun] if IPsec only need between A and B, then assume subnet behind B is S2, then in the ipsec tunnel TLV of tunnel-encap attr of BGP update for S, A could include a Remote Prefix sub-TLV as S2, this means this Ipsec tunnel requirement is only required between subnet S <-> S2;

Thank you,

Linda Dunbar

From: Hu, Jun (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, April 8, 2020 7:13 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; 'IDR List' <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Idr] Question about draft-hujun-idr-bgp-ipsec-02 ( was RE: 2 Week WG adoption call draft-hujun-idr-bgp-ipsec-02.txt and draft-hujun-idr-bgp-ipsec-transport-mode-00 (3/30 to 4/13/2020

Jun,

Thank you very much.

Linda Dunbar