Subject: [Idr] I-D Action: draft-ietf-idr-segment-routing-te-policy-09.txt

From: [email-masked]
Date: Thu, 28 May 2020 03:12:55 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Advertising Segment Routing Policies in BGP
        Authors         : Stefano Previdi
                          Clarence Filsfils
                          Ketan Talaulikar
                          Paul Mattes
                          Eric Rosen
                          Dhanendra Jain
                          Steven Lin
	Filename        : draft-ietf-idr-segment-routing-te-policy-09.txt
	Pages           : 39
	Date            : 2020-05-28

Abstract:
   This document defines a new BGP SAFI with a new NLRI in order to
   advertise a candidate path of a Segment Routing (SR) Policy.  An SR
   Policy is a set of candidate paths, each consisting of one or more
   segment lists.  The headend of an SR Policy may learn multiple
   candidate paths for an SR Policy.  Candidate paths may be learned via
   a number of different mechanisms, e.g., CLI, NetConf, PCEP, or BGP.
   This document specifies the way in which BGP may be used to
   distribute SR Policy candidate paths.  New sub-TLVs for the Tunnel
   Encapsulation Attribute are defined for signaling information about
   these candidate paths.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-09
https://datatracker.ietf.org/doc/html/draft-ietf-idr-segment-routing-te-policy-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-segment-routing-te-policy-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 28 May 2020 10:25:04 +0000

Hi All,

A new version of the draft has just been posted. Besides the refresh, it includes updates discussed over the list and a few other off-list comments/corrections received. 

Following are the changes:
- fixed error due to mix between bits and byte length in NLRI size
- renaming SR Policy Name sub-TLV to SR Policy Candidate Path Name sub-TLV and updates to it as per discussions on the list
- clarifications related to handling of error and unrecognized sub-TLVs based on feedback/inputs
- clarifications on how BGP could determine the originator for SR Policy
- Some editorial nits

Request the WG to review and provide feedback/comments.

Thanks,
Ketan (on behalf of co-authors)

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of [email-masked]
Sent: 28 May 2020 15:43
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-segment-routing-te-policy-09.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr