Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy: IPR call and call for implementations

From: Eugene Bogomazov <[email-masked]>
Date: Thu, 4 Jun 2020 18:19:49 +0300

The promised updated implementation on frr can be found at
https://github.com/error2407/frr

Dear chairs, can you advise when the WGLC will be announced?

On Mon, May 18, 2020 at 2:19 AM Keyur Patel <[email-masked]> wrote:

> I am not aware of any IPR on this draft or it’s content or ideas.
>
> Regards,
> Keyur
>
> > On May 15, 2020, at 5:48 PM, Randy Bush <[email-masked]> wrote:
> >
> > 
> >>
> >> This is an IPR Call for draft-ietf-idr-bgp-open-policy-10.txt.
> >>
> >> The authors should send in a IPR statement to the list - even if you
> have
> >> send in an IPR call during adoption.
> >
> > i am not aware of any ipr on this draft or its content or ideas.
> >
> > randy
>

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2020 13:02:58 -0400

Eugene:

I’m pleased to hear the updated implementation is published on:  

We’ll start the WG LC this evening.  

This delay is to allow you to answer the following questions on the FRR implementation. 

1) Do you have configuration syntax for your open policy? 

https://github.com/error2407/frr/blob/open_policy/doc/user/bgp.rst

I could not readily tell where you put the configuration for open policy. 

It seems like it would be in the peer section. 

Perhaps you could provide a link to the appropriate configuration section 

2)Could you please fill out the implementation report 

 (on the IDR Wiki for FRR for open-policy)?  

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgp-open-policy

If you do not have time to fill out the wiki, could you 

Please send me the implementation information listed below. 

]

Without 2 implementations, the draft-ietf-idr-bgp-open-policy 

will not be forwarded to the IESG.  At this time we only have FRR

as an officially mentioned implementation.  

Cheerily, Sue  

Implementation Information

============================

The questions are below 

1)  What Roles do you support in your configuration? 

[see section 1, draft-ietf-idr-bgp-open-policy] 

Provider, customer, RS (Route Server), RS-Client, Peer? 

2) Do you support the following: 

[see section 4, 5 of draft-ietf-idr-bgp-open-policy] 

a) sending (XMT) of BGP Open  with a BGP Role capability  

b) receiving a BGP Open with a BGP Role Capability

c) reject Open with Role Mismatch + 

    connection Rejection notification [Code 6, subcode 5]  

d) receive and process a rejected open 

   with Role Mismatch + connection rejection notification 

e) in strict mode configuration, 

      reject connection that does not have BGP Role 

     with  a) Connection rejection notification [code 6, subcode 5]  

f) receive a connection rejection notification [code 6, subcode 5] 

   without Role mismatch

3)  BGP Path Attribute – BGP Only to Customer 

a) sending transitive BGP Path Attribute – BGP Only to Customer  

b) receiving transitive BGP Path Attribute – BGP Only to Customer  

4) Have you tested this with another implementation? 

If so which one? 

5) Have you any concerns about the error handling? 

Cheerily, Susan Hares 

From: Eugene Bogomazov [mailto:[email-masked]] 
Sent: Thursday, June 4, 2020 11:20 AM
To: Keyur Patel
Cc: Randy Bush; Susan Hares; idr@ietf. org; [email-masked]
Subject: Re: WG LC for draft-ietf-idr-bgp-open-policy: IPR call and call for implementations

The promised updated implementation on frr can be found at https://github.com/error2407/frr

 

Regards,
Keyur 

>> The authors should send in a IPR statement to the list - even if you have

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2020 13:18:04 -0400

Eugene: 

In checking, I realized that you mentioned BIRD 1.76 and 2.0 in your 5/17/2020 email.  With these two implementations (BIRD, FRR), we will be able to send draft-idr-bgp-open-policy to the IESG.  Would you please fill out the implementation information or send me the implementation information? 

The wiki page is at: 

 

Most important, do these 2 implementation interoperate in your tests?  

This evening, we’ll start the WG LC for this draft. 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Eugene Bogomazov
Sent: Sunday, May 17, 2020 5:24 PM
To: Susan Hares; idr@ietf. org
Cc: [email-masked]
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy: IPR call and call for implementations

I am not aware of any IPR related to this draft.

Currently we have two realizations for this draft: for BIRD 1.6 and BIRD 2.0. You can find them on https://github.com/error2407/BGP_Open_Policy. There was also a realization on FRR, but it was for the previous version of the draft and it'll take about 2 weeks to update it to the latest version of the text.

On Sat, May 16, 2020 at 11:55 PM Brian Dickson <[email-masked]> wrote:

I am not aware of any IPR related to this draft or its predecessors-in-interest.

Brian

On Fri, May 15, 2020 at 5:35 PM Susan Hares <[email-masked]> wrote:

The authors should send in a IPR statement to the list – even if you have send in an IPR call during adoption.  

The WG LC will begin as soon as the all authors send in an IPR statement. 

Also, please send any information regarding implementations to the list. 

Cheers, Sue  

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Eugene Bogomazov <[email-masked]>
Date: Thu, 4 Jun 2020 23:08:27 +0300

Susan:

We support BIRD 1.6.4 and BIRD 2.0.5
https://github.com/error2407/BGP_Open_Policy
Examples of changes in configuration for both BIRD and FRR can be found in
https://github.com/error2407/BGP_Open_Policy/blob/master/README.md
All implementations support sending/receiving Role Capabilities and OTC
attribute. Also they support strict_mode.
Role Mismatch is sending/receiving, however in BIRD this value (Code 2,
Subcode 8) is already in use.
The only missing point is that we are not sending  "Connection Rejected"
notification in either of the versions yet, however BGP session is
correctly rejected.

And yes, we have tested BIRD and FRR between each other.

On Thu, Jun 4, 2020 at 8:18 PM Susan Hares <[email-masked]> wrote:

> Eugene:
>
>
>
> In checking, I realized that you mentioned BIRD 1.76 and 2.0 in your
> 5/17/2020 email.  With these two implementations (BIRD, FRR), we will be
> able to send draft-idr-bgp-open-policy to the IESG.  Would you please fill
> out the implementation information or send me the implementation
> information?
>
>
>
> The wiki page is at:
>
> *From:* Idr [mailto:[email-masked]] *On Behalf Of *Eugene Bogomazov
> *Sent:* Sunday, May 17, 2020 5:24 PM
> *To:* Susan Hares; idr@ietf. org
> *Cc:* [email-masked]
> *Subject:* Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy: IPR call
> and call for implementations
>
>
>
> Currently we have two realizations for this draft: for BIRD 1.6 and BIRD
> 2.0. You can find them on https://github.com/error2407/BGP_Open_Policy.
> There was also a realization on FRR, but it was for the previous version of
> the draft and it'll take about 2 weeks to update it to the latest version
> of the text.
>
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2020 16:53:34 -0400

Eugene: 

Thanks for the information.  Just one question, what does BIRD support on Code 2, Subcode 8. 

I will start WG LC while I wait. 

Sue

From: Eugene Bogomazov [mailto:[email-masked]] 
Sent: Thursday, June 4, 2020 4:08 PM
To: Susan Hares
Cc: idr@ietf. org; [email-masked]
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy: IPR call and call for implementations

Susan:

We support BIRD 1.6.4 and BIRD 2.0.5  https://github.com/error2407/BGP_Open_Policy 
Examples of changes in configuration for both BIRD and FRR can be found in https://github.com/error2407/BGP_Open_Policy/blob/master/README.md 
All implementations support sending/receiving Role Capabilities and OTC attribute. Also they support strict_mode.
Role Mismatch is sending/receiving, however in BIRD this value (Code 2, Subcode 8) is already in use.
The only missing point is that we are not sending  "Connection Rejected" notification in either of the versions yet, however BGP session is correctly rejected.

Eugene: 

The wiki page is at: 

 

Sue 

Brian

Cheers, Sue

---

From: Sander Steffann <[email-masked]>
Date: Thu, 4 Jun 2020 22:54:08 +0200

Hi,

> Most important, do these 2 implementation interoperate in your tests?

I just noticed that Mikrotik also implemented the draft in their beta 7:
https://help.mikrotik.com/docs/display/ROS/v7+Routing+Protocol+Status#space-menu-link-content

It would be interesting to see if that interoperates as well.

Cheers,
Sander

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 4 Jun 2020 17:04:26 -0400

Sander: 

Thank you for letting me know.   If you find out about interoperation,
please post to the list. 

Cheers, Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Sander Steffann
Sent: Thursday, June 4, 2020 4:54 PM
To: Susan Hares
Cc: idr@ietf. org; [email-masked]
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy: IPR call and
call for implementations

Hi,

I just noticed that Mikrotik also implemented the draft in their beta 7:
https://help.mikrotik.com/docs/display/ROS/v7+Routing+Protocol+Status#space-
menu-link-content

Cheers,
Sander