Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy-10.txt (6/4 to 6/18) - WG LC completed, awaiting -12.txt

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Mon, 6 Jul 2020 18:23:50 +0000

Hi Gyan,

You wrote:
"In the context of keeping the door open for future internal roles as the
reader would be confused when reading “any” meaning iBGP, however internal
roles don’t exist today.  My recommendation would be to update the draft to
say “any” when the internal roles are explicitly defined.  That could be
done anytime when you have fully vetted the internal role concept and the
draft is updated accordingly."

Would the following substitution take care of your concern?

Current text: BGP Role is a new configuration option that can
be configured on any BGP session.

New text: This document specifies a new configuration option
BGP Role that is intended to be used with eBGP.
However, in the future, the applicability of BGP Role
can be extended to iBGP when suitable internal roles are defined.

Thanks.

Sriram

---

From: Alexander Azimov <[email-masked]>
Date: Mon, 6 Jul 2020 22:35:44 +0300

Colleagues,

I'm sorry for the late response. If you don't mind I would suggest a bit
simpler wording:
        BGP Role is a new configuration option that is configured on a
per-session basis.
        BGP Roles reflect the agreement between two BGP speakers about
their relationship.
        One of the Roles described below SHOULD be configured on each eBGP
session between ISPs that carry IPv4 and(or) IPv6 unicast prefixes.

Does it resolve the issue?

-- 
Best regards,
Alexander Azimov

---

From: Brian Dickson <[email-masked]>
Date: Mon, 6 Jul 2020 12:48:30 -0700

> can be extended to iBGP when suitable internal roles are defined.
As an alternative, maybe change the text so that it references an IANA
table, and have the new table introduced via the IANA Actions section, with
particulars about how new table entries get added?
Allow for private roles as well as new standard roles, with details on what
to do with private roles (if private roles are defined/allowed), e.g. strip
or substitute on announcement via eBGP.
Or just have the well-defined roles table only, and require standards
action to add table entries with reference to RFCs in the table.

Brian

> Thanks.
>
> Sriram
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Alexander Azimov <[email-masked]>
Date: Mon, 6 Jul 2020 23:13:12 +0300

Brian,

I don't feel it's good to add any limitations aka stripping. Roles are
negotiated, that is their main idea.
And we already have an allocation policy for future roles:

   The allocation policy for new entries up to and including
>    value 127 is "Expert Review" [RFC5226].  The allocation policy for
>    values 128 through 251 is "First Come First Served".  The values from
>    252 through 255 are for "Experimental Use".

пн, 6 июл. 2020 г. в 22:49, Brian Dickson <[email-masked]>:

> Allow for private roles as well as new standard roles, with details on
> what to do with private roles (if private roles are defined/allowed), e.g.
> strip or substitute on announcement via eBGP.

-- 
Best regards,
Alexander Azimov

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Jul 2020 16:42:17 -0400

Alex and Brian: 

If you add any new limitations, this will need to go back through WG LC. 

However, WG LC is only 2 weeks (if no changes are made).   If you think it is required, then add it now – before I put in my shepherd’s repor.t 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Alexander Azimov
Sent: Monday, July 6, 2020 4:13 PM
To: Brian Dickson
Cc: IDR; Sriram, Kotikalapudi (Fed); Susan Hares
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy-10.txt (6/4 to 6/18) - WG LC completed, awaiting -12.txt

Brian,

I don't feel it's good to add any limitations aka stripping. Roles are negotiated, that is their main idea.

 

 

On Mon, Jul 6, 2020 at 11:24 AM Sriram, Kotikalapudi (Fed) <kotikalapudi.sriram=[email-masked]> wrote:

Hi Gyan,

You wrote:

As an alternative, maybe change the text so that it references an IANA table, and have the new table introduced via the IANA Actions section, with particulars about how new table entries get added?

Allow for private roles as well as new standard roles, with details on what to do with private roles (if private roles are defined/allowed), e.g. strip or substitute on announcement via eBGP.

Or just have the well-defined roles table only, and require standards action to add table entries with reference to RFCs in the table.

Brian

Thanks.

Sriram

 

-- 

Best regards,

Alexander Azimov

---

From: Brian Dickson <[email-masked]>
Date: Mon, 6 Jul 2020 15:16:46 -0700

Hi, Sue,

Per Alex's response, no changes. The table and policy are clear.
The only possible change would be minor text changes to reference the
table in the main text, if that makes sense to do (i.e. makes the document
clearer to the reader.)

Brian

On Mon, Jul 6, 2020 at 1:42 PM Susan Hares <[email-masked]> wrote:

> However, WG LC is only 2 weeks (if no changes are made).   If you think it
> is required, then add it now – before I put in my shepherd’s repor.t
>
>
>
> Sue
>
>
>
> *From:* Idr [mailto:[email-masked]] *On Behalf Of *Alexander Azimov
> *Sent:* Monday, July 6, 2020 4:13 PM
> *To:* Brian Dickson
> *Cc:* IDR; Sriram, Kotikalapudi (Fed); Susan Hares
> *Subject:* Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy-10.txt (6/4
> to 6/18) - WG LC completed, awaiting -12.txt
>
>
>
> Brian,
>
>
>

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Jul 2020 18:30:11 -0400

Brian and Alex: 

Would you please provide the text with the minor nits as -13.txt – so I know you are ready for shepherd’s review. 

I’d like to get this off to Alvaro’s list this week. 

Thank you, Susan Hares

From: Brian Dickson [mailto:[email-masked]] 
Sent: Monday, July 6, 2020 6:17 PM
To: Susan Hares
Cc: Alexander Azimov; IDR; Sriram, Kotikalapudi (Fed)
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy-10.txt (6/4 to 6/18) - WG LC completed, awaiting -12.txt

Hi, Sue,

The only possible change would be minor text changes to reference the table in the main text, if that makes sense to do (i.e. makes the document clearer to the reader.)

Brian

Alex and Brian: 

Sue 

Brian,

 

 

Hi Gyan,

You wrote:

Brian

Thanks.

Sriram

 

-- 

Best regards,

Alexander Azimov

---

From: Alexander Azimov <[email-masked]>
Date: Tue, 7 Jul 2020 22:47:54 +0300

Susan,

I've just pushed -13, it should resolve the ambiguity in roles definition.

вт, 7 июл. 2020 г. в 01:30, Susan Hares <[email-masked]>:

> Brian and Alex:
>
>
>
> Would you please provide the text with the minor nits as -13.txt – so I
> know you are ready for shepherd’s review.
>
> *From:* Brian Dickson [mailto:[email-masked]]
> *Sent:* Monday, July 6, 2020 6:17 PM
> *To:* Susan Hares
> *Cc:* Alexander Azimov; IDR; Sriram, Kotikalapudi (Fed)

-- 
Best regards,
Alexander Azimov

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 7 Jul 2020 15:49:58 -0400

Alex:

I’ve been watching for -13.txt – so our emails cross paths.   

Is this the revision you wish me to review in my shepherd’s review? 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Alexander Azimov
Sent: Tuesday, July 7, 2020 3:48 PM
To: Susan Hares
Cc: IDR; Sriram, Kotikalapudi (Fed)
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-open-policy-10.txt (6/4 to 6/18) - WG LC completed, awaiting -12.txt

Susan,

Brian and Alex: 

Thank you, Susan Hares

Hi, Sue,

Brian

Alex and Brian: 

Sue 

Brian,

 

 

Hi Gyan,

You wrote:

Brian

Thanks.

Sriram

 

-- 

Best regards,

Alexander Azimov

-- 

Best regards,

Alexander Azimov

---

From: Alexander Azimov <[email-masked]>
Date: Tue, 7 Jul 2020 22:59:50 +0300

Susan,

Yes, I hope this revision finally addresses all wording issues that were
found during the WGLC.
As it was for all recent revisions, the diff doesn't change the mechanics
described in the document, so no updates are needed in the implementations.

вт, 7 июл. 2020 г. в 22:50, Susan Hares <[email-masked]>:

> *Sent:* Tuesday, July 7, 2020 3:48 PM
> *To:* Susan Hares
> *Cc:* IDR; Sriram, Kotikalapudi (Fed)

-- 
Best regards,
Alexander Azimov

---

From: Randy Bush <[email-masked]>
Date: Wed, 08 Jul 2020 10:36:39 -0700

> can be extended to iBGP when suitable internal roles are defined.

how about also mentioning extension to is-is, idrp, and ice cream?

    It's perfectly appropriate to be upset.  I thought of it in a
    slightly different way--like a space that we were exploring and, in
    the early days, we figured out this consistent path through the
    space: IP, TCP, and so on.  What's been happening over the last few
    years is that the IETF is filling the rest of the space with every
    alternative approach, not necessarily any better.  Every possible
    alternative is now being written down.  And it's not useful.
    -- Jon Postel