Subject: Re: [Idr] IPSec Tunnels and draft-sajassi-bess-secure-evpn

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Fri, 31 Jul 2020 05:53:39 +0000

<added [email-masked]>

Sue,

Before getting to the discussions of the three IPsec proposals, there are some elements of draft-ietf-idr-tunnel-encaps-17.txt that I can see might have caused some confusions and I’d like to get those sorted out first.

The tunnel-encap draft specifies sub-tlv for VxLAN, VxLAN GDP, and NVGRE in sections 3.2.1, 3.2.2, and 3.2.3. I am not aware of any vendor that has implemented these sub-tlvs because the info in these sub-tlv already exist in EVPN routes (e.g., MAC addresses, Ethernet Tags, etc.) which they have implemented it. Therefore, all the vendors that I am aware of use Extended Community  defined in section 4.1  along with EVPN routes to signal VxLAN and GENEVE tunnel types. Furthermore, I am not aware of anyone using NVGRE encap! So, as the first step, we should remove these three sections from the draft if there is no objection.

Cheers,
Ali

From: Susan Hares <[email-masked]>
Date: Tuesday, July 28, 2020 at 8:30 AM
To: Cisco Employee <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "'Hu, Jun (Nokia - US/Mountain View)'" <[email-masked]>
Subject: IPSec Tunnels and draft-sajassi-bess-secure-evpn

Ali and bess WG:

IDR has 3 proposals for IPsec tunnels that impact draft-ietf-idr-tunnel-encaps-17.txt.  As an IDR co-chair/shepherd,  I have been discussing these three drafts (Ali and two other authors sets) to try to find out if we can have one general solutions.

The discussion has been very fruitful to point up BGP issues of interoperability, security, privacy, manageability, and scaling.  For example, there is a lack of a clear specification between RFC6514 (PMSI tunnel attribute) and the tunnel-encaps draft that specifies how these drafts interoperate.  I suspect the bess and idr chairs will need to discuss if tunnel-encaps has to address this point.

I wrote up my ideas in draft-hares-idr-bgp-ipsec-analysis-00.txt so the authors could tell me what I misunderstood.   You’ll find this draft stops half way.  I have the rest of the draft written, but I wanted feedback from all the author teams before sending it out.

After hearing some of the details from the authors, I would like to sponsor an IDR interim so we could discuss these issues at length.   If you think this is a good idea, please let me know.

One other thing… unfortunately, I scheduled a set of meetings for EDT time after IETF meetings this week.   Your next response will occur from 11-16 UTC on Wednesday.

Cheerily, Sue

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 31 Jul 2020 08:01:53 -0400

Ali:

It is wise to start with the RFC6514 and the draft-ietf-idr-tunnel-encapsulation draft.   

[WG chair hat on] 

The tunnel-encapsulation draft has passed general WG LC – so it is inappropriate to call for the request to remove these sections.  The WG LC that is currently running is whether to remove the “AS” field from the tunnel endpoint field, and replace it with a reserved field. 

The implementation page is on: 

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-tunnel-encaps%20implementations

If you wish to provide information on the cisco implementation, you are welcome to add information on the page. 

I can call for an update to the page from vendors.

[WG chair hat off[

[Document shepherd hat on] 

The issue is during the edits the text from RFC6514 from Eric Rosen was unclear.  The text was: 

   It has been suggested that it may sometimes be useful to attach a

   Tunnel Encapsulation attribute to a BGP UPDATE message that is also

   carrying a PMSI (Provider Multicast Service Interface) Tunnel

   attribute [ <https://datatracker.ietf.org/doc/html/rfc6514> RFC6514].  If the PMSI Tunnel attribute specifies an IP

   tunnel, the Tunnel Encapsulation attribute could be used to provide

   additional information about the IP tunnel.  The usage of the Tunnel

   Encapsulation attribute in combination with the PMSI Tunnel attribute

   is outside the scope of this document.

Since the text itself was unclear what additional information could be provided, the authors removed it from the draft. 

As we had not received any feedback about active RFC6514 interactions on the list. 

[document shepherd off]

If you have an implementation of the interaction between the RF6514 and tunnel encapsulation, it would be valuable to provide:

a)  either a draft specifying the interaction you wish to IDR WG, or  

b)  comments that could replace the original the original text. 

Since the IDR draft has gone through multiple WG LC and a very complete review from Alvaro – so a quick response would be appreciated.   IMHO a draft on the interaction between RFC6514 and the tunnel-encapsulation draft – would be the best thing at this point.  Let me know if you are interested in working on such a draft. 

Sue 

From: Ali Sajassi (sajassi) [mailto:[email-masked]] 
Sent: Friday, July 31, 2020 1:54 AM
To: Susan Hares; [email-masked]; [email-masked]
Cc: 'Hu, Jun (Nokia - US/Mountain View)'
Subject: Re: IPSec Tunnels and draft-sajassi-bess-secure-evpn 

<added [email-masked]>

Sue,

Cheers,

Ali

Ali and bess WG: 

Cheerily, Sue

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Sat, 1 Aug 2020 01:18:15 +0000

Sue,

I am afraid if we don’t clean up the draft, it can cause confusion as it has already and result in immediate errata filing for it after publication. A sub-bullet got added to the latest rev (rev17) that is not correct. It says that the VxLAN sub-tlv is sent with EVPN route when V bit not set. However, EVPN never uses this sub-tlv as its routes has all the needed info. Furthermore, RFC 8365 is very clear that EVPN uses Tunnel Encapsulation Extended Community (per section 4.1). As I said, I am not aware of any of the vendors using these sub-TVLs and it is easy to have a quick poll.

Regarding the paragraph that got omitted, it is making it much more ambiguous than it used to. I would opt for clarifying the paragraph rather than removing it. If needed I can provide an updated paragraph. Section 9 of RFC 8365 specifies how a VPN multicast route can be advertised with PMSI tunnel attribute and Encapsulation extended community and has been implemented by many vendors.

Cheers,
Ali

From: Susan Hares <[email-masked]>
Date: Friday, July 31, 2020 at 5:02 AM
To: Cisco Employee <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "'Hu, Jun (Nokia - US/Mountain View)'" <[email-masked]>
Subject: RE: IPSec Tunnels and draft-sajassi-bess-secure-evpn

Ali:

[WG chair hat on]

[WG chair hat off[

   attribute [RFC6514<https://datatracker.ietf.org/doc/html/rfc6514>].  If the PMSI Tunnel attribute specifies an IP

[document shepherd off]

Sue

<added [email-masked]>

Sue,

Cheers,
Ali

Ali and bess WG:

Cheerily, Sue