Subject: [Idr] I-D Action: draft-ietf-idr-flow-spec-v6-12.txt

From: [email-masked]
Date: Fri, 10 Jul 2020 12:31:28 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Dissemination of Flow Specification Rules for IPv6
        Authors         : Christoph Loibl
                          Robert Raszuk
                          Susan Hares
	Filename        : draft-ietf-idr-flow-spec-v6-12.txt
	Pages           : 16
	Date            : 2020-07-10

Abstract:
   Dissemination of Flow Specification Rules I-D.ietf-idr-rfc5575bis
   provides a protocol extension for propagation of traffic flow
   information for the purpose of rate limiting or filtering.  I-D.ietf-
   idr-rfc5575bis specifies those extensions for IPv4 protocol data
   packets only.

   This specification extends I-D.ietf-idr-rfc5575bis and defines
   changes to the original document in order to make it also usable and
   applicable to IPv6 data packets.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-flow-spec-v6/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-flow-spec-v6-12
https://datatracker.ietf.org/doc/html/draft-ietf-idr-flow-spec-v6-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-flow-spec-v6-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Christoph Loibl <[email-masked]>
Date: Fri, 10 Jul 2020 21:48:55 +0200

Hi IDR,

I just uploaded a new revision of draft-ietf-idr-flow-spec-v6-12.txt This revision addresses the following issues:

*) Issue raised in the shepherd’s report

*) Issues that have been raised during the IESG review of rfc5575bis and are of exactly the same nature:

	.) The SHOULD/MUST constructs in the component types encoding formats (the WG agreed to change this in rfc5575bis) to MUST/MUST

	.) Copied the last paragraph of ICMPv6 type to ICMPv6 code (same has been done in rfc5575bis)

	.) The IPv6 component type registration policy added and identical to the rfc5575bis component type registry (see latest post from John Scudder on this topic).

	.) Added the full python module for the sorting algorithm.

*) Changed all obsolete references to RFC 2460 to point to RFC 8200

For details I suggest to review the changes via rfcdiff:

https://www.ietf.org/rfcdiff?url1=draft-ietf-idr-flow-spec-v6-11&url2=draft-ietf-idr-flow-spec-v6-12

Cheers 

Christoph 

-- 
Christoph Loibl
[email-masked] | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

> On 10.07.2020, at 21:31, [email-masked] wrote:
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr