Subject: [Idr] Fwd: I-D Action: draft-zzhang-idr-bitmask-route-target-00.txt

From: Robert Raszuk <[email-masked]>
Date: Mon, 13 Jul 2020 08:49:53 +0200

Hi,

While bitmask has its own use don't you think that while making RT
structure more flexible we should also define the notion of RT prefix ?

That way filtering across groups or areas or ASNs could be very easy and
intuitive.

Thx,
R.

---------- Forwarded message ---------
From: <[email-masked]>
Date: Mon, Jul 13, 2020 at 3:02 AM
Subject: I-D Action: draft-zzhang-idr-bitmask-route-target-00.txt
To: <[email-masked]>

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

        Title           : Bitmask Route Target
        Authors         : Zhaohui Zhang
                          Srihari Sangli
                          Jeffrey Haas
        Filename        : draft-zzhang-idr-bitmask-route-target-00.txt
        Pages           : 5
        Date            : 2020-07-12

Abstract:
   This document specifies a new type of Route Target called Bitmask
   Route Target as a BGP Community Container.  The key element of a
   Bitmask Route Target is a Bitmask.  Two Bitmask Route Targets are
   considered equivalent for the purpose of controlling route
   propagation (via Route Target Constraints) and importation if the
   result of logical "AND" operation of the Bitmask of the two is non-
   zero.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-zzhang-idr-bitmask-route-target/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-zzhang-idr-bitmask-route-target-00
https://datatracker.ietf.org/doc/html/draft-zzhang-idr-bitmask-route-target-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 13 Jul 2020 10:16:11 +0000

If I understand it correctly, that concept is already used in RTC for the control of route propagation. Are you referring to using it for importation as well?

That seems to be just a matter of locally configuring a RTC membership for the purpose of route importation?

Jeffrey

Sent from my iPhone

On Jul 13, 2020, at 2:50 AM, Robert Raszuk <[email-masked]> wrote:

[External Email. Be cautious of content]

Hi,

While bitmask has its own use don't you think that while making RT structure more flexible we should also define the notion of RT prefix ?

That way filtering across groups or areas or ASNs could be very easy and intuitive.

Thx,
R.

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Mon, Jul 13, 2020 at 3:02 AM
Subject: I-D Action: draft-zzhang-idr-bitmask-route-target-00.txt
To: <[email-masked]<mailto:[email-masked]>>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-zzhang-idr-bitmask-route-target/<https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-zzhang-idr-bitmask-route-target/__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tAu1ci_T$>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-zzhang-idr-bitmask-route-target-00<https://urldefense.com/v3/__https://tools.ietf.org/html/draft-zzhang-idr-bitmask-route-target-00__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tC_K5Kga$>
https://datatracker.ietf.org/doc/html/draft-zzhang-idr-bitmask-route-target-00<https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-zzhang-idr-bitmask-route-target-00__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tGCfXsOz$>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http://tools.ietf.org__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tHAMEfVM$>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tP-azqXc$>

_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/i-d-announce__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tLdaza6z$>
Internet-Draft directories: http://www.ietf.org/shadow.html<https://urldefense.com/v3/__http://www.ietf.org/shadow.html__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tNIbC7W5$>
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt<https://urldefense.com/v3/__ftp://ftp.ietf.org/ietf/1shadow-sites.txt__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tKpPpARY$>

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 13 Jul 2020 15:36:56 +0200

HI,

While you can go and touch 1000s of PEs to add another import
statement there are cases when it would be convenient to advertise RT as
prefix.

Example ... I would like to add a new mgmt route to all VRFs with say
NO-EXPORT. I know that I can import ASN:XXXXXX So if I advertise RT ASN/32
it should get imported by any existing import RT statement which already is
importing ASN:*

Today correct me but I am not sure there is any way to attach and propagate
an RT as a prefix.

Not only basic 4364 but also RTC itself could benefit from it :).

Thx,
R.

On Mon, Jul 13, 2020 at 12:16 PM Jeffrey (Zhaohui) Zhang <[email-masked]>
wrote:

> If I understand it correctly, that concept is already used in RTC for the
> control of route propagation. Are you referring to using it for importation
> as well?
>
> <https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-zzhang-idr-bitmask-route-target/__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tAu1ci_T$>
>
> <https://urldefense.com/v3/__https://tools.ietf.org/html/draft-zzhang-idr-bitmask-route-target-00__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tC_K5Kga$>
>
> <https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-zzhang-idr-bitmask-route-target-00__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tGCfXsOz$>
>
>
> until the htmlized version and diff are available at tools.ietf.org
> <https://urldefense.com/v3/__http://tools.ietf.org__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tHAMEfVM$>
> .
>
> <https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tP-azqXc$>
>
>
> <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/i-d-announce__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tLdaza6z$>
> <https://urldefense.com/v3/__http://www.ietf.org/shadow.html__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tNIbC7W5$>
> <https://urldefense.com/v3/__ftp://ftp.ietf.org/ietf/1shadow-sites.txt__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tKpPpARY$>
>
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 13 Jul 2020 13:52:46 +0000

Let me see if I understood you correctly.

In my previous email, I was saying that we configure a RTC ASN/32 on each router (and each VRF for your example) to match a route’s attached more specific RTs for route importation purpose. That would be too much provisioning and your proposal is to attach a RT ASN/32 to the route and it will match all more specific local RTs that has that ASN in the Global Admin field.

Sounds interesting.

Jeffrey

Juniper Business Use Only
From: Robert Raszuk <[email-masked]>
Sent: Monday, July 13, 2020 9:37 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: Srihari Sangli <[email-masked]>; Jeff Haas <[email-masked]>; idr@ietf. org <[email-masked]>
Subject: Re: I-D Action: draft-zzhang-idr-bitmask-route-target-00.txt

HI,

While you can go and touch 1000s of PEs to add another import statement there are cases when it would be convenient to advertise RT as prefix.

Example ... I would like to add a new mgmt route to all VRFs with say NO-EXPORT. I know that I can import ASN:XXXXXX So if I advertise RT ASN/32 it should get imported by any existing import RT statement which already is importing ASN:*

Today correct me but I am not sure there is any way to attach and propagate an RT as a prefix.

Thx,
R.

On Mon, Jul 13, 2020 at 12:16 PM Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>> wrote:
If I understand it correctly, that concept is already used in RTC for the control of route propagation. Are you referring to using it for importation as well?

Jeffrey
Sent from my iPhone

On Jul 13, 2020, at 2:50 AM, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Thx,
R.
---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Mon, Jul 13, 2020 at 3:02 AM
Subject: I-D Action: draft-zzhang-idr-bitmask-route-target-00.txt
To: <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-zzhang-idr-bitmask-route-target/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-zzhang-idr-bitmask-route-target/__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tAu1ci_T$>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-zzhang-idr-bitmask-route-target-00<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-zzhang-idr-bitmask-route-target-00__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tC_K5Kga$>
https://datatracker.ietf.org/doc/html/draft-zzhang-idr-bitmask-route-target-00<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-zzhang-idr-bitmask-route-target-00__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tGCfXsOz$>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tHAMEfVM$>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://urldefense.com/v3/__ftp:/ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tP-azqXc$>

_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/i-d-announce__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tLdaza6z$>
Internet-Draft directories: http://www.ietf.org/shadow.html<https://urldefense.com/v3/__http:/www.ietf.org/shadow.html__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tNIbC7W5$>
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt<https://urldefense.com/v3/__ftp:/ftp.ietf.org/ietf/1shadow-sites.txt__;!!NEt6yMaO-gk!QBATyOcl6BcLqTZHucumuEBzuvnVxWuj3QOsgfrcwHhQFGGotvmk6JV-tKpPpARY$>