Subject: [Idr] WG status - 7/14/2020 (before shepherd reports)

From: "Susan Hares" <[email-masked]>
Date: Tue, 14 Jul 2020 15:43:46 -0400

Greetings: 

There are a number of WG LCs, shepherd reports, 

and design status  updates outstanding for the Group.   

Rather than wait for status after finishing all the shepherd reviews,

I'm going to announce the status before/after I finish the reviews. 

I have two drafts that I urgently need submitted for update: 

1) draft-ietf-idr-wide-bgp-communities-05.txt - we have 2 implementations. 

   It is time to complete our work on this draft

2) draft-ietf-idr-ext-opt-param-09.txt - the IANA early assignment 

   will disappear in august unless I get an updated draft. 

Please let me know if you can at least do this on 7/28/2020. 

Status Report 

----------------

WG LC on on RFC, but needing some change: 

1) draft-ietf-rfc5575bis-25 - WG LC on solution to IANA closes today (6/30 -
7/14) 

https://mailarchive.ietf.org/arch/msg/idr/ug9vTri1Ezf1HFfp71qfqX-d0gU/

This proposes making [128.255] change from FCFS to expert review. 

Reason: Expert Review will be required until we decide what to do about 

Flow-specification V2 (plan for fall Interim in September). 

At AD review 

=============

1)  <https://datatracker.ietf.org/doc/draft-ietf-idr-tunnel-encaps/>
draft-ietf-idr-tunnel-encaps-16.txt - 

  Planned: WG LC on Tunnel Endpoint Sub-TLV AS field going to reserved

    Query for Feedback from implementers on change 

   Status:  Awaiting new shepherd review and Alvaro's feedback.  

2) draft-ietf-idr-rfc8203bis-06.txt

     IETF LC + AD review comments require revision: 

     Status: Waiting on the authors  revision so 

          Alvaro can schedule IESG review 

3) draft-ietf-idr-flowspec-oid-12.txt 

      Status: Awaiting AD's review (aka in Alvaro's queue)

      Question:  RTG-Review requested combination of 

           RFC5575bis base, flowspec-v6, and oid 

          to improve document would make sense to operators. 

         Should we do this? 

Ready for publication later today

-----------------------------------------

4) draft-ietf-idr-flow-spec-v6-11.txt 

   Shepherd: Jie Dong

   Status: Ready for publication, waiting on the results of poll on 

                  RFC5575bis 

Next in the Shepherd's queue: 

-----------------------------------------

1)  draft-ietf-idr-bgp-ls-registry-txt-01 

    ETA:  7/14/2020 

2) draft-ietf-idr-eag-distribution-12  

[2 cisco implementations] 

   Shepherd report ETA:  7/14/2020 

3) draft-ietf-ext-opt-param implementations 

    Shepherd Report ETA: 7/14/2020

    I need implementation people to contact me off list. 

    The implementation report needs to additional input. 

4)  draft-ietf-idr-ext-opt-param-09.txt

      Shepherd report:  need updated draft

      ETA:  2 days after update posted 

5) draft-ietf-idr-open-policy-11.txt 

    Status: 2 implementations

    WG LC completed, Ready for publication 

    Shepherd Report ETA: 7/15/2020 

Past WG LC waiting for implementation 

================

1) draft-ietf-idr-flowspec-l2vpn

    Status: Past WG LC, awaiting implementations 

    Note: All WG drafts not at IESG for publication 

       will be reviewed in fall 2020.  

     WG LC: 6/24 to 7/8 

WG LC during 7/14 to 7/28/2020 

=========================

1) draft-ietf-idr-rpd-05.txt 

     Status: 2 implementation 

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-rpd%20implementations

     IPR call: 6/24 to  7/1 (started delayed due to IP response) 

2) draft-ietf-bgp-ls-app-specific-attr

     Status: 2 implementations record 

3) draft-ietf-idr-bgp-ls-sbfd-extensions 

     Status: 1 implementation recorded

WG LCs awaiting resolution of topics in LSR

1. draft-ietf-idr-bgp-ls-flex-algo-03.txt

Potential WG L 

1.  draft-ietf-idr-bgpls-srv6-ext-02.txt 

   Status: Ready?  (Did I miss a call for this one?)  

Early Allocation Requests

=======================

None in progress 

Design Groups reports:  bgp-autoconf

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 14 Jul 2020 21:49:55 +0200

Hi Sue,

Can you clarify chair's status on Optimal Route Reflection draft ? It is
passed WG LC long time back.

After review by Alvaro his comments triggered number of clarifications in
the text and now Alvaro cleared it to be moved to IESG.

Yet I do not see it even present on your list .....

Many thx,
Robert.

On Tue, Jul 14, 2020 at 9:44 PM Susan Hares <[email-masked]> wrote:

> I’m going to announce the status before/after I finish the reviews.
>
>
>
> 1) draft-ietf-idr-wide-bgp-communities-05.txt – we have 2 implementations.
>
> 1) draft-ietf-rfc5575bis-25 – WG LC on solution to IANA closes today (6/30
> – 7/14)
>
>
>
> This proposes making [128…255] change from FCFS to expert review.
>
> 1) draft-ietf-idr
> <https://datatracker.ietf.org/doc/draft-ietf-idr-tunnel-encaps/>-tunnel-encaps-16.txt
> –
>
>    Status:  Awaiting new shepherd review and Alvaro’s feedback.
>
>
>
>       Status: Awaiting AD’s review (aka in Alvaro’s queue)
>
> Next in the Shepherd’s queue:
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 14 Jul 2020 16:34:25 -0400

Robert: 

The silence was because I had not realized Alvaro had cleared 

it to be moved to the  IESG.    It goes to the head of the 

list of the shepherd checks.  I’ll try to finish that review today. 

Here’s the new list of shepherd work

1) optimal route reflection 

    ETA: 7/14/2020   

2)  draft-ietf-idr-bgp-ls-registry-txt-01 

    ETA:  7/14/2020 

   Shepherd report ETA:  7/15/2020 

4) draft-ietf-idr-open-policy-11.txt 

5) draft-ietf-ext-opt-param implementations 

    Shepherd Report ETA:  TBD   

    Shepherd report:  need updated draft + implementation specific 

 Sue Hares 

From: Idr [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Tuesday, July 14, 2020 3:50 PM
To: Susan Hares
Cc: idr@ietf. org
Subject: Re: [Idr] WG status - 7/14/2020 (before shepherd reports)

Hi Sue,

Can you clarify chair's status on Optimal Route Reflection draft ? It is passed WG LC long time back. 

After review by Alvaro his comments triggered number of clarifications in the text and now Alvaro cleared it to be moved to IESG. 

Many thx,
Robert..

Greetings: 

Status Report 

----------------

1) draft-ietf-rfc5575bis-25 – WG LC on solution to IANA closes today (6/30 – 7/14) 

At AD review 

=============

1)  <https://datatracker.ietf.org/doc/draft-ietf-idr-tunnel-encaps/> draft-ietf-idr-tunnel-encaps-16.txt – 

   Status:  Awaiting new shepherd review and Alvaro’s feedback..  

         Should we do this? 

   Shepherd: Jie Dong

                  RFC5575bis 

    ETA:  7/14/2020 

================

     WG LC: 6/24 to 7/8 

     Status: 2 implementation 

Potential WG L 

=======================

None in progress