Subject: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

From: "Susan Hares" <[email-masked]>
Date: Tue, 14 Jul 2020 15:22:42 -0400

This begins a 2 week WG LC for draft-ietf-bgp-ls-app-specific-attr-02.txt.  

You can find the draft at: 

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-app-specific-attr/

You can find the implementations reports at:

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgp-ls-app-specific-attr%
20implementations

This is a rather short draft (real text about 8 pages), and the 

the corresponding OSPF and ISIS drafts have recently approved by the IESG.

Therefore, we are going to combine WG LC and IPR together. 

In your comments please consider: 

1) Do you feel this draft is ready for publication? 

2) Do you know of deployments of these 2 implementations from Cisco? 

Are the features useful in these deployments?

3) Do you have any concerns regarding this technology? 

Also, please mention support/no support in your reply. 

Cheerily, Sue 

(co-chair and shepherd for draft).

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 14 Jul 2020 16:20:53 -0700

Sue,

As co-author I support the publication, not aware of any IPR associated with the draft.

Cheers,
Jeff
On Jul 14, 2020, 12:23 PM -0700, Susan Hares <[email-masked]>, wrote:
> https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgp-ls-app-specific-attr%20implementations
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 14 Jul 2020 23:41:14 +0000

Hi Sue,
I support publication. This draft is needed to support the IS-IS and OSPF application-specific attribute drafts on the RFC Queue. I have some editorial comments to align with these documents that I’ll post prior to WG last call end.
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Tuesday, July 14, 2020 at 3:23 PM
To: IDR List <[email-masked]>
Subject: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Cheerily, Sue

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 14 Jul 2020 20:41:26 -0400

Acee: 

Thank you for sending the editorial comments.   I’ve learned from getting Alvaro’s detailed reviews that I want all the editorial comments considered before I sent it into Alvaro. 

Sue 

From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Tuesday, July 14, 2020 7:41 PM
To: Susan Hares; 'idr@ietf. org'
Subject: Re: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Hi Sue, 

Thanks,
Acee

Cheerily, Sue

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 15 Jul 2020 05:02:39 +0000

Hi Sue,

I believe the document is ready for progression towards publication and not aware of any related IPR as a co-author.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: 15 July 2020 00:53
To: 'idr@ietf. org' <[email-masked]>
Subject: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Cheerily, Sue

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 15 Jul 2020 05:06:27 +0000

Also, please find answers to specific questions:

KT> Yes.

KT> Yes, I am aware of deployment plans. The extension in the document is used by controller to learn link attributes specific to an application (viz. SR and Flex Algo).

KT> No

From: Ketan Talaulikar (ketant)
Sent: 15 July 2020 10:33
To: Susan Hares <[email-masked]>; 'idr@ietf. org' <[email-masked]>
Subject: RE: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Hi Sue,

Thanks,
Ketan

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Susan Hares
Sent: 15 July 2020 00:53
To: 'idr@ietf. org' <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Cheerily, Sue

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 18 Jul 2020 20:03:23 +0000

Hi Authors, Sue,

I’ve suggested looks like a lot of changes (see attached). However, many of them are fall into these categories.

  1.  Hyphenate application-specific when the term is used as a compound adjective (as we did in the IGP documents).
  2.  Use “that” rather than “which” when it introduces a defining clause.
  3.  Use “advertised” rather than “sourced” – this is somewhat subjective and I’ll leave it to the discretion of the authors.

In general, I think the details of the procedures are well thought out.

Thanks,
Acee

From: Susan Hares <[email-masked]>
Date: Tuesday, July 14, 2020 at 8:41 PM
To: Acee Lindem <[email-masked]>, IDR List <[email-masked]>
Subject: RE: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Acee:

Sue

Hi Sue,

Cheerily, Sue

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 18 Jul 2020 20:27:38 +0000

It seems I should apply the same scrutiny to my Emails as I do to draft reviews… 😉
Acee

From: Idr <[email-masked]> on behalf of "Acee Lindem (acee)" <acee=[email-masked]>
Date: Saturday, July 18, 2020 at 4:14 PM
To: Susan Hares <[email-masked]>, IDR List <[email-masked]>
Subject: Re: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Hi Authors, Sue,

Thanks,
Acee

Acee:

Sue

Hi Sue,

Cheerily, Sue

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sun, 19 Jul 2020 04:50:00 +0000

Hi Acee,

Thanks for your review and we’ve incorporated all of your comments. These would be included in the next update.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: 19 July 2020 01:58
To: Acee Lindem (acee) <acee=[email-masked]>; Susan Hares <[email-masked]>; 'idr@ietf. org' <[email-masked]>
Subject: Re: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <acee=[email-masked]<mailto:acee=[email-masked]>>
Date: Saturday, July 18, 2020 at 4:14 PM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Hi Authors, Sue,

Thanks,
Acee

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 14, 2020 at 8:41 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Acee:

Sue

Hi Sue,

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 14, 2020 at 3:23 PM
To: IDR List <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Cheerily, Sue

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sun, 26 Jul 2020 05:06:50 +0000

Hi All,

Just wanted to share that an updated version with the following changes has just been posted : https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-app-specific-attr-03

Thanks,
Ketan

Sent: 19 July 2020 10:20

Hi Acee,

Thanks,
Ketan

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Acee Lindem (acee)
Sent: 19 July 2020 01:58
To: Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; 'idr@ietf. org' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] draft-ietf-idr-bgp-ls-app-specific-attr - IPR Call and WG LC (7/14 to 7/29/2020)

Hi Authors, Sue,

Thanks,
Acee

Acee:

Sue

Hi Sue,

Cheerily, Sue