Subject: [Idr] I-D Action: draft-ietf-idr-segment-routing-te-policy-10.txt

From: [email-masked]
Date: Mon, 02 Nov 2020 02:59:17 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Advertising Segment Routing Policies in BGP
        Authors         : Stefano Previdi
                          Clarence Filsfils
                          Ketan Talaulikar
                          Paul Mattes
                          Eric Rosen
                          Dhanendra Jain
                          Steven Lin
	Filename        : draft-ietf-idr-segment-routing-te-policy-10.txt
	Pages           : 47
	Date            : 2020-11-02

Abstract:
   This document defines a new BGP SAFI with a new NLRI in order to
   advertise a candidate path of a Segment Routing (SR) Policy.  An SR
   Policy is a set of candidate paths, each consisting of one or more
   segment lists.  The headend of an SR Policy may learn multiple
   candidate paths for an SR Policy.  Candidate paths may be learned via
   a number of different mechanisms, e.g., CLI, NetConf, PCEP, or BGP.
   This document specifies the way in which BGP may be used to
   distribute SR Policy candidate paths.  New sub-TLVs for the Tunnel
   Encapsulation Attribute are defined for signaling information about
   these candidate paths.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-10
https://datatracker.ietf.org/doc/html/draft-ietf-idr-segment-routing-te-policy-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-segment-routing-te-policy-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 2 Nov 2020 11:05:18 +0000

Hi All,

We've just posted an updated version for this draft and following is the summary of key changes:

1) Updates for new TLVs for alignment with the latest draft-ietf-spring-segment-routing-policy
	a) added SR Policy Name sub-TLV
2) Updates related to SRv6 for alignment with draft-ietf-spring-srv6-network-programming and draft-ietf-spring-segment-routing-policy
	a) added SRv6 BSID sub-TLV and clarifications for existing BSID sub-TLV use with SRv6
	b) updated SRv6 related Segment Type encoding and deprecated older ones for backward compatibility (moved to appendix)
3) Updates to IANA sections for the allocation of CO bit for alignment with Tunnel Encaps draft
4) Editorial changes/updates for clarifications

Looking forward to review and feedback from the WG.

Thanks,
Ketan (on behalf of co-authors)

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of [email-masked]
Sent: 02 November 2020 16:29
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-segment-routing-te-policy-10.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr