Subject: [Idr] I-D Action: draft-ietf-idr-rfc7752bis-05.txt

From: [email-masked]
Date: Mon, 02 Nov 2020 02:42:08 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Distribution of Link-State and Traffic Engineering Information Using BGP
        Author          : Ketan Talaulikar
	Filename        : draft-ietf-idr-rfc7752bis-05.txt
	Pages           : 62
	Date            : 2020-11-02

Abstract:
   In a number of environments, a component external to a network is
   called upon to perform computations based on the network topology and
   current state of the connections within the network, including
   Traffic Engineering (TE) information.  This is information typically
   distributed by IGP routing protocols within the network.

   This document describes a mechanism by which link-state and TE
   information can be collected from networks and shared with external
   components using the BGP routing protocol.  This is achieved using a
   new BGP Network Layer Reachability Information (NLRI) encoding
   format.  The mechanism is applicable to physical and virtual IGP
   links.  The mechanism described is subject to policy control.

   Applications of this technique include Application-Layer Traffic
   Optimization (ALTO) servers and Path Computation Elements (PCEs).

   This document obsoletes RFC 7752 by completely replacing that
   document.  It makes a number of small changes and clarifications to
   the previous specification.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-rfc7752bis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-rfc7752bis-05
https://datatracker.ietf.org/doc/html/draft-ietf-idr-rfc7752bis-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-rfc7752bis-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 2 Nov 2020 10:53:00 +0000

Hi All,

An update has just been posted for the RFC7752 (BGP-LS) bis draft and following is the summary of changes:

- Clarification on which OSPFv2/v3 TLVs can be natively encoded into the Opaque Node, Link and Prefix Attribute TLVs. This is because unlike ISIS, OSPF has a per LSA type TLV space and this brings rise to ambiguity on how these opaque information would actually get parsed by a receiver.
- Clarification on the length of IGP Flags TLV
- Clarification that advertisement of OSPF Virtual Links in BGP-LS are outside the scope of this document
- Clarification on how OSPF Sham Links may be advertised in BGP-LS
- Clarification that advertisement of information in OSPFv2 Type 4 LSA & OSPFv3 Inter-Area-Router-LSA are outside the scope of this document
- Updated the IANA sections to include some flags registries for a few TLVs that were previously missed out.

These were the last set of updates that I had in my edit buffer for this document in response to online/offline comments from the WG participants. 

Please do let know if there are any other aspects that remain to be addressed with respect to this document before we can progress it towards WGLC.

Thanks,
Ketan

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of [email-masked]
Sent: 02 November 2020 16:12
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-rfc7752bis-05.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr