Subject: [Idr] Barry Leiba's No Objection on draft-ietf-idr-flow-spec-v6-18: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Sun, 01 Nov 2020 07:32:07 -0800

Barry Leiba has entered the following ballot position for
draft-ietf-idr-flow-spec-v6-18: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-idr-flow-spec-v6/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for clearing up my confusion on the DISCUSS point that I had, and for
posting -18 with resolutions to that and my comments.

I’ll leave the remaining comment here for the record, leaving it for the
editors to do what they think best.

   In the case Length minus Offset is 0 every address matches.  Length
   MUST always be in the range 0-128 and Length minus Offset MUST always
   be 0 or more, otherwise this component is malformed.

Is there actually value in allowing 129 ways to match every address
(length=offset=0, length=offset=1, length=offset=87, and so on)?  If not, it
seems less prone to error to say that length=offset=0 matches every address,
and otherwise length MUST be greater than offset or the component is malformed.
 No?

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 2 Nov 2020 00:13:02 -0500

Barry: 

My co-authors reminded me that the WG did not really come down strongly on the offset text.  They also felt that your proposal cleans up the text.  If Christoph can put out the document before the WG draft submission deadline, you may see it in the next version.  

Thanks for the great suggestions after a fresh read on the document. 

Cheerily, Susan Hares 

-----Original Message-----
From: Barry Leiba via Datatracker [mailto:[email-masked]] 
Sent: Sunday, November 1, 2020 10:32 AM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; Jie Dong; [email-masked]; [email-masked]
Subject: Barry Leiba's No Objection on draft-ietf-idr-flow-spec-v6-18: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thanks for clearing up my confusion on the DISCUSS point that I had, and for posting -18 with resolutions to that and my comments.

I’ll leave the remaining comment here for the record, leaving it for the editors to do what they think best.

Is there actually value in allowing 129 ways to match every address (length=offset=0, length=offset=1, length=offset=87, and so on)?  If not, it seems less prone to error to say that length=offset=0 matches every address, and otherwise length MUST be greater than offset or the component is malformed.
 No?

---

From: Christoph Loibl <[email-masked]>
Date: Mon, 2 Nov 2020 18:29:50 +0100

Susan, Barry, IDR

I uploaded the -19 that includes the cleanup as discussed:

Section 3.1., paragraph 7:
OLD:

NEW:

    Length = Offset = 0 matches every address, otherwise Length MUST be
    in the range Offset < Length < 129 or the component is malformed.

I hope this is clear. Maybe still some minor rewording is needed.

Cheers Christoph

-- 
Christoph Loibl
[email-masked] | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

> On 02.11.2020, at 06:13, Susan Hares <[email-masked]> wrote:
> 
> Barry: 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Barry Leiba <[email-masked]>
Date: Tue, 3 Nov 2020 10:54:54 -0500

Thanks, Christoph.  That looks great to me.

Barry