Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

From: "Susan Hares" <[email-masked]>
Date: Sun, 1 Nov 2020 21:19:26 -0500

This begins a 2 week WG LC for  draft-ietf-idr-bgp-ls-flex-algo-04.txt 

(11/1 to 11/16).   

The authors should send their IPR statements by Tuesday (11/3)

or this WG LC will be extended 1 extra week. 

You can access the draft at: 

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-flex-algo/

This draft is also needed to match BGP work to LSR specification 

for draft-ietf-lsr-flex-algo-13.txt (at IESG). 

There are 2 Cisco implementations of draft-ietf-idr-bgp-ls-flex-algo. 

Details on the implementations are at:

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgp-ls-flex-algo%20implem
entations

WG members should consider in their response: 

a) Are there technical issues with the flexible algorithm technology? 

b) Is this draft ready for publication? 

c) Will this technology aid LSR deployments? 

d) Are you concerned about the 2 implementations coming 

only from Cisco? 

If you know of any other planned implementations, please send 

Chairs this information or respond to this email to inform the WG. 

Cheers, Susan Hares

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 2 Nov 2020 04:42:15 +0000

Hi Sue,

I am not aware of any IPR related to this document and support progressing it towards publication as a co-author.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: 02 November 2020 07:49
To: [email-masked]
Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

There are 2 Cisco implementations of draft-ietf-idr-bgp-ls-flex-algo.
Details on the implementations are at:
https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-bgp-ls-flex-algo%20implementations

Cheers, Susan Hares

---

From: Gaurav Dawra <[email-masked]>
Date: Sun, 1 Nov 2020 21:43:33 -0800

Hi Sue

Not aware of any IPR

Support as co-author.

Gaurav

Sent from my iPhone

> On Nov 1, 2020, at 6:19 PM, Susan Hares <[email-masked]> wrote:
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Peter Psenak <[email-masked]>
Date: Mon, 2 Nov 2020 10:13:15 +0100

Hi Susan,

I'm not aware of any undisclosed IPRs related to this draft.

thanks,
Peter

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 2 Nov 2020 12:42:43 +0000

I support publication.
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Sunday, November 1, 2020 at 9:21 PM
To: IDR List <[email-masked]>
Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Cheers, Susan Hares

---

From: Lizhenbin <[email-masked]>
Date: Tue, 3 Nov 2020 08:18:58 +0000

Hi All,

I support the WG LC of the draft.

Best Regards,

Zhenbin (Robin)

--------------------------------------------------
李振斌 Li Zhenbin
Mobile: +86-13651017745<tel:+86-13651017745>/+968-91797068
Email: [email-masked]<mailto:[email-masked]>

发件人：Susan Hares <[email-masked]>
收件人：idr <[email-masked]>
时 间：2020-11-02 10:20:41
主 题：[Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Cheers, Susan Hares

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 3 Nov 2020 12:35:51 +0000

Hi Sue, All,

Support to progress this draft.
Please be aware that no code point is assigned yet to the Flex Algo Exclude SRLG TLV (chapter 3.5 of draft BGP-LS Extensions for Flex-Algo).

Nokia has an implementation of this draft.

G/

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Monday, November 2, 2020 03:19
To: [email-masked]
Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Cheers, Susan Hares

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 3 Nov 2020 12:54:30 +0000

Hi Gunter,

You are correct that early allocation has not been yet made for the FA Exclude SRLG TLV. This was because none of the authors had (yet) got to implement it and there was no request received for it.

IMHO we should go ahead with a parallel request for early allocation if it is holding up an implementation. Do let know if we need to and if not wait for it happen at publication time.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Van De Velde, Gunter (Nokia - BE/Antwerp)
Sent: 03 November 2020 18:06
To: Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Hi Sue, All,

G/

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Susan Hares
Sent: Monday, November 2, 2020 03:19
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Cheers, Susan Hares

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 3 Nov 2020 13:06:05 +0000

Hi Ketan,

Thanks for the info.
Having early allocation code point will help me to progress Nokia implementation.

Kind Regards,
G/

From: Ketan Talaulikar (ketant) <[email-masked]>
Sent: Tuesday, November 3, 2020 13:55
To: Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Subject: RE: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Hi Gunter,

Thanks,
Ketan

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Van De Velde, Gunter (Nokia - BE/Antwerp)
Sent: 03 November 2020 18:06
To: Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Hi Sue, All,

G/

Cheers, Susan Hares

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 3 Nov 2020 12:27:05 -0800

yes/support

Cheers,
Jeff

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Tue, 3 Nov 2020 21:58:08 +0000

Support.

Regards,
Jakob.

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Sunday, November 1, 2020 6:19 PM
To: [email-masked]
Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)

Cheers, Susan Hares

---

From: Yingzhen Qu <[email-masked]>
Date: Tue, 3 Nov 2020 14:13:27 -0800

I support the publication of this draft.

Thanks,
Yingzhen

On Tue, Nov 3, 2020 at 1:58 PM Jakob Heitz (jheitz) <jheitz=
[email-masked]> wrote:

> Support.
>
>
>
> Regards,
>
> Jakob.
>
>
>
> *From:* Idr <[email-masked]> *On Behalf Of * Susan Hares
> *Sent:* Sunday, November 1, 2020 6:19 PM
> *To:* [email-masked]
> *Subject:* [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt
> (11/1 to 11/16)
>
>
>

---

From: "Krishna Muddenahally Ananthamurthy (kriswamy)" <[email-masked]>
Date: Thu, 12 Nov 2020 17:36:22 +0000

I support.

Thanks
Krishna

From: Idr <[email-masked]>
Date: Sunday, November 1, 2020 at 6:20 PM
To: [email-masked] <[email-masked]>
Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt (11/1 to 11/16)
This begins a 2 week WG LC for  draft-ietf-idr-bgp-ls-flex-algo-04.txt
(11/1 to 11/16).

Cheers, Susan Hares

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 16 Nov 2020 00:16:46 -0500

Gunter: 

Thank you for letting me know we need early allocation for the Flex Algo
Exclude SRLG TLV. 

Susan Hares 

From: Van De Velde, Gunter (Nokia - BE/Antwerp)
[mailto:[email-masked]] 
Sent: Tuesday, November 3, 2020 7:36 AM
To: Susan Hares; [email-masked]
Subject: RE: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt
(11/1 to 11/16)

Hi Sue, All,

Please be aware that no code point is assigned yet to the Flex Algo Exclude
SRLG TLV (chapter 3.5 of draft BGP-LS Extensions for Flex-Algo).

G/

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Monday, November 2, 2020 03:19
To: [email-masked]
Subject: [Idr] IPR and WG LC for draft-ietf-idr-bgp-ls-flex-algo-04.txt
(11/1 to 11/16)

(11/1 to 11/16).   

only from Cisco? 

Cheers, Susan Hares