Subject: Re: [Idr] IETF 109 draft idr agenda

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 11 Nov 2020 00:08:51 +0000

Hi Linda, et al, +BESS,
Isn’t this draft under the auspices of the BESS charter?
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Linda Dunbar <[email-masked]>
Date: Tuesday, November 10, 2020 at 6:02 PM
To: Jie Dong <[email-masked]>, IDR List <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Idr] IETF 109 draft idr agenda

Jimmy and IDR chairs,

Can you add the following to the agenda?

https://datatracker.ietf.org/doc/draft-dunbar-idr-sdwan-edge-discovery/

The document describes encoding of BGP UPDATE messages for the SDWAN edge node discovery.

Thank you very much.  I am very sorry that I missed sending the email (I thought I did).

Linda Dunbar
From: Idr <[email-masked]> On Behalf Of Dongjie (Jimmy)
Sent: Monday, November 9, 2020 9:26 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] IETF 109 draft idr agenda

Hi all,

A draft agenda of IDR session on IETF 109 has been posted at: https://datatracker.ietf.org/meeting/109/materials/agenda-109-idr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F109%2Fmaterials%2Fagenda-109-idr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cad3c8a327e784534676908d885286e7d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637405756005279871%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=R7BHCQgpilBDKeky4LsqL3nnfZb9T0ftGSKu5JNaW5I%3D&reserved=0>

Please take a look and let us know if any change is needed.

Presenters, please remember to send your slides to me and CC the chairs 24 hours before the meeting session of your presentation, for the first session it is Sunday 14:30 ICT (UTC +7) . Thanks.

And FYI here is the checklist for presenting at IDR:

https://trac.tools.ietf.org/wg/idr/trac/wiki/Checklist%20for%20presenting%20at%20an%20IDR%20meeting<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.tools.ietf.org%2Fwg%2Fidr%2Ftrac%2Fwiki%2FChecklist%2520for%2520presenting%2520at%2520an%2520IDR%2520meeting&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cad3c8a327e784534676908d885286e7d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637405756005279871%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=FfmaoS6o%2BfZOG7UC%2FVBZsfOWHNCKDLSdIvx9cy73ijs%3D&reserved=0>

Best regards,
Jie

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 10 Nov 2020 19:35:14 -0500

Acee: 

Linda’s started out in IDR as a replacement of IP-Sec tunnels for Tunnel encapsulation.   The Application draft for SDWAN is in BESS.  

Due to the shorten meeting time, I recommended to Linda and her co-authors to only do the mechanism presentation in either BESS or IDR.   I recommended if she presented mechanisms in IDR that she shorten her time slot in BESS to 2 slides and 5 minutes.   Or if she presents the mechanisms in BESS (15 minutes) we do not need to present in IDR.  

Hu Jun, Linda,  and Ali S. all proposed mechanisms as a replacement for 3 IP-Sec tunnel-types being removed by draft-ietf-idr-tunnel-encaps-20.txt.   Each of these 3 solutions proposed either a replacement for IP-SEC or a new tunnel type (EVPN from Ali).   As a replacement for the tunnels in IDR,  Jun and Linda’s draft could go in either WG.   The EVPN draft from Ali clearly belongs in the BESS WG.  I am convinced by the authors we have 3 different use cases.  

As part of a joint work between IDR and BESS, all 3 gave presentations in IETF 105 and received feedback on security issues.  I chaired this section joint section.  I have seen security corrections and packing improvements from Jun Hu draft and Linda’s draft.  I have not seen any textual security improvements in the EVPN text.  Ali has reported security improvements, but the text and the text of drafts it points to does not seem to matter.   I hope to see that we can use common sub-TLVs for 3 different tunnel types. 

The drafts for the new tunnel types will need to be review and vetted by both working groups (IDR and BESS). 

I hope if Ali presents on the -03.txt he will provide details on why he has not address the concerns from the security review in IETF 105 and what alignment he plans with draft-ietf-idr-tunnel-encaps-20.txt. 

Cheers, Sue 

From: BESS [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Tuesday, November 10, 2020 7:09 PM
To: Linda Dunbar; Dongjie (Jimmy); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [bess] [Idr] IETF 109 draft idr agenda

Hi Linda, et al, +BESS, 

Thanks,

Acee

Jimmy and IDR chairs, 

Linda Dunbar

Hi all,

A draft agenda of IDR session on IETF 109 has been posted at: https://datatracker.ietf.org/meeting/109/materials/agenda-109-idr <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F109%2Fmaterials%2Fagenda-109-idr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cad3c8a327e784534676908d885286e7d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637405756005279871%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=R7BHCQgpilBDKeky4LsqL3nnfZb9T0ftGSKu5JNaW5I%3D&reserved=0> 

https://trac.tools.ietf.org/wg/idr/trac/wiki/Checklist%20for%20presenting%20at%20an%20IDR%20meeting <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.tools.ietf.org%2Fwg%2Fidr%2Ftrac%2Fwiki%2FChecklist%2520for%2520presenting%2520at%2520an%2520IDR%2520meeting&data=04%7C01%7Clinda.dunbar%40futurewei.com%7Cad3c8a327e784534676908d885286e7d%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637405756005279871%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=FfmaoS6o%2BfZOG7UC%2FVBZsfOWHNCKDLSdIvx9cy73ijs%3D&reserved=0> 

Best regards,

Jie