Subject: Re: [Idr] [EVPN] RFC7432: Query on IPv6 Originating Router's IP Address usage with Inclusive Multicast Ethernet Tag Route

From: TULASI RAM REDDY <[email-masked]>
Date: Tue, 19 Jan 2021 11:04:23 +0530

+IDR WG
Can some one please help on this?

Thanks,
Tulasi.

On Mon, Jan 18, 2021 at 7:57 AM TULASI RAM REDDY <[email-masked]>
wrote:

> Hi All,
>
>
>
> According to below note in “Sec 11.1.  Constructing Inclusive Multicast
> Ethernet Tag Route”, It looks implementation can
>
> use BGP router ID(32-bit) as Originating Router's IP Address even with
> pure IPv6 deployment..
>
>
>
> If the implementation choose this way, does it cause any known
> interoperable issues or
>
> It is expected to use IPv6 loopback address here as the originating router
> IP address with IPv6 BGP peering?
>
>
>
> It will be great, if someone throws light on the major implementations
> here..
>
>
>
> <snip: “Sec 11.1.  Constructing Inclusive Multicast Ethernet Tag Route”>
>
>    The Originating Router's IP Address field value MUST be set to an IP
>
>    address of the PE that should be common for all the EVIs on the PE
>
>    (e.g., this address may be the PE's loopback address).  The IP
>
>    Address Length field is in bits.
>
> </snip>
>
>
>
> Thanks,
>
> Tulasi.
>

-- 
TULASI RAMI REDDY N

---

From: TULASI RAM REDDY <[email-masked]>
Date: Fri, 22 Jan 2021 11:42:14 +0530

Hi All,

Awaiting for inputs on this.

Thanks,
Tulasi.
On Tue, Jan 19, 2021 at 11:04 AM TULASI RAM REDDY <[email-masked]>
wrote:

> On Mon, Jan 18, 2021 at 7:57 AM TULASI RAM REDDY <
> [email-masked]> wrote:
>
>> Hi All,
>>
>>
>>
>> It is expected to use IPv6 loopback address here as the originating
>> router IP address with IPv6 BGP peering?
>>
>>
>>

-- 
TULASI RAMI REDDY N