Subject: Re: [Idr] [GROW] BGP Looking Glass Capability

From: Robert Raszuk <[email-masked]>
Date: Mon, 26 Apr 2021 00:48:31 +0200

Hi Rayhaan,

> I guess a good starting point would be to reach out to IDR folks / authors
> of the operational message draft and get their input as to why it didn't
> progress further since that would be useful to guide any revival attempts.
>

Good idea. As I am co-author of this draft taking the liberty to do it
right here :)

A bit of history  - in min 2010 I wrote
https://tools.ietf.org/html/draft-raszuk-bgp-diagnostic-message-00.

Then we spoke about it, trimmed a bit and formed what we considered most
important operationally into
https://tools.ietf.org/html/draft-ietf-idr-operational-message-00

The draft was having good support during the IDR WG adoption and hence it
became WG doc.

Since then most of the authors left the vendor world and our influence to
implement it in significant commercial BGP code bases was no longer
sufficient. Yet vendors told we will implement it if customers ask for it.
So we are 9+ years and still I am not sure if anyone cares much about
switching phone and email channels between NOCs into more programmatic way.

Yet we do see from time to time a pop request to some form to tell peer
ascii strings like sms by BGP, pass some well known address, etc ...

I think this is the fundamental challenge in how we operate peering
relations. I have seen a lot of good automation happening in the IX world,
but when trying to establish BGP sessions today it seems still emails, xls,
word documents style ...

While it does not need to be all TLVs as listed in the
https://tools.ietf.org/html/draft-ietf-idr-operational-message-00 draft but
I think operational message is indeed needed.

Cheers,
R.

---

From: "Rayhaan Jaufeerally (IETF)" <[email-masked]>
Date: Mon, 26 Apr 2021 01:24:32 +0200

Thanks for the history Robert, I should have read the authors list more
closely on that draft :)

>From that description it seems that it was more circumstances at the time
rather than push back on the implementation itself which is good news for
trying to revive it,

I'll try and rework the draft to use the operational message and see which
common parts are useful here, then reply to the list / IDR with the updated
draft,

Cheers,
Rayhaan

On Mon, Apr 26, 2021 at 12:48 AM Robert Raszuk <[email-masked]> wrote:

> Hi Rayhaan,
>
>
>> I guess a good starting point would be to reach out to IDR folks /
>> authors of the operational message draft and get their input as to why it
>> didn't progress further since that would be useful to guide any revival
>> attempts.
>>
>
> https://tools.ietf.org/html/draft-ietf-idr-operational-message-00 draft
> but I think operational message is indeed needed.
>
> Cheers,
> R.
>
>

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 25 Apr 2021 21:36:49 -0400

+1 on the new AFI idea.  I would support developing the new draft.

Out of al the ideas proposed I think the new AFI seems to be the best
method of achieving the BGP looking glass capability and propagation of
routes.

Thanks

Gyan

On Sun, Apr 25, 2021 at 7:25 PM Rayhaan Jaufeerally (IETF) <[email-masked]>
wrote:

>> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Mon, 26 Apr 2021 01:51:57 +0000

If we do that, we should secure it with the router certificate
https://tools.ietf.org/html/rfc8209
Then the URL should be secured with DNSSec, or why don't we just put the
IP address in place of the hostname portion of the URL?

Regards,
Jakob.

From: GROW <[email-masked]> On Behalf Of Gyan Mishra
Sent: Sunday, April 25, 2021 6:37 PM
To: Rayhaan Jaufeerally (IETF) <[email-masked]>
Cc: idr@ietf. org <[email-masked]>; [email-masked]
Subject: Re: [GROW] BGP Looking Glass Capability

Out of al the ideas proposed I think the new AFI seems to be the best method of achieving the BGP looking glass capability and propagation of routes.

Thanks

Gyan

On Sun, Apr 25, 2021 at 7:25 PM Rayhaan Jaufeerally (IETF) <[email-masked]<mailto:[email-masked]>> wrote:
Thanks for the history Robert, I should have read the authors list more closely on that draft :)

From that description it seems that it was more circumstances at the time rather than push back on the implementation itself which is good news for trying to revive it,

I'll try and rework the draft to use the operational message and see which common parts are useful here, then reply to the list / IDR with the updated draft,

Cheers,
Rayhaan

On Mon, Apr 26, 2021 at 12:48 AM Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:
Hi Rayhaan,

I guess a good starting point would be to reach out to IDR folks / authors of the operational message draft and get their input as to why it didn't progress further since that would be useful to guide any revival attempts.

Good idea. As I am co-author of this draft taking the liberty to do it right here :)

A bit of history  - in min 2010 I wrote https://tools.ietf.org/html/draft-raszuk-bgp-diagnostic-message-00.

Then we spoke about it, trimmed a bit and formed what we considered most important operationally into https://tools.ietf.org/html/draft-ietf-idr-operational-message-00

The draft was having good support during the IDR WG adoption and hence it became WG doc.

Since then most of the authors left the vendor world and our influence to implement it in significant commercial BGP code bases was no longer sufficient. Yet vendors told we will implement it if customers ask for it. So we are 9+ years and still I am not sure if anyone cares much about switching phone and email channels between NOCs into more programmatic way.

Yet we do see from time to time a pop request to some form to tell peer ascii strings like sms by BGP, pass some well known address, etc ...

I think this is the fundamental challenge in how we operate peering relations. I have seen a lot of good automation happening in the IX world, but when trying to establish BGP sessions today it seems still emails, xls, word documents style ...

While it does not need to be all TLVs as listed in the https://tools.ietf.org/html/draft-ietf-idr-operational-message-00 draft but I think operational message is indeed needed.

Cheers,
R.

_______________________________________________
GROW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/grow
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 25 Apr 2021 22:04:11 -0400

Agreed. Sounds good.

Gyan
On Sun, Apr 25, 2021 at 9:52 PM Jakob Heitz (jheitz) <[email-masked]>
wrote:

> *From:* GROW <[email-masked]> *On Behalf Of * Gyan Mishra
> *Sent:* Sunday, April 25, 2021 6:37 PM
> *To:* Rayhaan Jaufeerally (IETF) <[email-masked]>
> *Cc:* idr@ietf. org <[email-masked]>; [email-masked]
> *Subject:* Re: [GROW] BGP Looking Glass Capability
>
>
>
>
>
> On Sun, Apr 25, 2021 at 7:25 PM Rayhaan Jaufeerally (IETF) <
> [email-masked]> wrote:
>
> *Network Solutions Architect *
>
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: "Majumdar, Kausik" <[email-masked]>
Date: Mon, 26 Apr 2021 17:32:17 +0000

This seems to be an useful draft to develop the BGP diagnostic requirements based on the BGP Operational messages. I also support developing a new draft with the useful messages to start with and then probably can be extended. Yes, new AFI on this would be a good idea.

Thanks,
Kausik

From: Idr <[email-masked]> On Behalf Of Gyan Mishra
Sent: Sunday, April 25, 2021 6:37 PM
To: Rayhaan Jaufeerally (IETF) <[email-masked]>
Cc: idr@ietf. org <[email-masked]>; [email-masked]; Robert Raszuk <[email-masked]>
Subject: Re: [Idr] [GROW] BGP Looking Glass Capability

+1 on the new AFI idea. I would support developing the new draft. Out of al the ideas proposed I think the new AFI seems to be the best method of achieving the BGP looking glass capability and propaga
External ([email-masked]<mailto:[email-masked]>)
  Report This Email<https://shared.outlook.inky.com/report?id=Y29tbXNjb3BlL2thdXNpay5tYWp1bWRhckBjb21tc2NvcGUuY29tLzIyM2MxMzVkMThkYzhiOWRlYjI2MGI2NzIxMDdkMDVkLzE2MTk0MDEwNjkuNjE=#key=45d9a65d553996cbb4655e79b60a5bfc>  FAQ<https://www.inky.com/banner-faq/>  Protection by INKY<https://www.inky.com>

Thanks

Gyan

Cheers,
Rayhaan

A bit of history  - in min 2010 I wrote https://tools.ietf.org/html/draft-raszuk-bgp-diagnostic-message-00<https://secure-web.cisco.com/1P7ZPJ9-4Gu4-nnYkweuXnvZ77d-rJrwLjUIJDJMu6V3Xg7ThxWK6NtbuJJRS4rKtQV100Xcjmw0W4MrRQ8zEExrEHzCd2TuBTBbk4tgJT_-01zlckACrJ7Co3Q5tkGJoQOzmRx2qBE3T6Q8mjCbfl4UYo9KByKLC_K4Q-E0iaMoyb92D7CXiP8V1xXOVQ_0MV_OkWUaCNrsrPe6FJujhyuOnlm0XggQbdjPekojkJI3peKxz_LeXmDuyhNLJfNvbhEqsq2ZSBdEk5lmp4V1PSG5_V2lWXjZxAbrHeCM4qHMjbI8BySBfWnSDetJaX197/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-raszuk-bgp-diagnostic-message-00>.

Then we spoke about it, trimmed a bit and formed what we considered most important operationally into https://tools.ietf.org/html/draft-ietf-idr-operational-message-00<https://secure-web.cisco.com/1yI3ABCPc2fsLzu-XzjmaY-UmY_ZwFxEUanFzYbOBfHNjCYSer-dl9VsySEtLkS5x_oQcvxjhIZsKDrwsz3CdtYkG7LTJOZ4QnlAMOpQSdi3Wn0Ln6fLe8hsVJSZR1_zfMpzWHg_3EACko-jCftaK7YchGRjPO2ltGPNaG0y9l7XInjwPYDgVK0Q4SnPiezs9tLYL9S7oXcczgtoKTr3QWx_cr0PHOQWHbWBLSExXZVItlgEDQEWxs2wqZeLYMAGbRuGzyOKm3pwp9Kkvt7fqZi2Bl5eNfxD-G0dbwWLVl8eNiF3Xa-wcz94cOzhEor6i/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-idr-operational-message-00>

While it does not need to be all TLVs as listed in the https://tools.ietf.org/html/draft-ietf-idr-operational-message-00<https://secure-web.cisco.com/1yI3ABCPc2fsLzu-XzjmaY-UmY_ZwFxEUanFzYbOBfHNjCYSer-dl9VsySEtLkS5x_oQcvxjhIZsKDrwsz3CdtYkG7LTJOZ4QnlAMOpQSdi3Wn0Ln6fLe8hsVJSZR1_zfMpzWHg_3EACko-jCftaK7YchGRjPO2ltGPNaG0y9l7XInjwPYDgVK0Q4SnPiezs9tLYL9S7oXcczgtoKTr3QWx_cr0PHOQWHbWBLSExXZVItlgEDQEWxs2wqZeLYMAGbRuGzyOKm3pwp9Kkvt7fqZi2Bl5eNfxD-G0dbwWLVl8eNiF3Xa-wcz94cOzhEor6i/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-idr-operational-message-00> draft but I think operational message is indeed needed.

Cheers,
R.

_______________________________________________
GROW mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/grow<https://secure-web.cisco.com/1OUqmWKJuwO1TGJGsXs2KqT3H1CatGu7L0fMFXrN69byzdXxH8aMrlpfhdXrJ1HAMxSyFWXpbA4xKBz07uwJJEf_9-1f8G3aXnkjKVSFoI43YBWrCCJNO8ALVtM4MjUQibv-DdZaFSJR6m414Ds7moHLoZiU4T2-_sVFPw5OyJoV-opthFe7LD44i0WbN5FMRxIZNHMa7Bb9Xsj7hPmvAGXAwX7HCLK7qRV4_PKDZFnjcYieLwUAzf1kzerz7-uN6Iwbe7FZO2qzDxBovt6Ls4Mzcyv7qf96e6DzRQuSCGh67y_rmTTd-TFuO6iI9CvE8/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fgrow>
--

Gyan Mishra

M 301 502-1347