Subject: Re: [Idr] I-D Action: draft-lapukhov-bgp-ecmp-considerations-06.txt

From: Melchior Aelmans <[email-masked]>
Date: Mon, 24 May 2021 22:04:34 +0200

Dear Authors,

Thanks for the updated draft and the work which I think is very useful.

I did read the draft just now and have a few textual suggestions;

- Section 3: "...all iBGP paths from the the ECMP candidates set..." -->
remove 1x "the"

- Section 4: "...as "skip igp check" ." --> Remove space between " and .

- Section 4: "...IGP cost ." --> remove space between cost and .

- Section 4: "nessesary" --> replace with "necessary"

- Section 4: "deplyments" --> replace with "deployments"

- Section 8: "implementaion" --> replace with "implementation"

Cheers,

Melchior

On Mon, May 24, 2021 at 6:40 PM <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
>         Title           : Equal-Cost Multipath Considerations for BGP
>         Authors         : Petr Lapukhov
>                           Jeff Tantsura
>         Filename        : draft-lapukhov-bgp-ecmp-considerations-06.txt
>         Pages           : 7
>         Date            : 2021-05-24
>
> Abstract:
>    BGP (Border Gateway Protocol) [RFC4271] employs tie-breaking logic to
>    select a single best path among multiple paths available, known as
>    BGP best path selection.  At the same time, it has become a common
>    practice to allow for "equal-cost multipath" (ECMP) selection and
>    programming of multiple next-hops in routing tables.  This document
>    summarizes some common considerations for the ECMP logic when BGP is
>    used as the routing protocol, with the intent of providing common
>    reference for otherwise unstandardized set of features.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-lapukhov-bgp-ecmp-considerations/
>
> There is also an htmlized version available at:
>
> https://datatracker.ietf.org/doc/html/draft-lapukhov-bgp-ecmp-considerations-06
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-lapukhov-bgp-ecmp-considerations-06
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Mon, 24 May 2021 21:37:22 +0000

Couple more:

AS_SET is not completely ignored. An AS_SET counts as one hop
regardless of how many ASes are in the set.

Multiple paths with the same next-hop (possible with redundant
route reflectors) count as a single path for the purpose of computing
traffic distribution.

Regards,
Jakob.

From: Idr <[email-masked]> On Behalf Of Melchior Aelmans
Sent: Monday, May 24, 2021 1:05 PM
To: idr <[email-masked]>; [email-masked]
Subject: Re: [Idr] I-D Action: draft-lapukhov-bgp-ecmp-considerations-06.txt

Dear Authors,

- Section 3: "...all iBGP paths from the the ECMP candidates set..." --> remove 1x "the"

Cheers,

Melchior

On Mon, May 24, 2021 at 6:40 PM <[email-masked]<mailto:[email-masked]>> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Abstract:

[email-masked]<mailto:[email-masked]>

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 24 May 2021 23:02:32 -0700

Melchior and Jakob,

Many thanks for your comments, will address them ASAP.

Regards,
Jeff

> On May 24, 2021, at 14:37, Jakob Heitz (jheitz) <jheitz=[email-masked]> wrote:
> 
> 
> Couple more:
>  
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr