Subject: [Idr] I-D Action: draft-ietf-idr-segment-routing-te-policy-12.txt

From: [email-masked]
Date: Thu, 13 May 2021 05:40:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Advertising Segment Routing Policies in BGP
        Authors         : Stefano Previdi
                          Clarence Filsfils
                          Ketan Talaulikar
                          Paul Mattes
                          Eric Rosen
                          Dhanendra Jain
                          Steven Lin
	Filename        : draft-ietf-idr-segment-routing-te-policy-12.txt
	Pages           : 44
	Date            : 2021-05-13

Abstract:
   This document defines a new BGP SAFI with a new NLRI to advertise a
   candidate path of a Segment Routing (SR) Policy.  An SR Policy is a
   set of candidate paths, each consisting of one or more segment lists.
   The headend of an SR Policy may learn multiple candidate paths for an
   SR Policy.  Candidate paths may be learned via several different
   mechanisms, e.g., CLI, NetConf, PCEP, or BGP.  This document
   specifies how BGP may be used to distribute SR Policy candidate
   paths.  New sub-TLVs for the Tunnel Encapsulation Attribute are
   defined for signaling information about these candidate paths.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-segment-routing-te-policy/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-12
https://datatracker.ietf.org/doc/html/draft-ietf-idr-segment-routing-te-policy-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-segment-routing-te-policy-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 13 May 2021 12:48:36 +0000

Hello All,

We've posted an update to the draft where most of the changes are editorial and updated references.

Would like to draw attention to the following updates:

1) Clarification on the role of Distinguisher. Please refer to - https://mailarchive.ietf.org/arch/msg/spring/-PBIhqFgwlFShISoy0lN8GNZeHE/
2) Removed the appendix that was introduced in previous version to capture details of the deprecated sub-TLVs for WG review
3) Fixed issues in IANA sections to align with the latest updates from BGP Tunnel Encaps RFC9012

The authors believe that this document is ready for WGLC and would request the WG for review/feedback. 

We also request the IDR chairs to consider starting WGLC for this draft once the ongoing WGLC for draft-ietf-spring-segment-routing-policy in SPRING has concluded.

Thanks,
Ketan (on behalf of co-authors)

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of [email-masked]
Sent: 13 May 2021 18:10
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-segment-routing-te-policy-12.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr