Subject: Re: [Idr] WG adoption for draft-haas-flowspec-capability-bits - Extended till 5/18/21

From: Keyur Patel <[email-masked]>
Date: Tue, 4 May 2021 23:10:08 +0000

Hi Folks,

It seems like that the draft discussion is still going on and hasn't concluded. The chairs have decided to extend the working group adoption call for https://tools.ietf.org/html/draft-haas-flowspec-capability-bits for 2 more weeks till 5/18/21. 

We like to have a clear answer on the following questions:

1) Is this document clear about the proposal? 

2) Do you think we should do this with Flow Specification v1 or should we do this instead of Flow Specification v2? 

3) Will this help operational networks?

Best Regards,
Keyur

On 3/30/21, 6:33 AM, "Idr on behalf of Susan Hares" <[email-masked] on behalf of [email-masked]> wrote:

    This is a Working Group adoption call for
    https://tools.ietf.org/html/draft-haas-flowspec-capability-bits

    The draft suggests a mechanism to address our incremental deployment issues
    for BGP Flowspec.

    As you discuss this mechanism, there are 3 questions to consider:

    1) Is this document clear about the proposal? 

    2) Do you think we should do this with Flow Specification v2?
    Or should we do this instead of Flow Specification v2? 

    3) Will this help operational networks? 

    Cheerily, Susan Hares 

    _______________________________________________
    Idr mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/idr

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 5 May 2021 01:19:07 +0200

Hi Keyur, WG

I think we need more clarity on question #2. As stated it is ambiguous.

> 2) Do you think we should do this with Flow Specification v1 or should we
do this instead of Flow Specification v2?

Adding capabilities is not required for current operation of FlowSpec v1.

Yes no capabilities there makes it more difficult to add new stuff to v1
and that is why the general agreement was to consider going v2.

So the questions IMO should be:

*Do you as an IDR WG member realize that if we add those to FlowSpec v1 we
may delay or drop FlowSpec v2 all together ? *

And with that as it has been already stated on the list it may break some
current deployments for v1 as well not provide sufficient flexibility which
could come native with FlowSpec v2.

Many thx,
Robert.

On Wed, May 5, 2021 at 1:10 AM Keyur Patel <[email-masked]> wrote:

> Hi Folks,
>
> It seems like that the draft discussion is still going on and hasn't
> concluded. The chairs have decided to extend the working group adoption
> call for https://tools.ietf.org/html/draft-haas-flowspec-capability-bits
> for 2 more weeks till 5/18/21.
>
> 2) Do you think we should do this with Flow Specification v1 or should we
> do this instead of Flow Specification v2?
>

---

From: "Fomin, Sergey (Nokia - US/Mountain View)" <[email-masked]>
Date: Wed, 5 May 2021 04:27:24 +0000

Hi Keyur,

In my opinion:
1) yes
2) leave v1 as it is and do v2
3) it will help some in the long run

--
Sergey
-----Original Message-----
From: Idr <[email-masked]> On Behalf Of Keyur Patel
Sent: Tuesday, May 4, 2021 4:10 PM
To: [email-masked]
Subject: Re: [Idr] WG adoption for draft-haas-flowspec-capability-bits - Extended till 5/18/21

Hi Folks,

Best Regards,
Keyur

    Cheerily, Susan Hares