Subject: [Idr] RtgDir Early review: draft-ietf-idr-bgp-open-policy-15.txt

From: Mach Chen <[email-masked]>
Date: Thu, 13 May 2021 06:49:55 +0000

Hello

I have been selected to do a routing directorate “early” review of this draft.
​https://datatracker.ietf.org/doc/ draft-ietf-idr-bgp-open-policy /

The routing directorate will, on request from the working group chair, perform an “early” review of a draft before it is submitted for publication to the IESG. The early review can be performed at any time during the draft’s lifetime as a working group document. The purpose of the early review depends on the stage that the document has reached.

As this document has been sent to IESG for publication, my focus for the review was to determine whether the document is ready to be published. Please consider my comments along with the other last call comments.

Document: draft-ietf-idr-bgp-open-policy-15.txt
Reviewer: Mach Chen
Review Date: 2021/05/13
Intended Status: Standards Track

Summary:

This document is basically ready for publication, but has nits and minor concerns that should be considered prior to being submitted to the IESG.

Comments:

Section 6. 
It does not specify how a speaker handle a route with OTC attribute but the sender's role is unknown.

Nits:

Section 2. 
s/ their customers/its customers

Section 3.
s/Allowed Role values/Allowed Roles

Section 4.
It's better to update the table as follows:

                      +-------+---------------------+
                      | Value | Role name           |
                      +-------+---------------------+
                      |   0   | Sender is Provider  |
                      |   1   | Sender is RS        |
                      |   2   | Sender is RS-client |
                      |   3   | Sender is Customer  |
                      |   4   | Sender is Peer      |
                      | 5-255  | Reserved      |                         
                      +-------+---------------------+

Section 5.
OLD:
"If the role of the receiving speaker for the eBGP session in
   consideration is included in Table 1 and the observed Role pair is
   not in the above table,"
NEW:

"If the observed Role pair is not in the above table,"

IMHO, it's redundant to include "If the role of the receiving speaker for the eBGP session in consideration is included in Table 1", just keep the second half of the sentence is enough.

Section 5.1

s/send a send a/send a, there is a redundant "send a".

Best regards,
Mach

---

From: Alexander Azimov <[email-masked]>
Date: Fri, 28 May 2021 23:04:40 +0300

Dear Mach,

Thank you for your comments, all nits are already applied.

But it proved that different authors have a different reading of your

> the sender's role is unknown.

Are you speaking about the OTC processing in case of the absence of a
locally configured role?
Or does it about receiving OTC attribute from a neighbor that doesn't
participate in the role negotiation?

чт, 13 мая 2021 г. в 09:50, Mach Chen <[email-masked]>:

> The routing directorate will, on request from the working group chair,
> perform an “early” review of a draft before it is submitted for publication
> to the IESG. The early review can be performed at any time during the
> draft’s lifetime as a working group document. The purpose of the early
> review depends on the stage that the document has reached.
>
> As this document has been sent to IESG for publication, my focus for the
> review was to determine whether the document is ready to be published.
> Please consider my comments along with the other last call comments.
>
> This document is basically ready for publication, but has nits and minor
> concerns that should be considered prior to being submitted to the IESG.
>
> Comments:
>
> Section 6.
> IMHO, it's redundant to include "If the role of the receiving speaker for
> the eBGP session in consideration is included in Table 1", just keep the
> second half of the sentence is enough.
>
> Section 5.1
>

-- 
Best regards,
Alexander Azimov

---

From: Mach Chen <[email-masked]>
Date: Sat, 29 May 2021 08:03:26 +0000

Hi Alexander,

Please see me response inline with [Mach]

From: rtg-dir [mailto:[email-masked]] On Behalf Of Alexander Azimov
Sent: Saturday, May 29, 2021 4:05 AM
To: Mach Chen <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [RTG-DIR] RtgDir Early review: draft-ietf-idr-bgp-open-policy-15.txt

Dear Mach,

[Mach] OK.

But it proved that different authors have a different reading of your comment related to section 6:
Section 6.
It does not specify how a speaker handle a route with OTC attribute but the sender's role is unknown.
Are you speaking about the OTC processing in case of the absence of a locally configured role?
Or does it about receiving OTC attribute from a neighbor that doesn't participate in the role negotiation?

[Mach] Actually, in both cases, the role of the peer is uncertain, if so what will the ingress policy and egress policy be? For example, regarding ingress policy, how to handle a route with OTC attribute but not sure the sender’s role. And regarding the egress policy, if the peer’s role cannot be determined, Whether the route should be sent to the peer? Should the OTC be kept?

Best regards,
Mach

чт, 13 мая 2021 г. в 09:50, Mach Chen <[email-masked]<mailto:[email-masked]>>:
Hello

Summary:

Comments:

Section 6.

Nits:

Section 2.

Section 3.

Section 4.

Section 5.
OLD:

Section 5.1

Best regards,
Mach

--
Best regards,
Alexander Azimov