Subject: [Idr] I-D Action: draft-ietf-idr-bgp-ls-app-specific-attr-07.txt

From: [email-masked]
Date: Fri, 25 Jun 2021 01:11:52 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Application-Specific Attributes Advertisement with BGP Link-State
        Authors         : Ketan Talaulikar
                          Peter Psenak
                          Jeff Tantsura
	Filename        : draft-ietf-idr-bgp-ls-app-specific-attr-07.txt
	Pages           : 14
	Date            : 2021-06-25

Abstract:
   Various link attributes have been defined in link-state routing
   protocols like OSPF and IS-IS in the context of the MPLS Traffic
   Engineering (TE) and GMPLS.  BGP Link-State (BGP-LS) extensions have
   been defined to distribute these attributes along with other topology
   information from these link-state routing protocols.  Many of these
   link attributes can be used for applications other than MPLS-TE or
   GMPLS.

   Extensions to link-state routing protocols have been defined for such
   link attributes that enable distribution of their application-
   specific values.  This document defines extensions to BGP-LS address-
   family to enable advertisement of these application-specific
   attributes as a part of the topology information from the network.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-app-specific-attr/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-app-specific-attr-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-ls-app-specific-attr-07

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 25 Jun 2021 08:27:35 +0000

Hi All,

This draft update is to provide the clarifications and details of the procedures for handling the advertisements of the app-specific link attributes from ISIS into BGP-LS. We believe some aspects had been missed out.

For those who have not been following this discussion on this topic on the LSR list, please refer to the details on this thread : https://mailarchive.ietf.org/arch/msg/lsr/bO4WUsbHYs6D_qUQAi3HjAfMAXw/

We look forward to input/comments from the WG.

Thanks,
Ketan (on behalf of co-authors)

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of [email-masked]
Sent: 25 June 2021 13:42
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-bgp-ls-app-specific-attr-07.txt

Abstract:

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr