Subject: [Idr] Opsdir early review of draft-ietf-idr-bgpls-srv6-ext-08

From: Dan Romascanu via Datatracker <[email-masked]>
Date: Thu, 24 Jun 2021 01:16:26 -0700

Reviewer: Dan Romascanu
Review result: Ready

Ready with one editorial comment.

The document is well written, but it requires good familiarity with BGP-LS and
also reading 4 companion documents which are all work-in-progress. My principal
editorial comment would be that an abbreviations section (with references to
the sources of the terms) would greatly improve readability and make the life
easier for future users of the document.

I appreciate Section of the document which describes the operations and
manageability aspects following the recommendations of RFC 5706. This is the
section in the document that must be read by operators. Note that it looks
short but is actually quite rich in information and refers to a few other
documents.

---

From: Dan Romascanu <[email-masked]>
Date: Thu, 24 Jun 2021 13:54:38 +0300

In the second paragraph, I meant Section 10.

Sorry for skipping that.

Regards

Dan

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 24 Jun 2021 12:17:16 +0000

Hi Dan,

Thanks a lot for your review and feedback.

Regarding your comment; we’ve chosen to expand all abbreviations on first use in the document instead of an abbreviation section. It is possible that we might have missed something or not added references for them. It would help a lot if you could point to a few such instances so we can fix them.

Thanks,
Ketan

From: Dan Romascanu <[email-masked]>
Sent: 24 June 2021 16:25
To: Dan Romascanu <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Opsdir early review of draft-ietf-idr-bgpls-srv6-ext-08

Sorry for skipping that.

Regards

Dan

On Thu, Jun 24, 2021 at 11:16 AM Dan Romascanu via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Reviewer: Dan Romascanu
Review result: Ready

---

From: Dan Romascanu <[email-masked]>
Date: Thu, 24 Jun 2021 17:38:14 +0300

Hi Ketan,

Thank you for the answer and for addressing my concern. I recognize it's a
matter of preference, and that reading is easier for folks very familiar
with the topics. As I do not belong to the category I had to go back and
forth several times through the companion and referenced documents. Finding
terms and abbreviations in one place makes life easier for me and readers
like me. You did quite a good job in expanding acronyms at first reference,
there were still a few misses like NLRI, PSP, USP. There may be other.

I hope this helps.

Regards,

Dan

On Thu, Jun 24, 2021 at 3:17 PM Ketan Talaulikar (ketant) <[email-masked]>
wrote:

> Regarding your comment; we’ve chosen to expand all abbreviations on first
> use in the document instead of an abbreviation section. It is possible that
> we might have missed something or not added references for them. It would
> help a lot if you could point to a few such instances so we can fix them.
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* Dan Romascanu <[email-masked]>
> *Sent:* 24 June 2021 16:25
> *To:* Dan Romascanu <[email-masked]>
> *Cc:* [email-masked]; [email-masked];
> [email-masked]
> *Subject:* Re: Opsdir early review of draft-ietf-idr-bgpls-srv6-ext-08
>
>
>

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 24 Jun 2021 17:12:46 +0000

Hi Dan,

I agree that BGP-LS specifications in general and this one specifically has lots of references to not only the underlying IGP extensions but also to various other Segment Routing, BGP and BGP-LS specifications. It is mostly about protocol encodings and their advertisement procedures. Thanks for your efforts on this review and your feedback is very helpful.

Also, thanks for those pointers and we will fix them in the next update for the draft.

Thanks,
Ketan

From: Dan Romascanu <[email-masked]>
Sent: 24 June 2021 20:08
To: Ketan Talaulikar (ketant) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Opsdir early review of draft-ietf-idr-bgpls-srv6-ext-08

Hi Ketan,

Thank you for the answer and for addressing my concern. I recognize it's a matter of preference, and that reading is easier for folks very familiar with the topics. As I do not belong to the category I had to go back and forth several times through the companion and referenced documents. Finding terms and abbreviations in one place makes life easier for me and readers like me. You did quite a good job in expanding acronyms at first reference, there were still a few misses like NLRI, PSP, USP. There may be other.

I hope this helps.

Regards,

Dan

On Thu, Jun 24, 2021 at 3:17 PM Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Dan,

Thanks,
Ketan

From: Dan Romascanu <[email-masked]<mailto:[email-masked]>>
Sent: 24 June 2021 16:25
To: Dan Romascanu <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Opsdir early review of draft-ietf-idr-bgpls-srv6-ext-08

Sorry for skipping that.

Regards

Dan

---

From: tom petch <[email-masked]>
Date: Fri, 25 Jun 2021 09:11:13 +0000

From: Idr <[email-masked]> on behalf of Ketan Talaulikar (ketant) <ketant=[email-masked]>
Sent: 24 June 2021 13:17

Hi Dan,

<tp>

USP (Unique Selling Point?)
PSP

They both get an expansion in RFC8986

Tom Petch.

Thanks,
Ketan

Sorry for skipping that.

Regards

Dan

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 25 Jun 2021 09:31:25 +0000

Hi Tom,

Ack. The RFC8986 reference is there right next to the usage of PSP/USP, however I realize that it would be still helpful to expand them on the first use in this document.

Those changes are in the edit buffer and will come in the next version.

Thanks,
Ketan

-----Original Message-----
From: tom petch <[email-masked]> 
Sent: 25 June 2021 14:41
To: Ketan Talaulikar (ketant) <ketant=[email-masked]>; Dan Romascanu <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Opsdir early review of draft-ietf-idr-bgpls-srv6-ext-08

Hi Dan,

Regarding your comment; we've chosen to expand all abbreviations on first use in the document instead of an abbreviation section. It is possible that we might have missed something or not added references for them. It would help a lot if you could point to a few such instances so we can fix them.

<tp>

Tom Petch.

Thanks,
Ketan

Sorry for skipping that.

Regards

Dan

The document is well written, but it requires good familiarity with BGP-LS and also reading 4 companion documents which are all work-in-progress. My principal editorial comment would be that an abbreviations section (with references to the sources of the terms) would greatly improve readability and make the life easier for future users of the document.

I appreciate Section of the document which describes the operations and manageability aspects following the recommendations of RFC 5706. This is the section in the document that must be read by operators. Note that it looks short but is actually quite rich in information and refers to a few other documents.