Subject: Re: [Idr] I-D Action: draft-sas-idr-maxprefix-inbound-02.txt

From: Melchior Aelmans <[email-masked]>
Date: Wed, 16 Jun 2021 23:11:54 +0200

Dear WG, commenters,

Thanks for all the suggestions and great discussion.

I have just uploaded -03  (
https://datatracker.ietf.org/doc/html/draft-sas-idr-maxprefix-inbound)
version which includes the following statement:

Operators SHOULD take special care when applying soft-
         reconfiguration inbound, as it could still expose control plane
         to exhaustion if no pre-policy limits are available or are not
         configured.  Implementations SHOULD provide means to configure
         two thresholds for inbound limits.  One before soft-
         reconfiguration inbound and one after soft-reconfiguration
         inbound.  This is to prevent soft-reconfiguration inbound to
         exhaust control plane resources.  The threshold before soft-
         reconfiguration inbound SHOULD be higher than the limit
         configured after soft-reconfiguration inbound.

Does that make sense and addresses the issue? Please advise.

Thanks!
Melchior

On Fri, May 14, 2021 at 1:13 AM Gyan Mishra <[email-masked]> wrote:

>
> I understand for documentation purposes being in the draft.  I am in
> agreement as highlighted by Jacob & Robert.
>
> Gyan
>
> On Thu, May 13, 2021 at 4:13 PM Brian Dickson <
> [email-masked]> wrote:
>
>>
>>
>> On Thu, May 13, 2021 at 8:44 AM heasley <[email-masked]> wrote:
>>
>>> Wed, May 12, 2021 at 11:14:51PM -0400, Gyan Mishra:
>>> > +1 more for implementation not for draft
>>>
>>> I disagree; that has helped create the inconsistencies among impls.
>>> Document
>>> it.
>>>
>>
>> I also disagree, for the reasons highlighted by Jakob and Robert.
>> It needs to be in the draft.
>>
>> Brian Dickson
>>
>
>
> --
>
> <http://www.verizon.com/>
>
> *Gyan Mishra*
>
> *Network Solutions A**rchitect *
>
> *Email [email-masked] <[email-masked]>*
>
>
>
> *M 301 502-1347*
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Job Snijders <[email-masked]>
Date: Thu, 17 Jun 2021 13:54:11 +0200

Hi Melchior,

I believe 'soft-reconfiguration inbound' is a vendor-specific term which
we should try to avoid in Internet-Drafts.
See https://mailarchive.ietf.org/arch/msg/idr/X0_eoWM_v-LOmfPA23_ydZb_Ucc/

If the implementation supports 'Adj-RIB-In' (either through a command,
or enabled out off the box), then the implementation can offer
'pre-policy limit' functionality.

I also don't think the threshold SHOULD be higher, they could also be
equal :-)

Kind regards,

Job