Subject: [Idr] Francesca Palombini's No Objection on draft-ietf-idr-bgp-optimal-route-reflection-25: (with COMMENT)

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Wed, 16 Jun 2021 05:47:37 -0700

Francesca Palombini has entered the following ballot position for
draft-ietf-idr-bgp-optimal-route-reflection-25: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-optimal-route-reflection/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work on this document. I have a couple of very minor comments
below, and a non blocking question: it seems to me that this document could
have contained the "updates" header wrt RFC 4456. Was this considered by the
working group?

Francesca

1. -----

FP: Please expand AS, POP, SPF, IBGP on first use.

2. -----

   The core of this solution is the ability for an operator to specify

FP: I would suggest adding the name and abbreviation BGP ORR here, otherwise it
comes as a surprise in section 4.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 16 Jun 2021 16:10:49 +0200

Dear Francesca,

Thank you so much for your review of this document.

I added most of your suggestions to new version -26 which will be posted
soon.

On the other two points which perhaps require further clarification:

"ORR" is already explained in the title so I removed the hyphen there to
make it intuitive that this is the abbreviation for Optimal Route
Reflection.

As far as updating RFC4456 we have discussed this and the conclusion
reached is that this spec is not really an update. Reason being is that in
our understanding update is something that changes the previously defined
behaviour also in the same time obsoleting it. Here this spec is not
replacing traditional route reflection. It adds a new method on path
selection for situations where this is applicable and helpful. It is also
to be enabled explicitly by configuration.

The vanilla RFC4456 will continue to operate just fine for those networks
which deployed reflection in the data path or those AFs (AFI/SAFI) which by
itself reflect all paths.

Please kindly let us know if you are ok with the above explanations.

Kind regards,
Robert

---

From: Francesca Palombini <[email-masked]>
Date: Wed, 16 Jun 2021 21:41:59 +0000

Hi Robert,

Thanks for the quick answer.

Re: ORR being expanded in the title: I was hoping to find it expanded somewhere in the body of the document as well, as I seem to remember that’s part of the RFC Editor style guide, but I might remember wrong, and you’ll be able to change that in AUTH48, in case it’s needed.

Re: updating RFC4456 – I know that “Update” is an ambiguous header, so I do not want to bikeshed this: the “updates” header does have a flexible meaning, and I just wanted to make sure this had been discussed and decided within the community. Since it has, I am fine with it. But just for your information, “Update” does not necessarily mean “change and obsolete the previously defined spec”. The only meaning I could find is the one defined in https://datatracker.ietf.org/doc/html/rfc2223#section-12 which states:

   Updates

      To be used as a reference from a new item that cannot be used
      alone (i.e., one that supplements a previous document), to refer
      to the previous document.  The newer publication is a part that
      will supplement or be added on to the existing document; e.g., an
      addendum, or separate, extra information that is to be added to
      the original document.

I thought this matched well for this doc, which cannot be used alone without 4456, and which just adds to the existing document (without obsoleting it).

Anyway, I am fine without it, just wanted to clarify where my comment came from.

Thanks,
Francesca

From: Robert Raszuk <[email-masked]>
Date: Wednesday, 16 June 2021 at 16:11
To: Francesca Palombini <[email-masked]>
Cc: The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, idr-chairs <[email-masked]>, "idr@ietf. org" <[email-masked]>, John Scudder <[email-masked]>, Susan Hares <[email-masked]>, Alvaro Retana <[email-masked]>
Subject: Re: Francesca Palombini's No Objection on draft-ietf-idr-bgp-optimal-route-reflection-25: (with COMMENT)

Dear Francesca,

I added most of your suggestions to new version -26 which will be posted soon.

"ORR" is already explained in the title so I removed the hyphen there to make it intuitive that this is the abbreviation for Optimal Route Reflection.

As far as updating RFC4456 we have discussed this and the conclusion reached is that this spec is not really an update. Reason being is that in our understanding update is something that changes the previously defined behaviour also in the same time obsoleting it. Here this spec is not replacing traditional route reflection. It adds a new method on path selection for situations where this is applicable and helpful. It is also to be enabled explicitly by configuration.

The vanilla RFC4456 will continue to operate just fine for those networks which deployed reflection in the data path or those AFs (AFI/SAFI) which by itself reflect all paths.

Kind regards,
Robert

On Wed, Jun 16, 2021 at 2:47 PM Francesca Palombini via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Francesca Palombini has entered the following ballot position for
draft-ietf-idr-bgp-optimal-route-reflection-25: No Objection

Francesca

1. -----

2. -----

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 16 Jun 2021 23:59:03 +0200

Hello Francesca,

Many thx for the additional comments.

I expended ORR at the first occurrence in the body.

Based on your help it indeed makes sense to mark this spec as updating
RFC4456 as clearly it requires it to exist. If IESG or RFC editor decides
otherwise this marking can be removed, but understanding the motivation I
am putting it in for now.

Kind regards,
Robert

On Wed, Jun 16, 2021 at 11:42 PM Francesca Palombini <
[email-masked]> wrote:

> Re: ORR being expanded in the title: I was hoping to find it expanded
> somewhere in the body of the document as well, as I seem to remember that’s
> part of the RFC Editor style guide, but I might remember wrong, and you’ll
> be able to change that in AUTH48, in case it’s needed.
>
>
>
> Re: updating RFC4456 – I know that “Update” is an ambiguous header, so I
> do not want to bikeshed this: the “updates” header does have a flexible
> meaning, and I just wanted to make sure this had been discussed and decided
> within the community. Since it has, I am fine with it. But just for your
> information, “Update” does not necessarily mean “change and obsolete the
> previously defined spec”. The only meaning I could find is the one defined
> in https://datatracker.ietf.org/doc/html/rfc2223#section-12 which states:
>
>
>
>    Updates
>
>
>
> I thought this matched well for this doc, which cannot be used alone
> without 4456, and which just adds to the existing document (without
> obsoleting it).
>
>
>
> *From: *Robert Raszuk <[email-masked]>
> *Date: *Wednesday, 16 June 2021 at 16:11
> *To: *Francesca Palombini <[email-masked]>
> *Cc: *The IESG <[email-masked]>, "
> [email-masked]" <
> [email-masked]>, idr-chairs <
> [email-masked]>, "idr@ietf. org" <[email-masked]>, John Scudder <
> [email-masked]>, Susan Hares <[email-masked]>, Alvaro Retana <
> [email-masked]>
> *Subject: *Re: Francesca Palombini's No Objection on
> draft-ietf-idr-bgp-optimal-route-reflection-25: (with COMMENT)
>
>
>
> Dear Francesca,
>
>
>