Subject: [Idr] will draft-ietf-idr-flowspec-redirect-ip-02 be revived?

From: Linda Dunbar <[email-masked]>
Date: Tue, 29 Jun 2021 17:28:54 +0000

Jim, Jeff, et al,

Our https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/ needs to use Flowspec to influence the node (either on 5G UPF or directly connected to the 5GUPF) to steer a flow from 5G's UPF to a specific underlay path based on the  5G services characteristics.

The approach described in  draft-ietf-idr-flowspec-redirect-ip-02 are useful for our purpose.   But the draft has been expired.

Just curious if the  draft-ietf-idr-flowspec-redirect-ip-02 be revived? Were there any reasons the draft didn't move forward?

Thank you very much
Linda Dunbar

---

From: "Simpson, Adam 1. (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 29 Jun 2021 18:48:50 +0000

Hi Linda,

I don’t think there is any great reason why we didn’t continue to refresh this draft and take it to RFC. At the time of the last update there was a lot of churn in the flowspec area with respect to work on the bis draft, flowpsec-v2 and the best way to specify interaction between multiple actions. So I guess you could say that we wanted the dust to settle a bit.

This draft can and should be revived. It would be good to understand from my co-authors the current status of implementations. I can say that Nokia has implemented this draft for both IPv4 and IPv6, but only the redirect functionality, not the copy functionality.

-Adam

From: Linda Dunbar <[email-masked]>
Date: Tuesday, June 29, 2021 at 10:29 AM
To: UTTARO, JAMES <[email-masked]>, Jeffrey Haas <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, Simpson, Adam 1. (Nokia - US/Mountain View) <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [ALU] will draft-ietf-idr-flowspec-redirect-ip-02 be revived?
Jim, Jeff, et al,

Our https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/ needs to use Flowspec to influence the node (either on 5G UPF or directly connected to the 5GUPF) to steer a flow from 5G’s UPF to a specific underlay path based on the  5G services characteristics.

Just curious if the  draft-ietf-idr-flowspec-redirect-ip-02 be revived? Were there any reasons the draft didn’t move forward?

Thank you very much
Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 29 Jun 2021 19:01:08 +0000

Adam,

Great to hear the draft will be refreshed. Then we can reference the approach for our TN-AWARE flowspec.

Thank you
Linda

From: Simpson, Adam 1. (Nokia - US/Mountain View) <[email-masked]>
Sent: Tuesday, June 29, 2021 1:49 PM
To: Linda Dunbar <[email-masked]>; UTTARO, JAMES <[email-masked]>; Jeffrey Haas <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [ALU] will draft-ietf-idr-flowspec-redirect-ip-02 be revived?

Hi Linda,

I don't think there is any great reason why we didn't continue to refresh this draft and take it to RFC. At the time of the last update there was a lot of churn in the flowspec area with respect to work on the bis draft, flowpsec-v2 and the best way to specify interaction between multiple actions. So I guess you could say that we wanted the dust to settle a bit.

-Adam

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, June 29, 2021 at 10:29 AM
To: UTTARO, JAMES <[email-masked]<mailto:[email-masked]>>, Jeffrey Haas <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Simpson, Adam 1. (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [ALU] will draft-ietf-idr-flowspec-redirect-ip-02 be revived?
Jim, Jeff, et al,

Our https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mcd-rtgwg-extension-tn-aware-mobility%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C1078269790194e1cdc0508d93b2e8bd7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637605893374698969%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=PUDjhqA3Mqgd2krioVNCB1xXVDRbrgLOQ21EygjKvVI%3D&reserved=0> needs to use Flowspec to influence the node (either on 5G UPF or directly connected to the 5GUPF) to steer a flow from 5G's UPF to a specific underlay path based on the  5G services characteristics.

Thank you very much
Linda Dunbar

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 29 Jun 2021 15:30:11 -0400

Linda and Adam: 

The understanding of the IDR chairs from IDR members at the
flow-specification interim is that all new IDR flow specification drafts
will need to be done in flow specification v2.  

The flow specification v2 work will be expedited during the next IDR cycle.
Our anticipation is to select an single Editor and let the WG rapidly
suggest additions. 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Tuesday, June 29, 2021 3:01 PM
To: Simpson, Adam 1. (Nokia - US/Mountain View); UTTARO, JAMES; Jeffrey
Haas; [email-masked]; [email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: Re: [Idr] [ALU] will draft-ietf-idr-flowspec-redirect-ip-02 be
revived?

Adam, 

Great to hear the draft will be refreshed. Then we can reference the
approach for our TN-AWARE flowspec. 

Thank you

Linda

Sent: Tuesday, June 29, 2021 1:49 PM
To: Linda Dunbar <[email-masked]>; UTTARO, JAMES
<[email-masked]>; Jeffrey Haas <[email-masked]>; [email-masked];
[email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [ALU] will draft-ietf-idr-flowspec-redirect-ip-02 be revived? 

Hi Linda,

I don't think there is any great reason why we didn't continue to refresh
this draft and take it to RFC. At the time of the last update there was a
lot of churn in the flowspec area with respect to work on the bis draft,
flowpsec-v2 and the best way to specify interaction between multiple
actions. So I guess you could say that we wanted the dust to settle a bit.

This draft can and should be revived. It would be good to understand from my
co-authors the current status of implementations. I can say that Nokia has
implemented this draft for both IPv4 and IPv6, but only the redirect
functionality, not the copy functionality.

-Adam 

From: Linda Dunbar <[email-masked]>
Date: Tuesday, June 29, 2021 at 10:29 AM
To: UTTARO, JAMES <[email-masked]>, Jeffrey Haas <[email-masked]>,
[email-masked] <[email-masked]>, [email-masked] <[email-masked]>,
[email-masked] <[email-masked]>, Simpson, Adam
1. (Nokia - US/Mountain View) <[email-masked]>, [email-masked]
<[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [ALU] will draft-ietf-idr-flowspec-redirect-ip-02 be revived? 

Jim, Jeff, et al, 

Our
https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility
/
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrack
er.ietf.org%2Fdoc%2Fdraft-mcd-rtgwg-extension-tn-aware-mobility%2F&data=04%7
C01%7Clinda.dunbar%40futurewei.com%7C1078269790194e1cdc0508d93b2e8bd7%7C0fee
8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637605893374698969%7CUnknown%7CTWFpbG
Zsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3
000&sdata=PUDjhqA3Mqgd2krioVNCB1xXVDRbrgLOQ21EygjKvVI%3D&reserved=0>  needs
to use Flowspec to influence the node (either on 5G UPF or directly
connected to the 5GUPF) to steer a flow from 5G's UPF to a specific underlay
path based on the  5G services characteristics. 

The approach described in  draft-ietf-idr-flowspec-redirect-ip-02 are useful
for our purpose.   But the draft has been expired. 

Just curious if the  draft-ietf-idr-flowspec-redirect-ip-02 be revived? Were
there any reasons the draft didn't move forward? 

Thank you very much 

Linda Dunbar

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 29 Jun 2021 16:23:03 -0400

Matter of fact, there's an old mail chain in your inbox from me about trying to finish it off for RFC. :-)

I believe our assessment at the time was roughly:
- None of our implementations was implementing the 'copy' bit.
- Our implementations weren't quite in accord with the redirect to ip when also doing redirect to vrf.

I think it's mostly a matter of dusting of that thread and doing our implementation reports with all of the implementors and then adjusting for reality.

-- Jeff

> On Jun 29, 2021, at 2:48 PM, Simpson, Adam 1. (Nokia - US/Mountain View) <[email-masked]> wrote:
> 
> Hi Linda,
>  
> Our https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/ <https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/> needs to use Flowspec to influence the node (either on 5G UPF or directly connected to the 5GUPF) to steer a flow from 5G’s UPF to a specific underlay path based on the  5G services characteristics. 
>