Subject: [Idr] Call for IETF112 IDR agenda items

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 18 Oct 2021 15:56:57 +0000

Dear all, 

The final agenda of IETF 112 is available at https://datatracker.ietf.org/meeting/112/agenda.html. IDR has two sessions this time:

1st session: November 10 (Wednesday) 12:00-14:00 (UTC) 

2nd session: November 11 (Thursday) 16:00-18:00 (UTC)

Please start to send any IDR agenda item request to me and CC the chairs ([email-masked]). And Please include the name of the person who will be presenting, and the estimate time you'll need (including Q/A). 

If you plan to make a presentation, please keep in mind the IDR tradition, "no Internet Draft - no time slot". You should also plan to send your slides to me and CC the chairs no later than 24 hours prior to the IDR meeting, though earlier is better. Please number your slides for the benefit of remote attendees. By default your slides will be converted to PDF and presented from the PDF.

And potential presenters, please take a look at the checklist for presenting at IDR:
https://trac.tools.ietf.org/wg/idr/trac/wiki/Checklist%20for%20presenting%20at%20an%20IDR%20meeting

Best regards,
Jie

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 21 Oct 2021 23:05:56 -0400

Jie:

Would you put me on the agenda for a short presentation on Flow
Specification v2?  
I will just be reviewing specific scenarios for WG.   Probably 10 minutes,
but we'll see. 
I'll be uploading the attached file this weekend. 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
Sent: Monday, October 18, 2021 11:57 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Call for IETF112 IDR agenda items

Dear all, 

The final agenda of IETF 112 is available at
https://datatracker.ietf.org/meeting/112/agenda.html. IDR has two sessions
this time:

Please start to send any IDR agenda item request to me and CC the chairs
([email-masked]). And Please include the name of the person who will be
presenting, and the estimate time you'll need (including Q/A). 

If you plan to make a presentation, please keep in mind the IDR tradition,
"no Internet Draft - no time slot". You should also plan to send your slides
to me and CC the chairs no later than 24 hours prior to the IDR meeting,
though earlier is better. Please number your slides for the benefit of
remote attendees. By default your slides will be converted to PDF and
presented from the PDF.

And potential presenters, please take a look at the checklist for presenting
at IDR:
https://trac.tools.ietf.org/wg/idr/trac/wiki/Checklist%20for%20presenting%20
at%20an%20IDR%20meeting

Best regards,
Jie

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 22 Oct 2021 14:35:31 +0200

Hi Sue,

I have one question in respect to the current version of v2 draft. It says
as a rule:

3) FSv2 rules are added starting with Rule 1 and FSv1 rules are
added after FSv2 rules.

Well two observations:

* Shouldn't the decision which one to prefer should be given to operator ?
I am afraid if we blindly define that v2 rules MUST be considered first
number of current applications may break as long as match is applied to the
interesting flows. If you like that boolean of priority could be encoded in
the signalling on a per v2 NLRI basis

* Shouldn't v2 from start define the scope of the match ? Limit it to some
interfaces, some VRFs etc ... In that case on some scoped targets v2 may be
prioritized over v1, but on the others the same very rule may be
opposite v1 should take precedence over v2.

Many thx,
Robert

On Fri, Oct 22, 2021 at 5:06 AM Susan Hares <[email-masked]> wrote:

> <https://trac.tools.ietf.org/wg/idr/trac/wiki/Checklist%20for%20presenting%20at%20an%20IDR%20meeting>
>
> Best regards,
> Jie
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 22 Oct 2021 12:39:04 +0000

Hi Sue,

I will add flowspecv2 to the draft agenda. 

Best regards,
Jie

> From: Susan Hares [mailto:[email-masked]]
> Sent: Friday, October 22, 2021 11:06 AM
> To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Idr] Call for IETF112 IDR agenda items
> 
> Jie:
> 
> If you plan to make a presentation, please keep in mind the IDR tradition, "no
> Internet Draft - no time slot". You should also plan to send your slides to me
> and CC the chairs no later than 24 hours prior to the IDR meeting, though
> earlier is better. Please number your slides for the benefit of remote attendees.
> By default your slides will be converted to PDF and presented from the PDF.
>

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 22 Oct 2021 09:02:00 -0400

Robert: 

Good question.   Thanks for asking it. 

Flow specification v2 (FSv2) and Flow specification v1 (FSv1)  are running ships in the night.  

What I understand about ships in the night:

1)  Operators and implementations may configure the FSv1 and FSv2 separately to run on some BGP peers over some interfaces.   

2) Configuring how your FSv1 and FSv2 impact the filters in your forwarding database (because of ships in the night) is also up to the operators and the configuration.  

What the rules of order were for: 

1) Ordering has a been a problem in FSV1.   The rules in FSv2 provide a deterministic order for every case I could consider.  

2) One of the FSv2 ordering issue is where to put FSV1 (which does not have an order) 

Note:  Both filters and actions were defined to be “user-ordered”  - for flexible 

I will refine the text state the purpose behind the rules are  a “rule of thumb” to help provide deterministic ordering. 

Sue 

From: Robert Raszuk [mailto:[email-masked]] 
Sent: Friday, October 22, 2021 8:36 AM
To: Susan Hares
Cc: Dongjie (Jimmy); idr@ietf. org; idr-chairs
Subject: Re: [Idr] Call for IETF112 IDR agenda items

Hi Sue,

I have one question in respect to the current version of v2 draft. It says as a rule: 

Well two observations: 

* Shouldn't the decision which one to prefer should be given to operator ? I am afraid if we blindly define that v2 rules MUST be considered first number of current applications may break as long as match is applied to the interesting flows. If you like that boolean of priority could be encoded in the signalling on a per v2 NLRI basis

* Shouldn't v2 from start define the scope of the match ? Limit it to some interfaces, some VRFs etc ... In that case on some scoped targets v2 may be prioritized over v1, but on the others the same very rule may be opposite v1 should take precedence over v2. 

Many thx,
Robert

Jie:

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
Sent: Monday, October 18, 2021 11:57 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Call for IETF112 IDR agenda items

Dear all, 

And potential presenters, please take a look at the checklist for presenting
at IDR:
https://trac.tools.ietf.org/wg/idr/trac/wiki/Checklist%20for%20presenting%20 <https://trac.tools.ietf.org/wg/idr/trac/wiki/Checklist%20for%20presenting%20at%20an%20IDR%20meeting> 
at%20an%20IDR%20meeting

Best regards,
Jie

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 26 Oct 2021 16:57:19 +0000

Jimmy and IDR chairs, 

Can we have 10 minutes to present the update to the https://datatracker.ietf.org/doc/draft-dunbar-idr-5g-edge-compute-app-meta-data/ ?

Major change includes using Tunnel_encap Path Attribute to carry the AppMetaData subTLV for egress router to advertise the running status and environment of the directly attached 5G Edge Computing servers. 

The AppMetaData can be  used by the ingress routers in the 5G Local Data Network to make intelligent path selection for flows from UEs. The goal is to improve latency and performance for 5G Edge Computing services.

Thank you. 
Linda

> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdata
> tracker.ietf.org%2Fmeeting%2F112%2Fagenda.html&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C243506649cc445f1032108d995592cbf%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637705032545135961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=76UG5zZJGpm3Sb7LemacwXetaIClz%2Fhim8s2WJNoKy0%3D&amp;reserved=0. IDR has two sessions this time:
> 
> Please start to send any IDR agenda item request to me and CC the 
> chairs ([email-masked]). And Please include the name of the 
> person who will be presenting, and the estimate time you'll need (including Q/A).
> 
> If you plan to make a presentation, please keep in mind the IDR 
> tradition, "no Internet Draft - no time slot". You should also plan to 
> send your slides to me and CC the chairs no later than 24 hours prior 
> to the IDR meeting, though earlier is better. Please number your slides for the benefit of remote attendees.
> And potential presenters, please take a look at the checklist for 
> presenting at
> IDR:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac
> .tools.ietf.org%2Fwg%2Fidr%2Ftrac%2Fwiki%2FChecklist%2520for%2520prese
> nting%2520&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C243506649
> cc445f1032108d995592cbf%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C6
> 37705032545135961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoi
> V2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=UdlquzUbzKiKUO
> b6OpfLLhakgKRWTIq%2Bm2BzAcaB0ls%3D&amp;reserved=0
> at%20an%20IDR%20meeting
> 
> Best regards,
> Jie
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Fmailman%2Flistinfo%2Fidr&amp;data=04%7C01%7Clinda.dunbar%40
> futurewei.com%7C243506649cc445f1032108d995592cbf%7C0fee8ff2a3b240189c7
> 53a1d5591fedc%7C1%7C1%7C637705032545135961%7CUnknown%7CTWFpbGZsb3d8eyJ
> WIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000
> &amp;sdata=3SNwMLCi5BIc%2FwlSrionA7R%2BlLtG83H2Qtd1CWc93Gw%3D&amp;rese
> rved=0

_______________________________________________
Idr mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fidr&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C243506649cc445f1032108d995592cbf%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637705032545135961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=3SNwMLCi5BIc%2FwlSrionA7R%2BlLtG83H2Qtd1CWc93Gw%3D&amp;reserved=0

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 27 Oct 2021 02:32:21 +0000

Hi Linda,

Your slot request is noted, please pay attention to the draft idr agenda when posted. Thanks.

Best regards,
Jie

> From: Linda Dunbar [mailto:[email-masked]]
> Sent: Wednesday, October 27, 2021 12:57 AM
> To: Dongjie (Jimmy) <[email-masked]>; Susan Hares
> <[email-masked]>; [email-masked]
> Cc: [email-masked]
> Can we have 10 minutes to present the update to the
> https://datatracker.ietf.org/doc/draft-dunbar-idr-5g-edge-compute-app-meta
> -data/ ?
> 
> Major change includes using Tunnel_encap Path Attribute to carry the
> AppMetaData subTLV for egress router to advertise the running status and
> environment of the directly attached 5G Edge Computing servers.
> 
> The AppMetaData can be  used by the ingress routers in the 5G Local Data
> Network to make intelligent path selection for flows from UEs. The goal is to
> improve latency and performance for 5G Edge Computing services.
> 
> 
> Thank you.
> Linda
> 
> >
> >
> tracker.ietf.org%2Fmeeting%2F112%2Fagenda.html&amp;data=04%7C01%7
> Clinda.dunbar%40futurewei.com%7C243506649cc445f1032108d995592cbf
> %7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637705032545135
> 961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2lu
> MzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=76UG5zZJGp
> m3Sb7LemacwXetaIClz%2Fhim8s2WJNoKy0%3D&amp;reserved=0. IDR has
> two sessions this time:
> >
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fww
> w.ietf.org%2Fmailman%2Flistinfo%2Fidr&amp;data=04%7C01%7Clinda.dunb
> ar%40futurewei.com%7C243506649cc445f1032108d995592cbf%7C0fee8ff2
> a3b240189c753a1d5591fedc%7C1%7C1%7C637705032545135961%7CUnk
> nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik
> 1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=3SNwMLCi5BIc%2FwlSrion
> A7R%2BlLtG83H2Qtd1CWc93Gw%3D&amp;reserved=0

---

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Wed, 27 Oct 2021 08:49:29 +0000

Hi Jimmy,

  I would link to request two slots:
    Draft:      Revised Error Handling for BGP Messages
    Document:  https://datatracker.ietf.org/doc/draft-wang-idr-bgp-error-enhance
    Presenter:  Haibo Wang
    Time:      10 minutes

    Draft:      Extension of Link Bandwidth Extended Community
    Document:  https://datatracker.ietf.org/doc/draft-li-idr-link-bandwidth-ext/
    Presenter:  Wenyan Li
    Time:      10 minutes

Best Regards,
Haibo

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Dongjie (Jimmy)
Sent: Monday, October 18, 2021 11:57 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Call for IETF112 IDR agenda items

Dear all, 

Best regards,
Jie

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 27 Oct 2021 13:35:47 +0000

Hi Haibo, 

Best regards,
Jie

> From: Wanghaibo (Rainsword)
> Sent: Wednesday, October 27, 2021 4:49 PM
> Subject: RE: Call for IETF112 IDR agenda items
> 
> Hi Jimmy,
> 
>     Document:
> https://datatracker.ietf.org/doc/draft-wang-idr-bgp-error-enhance
>     Presenter:  Haibo Wang
>     Time:      10 minutes
> 
>     Document:
> https://datatracker.ietf.org/doc/draft-li-idr-link-bandwidth-ext/
>     Presenter:  Wenyan Li
>     Time:      10 minutes
> 
> Best Regards,
> Haibo
>