Subject: Re: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022

From: Haisheng Yu(Johnson) <[email-masked]>
Date: Fri, 24 Dec 2021 18:01:36 +0800

Hi, all，

I support the adoption of this draft. In segment routing, the most important thing for a flow is to calculate the transmission path based on the network topology and the transmission requirements of the flow. The transmission requirements of the stream are known and determined, but how to obtain the network topology is still unknown and a very important process. Because only after the topology is known, the SR controller can calculate the SR path of the flow based on the input network topology and flow transmission requirements, that is, the segment list. So how to get the network topology in the network, this draft gives a great plan.

BTW, NLRI is mentioned many times in this draft, but no explanation is given.

Best regards.

Haisheng Yu(Johnson)

[email-masked]

Hi, Sue and all:

I have read this draft and support its adoption.

Answers to the questions:
1) Yes, it is useful for meeting the requirement of the new services in 5G and other network scenarios.
2) Global VTN-ID is not required in this document, and can be discussed separately. IDR can follow the discussion about the global ID in TEAS.

Best Regards
Shunwan

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Sunday, December 19, 2021 12:33 AM
To: [email-masked]
Subject: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022

This begins a WG Adoption call for draft-xie-idr-bgpls-sr-vtn-mt-03.txt from 12/18 2021 to 1/7/2022. The longer period is due to the Holiday/New Year time period.

The draft can be found at:
https://datatracker.ietf.org/doc/draft-xie-idr-bgpls-sr-vtn-mt/

While reviewing the document consider the following questions:

1) Does this informational draft aid operation of 5G networks for new applications?

New 5G services require stringent performance requirements for applications. This information draft describes how to use existing segment routing (SR)
mechanisms to allow a centralized control to allocate a set of virtual transport networks (VTNs) which are resource aware. Isolation between resources for multi-AS transport may be necessary to protect the application.

Intra-domain:
a) Uses MT-ID which identifies 1 or more ISIS/OSPF topologies.
[drafts referenced: draft-ietf-idr-rfc7752bis, draft-ietf-idr-bgp-ls-segment-routing-ext, draft-ietf-idr-bgpls-srv6-ext]
b) New VTN-ID which specifies resources associated with each VTN
[draft referenced: draft-ietf-lsr-isis-sr-vtn-mt]

Inter-Domain mechanisms used include:
a) Isolation of certain VTNs to specific inter-domain links or BGP peers,
b) consistent use of MT-ID across multiple domains or use of VTN-ID TLV

VTN-ID TLV is a bgp-ls TLV that specifies unique set of resources per VTN.

[existing WG drafts referenced: draft-ietf-idr-bgpls-segment-routing-epe, draft-ietf-idr-bgpls-srv6-ext, draft-ietf-idr-rfc7752bis]
New drafts referenced: draft-dong-idr-bgpls-sr-enhanced-vpn-03.txt]

2) Should IDR recommend the global VTN-ID?

The MT-ID is not an IANA registered named space. VTN-ID is proposed as a global name space, but does not have any proposed IANA registry text. Should VTN-ID become a register global name space that identifies a set of MT-IDs and other resources?

Cheers, Sue

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 27 Dec 2021 02:08:14 +0000

Hi Haisheng,

Thanks for your support and comments.

In next version we will expand the acronym “NLRI” at its first appearance.

Best regards,
Jie

From: Idr [mailto:[email-masked]] On Behalf Of Haisheng Yu
Sent: Friday, December 24, 2021 6:02 PM
To: [email-masked]
Subject: Re: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022

Hi, all，

Best regards.

[图像已被发件人删除。]

Haisheng Yu(Johnson)

[email-masked]

Hi, Sue and all:

Best Regards

Shunwan

To: [email-masked]<mailto:[email-masked]>

Intra-domain:

Cheers, Sue