Subject: [Idr] 答复: draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022

From: "qinfengwei" <[email-masked]>
Date: Sun, 2 Jan 2022 19:57:44 +0800

Hi all,

I support the adoption of this document. It describes a useful mechanism for
distributing the information of virtual underlay networks to the network
controller. 

And here are my answers to the questions:

1)  Does this informational draft aid operation of 5G networks for new
applications? 

Yes.

2) Should IDR recommend the global VTN-ID? 

This document proposes to reuse MT-IDs, thus it does not rely on global
VTN-ID. The global ID based mechanism may be helpful in some other cases,
and the discussion can happen in TEAS WG first. 

 

Thanks & BR,

Fengwei Qin

发件人: Idr [mailto:[email-masked]] 代表 Susan Hares
发送时间: 2021年12月19日 00:33
收件人: [email-masked]
主题: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption:
12/18/2021 to 1/7/2022

This begins a WG Adoption call for draft-xie-idr-bgpls-sr-vtn-mt-03.txt from
12/18 2021 to 1/7/2022.  The longer period is due to the Holiday/New Year
time period. 

The draft can be found at: 

https://datatracker.ietf.org/doc/draft-xie-idr-bgpls-sr-vtn-mt/

While reviewing the document consider the following questions: 

1)  Does this informational draft aid operation of 5G networks for new
applications? 

New 5G services require stringent  performance requirements for
applications.  This information draft describes how to use existing segment
routing (SR) 

mechanisms to allow a centralized control to allocate a set of  virtual
transport networks (VTNs) which are resource aware.  Isolation between
resources for multi-AS transport may be necessary to protect the
application. 

Intra-domain:  

a) Uses MT-ID which identifies 1 or more ISIS/OSPF topologies.

[drafts referenced:  draft-ietf-idr-rfc7752bis,
draft-ietf-idr-bgp-ls-segment-routing-ext,  draft-ietf-idr-bgpls-srv6-ext] 

b) New VTN-ID which specifies resources associated with each VTN

[draft referenced: draft-ietf-lsr-isis-sr-vtn-mt] 

Inter-Domain mechanisms used include: 

a) Isolation of certain VTNs to specific inter-domain links or BGP peers,  

b) consistent use of MT-ID across multiple domains or use of VTN-ID TLV 

VTN-ID TLV is a bgp-ls TLV that specifies unique set of resources per VTN.  

[existing WG drafts referenced: draft-ietf-idr-bgpls-segment-routing-epe,
draft-ietf-idr-bgpls-srv6-ext, draft-ietf-idr-rfc7752bis] 

New drafts referenced: draft-dong-idr-bgpls-sr-enhanced-vpn-03.txt] 

2) Should IDR recommend the global VTN-ID? 

The MT-ID is not an IANA registered named space.  VTN-ID is proposed as a
global name space, but does not have any proposed IANA registry text.
Should VTN-ID become a register global name space that identifies a set of
MT-IDs and other resources?  

Cheers, Sue

---

From: Di Ma <[email-masked]>
Date: Mon, 3 Jan 2022 13:28:48 +0800

I think the proposal here is suitable for networks with a limited number of VTNs (comparable to the number of MT-IDs) , and coordinated MT-ID assignment can scale to those involved network domains administrated by the same operator.

I support adoption as an informational item which does not extend BGP-LS  or define new ID.

Di

> 2021年12月29日 22:37，Chongfeng Xie <[email-masked]> 写道：
> 
> Hi，folks，
> I support the adoption of this draft as the author.
> Generally, our network services provide not only 5G-based wireless mobile data, but  also wireline sevice for enterprise services, this poses wide variety of requirements to the underlying transport network, this draft illustrates how to management virtual transport networks (VTNs) which are resource-aware and  resources-isolated among each over the common transport network. Obviously, this is valuable for operators.
> As mentioned several times in the mailist, this draft does not intend to design new ID or bop extension  it mainly discusses how to use mt-id and provide slicing service rapidly in operator networks. Global VTN-ID can be discussed in the future in other drafts or in other WGs.
> 
> Best regards!
> Chongfeng
> 
> 
>> 2021年12月28日 下午3:59，Lizhenbin <lizhenbin=[email-masked]> 写道：
>> 
>> Hi All,
>> I support the adoption of the draft.
> 
>  
>> My answers to the questions is as follows:
>> 1) Yes.
>> 2) Global VTN-ID is not required in this document. The work of the Global VTN ID can be discussed separately and should be discussed firstly in the TEAS WG.
>>  
>>  
>> Best Regards,
>> Zhenbin (Robin)
>>  
>>  
>>  
>> From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
>> Sent: Sunday, December 19, 2021 12:33 AM
>> To: [email-masked]
>> Subject: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022
>>  
>> This begins a WG Adoption call for draft-xie-idr-bgpls-sr-vtn-mt-03.txt from 12/18 2021 to 1/7/2022.  The longer period is due to the Holiday/New Year time period.
>>  
>> 1)  Does this informational draft aid operation of 5G networks for new applications?
>>  
>> New 5G services require stringent  performance requirements for applications.  This information draft describes how to use existing segment routing (SR)
>> mechanisms to allow a centralized control to allocate a set of  virtual transport networks (VTNs) which are resource aware.  Isolation between resources for multi-AS transport may be necessary to protect the application.
>>  
>> Intra-domain:  
>> [drafts referenced:  draft-ietf-idr-rfc7752bis, draft-ietf-idr-bgp-ls-segment-routing-ext,  draft-ietf-idr-bgpls-srv6-ext]
>> [existing WG drafts referenced: draft-ietf-idr-bgpls-segment-routing-epe, draft-ietf-idr-bgpls-srv6-ext, draft-ietf-idr-rfc7752bis]
>> The MT-ID is not an IANA registered named space.  VTN-ID is proposed as a global name space, but does not have any proposed IANA registry text.  Should VTN-ID become a register global name space that identifies a set of MT-IDs and other resources?  
>>  
>> Cheers, Sue 
>>  
>> _______________________________________________
>> Idr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/idr
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 7 Jan 2022 09:36:38 +0800

Hi  All,
 
I have read this draft and support the adoption of this document. Please see my answers to the questions as below:

Yes, the proposed mechanism is useful to networks where 5G applications and other demanding services are provided.

This informational document does not rely on global VTN-ID. The global ID based mechanism needs to be discussed in TEAS WG first.

Regards,
Chenhao
 
From: Susan Hares
Date: 2021-12-19 00:32
To: [email-masked]

 

Intra-domain:  

 

 
Cheers, Sue

---

From: Stefano Previdi <[email-masked]>
Date: Fri, 7 Jan 2022 10:32:42 +0100

Hi,

I’ve read the draft. The proposal to use existing BGP-LS (igp-derived) TLVs in order to advertise information related to the VTN and its resources makes sense to me.

I support the adoption of the document. 

Thanks.
s.

> On Dec 18, 2021, at 5:32 PM, Susan Hares <[email-masked]> wrote:
>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 7 Jan 2022 09:56:39 +0000

Hi All,
I support the adoption of this draft. It describes a mechanism of distributing VTN information using BGP-LS. It reuses MT-ID TLV (as defined in RFC7752bis) and segment routing mechanisms, so it does not require new extensions to BGP-LS.

Regarding the questions:

  1.  I think that the draft aids operation of 5G networks.
  2.  The global VTN-ID is not required in this draft. However, it should be further discussed separately and together with TEAS WG.

Best Regards,

Giuseppe

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: Saturday, December 18, 2021 5:33 PM
To: [email-masked]
Subject: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022

Intra-domain:

Cheers, Sue

---

From: "Luis M. Contreras" <[email-masked]>
Date: Fri, 7 Jan 2022 17:13:12 +0100

Hi All,

I think the draft is valuable, so I support the adoption of this draft.
Regarding Sue's questions:

1) I see it applicable to general situations as well, not only for 5G
scenarios (in fact talking of 5G scenarios where in some specific cases
there could be very stringent requirements - e.g., latency or jitter - is
something that could require further assessment).

2) The draft mentions that " (Abstract) The association between the network
topology, the network resource attributes and the SR SIDs may need to be
distributed to a centralized network controller." and then "(Section 2.2)
In network scenarios where consistent usage of MT-ID among multiple domains
can not be expected, a global-significant VTN-ID needs to be introduced to
define the inter-domain topologies." So it is not clear to me if some
additional signaling between controllers in different domains could map the
MT-IDs in each particular domain instead of going for a global VTN-ID
(which anyway should require some agreement between controllers as well). I
think this part requires more elaboration (could it even deserve a separate
document for that?).

Best regards

Luis

El sáb, 18 dic 2021 a las 17:33, Susan Hares (<[email-masked]>) escribió:

> This begins a WG Adoption call for draft-xie-idr-bgpls-sr-vtn-mt-03.txt
> from 12/18 2021 to 1/7/2022.  The longer period is due to the Holiday/New
> Year time period.
>
>
>

-- 
___________________________________________
Luis M. Contreras
[email-masked]
[email-masked]
Global CTIO unit / Telefonica

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 7 Jan 2022 19:20:02 -0500

Forwarding email received by chair.  

Sue 

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 6, 2022 8:31 PM
To: Susan Hares; [email-masked]
Subject: Re: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022

Hi  All,

 

Regards,

Chenhao

From: Susan Hares <mailto:[email-masked]> 

Date: 2021-12-19 00:32

To: [email-masked]

Intra-domain:  

Cheers, Sue

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sat, 8 Jan 2022 01:49:51 +0000

Hi Luis,

Thanks for your support and comment. Please see some replies inline:

From: Idr [mailto:[email-masked]] On Behalf Of Luis M. Contreras
Sent: Saturday, January 8, 2022 12:13 AM
To: Susan Hares <[email-masked]>
Cc: [email-masked]
Subject: Re: [Idr] draft-xie-idr-bgpls-sr-vtn-mt-03.txt - Call for WG adoption: 12/18/2021 to 1/7/2022

Hi All,

I think the draft is valuable, so I support the adoption of this draft. Regarding Sue's questions:

1) I see it applicable to general situations as well, not only for 5G scenarios (in fact talking of 5G scenarios where in some specific cases there could be very stringent requirements - e.g., latency or jitter - is something that could require further assessment).

[Jie] Agree this mechanism can be used for both 5G and the general cases.

2) The draft mentions that " (Abstract) The association between the network topology, the network resource attributes and the SR SIDs may need to be distributed to a centralized network controller." and then "(Section 2.2) In network scenarios where consistent usage of MT-ID among multiple domains can not be expected, a global-significant VTN-ID needs to be introduced to define the inter-domain topologies." So it is not clear to me if some additional signaling between controllers in different domains could map the MT-IDs in each particular domain instead of going for a global VTN-ID (which anyway should require some agreement between controllers as well). I think this part requires more elaboration (could it even deserve a separate document for that?).

[Jie] This document mainly targets on the scenarios where consistent usage of MT-ID among multiple domains can be achieved. For scenarios where consistent MT-ID is not possible, your point about providing mapping between the MT-IDs in different domains is something could be considered further, and it may be an alternative to the global VTN-ID approach.

Best regards,
Jie

Best regards

Luis

El sáb, 18 dic 2021 a las 17:33, Susan Hares (<[email-masked]<mailto:[email-masked]>>) escribió:
This begins a WG Adoption call for draft-xie-idr-bgpls-sr-vtn-mt-03.txt from 12/18 2021 to 1/7/2022.  The longer period is due to the Holiday/New Year time period.

Intra-domain:

Cheers, Sue

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

--
___________________________________________
Luis M. Contreras
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
Global CTIO unit / Telefonica