Subject: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

From: Keyur Patel <[email-masked]>
Date: Fri, 4 Feb 2022 16:27:57 +0000

Hi Folks:

The working group last call has been issued for draft-ietf-idr-wide-bgp-communities-06.txt, “BGP Community Container Attribute”.  Please reply to the list with your comments. This adoption call will conclude on February 18th, 2022.

The draft can be found at: https://datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/. The implementation report for the draft can be found at: https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities.  Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Best Regards,

Keyur

---

From: Huaimo Chen <[email-masked]>
Date: Fri, 4 Feb 2022 17:14:30 +0000

Hi Everyone,

    I read through the document. It is useful and ready. I support it.

Best Regards,
Huaimo
________________________________
From: Idr <[email-masked]> on behalf of Keyur Patel <[email-masked]>
Sent: Friday, February 4, 2022 11:27 AM
To: [email-masked] <[email-masked]>
Subject: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

The draft can be found at: https://datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-wide-bgp-communities%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cc3cbc85cf6c145d25e2508d9e7fb5d04%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637795889070596194%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=j0s2kD%2B2xH5ztK%2F4O4e5Hsjtf0gMxTwn0KvNY0pD24U%3D&reserved=0>. The implementation report for the draft can be found at: https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fidr%2Fwiki%2Fdraft-ietf-idr-wide-bgp-communities&data=04%7C01%7Chuaimo.chen%40futurewei.com%7Cc3cbc85cf6c145d25e2508d9e7fb5d04%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637795889070596194%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=EWbmVCdgFMszGPK993r%2F%2BWQKkPsI%2BkACJVGJCBw6ywU%3D&reserved=0>.  Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Best Regards,

Keyur

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 4 Feb 2022 10:11:55 -0800

Yes/support (about time 😊)

Cheers,

Jeff

From: Keyur Patel
Sent: Friday, February 4, 2022 8:28 AM
To: [email-masked]
Subject: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

Best Regards,

Keyur

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 4 Feb 2022 16:22:47 -0500

I support publication.

This specification is valuable for operators.

Thanks

Gyan

On Fri, Feb 4, 2022 at 1:13 PM Jeff Tantsura <[email-masked]>
wrote:

> *From: *Keyur Patel <[email-masked]>
> *Sent: *Friday, February 4, 2022 8:28 AM
> *To: [email-masked]
> *Subject: *[Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt
> (2/4/2022 to 2/18/2022)
>
>
>
> Hi Folks:
>
>
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 4 Feb 2022 22:47:31 +0100

Support.

I am not aware of any undisclosed relevant IPR related to this proposal.

Kind regards,
Robert.

---

From: Melchior Aelmans <[email-masked]>
Date: Fri, 4 Feb 2022 23:49:35 +0100

I support! Thanks.

Cheers,
Melchior

---

From: Zhuangshunwan <[email-masked]>
Date: Mon, 7 Feb 2022 02:25:04 +0000

Hi Everyone,

I have reviewed this document, It is a useful solution for conveying routing policy in the centralized control scenarios from centralized devices to routers and the distributed scenarios from routers to routers.
It is ready, I support publication.

Best Regards,

Shunwan

From: Idr [mailto:[email-masked]] On Behalf Of Keyur Patel
Sent: Saturday, February 5, 2022 12:28 AM
To: [email-masked]
Subject: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

Best Regards,

Keyur

---

From: <[email-masked]>
Date: Mon, 7 Feb 2022 12:59:39 +0000

Hi Keyur, WG,

I'm not aware of non-disclosed IPR.

Best regards,
--Bruno

Orange Restricted
From: Idr <[email-masked]> On Behalf Of Keyur Patel
Sent: Friday, February 4, 2022 5:28 PM
To: [email-masked]
Subject: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

The working group last call has been issued for draft-ietf-idr-wide-bgp-communities-06.txt, "BGP Community Container Attribute".  Please reply to the list with your comments. This adoption call will conclude on February 18th, 2022.

Best Regards,

Keyur

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Job Snijders <[email-masked]>
Date: Mon, 7 Feb 2022 15:28:18 +0100

Dear IDR chairs & working group,

On Fri, Feb 04, 2022 at 04:27:57PM +0000, Keyur Patel wrote:
> The working group last call has been issued for
> draft-ietf-idr-wide-bgp-communities-06.txt, “BGP Community Container
> Attribute”.  Please reply to the list with your comments. This
> adoption call will conclude on February 18th, 2022.
> 
> The draft can be found at:
> https://datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/.
> The implementation report for the draft can be found at:
> https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities.

IDR tradition is to demand multiple interopable implementations exist
before a document can progress towards the RFC publication status. I
noticed that large parts of the draft are NOT implemented by either of
the two implementations; such as:

	* support for T/C/R bits (section 3.1)
	* no targets
	* atoms (both 4.4.1 + 4.4.2)
	* RouterAttr_

While the implementation report available to us indicates that some of
the features are "optional", this does not relief us from the burden of
demonstrating that the "optional" feature can actually be implemented in
an interoperable way. As such, the path forward is either to implement
the optional features, or to remove the text from the Internet-Draft and
spin it off into a separate Internet-Draft (which in turn could proceed
if implementations ever show up).

I strongly believe that IDR, SIDROPS, and other inter-domain working
groups should not ship any text (as part of large docs) which is not
directly or indirectly covered in an interopability matrix. E.g. I don't
see an issue if there are 3 features, and implementation A covers
features 1+2, B covers 2+3, and C covers 3+1 - in such scenarios the
full feature set has multiple implementations. Unfortunately this does
not appear to be the case for the 'wide communities' document.

Many in this working group will probably remember that flexible/wide
communities were somewhat contentious because of perceived complexity -
the lack of full coverage in implementation reports, and the presence of
merely 2 half implementations does not increase confidence that
publication of this document will benefit operators in the long term.

It is also entirely possible I am misreading the implementation report!

I look forward to hear other people's thoughts on this matter.

Kind regards,

Job

ps. I do not mind the two implementations coming from the same vendor
house; I trust the two product lines to be sufficiently distinct to
be viewed as independently developed implementations.

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 7 Feb 2022 15:52:45 +0100

Hi Job,

>   * support for T/C/R bits (section 3.1)

Where do you see R bit in the latest version as per subject line ?

>       * atoms (both 4.4.1 + 4.4.2)

Implementations can clarify that,.

>      * RouterAttr_

Can you point to the text ?

- - -

In general I think if we start cutting any spec into N different documents
each progressing only when there are two documented implementations of its
optional parameters or fields it is going to be a huge mess both
implementation wise as well as

What I think matters is if not implementing optional capabilities in any
negative way affects the core purpose of the spec. If yes I agree such
elements should be removed before publication. But if not I see no harm to
leave them in the WG document/RFC.

Thx,
Robert,.

---

From: Job Snijders <[email-masked]>
Date: Mon, 7 Feb 2022 16:11:49 +0100

Hi Robert,

On Mon, Feb 07, 2022 at 03:52:45PM +0100, Robert Raszuk wrote:
> Can you point to the text 

If the text at this URL is outdated, WGLC is going to be really hard
because how can the working group assess whether the document has been
adequately implemented and tested for interopability, if the report
contains outdated or incorrect information?

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities

Please revise the above Trac wiki as needed.

> implementation wise as well as

I disagree.

> leave them in the WG document/RFC.

So we agree on removing substantial parts of the internet-draft?

Kind regards,

Job

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 7 Feb 2022 16:27:53 +0100

Hi Job,

The URL Keyur sent is correct and points to correct document:

https://datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/

The implementation wiki indeed has some broken links to draft-idr-rpd ...
maybe copy and paste error ? Not sure. Maybe someone needs to do some
cleanup on it ?

Many thx,
Robert

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 7 Feb 2022 15:38:41 +0000

Hi Job,

    Thank you for your comments.

> I noticed that large parts of the draft are NOT implemented by either of

In fact, large parts of the draft are implemented. The container structure
is the big and core part, and is implemented.
* RouterAttr is supported in target TLV.
The others you mentioned above seem small.
*T/C bits are just two bits, No R bits.
*no targets is a corner case, where target TLV does not contain any sub-TLV.
*atoms (both 4.4.1 + 4.4.2). The key parts of these are generalized and
implemented in RouterAttr from functions' point of view.

Best Regards,
Huaimo
________________________________
From: Idr <[email-masked]> on behalf of Job Snijders <job=[email-masked]>
Sent: Monday, February 7, 2022 9:28 AM
To: Keyur Patel <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

On Fri, Feb 04, 2022 at 04:27:57PM +0000, Keyur Patel wrote:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-wide-bgp-communities%2F&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea462d54%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=P4FuUp7LztEycz1Mp57LmHlRj2mLYQN6N21J%2FsKHJ7s%3D&amp;reserved=0.
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fidr%2Fwiki%2Fdraft-ietf-idr-wide-bgp-communities&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea462d54%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=4IbMmOGntVIS%2BKciDnjjSGRBK1io7HivFuWb%2F6%2FXmN0%3D&amp;reserved=0.

Kind regards,

Job

_______________________________________________
Idr mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fidr&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea462d54%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=GbUJjgACwnki8CUSfbpavFI1mm4HuiF4zjKGqzDGbKA%3D&amp;reserved=0

---

From: Job Snijders <[email-masked]>
Date: Mon, 7 Feb 2022 16:40:59 +0100

> maybe copy and paste error ? Not sure. Maybe someone needs to do some

Again, I am referring to the content on
https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities
- a URL that Keyur provided.

trac != datatracker

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 7 Feb 2022 11:18:36 -0500

Job: 

<WG chair hat on> 

IDR WG has done WG LC for protocols without 2 complete implementations.
If a draft passes WG LC, the Chairs then hold the 
Draft until we have 2 implementations. 

In the past, the IDR WG chairs required 
all mandatory requirements are implemented. 

a) The T/C bits in section 3.1 are mandatory.  
B_ The TargetTLV with "no Targets" is a mandatory attribute. 
(see 4.4.1 in version -06.txt) 

The IDR WG may request WG chairs to forward a  
draft for publication with some
optional features not implemented.   

The atoms (both 4.4.1 + 4.4.2) are included in that list. 

The implementation report is at: 
https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities

The WG draft is at: 

 <WG chair hat off>

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Job Snijders
Sent: Monday, February 7, 2022 10:12 AM
To: Robert Raszuk
Cc: Keyur Patel; [email-masked]
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt
(2/4/2022 to 2/18/2022)

Hi Robert,

> Can you point to the text

If the text at this URL is outdated, WGLC is going to be really hard because
how can the working group assess whether the document has been adequately
implemented and tested for interopability, if the report contains outdated
or incorrect information?

> In general I think if we start cutting any spec into N different 
> documents each progressing only when there are two documented 
> implementations of its optional parameters or fields it is going to be 
> a huge mess both implementation wise as well as

I disagree.

> What I think matters is if not implementing optional capabilities in 
> any negative way affects the core purpose of the spec. If yes I agree 
> such elements should be removed before publication. But if not I see 
> no harm to leave them in the WG document/RFC.

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 7 Feb 2022 11:30:40 -0500

Job: 

<WG Chair> 
Thank you for letting me know there are broken links
 on the implementation page.  I believe I have addressed these issues.  
Please reload your page and let me know if there are more. 

I hope you will provide feedback on atoms 1-8 
as optional  features that are not implemented. 

In the past, the IDR has made the following choices on
1) remove from specification (knowing may come back as a BIS)
2) hold the draft for implementations of atoms 1-8. 
3) keep optional features in the text, but note lack of 
    implementations  (rare, but possible if WG desires). 
<WG chair off> 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Job Snijders
Sent: Monday, February 7, 2022 10:41 AM
To: Robert Raszuk
Cc: Keyur Patel; [email-masked]
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt
(2/4/2022 to 2/18/2022)

trac != datatracker

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 7 Feb 2022 11:19:18 -0500

Huaimo: 

Thank  you for this feedback on implementation. 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Huaimo Chen
Sent: Monday, February 7, 2022 10:39 AM
To: Job Snijders; Keyur Patel
Cc: [email-masked]
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt
(2/4/2022 to 2/18/2022)

Hi Job,

Best Regards, 

Huaimo

  _____  

From: Idr <[email-masked]> on behalf of Job Snijders
<job=[email-masked]>
Sent: Monday, February 7, 2022 9:28 AM
To: Keyur Patel <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt
(2/4/2022 to 2/18/2022) 

On Fri, Feb 04, 2022 at 04:27:57PM +0000, Keyur Patel wrote:
> draft-ietf-idr-wide-bgp-communities-06.txt, "BGP Community Container
> Attribute".  Please reply to the list with your comments. This
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracke
r.ietf.org%2Fdoc%2Fdraft-ietf-idr-wide-bgp-communities%2F
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrack
er.ietf.org%2Fdoc%2Fdraft-ietf-idr-wide-bgp-communities%2F&amp;data=04%7C01%
7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea462d54%7C0fee8ff2a
3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnknown%7CTWFpbGZsb3d
8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&a
mp;sdata=P4FuUp7LztEycz1Mp57LmHlRj2mLYQN6N21J%2FsKHJ7s%3D&amp;reserved=0>
&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea
462d54%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnk
nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXV
CI6Mn0%3D%7C3000&amp;sdata=P4FuUp7LztEycz1Mp57LmHlRj2mLYQN6N21J%2FsKHJ7s%3D&
amp;reserved=0.
> The implementation report for the draft can be found at:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.
org%2Ftrac%2Fidr%2Fwiki%2Fdraft-ietf-idr-wide-bgp-communities
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf
.org%2Ftrac%2Fidr%2Fwiki%2Fdraft-ietf-idr-wide-bgp-communities&amp;data=04%7
C01%7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea462d54%7C0fee8
ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnknown%7CTWFpbGZ
sb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C30
00&amp;sdata=4IbMmOGntVIS%2BKciDnjjSGRBK1io7HivFuWb%2F6%2FXmN0%3D&amp;reserv
ed=0>
&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea
462d54%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnk
nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXV
CI6Mn0%3D%7C3000&amp;sdata=4IbMmOGntVIS%2BKciDnjjSGRBK1io7HivFuWb%2F6%2FXmN0
%3D&amp;reserved=0.

Kind regards,

Job

_______________________________________________
Idr mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.o
rg%2Fmailman%2Flistinfo%2Fidr
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.
org%2Fmailman%2Flistinfo%2Fidr&amp;data=04%7C01%7Chuaimo.chen%40futurewei.co
m%7C50fb90d944c84707a7ad08d9ea462d54%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%
7C0%7C637798409450407938%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjo
iV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=GbUJjgACwnki8CUSfbp
avFI1mm4HuiF4zjKGqzDGbKA%3D&amp;reserved=0>
&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C50fb90d944c84707a7ad08d9ea
462d54%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798409450407938%7CUnk
nown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXV
CI6Mn0%3D%7C3000&amp;sdata=GbUJjgACwnki8CUSfbpavFI1mm4HuiF4zjKGqzDGbKA%3D&am
p;reserved=0

---

From: 'Job Snijders' <[email-masked]>
Date: Mon, 7 Feb 2022 17:42:11 +0100

Dear Sue, others,

Thank you for your message.

>     implementations  (rare, but possible if WG desires). 

As 'Atoms' appear to be a core aspect of Wide Communities, so it seems
quite awkward to publish this document - without any implementation of
the concept of Atoms!

To me it seems that 'option 2 - hold the draft for implementation' is
the simplest path forward, or as secondary choice 'remove from spec'.

Publication of internet-drafts which lack implementations, in my opinion
sets dangerous precedent for IDR; I hope the WG appreciates my
insistence on this matter.

Kind regards,

Job

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 7 Feb 2022 17:48:34 +0100

Job,

https://datatracker.ietf.org/doc/html/draft-ietf-idr-rpd-15#page-8 defines
two new atoms and documents its implementation. Does this mean that atoms
from the original spec are to be removed ? To me this proves that core of
the spec is extensible which is a feature not a bug.

Thx a lot,
R.

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 7 Feb 2022 16:50:06 +0000

Hi Job,

> quite awkward to publish this document - without any implementation of

    The concept of Atoms is implemented.  RouterAttr is an atom implemented.

Best Regards,
Huaimo
________________________________
From: Idr <[email-masked]> on behalf of 'Job Snijders' <job=[email-masked]>
Sent: Monday, February 7, 2022 11:42 AM
To: Susan Hares <[email-masked]>
Cc: 'Keyur Patel' <[email-masked]>; 'Robert Raszuk' <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Dear Sue, others,

Kind regards,

Job

_______________________________________________
Idr mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fidr&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C1b95dad810b3402e3b3408d9ea58de0e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637798489703254316%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=h5sCHCY%2F6bO8mO5EInGn3TZ5r3bYXLcTSFuEjqcnv1c%3D&amp;reserved=0

---

From: 'Job Snijders' <[email-masked]>
Date: Mon, 7 Feb 2022 18:52:02 +0100

>     The concept of Atoms is implemented.  RouterAttr is an atom implemented.

I'm increasingly confused, "RouterAttr" is a word which does not appear
anywhere in: https://datatracker.ietf.org/doc/html/draft-ietf-idr-wide-bgp-communities

Furthermore, I see on https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities
indeed has a reference to the word "RouterAttr", but also the wiki shows
"Atoms (1-8): Not Support | Not Support"

Perhaps at the next IDR meeting at IETF113 a coherent consistent
overview can be presented on what is and is not implemented?

Kind regards,

Job

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 7 Feb 2022 18:11:08 +0000

Hi Job,

> I'm increasingly confused, "RouterAttr" is a word which does not appear ...

    It seems clear in the report with the notes.  "RouterAttr" is an atom, different from atoms 1 - 8, and from the reference given.

Best Regards,
Huaimo
________________________________
From: 'Job Snijders' <[email-masked]>
Sent: Monday, February 7, 2022 12:52 PM
To: Huaimo Chen <[email-masked]>
Cc: Susan Hares <[email-masked]>; 'Keyur Patel' <[email-masked]>; 'Robert Raszuk' <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

I'm increasingly confused, "RouterAttr" is a word which does not appear
anywhere in: https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-idr-wide-bgp-communities&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C1dfacdbe9f1a4cf8dafa08d9ea628e3c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637798531300096884%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=y6%2B5HjDtJfsJgPJOgAMIqkHwL59wJB5tcp7GNeIKj%2Bk%3D&amp;reserved=0

Furthermore, I see on https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fidr%2Fwiki%2Fdraft-ietf-idr-wide-bgp-communities&amp;data=04%7C01%7Chuaimo.chen%40futurewei.com%7C1dfacdbe9f1a4cf8dafa08d9ea628e3c%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637798531300096884%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=bcIqXss72YhiCMiNDVa24j15fUsSEmA8VoG1qz4uw3c%3D&amp;reserved=0
indeed has a reference to the word "RouterAttr", but also the wiki shows
"Atoms (1-8): Not Support | Not Support"

Kind regards,

Job

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 7 Feb 2022 18:41:30 -0500

Robert: 

I agree that the concept of atoms has clearly been proven by the RouteAttr. 

The RouteAttr_  in the implementation report is a hack to work around the wiki formatting issues.  

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Monday, February 7, 2022 11:49 AM
To: Job Snijders
Cc: Keyur Patel; Susan Hares; idr@ietf. org
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Job, 

https://datatracker.ietf.org/doc/html/draft-ietf-idr-rpd-15#page-8 defines two new atoms and documents its implementation. Does this mean that atoms from the original spec are to be removed ? To me this proves that core of the spec is extensible which is a feature not a bug. 

Thx a lot,

R.

Dear Sue, others,

Kind regards,

Job

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 8 Feb 2022 00:50:47 +0100

Indeed Sue - 100 % with your assessment on this.

In fact the current implementation report proves very well Job's point that
atoms can be defined also as separate documents.

The only question which I think Job brings to the table is if currently
defined atoms in the WGLC draft could stay or should be removed.

My personal recommendation is to keep them in the spec. Reason being that
authors went via extensive discussions with community which lead to define
and document those atoms. Keeping them in the document also for one allows
any implementation to catch up while does not close the door (as proven) to
define new atoms.

Kind regards,
Robert.

On Tue, Feb 8, 2022 at 12:41 AM Susan Hares <[email-masked]> wrote:

> *From:* Idr [mailto:[email-masked]] *On Behalf Of *Robert Raszuk
> *Sent:* Monday, February 7, 2022 11:49 AM
> *To:* Job Snijders
> *Cc:* Keyur Patel; Susan Hares; idr@ietf. org
> *Subject:* Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt
> (2/4/2022 to 2/18/2022)
>
>
>
> Job,
>
>
>
> https://datatracker.ietf.org/doc/html/draft-ietf-idr-rpd-15#page-8
> defines two new atoms and documents its implementation. Does this mean that
> atoms from the original spec are to be removed ? To me this proves that
> core of the spec is extensible which is a feature not a bug.
>
>
>
> Thx a lot,
>
> R.
>
>
>

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 7 Feb 2022 23:57:38 +0000

I think the draft-ietf-idr-wide-bgp-communities-06 is ready for publication. I support the WGLC.
Linda Dunbar

From: Keyur Patel<mailto:[email-masked]>
Sent: Friday, February 4, 2022 8:28 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

The draft can be found at: https://datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-wide-bgp-communities%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C643de43c0ba04a002b7d08d9e8249406%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637796066078367604%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=4B4iqtEQX14eaGgiFMZjCC%2F9Pe5E50ABt2dj9tYqW9U%3D&reserved=0>. The implementation report for the draft can be found at: https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fidr%2Fwiki%2Fdraft-ietf-idr-wide-bgp-communities&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C643de43c0ba04a002b7d08d9e8249406%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637796066078367604%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=VSV07uT5gxoU7V76CVjsL7ID0mGF7oMSEtOzLsyJa4I%3D&reserved=0>.  Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Best Regards,

Keyur

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fidr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C643de43c0ba04a002b7d08d9e8249406%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637796066078367604%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Eqe8KBV19SGW5LBx4gBUCRhHSc%2FcoYlSjwpJM1stSF8%3D&reserved=0>
--

---

From: Job Snijders <[email-masked]>
Date: Tue, 8 Feb 2022 13:35:34 +0100

Hi,

> any implementation to catch up while does not close the door (as proven) to

Interesting! From my recollection of discussions with the community
there is low appetite for those atoms.

I fear IDR would do itself a disservice if the WG publishes documents
which (in part) never have been implemented. I forsee that challenges
could arise down the road due to perceived ambiguities, not so
dissimilar from issues with the original FlowSpec specification.

Kind regards,

Job

---

From: "Lange, Andrew (Nokia - US)" <[email-masked]>
Date: Tue, 8 Feb 2022 03:29:57 +0000

I agree with Robert, the atom mechanism is proven by implementation, and keeping the existing atoms documented reflects community consensus.

I also agree with Linda that the document is ready for publication.

Andrew
________________________________
From: Idr <[email-masked]> on behalf of Linda Dunbar <[email-masked]>
Sent: Monday, February 7, 2022 3:57 PM
To: [email-masked] <[email-masked]>
Cc: Keyur Patel <[email-masked]>
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Linda Dunbar

Hi Folks:

Best Regards,

Keyur

--

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 8 Feb 2022 13:38:59 -0500

+1

I agree with Robert as well that the atom mechanism has been proven by the
implementation and that all atoms defined in the specification should
remain for future extensibility by operators as well as developers seeking
new innovations such as RPD that could reap the benefit of this
extensibility.

The key point here is that the wide community draft can be implemented by
operators as well as can be utilized to design new solutions like the RPD
 that can be still developed in the future that may need to take advantage
of the other atoms or features not implemented by RPD.

So I think in this case it’s is different then the norm that every feature
must be implemented for interoperability.

This document is ready for publication.

Kind Regards

Gyan
On Tue, Feb 8, 2022 at 11:31 AM Lange, Andrew (Nokia - US) <
[email-masked]> wrote:

> I agree with Robert, the atom mechanism is proven by implementation, and
> keeping the existing atoms documented reflects community consensus.
>
> ------------------------------
> *From:* Idr <[email-masked]> on behalf of Linda Dunbar <
> [email-masked]>
> *Sent:* Monday, February 7, 2022 3:57 PM
> *To:* [email-masked] <[email-masked]>
> *Cc:* Keyur Patel <[email-masked]>
> The draft can be found at: https://datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/ <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-wide-bgp-communities%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C643de43c0ba04a002b7d08d9e8249406%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637796066078367604%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=4B4iqtEQX14eaGgiFMZjCC%2F9Pe5E50ABt2dj9tYqW9U%3D&reserved=0>. The implementation report for the draft can be found at: https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fidr%2Fwiki%2Fdraft-ietf-idr-wide-bgp-communities&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C643de43c0ba04a002b7d08d9e8249406%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637796066078367604%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=VSV07uT5gxoU7V76CVjsL7ID0mGF7oMSEtOzLsyJa4I%3D&reserved=0>.  Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.
>
>
>
> Best Regards,
>
> Keyur
>
>
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fidr&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C643de43c0ba04a002b7d08d9e8249406%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637796066078367604%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Eqe8KBV19SGW5LBx4gBUCRhHSc%2FcoYlSjwpJM1stSF8%3D&reserved=0>
>
> --
>
>
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Fri, 11 Feb 2022 03:09:19 +0000

Hi Everyone:
I have read the document, this extension can bring more convenience for operator's usage.
I support publication.

Regards,
Haibo

Hi Folks:

Best Regards,

Keyur

---

From: Lizhenbin <[email-masked]>
Date: Fri, 11 Feb 2022 11:26:15 +0000

Hi All,
I support the publication of the draft.

Best Regards,
Zhenbin (Robin)

李振斌 Li Zhenbin
Mobile: +86-13651017745/+968-91797068
Email: [email-masked]

发件人：Keyur Patel <[email-masked]>
收件人：idr <[email-masked]>
时 间：2022-02-05 00:28:40
主 题：[Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

Best Regards,

Keyur

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Fri, 11 Feb 2022 12:19:16 +0000

Support

Thanks,
              Jim Uttaro

From: Idr <[email-masked]> On Behalf Of Lizhenbin
Sent: Friday, February 11, 2022 6:26 AM
To: Keyur Patel <[email-masked]>; idr <[email-masked]>
Subject: Re: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi All,

Best Regards,
Zhenbin (Robin)

李振斌 Li Zhenbin
Mobile: +86-13651017745/+968-91797068
Email: [email-masked]<mailto:[email-masked]>
发件人：Keyur Patel <[email-masked]<mailto:[email-masked]>>
收件人：idr <[email-masked]<mailto:[email-masked]>>
时 间：2022-02-05 00:28:40
主 题：[Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

The draft can be found at: https://datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-idr-wide-bgp-communities/__;!!BhdT!yEnKDDvzNlGB4bMJCu6fZDkqO-Nl-yCcXpKwsBmrVV0bG1xq0wCNjS-NGYw$>. The implementation report for the draft can be found at: https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities<https://urldefense.com/v3/__https:/trac.ietf.org/trac/idr/wiki/draft-ietf-idr-wide-bgp-communities__;!!BhdT!yEnKDDvzNlGB4bMJCu6fZDkqO-Nl-yCcXpKwsBmrVV0bG1xq0wCNUSJHSa0$>.  Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Best Regards,

Keyur

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 11 Feb 2022 19:28:47 -0500

Support.

Thanks,

- Xufeng

Sent from Mail for Windows

From: Keyur Patel
Sent: Friday, February 4, 2022 11:28 AM
To: [email-masked]
Subject: [Idr] WG LC on draft-ietf-idr-wide-bgp-communities-06.txt (2/4/2022 to 2/18/2022)

Hi Folks:

Best Regards,

Keyur

Virus-free. www.avast.com

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 18 Feb 2022 06:48:45 +0000

Hi Keyur,

I support the publication of this document. It provides a flexible approach for carrying atom information in BGP.

Best regards,
Jie

Hi Folks:

Best Regards,

Keyur