Subject: [Idr] I-D Action: draft-ymbk-idr-l3nd-02.txt

From: [email-masked]
Date: Mon, 07 Mar 2022 13:33:14 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Layer-3 Neighbor Discovery
        Authors         : Randy Bush
                          Russ Housley
                          Rob Austein
                          Susan Hares
                          Keyur Patel
	Filename        : draft-ymbk-idr-l3nd-02.txt
	Pages           : 27
	Date            : 2022-03-07

Abstract:
   Data Centers where the topology is BGP-based need to discover
   neighbor IP addressing, IP Layer-3 BGP neighbors, etc.  This Layer-3
   Neighbor Discovery protocol identifies BGP neighbor candidates.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ymbk-idr-l3nd/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ymbk-idr-l3nd-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ymbk-idr-l3nd-02

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 7 Mar 2022 16:49:21 -0500

I'll be responding to the longer messages in detail early this week.  However, I did want to note a consideration from one of the obvious changes between -01 and -02:

There is a strong implication that HELLO must be advertised in both directions.  

This means that it's not possible to only have the "server" side of a BGP auto discovery session advertising that it's ready to accept incoming sessions.  Clients must also make similar advertisements with the option to reject incoming sessions.  

In situations where all BGP Speakers are willing to mutually peer with each other, this is perhaps not a problem.  However, I don't think that's the desired behavior.

-- Jeff

> On Mar 7, 2022, at 4:33 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Randy Bush <[email-masked]>
Date: Mon, 07 Mar 2022 14:13:01 -0800

> I'll be responding to the longer messages in detail early this week.

including walls of text of similar deep dive reviews
of the other proposals as you told sue?

randy

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 7 Mar 2022 17:16:12 -0500

> On Mar 7, 2022, at 5:13 PM, Randy Bush <[email-masked]> wrote:
> 

Yes, Randy.

It's not as if you're special or something.

-- Jeff