Subject: [Idr] l3nd questions

From: Randy Bush <[email-masked]>
Date: Tue, 22 Mar 2022 13:11:31 -0700

due to funky audio/video and fried brain, i did not get the post l3nd
questions and discussions as i should have.

a short and terse precis would be very helpful.  walls of text just turn
what's left of my brain off.

thanks!

randy

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 22 Mar 2022 16:43:13 -0400

> On Mar 22, 2022, at 4:11 PM, Randy Bush <[email-masked]> wrote:
> 

In an effort to conserve your brain, here are the four things I mentioned.  The minutes will have the rest of the details:

The lowest address for the session, similar to LDP, will mean that discovery on a broadcast network wants to turn into a full mesh of connections.  
Thought exercise, what happens with this mechanism on an IXP network with a route server and all participants using discovery?

I mentioned attributes looked like the roles you fought to get out of the design team requirements doc.  This was so even after it was pointed out that only a few well known code points were desired and the rest were for the users.
See also wall of text in prior messages asking how change of attributes influences restart procedures.

You're quite concerned about stochastic behaviors.  L3ND requires a HELLO to be heard before TCP engages.  This is no different than any of the "shout in the dark" procedures requiring a listener to hear at least one packet.  The difference with those is one packet is enough wherein the session based protocols just get their state machines run, and not the BGP state machines.

For encapsulations, it's not clear why you need these PDUs.  They're a source of conflicting state.
ULPC provides the IPv4 and IPv6 peering addresses.  (Erroneously specified as prefixes, I think.)
BGP just needs to know the address to peer with.
The receiver of discovery either has a IPv4 or IPv6 subnet configured for the link or not.  Hearing that the sender of the discovery message has a subnet isn't helpful.

-- Jeff