Subject: [Idr] SCION Internet Architecture side meeting today

From: Nicola Rustignoli <[email-masked]>
Date: Tue, 22 Mar 2022 09:16:45 +0000

Dear idr,

Today we are organizing a side meeting on SCION, a next-generation Internet architecture providing route control, failure isolation, and explicit trust information for inter-domain communication.
If you are interested, you are welcome to attend our side meeting today at 16:30 (Vienna time,  on-site or on Zoom, right after idr ).
In this meeting, Adrian Perrig and other SCION practitioners would welcome an open discussion about the SCION concept and setup, and address possible future work at the IETF.
For more details, see https://notes.ietf.org/s/LaApgxo2b

If you want to focus on the routing-related aspects of SCION: Please join the Routing Area Open Meeting<https://datatracker.ietf.org/doc/agenda-113-rtgarea/> tomorrow, Wednesday, March 23, where Adrian Perrig will give a presentation that focuses on these aspects.

Looking forward to a good discussion
Best regards,
Nicola Rustignoli
ETH Zürich

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 22 Mar 2022 14:13:03 +0100

Hi Nicola,

I have been following SCION privately for a while ... I must admit that you
got a few things right. Of course there will be lots of folks saying that
you can accomplish most if not all what you claim as well with BGP-4 today.

But do you think this is ready for IETF vs IRTF ? I think at this stage it
seems like a great solid work for IRTF.

For IDR I am not sure. Clearly it is not in the charter to work on it.
Maybe new WG ? Maybe RTGWG ?

Kind regards,
Robert

On Tue, Mar 22, 2022 at 10:18 AM Nicola Rustignoli <[email-masked]>
wrote:

> Dear idr,
>
> Today we are organizing a side meeting on SCION, a next-generation
> Internet architecture providing route control, failure isolation, and
> explicit trust information for inter-domain communication.
> If you are interested, you are welcome to attend our side meeting today at
> 16:30 (Vienna time,  on-site or on Zoom, right after idr ).
> In this meeting, Adrian Perrig and other SCION practitioners would
> welcome an open discussion about the SCION concept and setup, and address
> possible future work at the IETF.
> If you want to focus on the routing-related aspects of SCION: Please join
> the Routing Area Open Meeting
> <https://datatracker.ietf.org/doc/agenda-113-rtgarea/> tomorrow, Wednesday,
> March 23, where Adrian Perrig will give a presentation that focuses on
> these aspects.
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 22 Mar 2022 16:07:59 +0100

Robert,

This IETF champions in finding new work for RTGWG :)

On a serious note - I have been encouraging SCION folks to come to IETF for a number of years, and I’m rather happy to see them here (no-one is an island in the global routing system). Creating awareness and explaining the technology is the 1st step in a potential collaboration. I agree with you on IDR point wrt wg. the work could potentially be done, however IDR participants are the main target audience for the technology.

New work in IETF is driven by willingness of IETF community to take on potential new work and (hopefully) industry willing to use this work. Same would apply to SCION.

Let’s meet each other before getting married ;-)

Cheers,
Jeff 

> On Mar 22, 2022, at 14:13, Robert Raszuk <[email-masked]> wrote:
> 
> Hi Nicola,
> 
> I have been following SCION privately for a while ... I must admit that you got a few things right. Of course there will be lots of folks saying that you can accomplish most if not all what you claim as well with BGP-4 today. 
> 
> But do you think this is ready for IETF vs IRTF ? I think at this stage it seems like a great solid work for IRTF. 
> 
> For IDR I am not sure. Clearly it is not in the charter to work on it. Maybe new WG ? Maybe RTGWG ? 
> 
> Kind regards,
> Robert
> 
> 
> On Tue, Mar 22, 2022 at 10:18 AM Nicola Rustignoli <[email-masked] <mailto:[email-masked]>> wrote:
> Dear idr,
> 
> For more details, see https://notes.ietf.org/s/LaApgxo2b <https://notes.ietf.org/s/LaApgxo2b> 
> 
> 
> If you want to focus on the routing-related aspects of SCION: Please join the Routing Area Open Meeting <https://datatracker.ietf.org/doc/agenda-113-rtgarea/> tomorrow, Wednesday, March 23, where Adrian Perrig will give a presentation that focuses on these aspects.
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/idr <https://www.ietf.org/mailman/listinfo/idr>