Subject: [Idr] BGP CAR question: Expressing Intent..

From: Kaliraj Vairavakkalai <[email-masked]>
Date: Fri, 25 Mar 2022 19:08:41 +0000

Hi CAR authors,

I wanted to list this question in a separate email, so it doesn’t get lost amongst others.

Q: In CAR, how does one express intent, to achieve the following scenarios? Where different routes may want the same primary color but distinct fallbacks. Or two routes want opposite (primary, fallback) colors.

To illustrate with a topology:
                                                                           Color 100
                                                [PE1]------------ Color 200 --------------------[PE2]
                                                                           Color 200

E.g. Simple topology with an ingress PE1 and egress PE2. Single color domain. Tunnels of colors 100, 200, 300 exist from PE1 -> PE2.

Now, if PE2 wants to advertise the following routes Route1 to Route5 to PE1.

Such that at PE1,

  1.  Route1 wants to use color 100, fallback on best-effort.
  2.  Route2 wants to use color 100, fallback on color 200.
  3.  Route3 wants to use color 100, fallback on color 300.
  4.  Route4 wants to use color 200, fallback on color 100.
  5.  Route5 wants to use color 200, without any fallback.

How is this achieved in CAR?

Thanks
Kaliraj

Juniper Business Use Only

---

From: Natrajan Venkataraman <[email-masked]>
Date: Wed, 30 Mar 2022 19:58:09 +0000

A Gentle Reminder.

Regards,
-Nats-

From: Idr <[email-masked]> on behalf of Kaliraj Vairavakkalai <kaliraj=[email-masked]>
Date: Friday, March 25, 2022 at 12:09 PM
To: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: [Idr] BGP CAR question: Expressing Intent..
[External Email. Be cautious of content]

Hi CAR authors,

Such that at PE1,

Thanks
Kaliraj