Subject: Re: [Idr] draft-hb-idr-sr-p2mp-policy (3/10 to 3/24/2022) - Adoption call - TEA attribute - for P2MP Policy Route

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 7 Apr 2022 13:02:20 +0000

Hi Sue, Hooman,

Let me use this separate email to comment on the TEA for the P2MP Policy Route.

>From RFC9012:

   This document defines a BGP path attribute known as the "Tunnel
   Encapsulation attribute", which can be used with BGP UPDATEs of
   various Subsequent Address Family Identifiers (SAFIs) to provide
   information needed to create tunnels and their corresponding
   encapsulation headers.  It provides encodings for a number of tunnel
   types, along with procedures for choosing between alternate tunnels
   and routing packets into tunnels

>From https://datatracker.ietf.org/doc/html/draft-hb-idr-sr-p2mp-policy-05#section-3.2.1:

   SR P2MP Policy SAFI NLRI: <route-type p2mp-policy>

   Attributes:

      Tunnel Encaps Attribute (23)

         Tunnel Type: (TBD, P2MP-Policy)

            Preference

            Policy Name

            Policy Candidate Path Name

            leaf-list (optional)

               remote-end point

               remote-end point

                        ...

            path-instance

               active-instance-id

               instance-id

               instance-id

                       ...

The information encoded in the "P2MP-policy" tunnel in the TEA do not seem to be "encapsulation" related at all. It's just the control plane information listing candidate paths and instances.

Rather than adding that to TEA, perhaps we should just have a top level "SR-P2MP Policy Information" attribute?

Draft-bess can move towards this approach - have a separate "P2MP Policy" route (vs. using a wide community attached to the Replication State route), with the "SR-P2MP Policy Information" attribute.

Thanks.

Jeffrey

Juniper Business Use Only

---

From: "Bidgoli, Hooman (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 7 Apr 2022 18:35:24 +0000

HI Jeffrey

As per my other email the only solution and collaboration I see you keep proposing is for us to abandon draft-hb-idr-sr-p2mp-policy and bring the ideas to draft-bess?

As mentioned by yourself and other members draft-bess is heavily loaded and hard to follow and we should separate the P2MP policy from that draft for easy digestion, again as per your own suggestion.

I propose we go forward with draft-hb-idr as the underlay tunneling belongs in idr.

As previously done and mentioned we are more then happy to incorporate your suggestions to improve this draft, we have incorporate your suggestion on the route types and creating a single route type for replication segment and shared replication segment.

Thanks and Regards
Hooman

From: Jeffrey (Zhaohui) Zhang <[email-masked]>
Sent: Thursday, April 7, 2022 9:02 AM
To: Susan Hares <[email-masked]>; [email-masked]; Bidgoli, Hooman (Nokia - CA/Ottawa) <[email-masked]>
Subject: RE: [Idr] draft-hb-idr-sr-p2mp-policy (3/10 to 3/24/2022) - Adoption call - TEA attribute - for P2MP Policy Route

Hi Sue, Hooman,

   Attributes:

            Preference

            Policy Name

            leaf-list (optional)

               remote-end point

               remote-end point

                        ...

            path-instance

               active-instance-id

               instance-id

               instance-id

                       ...

Thanks.

Jeffrey

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 7 Apr 2022 22:19:02 +0000

Hi Hootman,

Please see zzh> below.

Juniper Business Use Only
From: Bidgoli, Hooman (Nokia - CA/Ottawa) <[email-masked]>
Sent: Thursday, April 7, 2022 2:35 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Subject: RE: [Idr] draft-hb-idr-sr-p2mp-policy (3/10 to 3/24/2022) - Adoption call - TEA attribute - for P2MP Policy Route

[External Email. Be cautious of content]

HI Jeffrey

Zzh> I have been explaining why I think the draft-bess methods are good/better - purely technical discussions. I have accepted methods in draft-hb as well, and I am fine with having a separate draft.

Zzh> Please see above.

Zzh> I am not against that; I am just asking for consolidation/alignment discussions before adoption.

Zzh> My email today are about the inconsistency between the two approaches, and why I think we can/should consolidate.
Zzh> Thanks.
Zzh> Jeffrey

Thanks and Regards
Hooman

From: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, April 7, 2022 9:02 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Bidgoli, Hooman (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Idr] draft-hb-idr-sr-p2mp-policy (3/10 to 3/24/2022) - Adoption call - TEA attribute - for P2MP Policy Route

Hi Sue, Hooman,

>From https://datatracker.ietf.org/doc/html/draft-hb-idr-sr-p2mp-policy-05#section-3.2.1<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-hb-idr-sr-p2mp-policy-05*section-3.2.1__;Iw!!NEt6yMaO-gk!VewHupnK7UeQNb4vJD6w7QYdlfJacVPbRpexg4wqAjailBpOMC4zhlkexAcEftWr$>:

   Attributes:

            Preference

            Policy Name

            leaf-list (optional)

               remote-end point

               remote-end point

                        ...

            path-instance

               active-instance-id

               instance-id

               instance-id

                       ...

Thanks.

Jeffrey