Subject: [ieee-ietf-coord] FW: IESG Statement on Ethertypes

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 26 Oct 2012 12:44:48 +0200

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of IESG Secretary
Sent: Thursday, October 25, 2012 8:35 PM
To: IETF Announcement List
Cc: [email-masked]
Subject: IESG Statement on Ethertypes

The IEEE Registration Authority (IEEE RA) assigns Ethertypes with oversight from the IEEE Registration Authority Committee (IEEE RAC).
(See http://standards.ieee.org/develop/regauth/ethertype/.)  Some IETF protocol specification make use of Ethertypes.  All Ethertype requests are subject to review by a consultant to the IEEE RA followed by IEEE RAC confirmation. 

Since Ethertypes are a fairly scarce resource, the IEEE RAC has let us know that they will not assign a new Ethertype to a new IETF protocol specification until the IESG has approved the protocol specification for publication as an RFC.  In exceptional cases, the IEEE RA is willing to consider "early allocation" of an Ethertype for an IETF protocol that is still under development as long as the request comes from and has been vetted by the IESG.

To let the IEEE RAC know that the IESG has approved the request for an Ethernet assignment for an IETF protocol, all future requests for assignment of Ethertypes for IETF protocols will be made by the IESG.

Note that playpen Ethertypes have been assigned in IEEE 802 [1] for use during protocol development and experimentation.

[1] IEEE Std 802a-2003 (Amendment to IEEE Std 802-2001).
    IEEE standard for Local and Metropolitan Area Networks:
    Overview and Architecture -- Amendment 1: Ethertypes for
    Prototype and Vendor-Specific Protocol Development.

---

From: Geoff Thompson <[email-masked]>
Date: Fri, 26 Oct 2012 16:08:10 -0700

Dan-

That statement is lovely as far as it goes.
It applies very nicely to new work.

Does there exist the case where the IETF gives its imprimatur to an 
existing protocol?

Ifso, then the RA should be perfectly willing to continue the use of an 
existing EtherType, especially if the original type had provision for 
sub-typing. In such a situation I strongly guess that the RA would be 
willing to update the information in the EtherType database to reflect 
the change of control of the protocol from the original applicant to the 
IETF upon appropriate notification.

If the odds of this happening are well above zero then we should 
generates agreements and add text to the agreement to cover such a 
situation.

Geoff Thompson

On 2610//12 3:44 AM, Romascanu, Dan (Dan) wrote:
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>
>

---

From: Russ Housley <[email-masked]>
Date: Sat, 27 Oct 2012 00:26:58 -0400

Geoff:

In such cases, I believe that the IESG would want to continue to use an already assigned ethertype as well.

Russ

On Oct 26, 2012, at 7:08 PM, Geoff Thompson wrote:

> Does there exist the case where the IETF gives its imprimatur to an existing protocol?
> 
> Ifso, then the RA should be perfectly willing to continue the use of an existing EtherType, especially if the original type had provision for sub-typing. In such a situation I strongly guess that the RA would be willing to update the information in the EtherType database to reflect the change of control of the protocol from the original applicant to the IETF upon appropriate notification.
> 
> If the odds of this happening are well above zero then we should generates agreements and add text to the agreement to cover such a situation.
> 
> Geoff Thompson
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sat, 27 Oct 2012 11:45:09 +0200

Should we include text in 4441bis to describe this? 

Dan

> From: Russ Housley [mailto:[email-masked]]
> Sent: Saturday, October 27, 2012 6:27 AM
> To: [email-masked]
> Cc: Romascanu, Dan (Dan); IEEE RAC; Pat Thaler;
[email-masked]
> Subject: Re: [ieee-ietf-coord] FW: IESG Statement on Ethertypes
> 
> Geoff:
> 
> In such cases, I believe that the IESG would want to continue to use
an
> already assigned ethertype as well.
> 
> Russ
> 
> > Ifso, then the RA should be perfectly willing to continue the use of
> an existing EtherType, especially if the original type had provision
for
> >> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of IESG Secretary
> >> The IEEE Registration Authority (IEEE RA) assigns Ethertypes with
> oversight from the IEEE Registration Authority Committee (IEEE RAC).
> >> (See http://standards.ieee.org/develop/regauth/ethertype/.)  Some
> IETF protocol specification make use of Ethertypes.  All Ethertype
> requests are subject to review by a consultant to the IEEE RA followed
> by IEEE RAC confirmation.
> >>
> >> Since Ethertypes are a fairly scarce resource, the IEEE RAC has let
> us know that they will not assign a new Ethertype to a new IETF
protocol
> specification until the IESG has approved the protocol specification
for
> publication as an RFC.  In exceptional cases, the IEEE RA is willing
to
> consider "early allocation" of an Ethertype for an IETF protocol that
is
> still under development as long as the request comes from and has been
> vetted by the IESG.
> >>
> >> To let the IEEE RAC know that the IESG has approved the request for
> an Ethernet assignment for an IETF protocol, all future requests for
> assignment of Ethertypes for IETF protocols will be made by the IESG.
> >>
> >> Note that playpen Ethertypes have been assigned in IEEE 802 [1] for
> use during protocol development and experimentation.
> >>
> >>