Subject: [ieee-ietf-coord] FW: SARP

From: Eric Gray <[email-masked]>
Date: Fri, 27 Sep 2013 17:13:45 +0000

Folks,

        I recently (yesterday) received this mail regarding an issue that has only
just came to the attention of the Vice Chair of IEEE 802.1 (Glenn Parsons).

        This issue submarined us because the title of the draft does not reflect
what it actually does.

        Unfortunately, this came to light because it has been proposed as a
candidate for WG adoption by the INT Area WG.

        I discussed this with Dan Romascanu and he hopes to add it to the agenda
for the Coordination meeting scheduled for next Monday.  Dan also suggested I
should get this out to folks as early as possible so that we can be prepared to both
discuss and - potentially - address this issue.

        I have explicitly copied the Internet ADs and the INT Area WG Chairs in
hopes that this will make it more visible in their E-Mail queues.

--
Eric

_____________________________________________
From: Glenn Parsons
Sent: Thursday, September 26, 2013 11:52 AM
To: [email-masked]; Mick Seaman; Panagiotis Saltsidis; Norman Finn (nfinn); Janos Farkas; Pat Thaler; Michael Johas Teener; John Messenger; Eric Gray
Subject: SARP
Importance: High

Folks,

I have just noticed an IETF draft called Scaling ARP that is being pushed to become a WG document in the INTAREA WG.  But I think this "SARP proxy" is really a MAC NAT...

http://tools.ietf.org/html/draft-nachum-sarp-06

This breaks a lot of things in my view but there are a lot of supporters :-(    That is, the WG chairs are not able to dismiss it.

The obvious thing thing is that this is a 1:N NAT function.  As well,  L3 has to be in the frame for it to work so all L2 E2E non-IP protocols are off the table.

Anyway, I think we (802.1) need to engage in this to understand it better.

I suppose we could go so far to say that this is our turf, and make that known to the IESG.  The next coordination call with IESG is on Sept 30th.

I'd appreciate your views...

Cheers,
Glenn.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 27 Sep 2013 17:27:51 +0000

Hi,

Thanks Eric for bringing this up.

To some extent we are lucky with the timing, as the next coordination call is on Monday. I will add the issue to the agenda. Please look into the issue and prepare the discussion.

I am also copying Bernard and Eliot.

Regards,

Dan

From: Eric Gray [mailto:[email-masked]]
Sent: Friday, September 27, 2013 8:14 PM
To: [email-masked]
Cc: Romascanu, Dan (Dan); Brian Haberman; Ted Lemmon; Suresh Krishnan; Julien Langanier
Subject: FW: SARP
Importance: High

Folks,

--
Eric

_____________________________________________
From: Glenn Parsons
Sent: Thursday, September 26, 2013 11:52 AM
To: [email-masked]<mailto:[email-masked]>; Mick Seaman; Panagiotis Saltsidis; Norman Finn (nfinn); Janos Farkas; Pat Thaler; Michael Johas Teener; John Messenger; Eric Gray
Subject: SARP
Importance: High

Folks,

Cheers,
Glenn.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 27 Sep 2013 17:34:02 +0000

Hi,

(resending to a better - I hope - address for Ted)

Regards,

Dan

Folks,

--
Eric

Folks,

Cheers,
Glenn.

---

From: Brian Haberman <[email-masked]>
Date: Fri, 27 Sep 2013 15:05:35 -0400

Hi Eric,
     This draft has been shopped around to several WGs based on the
feedback I have gotten.  I will point out that almost everyone who has
voiced support for this document has some type of relationship
(typically co-workers) with the authors.

     The call for adoption has recently ended and one of the WG chairs
is looking for advice from the IESG on how to proceed.  It would be good
if the folks in the IEEE interested in, or concerned with, this draft
could provide concrete comments on it.  That feedback would be quite
valuable.

Regards,
Brian

On 9/27/13 1:13 PM, Eric Gray wrote:
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Sep 2013 16:39:06 -0400

Remember that the IETF doesn't vote.   Technical objections have to be answered.   I would strongly encourage the IEEE participants who think there are problems with this spec to raise those objections, and that will empower the working group chairs to make a decision not to move forward, if those objections can't be meaningfully answered.

The objections can of course be raised in a liaison statement or at the ieee-coord meeting, but the most effective way to raise them is on the mailing list, which is open to all participants.   Liaison statements take a lot of time, and document adoption periods in the IETF are short.

I apologize for not catching this and bringing it to the IEEE's attention—it's obviously something that you should have had an earlier opportunity to weigh in on, but for some reason when I reviewed it I wasn't wearing my ieee-coord thinking cap, and it just didn't occur to me.   I intend to take this as a teaching moment, FWIW.

---

From: Eric Gray <[email-masked]>
Date: Fri, 27 Sep 2013 20:55:15 +0000

Ted,

	Without realizing that this is more than just ARP, but also requires MAC
address translation, it is hard to see where this would be a problem.  As I have
just explained to someone else, it takes a fairly in-depth review to really get a
handle on exactly what the mechanism does.

	If one is thinking strictly in terms of ARP, it seems obvious that this will
not be an issue for anyone outside of the IETF.

	Don't beat yourself up over it.  :-)

--
Eric

-----Original Message-----
From: Ted Lemon [mailto:[email-masked]] 
Sent: Friday, September 27, 2013 4:39 PM
To: Eric Gray
Cc: [email-masked]; Romascanu, Dan (Dan) ([email-masked]); Brian Haberman; Julien Langanier; Suresh Krishnan
Subject: Re: [ieee-ietf-coord] SARP
Importance: High

I apologize for not catching this and bringing it to the IEEE's attention-it's obviously something that you should have had an earlier opportunity to weigh in on, but for some reason when I reviewed it I wasn't wearing my ieee-coord thinking cap, and it just didn't occur to me.   I intend to take this as a teaching moment, FWIW.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Sep 2013 19:39:32 -0400

> 	Don't beat yourself up over it.  :-)

I'm not beating myself up, but really I should have a trigger that "innovation at layer 2 should be mentioned to the IEEE."   :)