Subject: [ieee-ietf-coord] FW: Time-Sensitive Networking Side Meeting (Bar BOF)

From: Eric Gray <[email-masked]>
Date: Wed, 16 Jul 2014 22:02:01 +0000

Forwarded on behalf of Norm Finn...

-----Original Message-----
From: Norman Finn (nfinn) [mailto:[email-masked]] 
Sent: Wednesday, July 16, 2014 5:56 PM
To: [email-masked]; Richard Barnes; Alissa Cooper; Alia Atlas; Adrian Farrel; Julien Meuric; JP Vasseur; Alvaro Retana (aretana); Jeff Tantsura; Brian Haberman; Ted Lemon; Pascal Thubert (pthubert); Thomas Watteyne; Ray Bellis; Mark Townsley; Spencer Dawkins; Martin Stiemerling; David Black; Gorry Fairhurst; James Polk (jmpolk)
Cc: Michael Teener; Eric Gray; Jouni Korhonen; Paul Unbehagen; Glenn Parsons
Subject: Time-Sensitive Networking Side Meeting (Bar BOF)

This is a heads-up to the addressed ADs and WG chairs.  I (and a number of others, including the CCed people, above) have been at an IEEE 802.1 meeting, this week, and will also be at IETF90 next week.  A straw poll, yesterday, resulted in this email from me.  We wish to have a side meeting (was Bar BOF — I have read and understand RFC6771) on the subject of Time-Sensitive Networking.  There has not yet been time to coordinate this with the other IEEE people, even those listed, above, so consider this a message from me only.  It is possible that an official liaison from IEEE
802.1 will be generated, tomorrow.

Separately from this email, I have initiated a room request for IETF90.  I realize that it is very late, but the meeting schedules for our respective groups are what they are.  Perhaps any arrangements can be contingent upon an official liaison from IEEE 802.1.

The following would be (something similar to) the announcement that we would make to your working group mailing lists (not your area mailing lists), in order to get the right number of people (including as many of the above-addressed ADs and WG chairs as possible) to the meeting:

Over the last few years, the IEEE 802 Time-Sensitive Networking Task Group has released standards that support:

1. Reserving network resources for critical flows.
2. Providing critical flows a guarantee of 0 congestion loss and
(consequently) a known finite end-to-end latency.

The IEEE 802.1 Time-Sensitive Networking Task Group is currently expanding these capabilities from the audio/video world to include industrial, vehicular, and other real-time systems.  We have come to realize that, by definition, we are building circuits.  Looking beyond Ethernet and Wi-Fi networks to something I call Deterministic Networking, it is abundantly clear to many of us that we need the following to make the market explode:

A. Deterministic Networking has to be a QoS feature of standard networks, not a set of hard-to-use features around which you can write an Application.
B. The networks of interest contain a mixture of bridges and routers.  The QoS features have to be supported regardless of L2/L3 boundaries.  The control protocols must be visible to both routers and bridges; every box along the path must reserve resources.
C. The host must not know or care whether the first box to which it is connected is a bridge or a router.

A number of us believe that the model for information propagation used by the Path Computation Element, RSVP, RSVP-TE, and PCEP are a superset of that used by the IEEE 802.1Qat Stream Reservation Protocol (intentionally), and offer at least a model for an L2/L3 combined effort.
We would very much like to test the waters in IETF, and see if there is interest in working on some of the above problems.

A side meeting will be held at ________ in _____________ to discuss this.

— Norm Finn

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 16 Jul 2014 23:29:02 +0000

I support holding this meeting, and I hope that the ADs will approve allocating space for it. We have this item also on the preliminary agenda for the 9/29 f2f leadership meeting and a discussion between the experts in IEEE 802.1 and IETF would prepare the ground. 

Norm - you left the date/time open, is there a preferred time? Monday evening after the technical plenary? 

Regards,

Dan

> From: ieee-ietf-coord [mailto:[email-masked]] On Behalf
> Of Eric Gray
> Sent: Thursday, July 17, 2014 1:02 AM
> To: [email-masked]
> Subject: [ieee-ietf-coord] FW: Time-Sensitive Networking Side Meeting (Bar
> BOF)
> 
> To: [email-masked]; Richard Barnes; Alissa Cooper; Alia Atlas; Adrian
> Farrel; Julien Meuric; JP Vasseur; Alvaro Retana (aretana); Jeff Tantsura;
> Brian Haberman; Ted Lemon; Pascal Thubert (pthubert); Thomas Watteyne;
> Ray Bellis; Mark Townsley; Spencer Dawkins; Martin Stiemerling; David Black;
> Gorry Fairhurst; James Polk (jmpolk)
> This is a heads-up to the addressed ADs and WG chairs.  I (and a number of
> others, including the CCed people, above) have been at an IEEE 802.1
> meeting, this week, and will also be at IETF90 next week.  A straw poll,
> yesterday, resulted in this email from me.  We wish to have a side meeting
> (was Bar BOF — I have read and understand RFC6771) on the subject of
> Time-Sensitive Networking.  There has not yet been time to coordinate this
> with the other IEEE people, even those listed, above, so consider this a
> message from me only.  It is possible that an official liaison from IEEE
> Separately from this email, I have initiated a room request for IETF90.  I
> realize that it is very late, but the meeting schedules for our respective
> groups are what they are.  Perhaps any arrangements can be contingent
> upon an official liaison from IEEE 802.1.
> 
> The following would be (something similar to) the announcement that we
> would make to your working group mailing lists (not your area mailing lists), in
> order to get the right number of people (including as many of the above-
> addressed ADs and WG chairs as possible) to the meeting:
> 
> The IEEE 802.1 Time-Sensitive Networking Task Group is currently expanding
> these capabilities from the audio/video world to include industrial, vehicular,
> and other real-time systems.  We have come to realize that, by definition, we
> are building circuits.  Looking beyond Ethernet and Wi-Fi networks to
> something I call Deterministic Networking, it is abundantly clear to many of us
> that we need the following to make the market explode:
> 
> A. Deterministic Networking has to be a QoS feature of standard networks,
> not a set of hard-to-use features around which you can write an Application.
> B. The networks of interest contain a mixture of bridges and routers.  The
> QoS features have to be supported regardless of L2/L3 boundaries.  The
> control protocols must be visible to both routers and bridges; every box
> along the path must reserve resources.
> A number of us believe that the model for information propagation used by
> the Path Computation Element, RSVP, RSVP-TE, and PCEP are a superset of
> that used by the IEEE 802.1Qat Stream Reservation Protocol (intentionally),
> and offer at least a model for an L2/L3 combined effort.
> We would very much like to test the waters in IETF, and see if there is
> interest in working on some of the above problems.
> 
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 17 Jul 2014 12:57:58 +0100

Are there no bars in Toronto? :-)

> From: ieee-ietf-coord [mailto:[email-masked]] On Behalf Of
> Romascanu, Dan (Dan)
> Sent: 17 July 2014 00:29
> Subject: Re: [ieee-ietf-coord] FW: Time-Sensitive Networking Side Meeting (Bar
> BOF)
> 
> I support holding this meeting, and I hope that the ADs will approve allocating
> space for it. We have this item also on the preliminary agenda for the 9/29 f2f
> leadership meeting and a discussion between the experts in IEEE 802.1 and IETF
> would prepare the ground.
>

---

From: "Fedyk, Don" <[email-masked]>
Date: Thu, 17 Jul 2014 18:37:11 +0000

http://alltorontopubs.com/

Isn't this why we have the internet? :-)

-----Original Message-----
From: ieee-ietf-coord [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, July 17, 2014 7:58 AM
To: 'Romascanu, Dan (Dan)'; [email-masked]
Subject: Re: [ieee-ietf-coord] FW: Time-Sensitive Networking Side Meeting (Bar BOF)

> From: ieee-ietf-coord [mailto:[email-masked]] On 
> Behalf Of Romascanu, Dan (Dan)
> Sent: 17 July 2014 00:29
> I support holding this meeting, and I hope that the ADs will approve 
> allocating space for it. We have this item also on the preliminary 
> agenda for the 9/29 f2f leadership meeting and a discussion between 
> the experts in IEEE 802.1 and IETF would prepare the ground.
> 
> > From: ieee-ietf-coord [mailto:[email-masked]] On 
> > Behalf Of Eric Gray
> > To: [email-masked]; Richard Barnes; Alissa Cooper; Alia 
> > Atlas; Adrian Farrel; Julien Meuric; JP Vasseur; Alvaro Retana 
> > (aretana); Jeff Tantsura; Brian Haberman; Ted Lemon; Pascal Thubert 
> > (pthubert); Thomas Watteyne; Ray Bellis; Mark Townsley; Spencer 
> > Dawkins; Martin Stiemerling; David Black; Gorry Fairhurst; James 
> > Polk (jmpolk)
> > This is a heads-up to the addressed ADs and WG chairs.  I (and a 
> > number of others, including the CCed people, above) have been at an 
> > IEEE 802.1 meeting, this week, and will also be at IETF90 next week.  
> > A straw poll, yesterday, resulted in this email from me.  We wish to 
> > have a side meeting (was Bar BOF — I have read and understand 
> > RFC6771) on the subject of Time-Sensitive Networking.  There has not 
> > yet been time to coordinate this with the other IEEE people, even 
> > those listed, above, so consider this a message from me only.  It is 
> > possible that an official liaison from IEEE
> > Separately from this email, I have initiated a room request for 
> > IETF90.  I realize that it is very late, but the meeting schedules 
> > for our respective groups are what they are.  Perhaps any 
> > arrangements can be contingent upon an official liaison from IEEE 802.1.
> >
> > The following would be (something similar to) the announcement that 
> > we would make to your working group mailing lists (not your area 
> > mailing lists), in order to get the right number of people 
> > (including as many of the above- addressed ADs and WG chairs as possible) to the meeting:
> >
> > Over the last few years, the IEEE 802 Time-Sensitive Networking Task 
> > Group has released standards that support:
> >
> > The IEEE 802.1 Time-Sensitive Networking Task Group is currently 
> > expanding these capabilities from the audio/video world to include 
> > industrial, vehicular, and other real-time systems.  We have come to 
> > realize that, by definition, we are building circuits.  Looking 
> > beyond Ethernet and Wi-Fi networks to something I call Deterministic 
> > Networking, it is abundantly clear to many of us that we need the following to make the market explode:
> >
> > A. Deterministic Networking has to be a QoS feature of standard 
> > networks, not a set of hard-to-use features around which you can write an Application.
> > B. The networks of interest contain a mixture of bridges and 
> > routers.  The QoS features have to be supported regardless of L2/L3 
> > boundaries.  The control protocols must be visible to both routers 
> > and bridges; every box along the path must reserve resources.
> > A number of us believe that the model for information propagation 
> > used by the Path Computation Element, RSVP, RSVP-TE, and PCEP are a 
> > superset of that used by the IEEE 802.1Qat Stream Reservation 
> > Protocol (intentionally), and offer at least a model for an L2/L3 combined effort.
> > We would very much like to test the waters in IETF, and see if there 
> > is interest in working on some of the above problems.
> >