Subject: Re: [ieee-ietf-coord] IETF and IEEE 802 coordination teams meeting @ IETF 95 - April 5

From: Jodi Haasz <[email-masked]>
Date: Wed, 22 Jun 2016 12:13:23 -0400

Dear Dan:

>From our meeting in April, I had the action item to follow up on the ICSG
Encrypted Traffic Inspection (ETI) Working Group.  After discussions, the
working group has agreed not to extend; rather to build on it, if
feasible.  If IETF is interested in establishing a liaison with IETF,
please contact the ETI Working Group Chair, Olaf Bonorden via email at at
[email-masked].

If I can be of any further assistance, please let me know.

Best regards,

Jodi Haasz
International Affairs Senior Liaison
IEEE Standards Association
445 Hoes Lane
Piscataway, NJ 08854-4141 USA
Phone +1 732 562 6367
Mobile +1 732 439 9144
FAX +1 732 562 1571
Email: [email-masked]
-----------------------------------------------------------------------------
IEEE – Advancing Technology for Humanity

On Mon, Apr 11, 2016 at 10:47 AM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

> Hi,
>
>
>
> The teams working on the coordination of the IETF and IEEE 802 activities
> met at IETF 95, at the traditional breakfast gathering. The meeting was
> well attended, > 25 participants. Here are my principal takes. If anything
> important is missing – especially as action items / next steps – please
> comment.
>
>
>
> 1.       Coordination of the VLAN YANG models work in the IETF with YANG
> models development in the IEEE 802.1 WG (related to item 27 in the shared
> list)
>
> -          We need a conference call with the participation of all
> interested parties. The proposal is to get time on the agenda of one of the
> IEEE 802.1 TSN TG calls which take place on Mondays from 11AM ET. Target
> date is Monday 5/9 – to be confirmed on the mail list.
>
> 2.       IP multicast over wireless LAN (item 28) – status after the
> Sunday tutorial, next steps
>
> -          Sunday tutorial was well attended – estimated audience was
> 100. Needs to be updated, as during 2016 there will be more new work and
> progress on existing work.
>
> -          Continue discussions on the shared list, INT area, 6tisch and
> other WGs
>
> -          Ask the edu team for another tutorial slot on the same topic
> at IETF 97 – with updates
>
> 3.       Another tutorial topic for IETF 96 ‘: 'Advanced issues in IEEE
> 802' (with two items currently discussed: Local Addresses, IEEE 802
> Privacy) - Pat Thaler and Juan Carlos Zuniga owners
>
> -          Both tutorial requests were forwarded by Dan to the edu team.
> They will be considered relative to the other items that requested
> schedules and prioritized
>
> 4.       Industry Connections Security Group (ICSG) and TLS
>
> -          Stephen Farrell informed on this new activity. Not an IEEE 802
> project, but rather a community group under IEEE-SA. Charter and status are
> not clear yet, but there is a potential to clash/break TLS implementations
> and deployments. Jodi Hasz (from IEEE-SA) offered to clarify status in IEEE
> and help establishing communication. To follow-up.
>
> 5.       Future meetings (June virtual, September f2f)
>
> -          Next virtual meeting on Wednesday 6/8 at 1PM
>
> -          F2F meeting on 9/9: we got proposals from York (John
> Messenger) and Warsaw (Bob Heile). Some participants rather prefer an
> airport hub in Europe. Dan and Pat will contact Ray Pelletier and Jon
> Rosdahl to look for proposals. Preliminary agenda to be distributed in the
> coming weeks.
>
>
>
> Thanks and Regards,
>
>
>
> Dan
>
>
>
>
>
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>
>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 22 Jun 2016 19:24:22 +0100

Hi Jodi,

On 22/06/16 17:13, Jodi Haasz wrote:
> Encrypted Traffic Inspection (ETI) Working Group.  

Thanks for following up.

> After discussions, the
> feasible. 

Sorry, I'm not clear what you mean. On which "it" is someone planning
to build what?

> If IETF is interested in establishing a liaison with IETF,

I don't think a liaison is what we're after here. Rather, I think
we wanted to note that the seemingly planned work appears to run
counter to IETF consensus as e.g. reflected in RFC7258, that the
IETF has repeatedly been asked to break TLS in the manner that ETI
group seem to be assuming, and that the IETF has refused to do that
also basing for example on RFC2804. And in fact I did note that in
a call with the ETI group, and again at IETF95. So I'm not at all
sure what remains to be said. Would it make some difference to say
such things in some formal sense? If so, to whom? I've already
passed on that information to the ETI group.

I'd also note that the ETI work also seems to me at least to be
in conflict with efforts such as those to improve privacy of MAC
addresses.

Thanks,
S.

---

From: Jodi Haasz <[email-masked]>
Date: Wed, 22 Jun 2016 15:04:18 -0400

Dear Stephen:

"It" refers to TLS; therefore, the group has agreed not to extend TLS but
rather to build upon it, if possible.  They will be exploring their options.

If there are still concerns, I would highly recommend setting up a liaison
so that IETF can receive information on the group's activities (and provide
information/comments in return).

Best regards,

Jodi Haasz

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 22 Jun 2016 20:10:44 +0100

Thanks Jodi,

On 22/06/16 20:04, Jodi Haasz wrote:
> rather to build upon it, if possible.  

Ah good. That's great to know thanks.

> They will be exploring their options.
> 

I think it'd be good to get a status update from them sometime, so's
we avoid future confusion. I'm not sure that an ongoing liaison is
a useful way to do that, (seems heavyweight), but if there were a way
to get the information that that group had reached a checkpoint in
their work, that was visible to IETFers, that'd be good perhaps. If
it makes it easier to track that by having the IETF send a liaison
along the lines of "please do let us know when you've gotten to a
thing you can show us, so we all avoid surprises" I'd be happy to
get that sent from our side. Or is there a better plan?

Cheers,
S.

---

From: Jodi Haasz <[email-masked]>
Date: Wed, 22 Jun 2016 15:48:21 -0400

Dear Stephen:

What our groups consider a liaison (and the rules for establishing such a
liaison) and the IETF definition and rules may be very different.  We
consider a liaison to be an exchange of information.  So, if Dan agrees (as
I believe he is the liaison to IEEE?), perhaps it may be best to reach out
to the working group chair to see how this could best be accomplished as
this is not a standards developing group.

Best regards,

Jodi Haasz

On Wed, Jun 22, 2016 at 3:10 PM, Stephen Farrell <[email-masked]>
wrote:

> >>>> interested parties. The proposal is to get time on the agenda of one
> of
> >> the
> >>>> project, but rather a community group under IEEE-SA. Charter and
> status
> >> are

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 23 Jun 2016 08:45:22 +0000

Hi Jodi,

I can confirm that I am the IETF liaison manager to the IEEE-SA.

We are working on a possible communication to the ETI WG on this matter. Thanks for the information and advice that you provided.

One point of clarification, though. You write that the ETI WG is not a standards development group. Can you clarify for the IETF participants what type if group it is and what kind of deliverables are within its charter?

Thanks and Regards,

Dan

From: Jodi Haasz [mailto:[email-masked]]
Sent: Wednesday, June 22, 2016 10:48 PM
To: Stephen Farrell
Cc: Romascanu, Dan (Dan); [email-masked]
Subject: Re: [ieee-ietf-coord] IETF and IEEE 802 coordination teams meeting @ IETF 95 - April 5

Dear Stephen:

What our groups consider a liaison (and the rules for establishing such a liaison) and the IETF definition and rules may be very different.  We consider a liaison to be an exchange of information.  So, if Dan agrees (as I believe he is the liaison to IEEE?), perhaps it may be best to reach out to the working group chair to see how this could best be accomplished as this is not a standards developing group.

Best regards,

Jodi Haasz
Email: [email-masked]<mailto:[email-masked]>

On Wed, Jun 22, 2016 at 3:10 PM, Stephen Farrell <[email-masked]<mailto:[email-masked]>> wrote:

Thanks Jodi,

Cheers,
S.

> Phone +1 732 562 6367<tel:%2B1%20732%20562%206367>
> Mobile +1 732 439 9144<tel:%2B1%20732%20439%209144>
> FAX +1 732 562 1571<tel:%2B1%20732%20562%201571>
> Email: [email-masked]<mailto:[email-masked]>
> On Wed, Jun 22, 2016 at 2:24 PM, Stephen Farrell <[email-masked]<mailto:[email-masked]>>
> wrote:
>
>>
>> Hi Jodi,
>>
>>> [email-masked]<mailto:[email-masked]>.
>>
>>> Phone +1 732 562 6367<tel:%2B1%20732%20562%206367>
>>> Mobile +1 732 439 9144<tel:%2B1%20732%20439%209144>
>>> FAX +1 732 562 1571<tel:%2B1%20732%20562%201571>
>>> Email: [email-masked]<mailto:[email-masked]>
>>>
>>> On Mon, Apr 11, 2016 at 10:47 AM, Romascanu, Dan (Dan) <
>> [email-masked]<mailto:[email-masked]>>
>>> wrote:
>>>
>>>> Hi,
>>>>
>>>>
>>>>
>>>> [email-masked]<mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ieee-2Dietf-2Dcoord&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=hM2cdaoa__1ytnuPj59MqhyXqmSOArJELdkTVJjyEV0&s=J0As3xhkrFMX2ahPwIvEOkNwWkPpmwrfIVkuN8HN49k&e=>
>>>>
>>>>
>>>
>>>
>>>
>>> [email-masked]<mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ieee-2Dietf-2Dcoord&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=hM2cdaoa__1ytnuPj59MqhyXqmSOArJELdkTVJjyEV0&s=J0As3xhkrFMX2ahPwIvEOkNwWkPpmwrfIVkuN8HN49k&e=>
>>>
>>
>>
>
>
>
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ieee-2Dietf-2Dcoord&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=hM2cdaoa__1ytnuPj59MqhyXqmSOArJELdkTVJjyEV0&s=J0As3xhkrFMX2ahPwIvEOkNwWkPpmwrfIVkuN8HN49k&e=>
>

---

From: Jodi Haasz <[email-masked]>
Date: Thu, 23 Jun 2016 11:35:07 -0400

Dear Dan:

Information on the IEEE-SA Industry Connections Program can be found at
http://standards.ieee.org/develop/indconn/.  More information on the
Industry Connections Security Group can be found at
http://standards.ieee.org/develop/indconn/icsg/index.html.  The charter for
the ETI working group is currently under development.  Once that is
complete, I will send you that information.

Best regards,

Jodi Haasz

On Thu, Jun 23, 2016 at 4:45 AM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

> We are working on a possible communication to the ETI WG on this matter.
> Thanks for the information and advice that you provided.
>
>
>
> One point of clarification, though. You write that the ETI WG is not a
> standards development group. Can you clarify for the IETF participants what
> type if group it is and what kind of deliverables are within its charter?
>
>
>
> Thanks and Regards,
>
>
>
> Dan
>
>
>
>
>
> *From:* Jodi Haasz [mailto:[email-masked]]
> *Sent:* Wednesday, June 22, 2016 10:48 PM
> *To:* Stephen Farrell
> *Cc:* Romascanu, Dan (Dan); [email-masked]
> *Subject:* Re: [ieee-ietf-coord] IETF and IEEE 802 coordination teams
> meeting @ IETF 95 - April 5
>
>
>
> Dear Stephen:
>
>
>
> On Wed, Jun 22, 2016 at 3:10 PM, Stephen Farrell <
> [email-masked]> wrote:
>
>
> Thanks Jodi,
>
> >> [email-masked]>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ieee-2Dietf-2Dcoord&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=hM2cdaoa__1ytnuPj59MqhyXqmSOArJELdkTVJjyEV0&s=J0As3xhkrFMX2ahPwIvEOkNwWkPpmwrfIVkuN8HN49k&e=>
> >>>>
> >>>>
> >>>
> >>>
> >>>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ieee-2Dietf-2Dcoord&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=hM2cdaoa__1ytnuPj59MqhyXqmSOArJELdkTVJjyEV0&s=J0As3xhkrFMX2ahPwIvEOkNwWkPpmwrfIVkuN8HN49k&e=>
> >>>
> >>
> >>
> >
> >
> >
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ieee-2Dietf-2Dcoord&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=hM2cdaoa__1ytnuPj59MqhyXqmSOArJELdkTVJjyEV0&s=J0As3xhkrFMX2ahPwIvEOkNwWkPpmwrfIVkuN8HN49k&e=>
> >
>
>
>

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 23 Jun 2016 19:55:56 +0100

Thanks Jodi,

I'll chat with Dan at the upcoming IETF meeting or before and
figure out what seems sensible to do.

Cheers,
S.

---

From: Jodi Haasz <[email-masked]>
Date: Thu, 23 Jun 2016 15:20:35 -0400

Dear Dan:

I just received the following information about the ETI Working Group.

ABOUT THE ICSG ENCRYPTED TRAFFIC INSPECTION (ETI) WORKING GROUP

More and more applications use encrypted network connections to secure the
transport of data. While this trend may be useful for enhanced security, it
introduces new challenges for traffic inspection by trusted parties.  For
example, most network operators and users want to manage their traffic
effectively, meet SLA and regulatory requirements, and apply security
policies to their internet traffic like malware detection, data leak
prevention or similar.

Current solutions do not allow the client to see, verify the trust level,
or control who is inspecting the traffic. They also fail completely if the
client applies additional certificate checks (e.g., certificate pinning).

The ETI working group’s aim is to develop an accepted way of traffic
inspection on top of encrypted transport standards.

The group will discuss requirements for traffic inspection mechanisms based
on different use cases and explore proofs of concepts of implementations.

Jodi Haasz

On Thu, Jun 23, 2016 at 11:35 AM, Jodi Haasz <[email-masked]> wrote:

> http://standards.ieee.org/develop/indconn/icsg/index.html.  The charter
> for the ETI working group is currently under development.  Once that is
>> >>>> and deployments. Jodi Hasz (from IEEE-SA) offered to clarify status
>> in
>> >> IEEE
>> >>>> Rosdahl to look for proposals. Preliminary agenda to be distributed
>> in
>> >> the
>> >>>> coming weeks.
>> >>>>
>> >>>>
>> >>>>
>> >>>> Thanks and Regards,
>> >>>>
>> >>>>
>> >>>>
>> >>>> Dan
>> >>>>
>> >>>>
>> >>>>
>> >>>>
>> >>>>