Subject: [ieee-ietf-coord] Intelligent Transportation Systems (ITS) BoF at IETF 96

From: Russ Housley <[email-masked]>
Date: Thu, 21 Jul 2016 10:53:46 -0400

I just wanted to give everyone on this list a heads-up note.  The IESG will soon be considering a charter for IPv6 over 802.11-OCB.  The current draft of the ITS charter is below.

Please speak up if anything on this draft charter causes you concern.

Russ

= = = = = = = = =

CHARTER

Automobiles and vehicles of all types are increasingly connected to
the Internet.  Comfort-enhancing entertainment applications, road
safety applications using bidirectional data flows, and connected
automated driving are but a few new features expected in automobiles
to hit the roads from now to year 2020.

Today, there are several deployed Vehicle-to-Internet technologies
(V2Internet) that make use of embedded Internet modules, or through
driver's cellular smartphone: mirrorlink, carplay, android auto.
However, Vehicle-to-Vehicle (V2V) and Vehicle-to-Infrastructure (V2I,
not to be mistaken with V2Internet) communications are still being
developed.

Some vehicle and infrastructure communications will use IP and
others will not.  Multiple applications need to share one data
link, including non-IP-based protocols sharing the data link with
IP-based protocols.

This group will work on V2V and V2I use-cases where IP is well-suited
as a networking technology, supporting also applications that involve
exchanges of safety-related messages between vehicles and
infrastructure if necessary.

This group will develop IP-based protocols to establish direct and
secure connectivity between a vehicle, which is often comprised of
moving networks, and other vehicles and stationary systems.  Some
communications will be extremely short lived, but others will last for
many hours or days.

Moving network to nearby moving or fixed network communications may
involve various kinds of link layers: 802.11-OCB (Outside the Context
of a Basic Service Set, also called 802.11p), 802.15.4 with 6lowpan,
802.11ad, VLC (Visible Light Communications), IrDA, LTE-D, LP-WAN.  One
of the most used link layers for vehicular networks is IEEE 802.11-OCB,
as a basis for DSRC.  However, IPv6 on 802.11-OCB is not yet defined.

The group will work only on IPv6 solutions.

The group will leverage on technologies for Internet of Things (IoT)
which are developed in other IETF and IRTF efforts: 6lo WG, LP-WAN WG,
and T2T RG.  Co-existence with techniques of infrastructure mobility
management will be coordinated with the DMM WG, LISP WG, and other
mobility solutions.

The SDOs interested in this work are: ISO/TC204, ETSI TC ITS, 3GPP,
NHTSA and more.

This group will not work on V2V or V2I use-cases where IP is not
well-suited.  Without re-chartering, this group will not work on
Delay-Tolerant Networking nor on Information-Centric Networking.

If the group is successful in accomplishing its first goals, then it
can be rechartered to work on other things (examples include but are
not limited to: a 1-hop mechanism of IP prefix exchange between moving
networks, an n-hop extension, naming for moving networks;
generalization for trains, air, unmanned and space use-cases).

WORK ITEMS

1. Standards Track RFC "IPv6 over 802.11p"

2. Potential Informational RFC "ITS General Problem Area" covering:
 - What is ITS?
    -- Explain V2V, V2I, and related terms
 - Why is IPv6 needed?
    -- Explain why some traffic will not use IPv6
    -- Explain why other traffic will use IPv6
 - Use-cases, illustrating the expected areas for initial focus
 - Informative references, relationship with other SDOs 

3. Potential Informational RFC "Problem Statement" covering:
  - Problem statement
  - Security considerations
  - Privacy considerations

MILESTONES

Oct 2016 - Draft for "IPv6 over 802.11-OCB" adopted by WG

Dec 2016 - Draft for "ITS General Problem Area" adopted by WG

Mar 2017 - Draft for "Problem Statement" adopted by WG

May 2017 - Submit "IPv6 over 802.11-OCB" to IESG

Oct 2017 - Submit "ITS General Problem Area" to IESG

May 2018 - Submit "Problem Statement" to IESG

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 21 Jul 2016 15:01:11 +0000

Thanks for bringing this up to the list, Russ. 

As I mentioned in the meeting, there is a need to closely coordinate with the IEEE 802.11 WG. It would be nice to mention this explicitly in the charter. The coordination team will play its role, we have this activity on the agenda of the face-to-face meeting on 9/9. I expect this to result in a new item on the shared list of coordinated activities. 

As this text is pretty close to the one that will be submitted to public review, and in order to save time, I suggest that Dorothy Stanley presents it for unformal review at the IEEE Plenary in San Diego next week, and solicits feedback from the IEEE 802.11 participants. 

Regards,

Dan

> -----Original Message-----
> From: ieee-ietf-coord [mailto:[email-masked]] On Behalf
> Of Russ Housley
> Sent: Thursday, July 21, 2016 5:54 PM
> To: [email-masked]
> Subject: [ieee-ietf-coord] Intelligent Transportation Systems (ITS) BoF at IETF
> 96
> 
> I just wanted to give everyone on this list a heads-up note.  The IESG will
> soon be considering a charter for IPv6 over 802.11-OCB.  The current draft of
> the ITS charter is below.
> 
> Automobiles and vehicles of all types are increasingly connected to the
> Internet.  Comfort-enhancing entertainment applications, road safety
> applications using bidirectional data flows, and connected automated driving
> are but a few new features expected in automobiles to hit the roads from
> now to year 2020.
> 
> However, Vehicle-to-Vehicle (V2V) and Vehicle-to-Infrastructure (V2I, not to
> be mistaken with V2Internet) communications are still being developed.
> 
> Some vehicle and infrastructure communications will use IP and others will
> not.  Multiple applications need to share one data link, including non-IP-
> based protocols sharing the data link with IP-based protocols.
> 
> This group will work on V2V and V2I use-cases where IP is well-suited as a
> networking technology, supporting also applications that involve exchanges
> of safety-related messages between vehicles and infrastructure if necessary.
> 
> This group will develop IP-based protocols to establish direct and secure
> connectivity between a vehicle, which is often comprised of moving
> networks, and other vehicles and stationary systems.  Some communications
> will be extremely short lived, but others will last for many hours or days.
> 
> involve various kinds of link layers: 802.11-OCB (Outside the Context of a
> Basic Service Set, also called 802.11p), 802.15.4 with 6lowpan, 802.11ad, VLC
> (Visible Light Communications), IrDA, LTE-D, LP-WAN.  One of the most used
> link layers for vehicular networks is IEEE 802.11-OCB, as a basis for DSRC.
> However, IPv6 on 802.11-OCB is not yet defined.
> 
> The group will leverage on technologies for Internet of Things (IoT) which are
> developed in other IETF and IRTF efforts: 6lo WG, LP-WAN WG, and T2T RG.
> Co-existence with techniques of infrastructure mobility management will be
> coordinated with the DMM WG, LISP WG, and other mobility solutions.
> 
> The SDOs interested in this work are: ISO/TC204, ETSI TC ITS, 3GPP, NHTSA
> and more.
> 
> This group will not work on V2V or V2I use-cases where IP is not well-suited.
> Without re-chartering, this group will not work on Delay-Tolerant Networking
> nor on Information-Centric Networking.
> 
> If the group is successful in accomplishing its first goals, then it can be
> rechartered to work on other things (examples include but are not limited to:
> a 1-hop mechanism of IP prefix exchange between moving networks, an n-
> hop extension, naming for moving networks; generalization for trains, air,
> unmanned and space use-cases).
> 
> WORK ITEMS
>

---

From: "Stanley, Dorothy" <[email-masked]>
Date: Sun, 24 Jul 2016 18:50:58 +0000

Hi Dan, Russ,

I have forward this charter information to the 802.11 WG, along with a request for
any comments on the charter to be sent to Russ and Carlos Pignataro.

I'll also review the ITS charter in the Wednesday report this week, again with the same review request.
Sorry that I missed the Berlin meeting, hope it was a productive one.

Thanks,

Dorothy

------------------------
Dorothy Stanley
Hewlett Packard Enterprise
[email-masked]
+1 630-363-1389

-----Original Message-----
From: ieee-ietf-coord [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, July 21, 2016 8:01 AM
To: Russ Housley; [email-masked]
Subject: Re: [ieee-ietf-coord] Intelligent Transportation Systems (ITS) BoF at IETF 96

Regards,

Dan

> From: ieee-ietf-coord [mailto:[email-masked]] On 
> Behalf Of Russ Housley
> I just wanted to give everyone on this list a heads-up note.  The IESG 
> will soon be considering a charter for IPv6 over 802.11-OCB.  The 
> current draft of the ITS charter is below.
> 
> not to be mistaken with V2Internet) communications are still being developed.
> 
> Some vehicle and infrastructure communications will use IP and others 
> will not.  Multiple applications need to share one data link, 
> including non-IP- based protocols sharing the data link with IP-based protocols.
> 
> exchanges of safety-related messages between vehicles and infrastructure if necessary.
> 
> communications will be extremely short lived, but others will last for many hours or days.
> 
> 802.11ad, VLC (Visible Light Communications), IrDA, LTE-D, LP-WAN.  
> One of the most used link layers for vehicular networks is IEEE 802.11-OCB, as a basis for DSRC.
> which are developed in other IETF and IRTF efforts: 6lo WG, LP-WAN WG, and T2T RG.
> Co-existence with techniques of infrastructure mobility management 
> will be coordinated with the DMM WG, LISP WG, and other mobility solutions.
> 
> Without re-chartering, this group will not work on Delay-Tolerant 
> Networking nor on Information-Centric Networking.
> 
> can be rechartered to work on other things (examples include but are not limited to:
> hop extension, naming for moving networks; generalization for trains, 
> air, unmanned and space use-cases).
> 
> WORK ITEMS
> 

_______________________________________________
ieee-ietf-coord mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ieee-ietf-coord

---

From: Russ Housley <[email-masked]>
Date: Sun, 24 Jul 2016 17:32:42 -0400

I think we made good progress in the ITS group.  The decision was to move forward on forming a working group, so any comments will be timely.

Russ

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 27 Jul 2016 14:07:22 +0000

Hi Dorothy,

> any comments on the charter to be sent to Russ and Carlos Pignataro.

Please keep me in the loop as well.

Thanks
Suresh