Subject: [ieee-ietf-coord] IEEE-SA ICSG Encrypted Traffic Inspection

From: Russ Housley <[email-masked]>
Date: Wed, 5 Apr 2017 15:39:59 -0400

Jodi:

Last June you provided a pointer to the IEEE-SA ICSG Encrypted Traffic Inspection (ETI) Working Group.  The ICSG web pages also that about a Malware effort that involves Man-in-the-Middle (MitM) approach.

	http://standards.ieee.org/develop/indconn/icsg/eti.html <http://standards.ieee.org/develop/indconn/icsg/eti.html>
	http://standards.ieee.org/develop/indconn/icsg/malware.html <http://standards.ieee.org/develop/indconn/icsg/malware.html>

Is this group active?  If so, ss the IETF development of TLS 1.3 is coming close the the end, it might be useful to understand what they are doing?

Russ

> http://standards.ieee.org/develop/indconn/icsg/malware.html <http://standards.ieee.org/develop/indconn/icsg/malware.html>On Jun 23, 2016, at 3:20 PM, Jodi Haasz <[email-masked]> wrote:
> 
> Dear Dan:
> 
> I just received the following information about the ETI Working Group.
> 
> ABOUT THE ICSG ENCRYPTED TRAFFIC INSPECTION (ETI) WORKING GROUP
> 
> More and more applications use encrypted network connections to secure the transport of data. While this trend may be useful for enhanced security, it introduces new challenges for traffic inspection by trusted parties.  For example, most network operators and users want to manage their traffic effectively, meet SLA and regulatory requirements, and apply security policies to their internet traffic like malware detection, data leak prevention or similar.
> 
> Current solutions do not allow the client to see, verify the trust level, or control who is inspecting the traffic. They also fail completely if the client applies additional certificate checks (e.g., certificate pinning).
> 
> The ETI working group’s aim is to develop an accepted way of traffic inspection on top of encrypted transport standards.
> 
> The group will discuss requirements for traffic inspection mechanisms based on different use cases and explore proofs of concepts of implementations.
> 
> 
> Jodi Haasz
> International Affairs Senior Liaison
> IEEE Standards Association
> 445 Hoes Lane
> Piscataway, NJ 08854-4141 USA
> Phone +1 732 562 6367
> Mobile +1 732 439 9144
> FAX +1 732 562 1571
> Email: [email-masked] <mailto:[email-masked]>
> -----------------------------------------------------------------------------
> IEEE – Advancing Technology for Humanity

---

From: Jodi Haasz <[email-masked]>
Date: Thu, 6 Apr 2017 09:44:53 +0200

Dear Russ:

By copy of this email, I would like to direct your question to Walter
Pienciak, who has been monitoring this.

Best regards,

Jodi Haasz
Email: [email-masked]
http://standards.ieee.org/develop/intl/index.html

On Wed, Apr 5, 2017 at 9:39 PM, Russ Housley <[email-masked]> wrote:

> Jodi:
>
> Last June you provided a pointer to the IEEE-SA ICSG Encrypted Traffic
> Inspection (ETI) Working Group.  The ICSG web pages also that about a
> Malware effort that involves Man-in-the-Middle (MitM) approach.
>
> http://standards.ieee.org/develop/indconn/icsg/eti.html
> http://standards.ieee.org/develop/indconn/icsg/malware.html
>
> Is this group active?  If so, ss the IETF development of TLS 1.3 is coming
> close the the end, it might be useful to understand what they are doing?
>
> Russ
>
>
> http://standards.ieee.org/develop/indconn/icsg/malware.html
>
> On Jun 23, 2016, at 3:20 PM, Jodi Haasz <[email-masked]> wrote:
>
> Dear Dan:
>
> More and more applications use encrypted network connections to secure the
> transport of data. While this trend may be useful for enhanced security, it
> introduces new challenges for traffic inspection by trusted parties.  For
> example, most network operators and users want to manage their traffic
> effectively, meet SLA and regulatory requirements, and apply security
> policies to their internet traffic like malware detection, data leak
> prevention or similar.
>
> Current solutions do not allow the client to see, verify the trust level,
> or control who is inspecting the traffic. They also fail completely if the
> client applies additional certificate checks (e.g., certificate pinning).
>
> The ETI working group’s aim is to develop an accepted way of traffic
> inspection on top of encrypted transport standards.
>
> The group will discuss requirements for traffic inspection mechanisms
> based on different use cases and explore proofs of concepts of
> implementations.
>
>
> Jodi Haasz
> Phone +1 732 562 6367 <(732)%20562-6367>
> Mobile +1 732 439 9144 <(732)%20439-9144>
> FAX +1 732 562 1571 <(732)%20562-1571>
> Email: [email-masked]

---

From: Walter Pienciak <[email-masked]>
Date: Fri, 7 Apr 2017 07:31:12 -0600

HI, Russ, all,

The ICSG Encrypted Traffic Inspection (ETI) group is active.  If you want
direct conversation on the technical activity of the group, Olaf Bonorden <
[email-masked]> is the group's chair.

Walter

Walter Pienciak
Senior Manager, Strategic Programs, IEEE Standards Association

[email-masked]
+1 303 527 0934

On Thu, Apr 6, 2017 at 1:44 AM, Jodi Haasz <[email-masked]> wrote:

>> Is this group active?  If so, ss the IETF development of TLS 1.3 is
>> coming close the the end, it might be useful to understand what they are
>> doing?
>>
>> Russ
>>
>>
>> More and more applications use encrypted network connections to secure
>> the transport of data. While this trend may be useful for enhanced
>> security, it introduces new challenges for traffic inspection by trusted
>> parties.  For example, most network operators and users want to manage
>> their traffic effectively, meet SLA and regulatory requirements, and apply
>> security policies to their internet traffic like malware detection, data
>> leak prevention or similar.
>>
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>
>