Subject: Re: [ieee-ietf-coord] DRAFT Minutes for meeting on 31 March 2017

From: Benoit Claise <[email-masked]>
Date: Tue, 9 May 2017 10:37:55 +0200

Dear all,

Coming back to this AI:

    2.  YANG

        At the Hackathon a tool for the YANG model catalog advanced.  The
        tool shows the dependencies among modules and keeps the metadata.

        Benoit expressed concern that too many YANG models are proprietary.

        Yan Zhuang volunteered to help with for 802.3 YANG modules.  A
        volunteer for 802.1 YANG modules is still needed.  Glenn can you find
        someone?

Thanks to Marc Holness, all 802.1 cd ..YANG modules for approved PAR now 
validate correctly.
See http://www.claise.be/IEEEStandardYANGPageCompilation.html
Note that some other YANG modules still don't validate correctly. See 
http://www.claise.be/IEEEExperimentalYANGPageCompilation.html

The IEEE YANG modules are now inserted into the YANG catalog 
<https://www.yangcatalog.org/>.
Hereafter some examples:

1. YANG module search:
Search for "ether-type" at 
https://www.yangcatalog.org/yang-search/yang-search.php, and you will 
find the IEEE YANG modules

2. Impact analysis
https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ieee802-dot1q-types.yang&recurse=0&rfcs=1
This shows that the ieee802-dot1q-types import the ietf-interfaces YANG 
module (RFC 7223).
There are discussions right now to update RFC 7223, to be in line with 
"Network Management Datastore Architecture 
<https://datatracker.ietf.org/doc/draft-ietf-netmod-revised-datastores/>"
So there is a potential impact on the IEEE YANG modules.

3. YANG tree.
https://www.yangcatalog.org/yang-search/yang_tree.php?module=ieee802-dot1q-bridge

What is the next step? Starting the metadata population
As a first example, we could start with the maturity level. If you look 
at the figures at https://yangvalidator.wordpress.com/about/, we have 
maturity levels such as IETF:INDIVIDUAL-DRAFT, IETF:WG-DRAFT, IETF:RFC, 
BBF:DRAFT, BBF:RATIFIED
We should have similar (and consistent) maturity level for the IEEE.
We'll take it offline with Marc Holness and Yan Zhuang

Regards, Benoit
> Thanks for the correction.  I post corrected minutes after others have a changes to review.
>
> Russ
>
>
>> On Apr 7, 2017, at 11:53 AM, Benoit Claise <[email-masked]> wrote:
>>
>> On 4/7/2017 8:47 AM, Russ Housley wrote:
>>> Please review and report any needed corrections to the list.
>>>
>>> Russ
>>>
>>> = = = = = = = = =
>>>
>>>                    IEEE 802 / IETF Coordination Meeting
>>>                              Chicago, IL, USA
>>>                               31 March 2017
>>>
>>> 0.  Agenda
>>>
>>>     1.  Copyright Issue
>>>     2.  YANG
>>>     3.  Multicast
>>>     4.  Meeting in Prague on the Saturday before IETF 99
>>>     5.  Any other business
>>>
>>> 1.  Copyright Issue
>>>
>>>     Worked out the issue with the Internet-Draft that included some text
>>>     from IEEE P1588.  There are no permission issues with MIBs or YANG
>>>     modules, but explanatory text is often needed as well.  Pat asked for
>>>     volunteers to gather the right people to come up with a process for
>>>     future documents:
>>>
>>>        Pat    -- coordinate the discussion
>>>        Suresh -- get the IETF and IETF Trust volunteers
>>>        Jodi   -- get the IEEE staff members that are involved
>>>
>>> 2.  YANG
>>>
>>>     At the Hackathon a tool for the YANG model catalog advanced.  The
>>>     tool shows the dependencies among modules and keeps the metadata.
>>>
>>>     Benoit expressed concern that too many YANG models are proprietary.
>>>
>>>     Yan Zhuang volunteered to help with for 802.3 YANG modules.  A
>>>     volunteer for 802.1 YANG modules is still needed.  Glenn can you find
>>>     someone?
>>>
>>> 3.  Multicast
>>>
>>>     The INT Area WG is putting together a document on multicast over
>>>     wireless, and Juan Carlos made a call for contributions.
>>>
>>> 4.  Meeting in Prague -- Saturday before IETF -- Noon to 7pm
>>>
>>>     These topics are of interest to the group:
>>>        - YANG models
>>>        - Low Latency and Time-sensitive Networking
>>>        - FlexE, Network slicing, DETnet
>>>        - Multicast
>>>        - 48-bit and 64-bit MAC Addresses
>>>        - 5G
>>>
>>>     Benoit pointed out that the IETF hackathon did a review of IETF YANG
>>>     modules.
>> The review was for the Broadband Forum YANG modules.
>> Hence the proposal to have something similar at the next hackathon for IEEE YANG modules.
>>
>> Regards, Benoit
>>> They found bugs in modules and compilers, and they made
>>>     many improvements to the modules too.  He suggested that it would be
>>>     good to have a similar hackathon for the IEEE 802 YANG modules.
>>>     Maybe this can be part of the IETF Hackathon in Prague on Sunday.
>>>
>>> 5.  AOB
>>>
>>>     A liaison statement about draft-nordmark-intarea-ippl-05 was
>>>     sent to the IETF INT Area by IEEE 802.1.  It can be found at
>>>     https://datatracker.ietf.org/liaison/1510/.  An update was made
>>>     to the document to resolve the concern.  Pat Thaler asked for a
>>>     heads up when any working group or document relates to bridges,
>>>     VLANs, or any other technology that overlaps IEEE 802 and the IETF.
>>>
>>>     Long LLC frames are now available.  IEEE 802AC-2016 allows a
>>>     length/type encoded media (Ethernet) to carry a long LLC frame.
>>>     Clause 12.2 defines an Ethertype to use when the frame is longer than
>>>     1500 bytes.  Unfortunately, this is not the same Ethertype that is
>>>     used by many IS-IS implementations.  IEEE 802.1 tried to contact the
>>>     owner of the Ethertype used in IS-IS implementations, but due to
>>>     acquisitions, they were not able to find a proper contact.
>>>
>>> _______________________________________________
>>> ieee-ietf-coord mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>>> .
>>>
>> _______________________________________________
>> ieee-ietf-coord mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
> .
>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 9 May 2017 10:44:14 +0200

On 5/9/2017 10:37 AM, Benoit Claise wrote:
> Thanks to Marc Holness, all 802.1 cd ..YANG modules for approved PAR 
> now validate correctly.
                                                             ^^^^

Hmm, I was wondering where my command went :-)

Regards, Benoit