Subject: Re: [ieee-ietf-coord] IEEE 802 Coordination on YANG

From: Benoit Claise <[email-masked]>
Date: Mon, 16 Oct 2017 15:18:31 +0200

Dear all,

Sorry for the late notice, but I won't be able to attend today.
So I'm trying to address all my open issues via email beforehand.
> Benoit:
>
> In preparation for the coordination call that will take place on October 16th, I have a request regarding YANG.
>
> Coordination Item 27: development of YANG models in the IEEE 802
>
> Some folks involved in IEEE 802 have observed a proposed change to the way that the configuration branch is handled.  They would like advise on this topic for the YANG modules that they are developing.  Should they follow the RFC or the I-D?  Can you make the call and offer some advice?  If not, can you get someone knowledgeable to cover the call for you?
Here is the important draft: 
https://datatracker.ietf.org/doc/draft-ietf-netmod-revised-datastores/, 
as known as a NMDA

The first step is to check if the YANG module is NMDA compliant. The 
YANG catalog <https://www.yangcatalog.org/> can help you here.
Select the "metadata details" tool and insert your module.
For example, for the ietf-interfaces YANG module 
<https://www.yangcatalog.org/yang-search/module_details.php?module=ietf-interfaces>, 
you can see that the tree-type is nmda-compatible.

You can see the tree-type definitions by clicking on question mark. Or 
by looking in the draft 
<https://datatracker.ietf.org/doc/draft-clacla-netmod-model-catalog/>definition:

     leaf tree-type {
         type enumeration {
           enum "split" {
             description
               "This module uses a split config/operational state layout.";
           }
           enum "nmda-compatible" {
             description
               "This module is compatible with the Network Management Datastores
                Architecture (NMDA) and combines config and operational state nodes.";
           }
           enum "transitional-extra" {
             description
               "This module is derived as a '-state' module to allow for transitioning
                to a full NMDA-compliant tree structure.";
           }
           enum "openconfig" {
             description
               "This module uses the Openconfig data element layout.";
           }
           enum "unclassified" {
             description
               "This module does not belong to any category or can't be determined.";
           }
           enum "not-applicable" {
             description
               "This module is not applicable. For example, because the YANG module only contains typedefs, groupings, or is a submodule";
           }
         }
         description
           "The type of data element tree used by the module as it relates to the
            Network Management Datastores Architecture.";
         reference "draft-dsdt-nmda-guidelines Guidelines for YANG Module Authors (NMDA)";
       }
       description
         "Grouping of YANG module metadata that extends the common list defined in the YANG
          Module Library (RFC 7895).";
     }

If I take an IEEE example from this report 
<http://www.claise.be/IEEEStandardYANGPageCompilation.html>, 
https://www.yangcatalog.org/yang-search/module_details.php?module=[email-masked], 
<https://www.yangcatalog.org/yang-search/module_details.php?module=[email-masked]>you 
see that the tree-type is split, so it needs to be updated.

Rob Wilton created a NMDA Existing Model Migration FAQ 
<https://github.com/netmod-wg/FAQ/wiki/NMDA-Existing-Model-Migration-FAQ>and 
also the FAQ related to NMDA implementations 
<https://github.com/netmod-wg/FAQ/wiki/FAQ-rehttps://github.com/netmod-wg/FAQ/wiki/FAQ-related-to-NMDA-implementationslated-to-NMDA-implementations>.
Rob also developed a tool for the migration. It does most of the job, 
but some manual interventions might be required for corner cases.

I hope this helps.
During the last meeting, we discussed this point:

       Benoit Claise said that the next steps include working with the IEEE
       to add their YANG models to the catalog. Benoit and Glenn Parsons
    will
       coordinate offline about how to best handle this; IEEE 802 recently
       formed a YANG coordination group to coordinate internally on their
       YANG modules.

    I'm wondering what the latest news are regarding the IEEE YANG
    coordination group?

Since I won't be able to make the call, I'll try to see if Rob can cover 
this topic in the call today.

Regards, Benoit
> Russ
> .

---

From: Robert Wilton <[email-masked]>
Date: Mon, 16 Oct 2017 14:40:27 +0100

On 16/10/2017 14:18, Benoit Claise wrote:
<snipped>
>       to add their YANG models to the catalog. Benoit and Glenn
>     Parsons will
> Since I won't be able to make the call, I'll try to see if Rob can 
> cover this topic in the call today.
I can attend today's call, and cover any NMDA questions, but I'm not up 
to date with the IEEE 802 YANG coordination group.  Hopefully Glenn can 
cover this today if he is joining today's meeting.

Thanks,
Rob