Subject: Re: [ieee-ietf-coord] Notes from breakfast meeting at IETF

From: Benoit Claise <[email-masked]>
Date: Fri, 8 Dec 2017 15:45:42 +0100

Thanks Pat for the meeting minutes.
As a follow up, below is the output of a search for:
     * filter only the most recent YANG modules (we added this 
functionality after our meeting)
     * where organization = ieee

Many YANG modules are NMDA compliant ("tree-type": "nmda-compatible"), 
which is good.
Btw, the tree-type possible values are described in 
https://tools.ietf.org/html/draft-clacla-netmod-model-catalog-02
Some of the YANG module have "tree-type": "split":
     "ieee802-dot1ax",
     "ieee802-dot1x"
     "ieee802-ethernet-interface"
     "ieee802-ethernet-interface-legacy"
     "ieee802-ethernet-link-oam"
     "ieee802-ethernet-pon"
     "ieee802-ethernet-pse"
     "ieee802-pse"
Those should become NMDA compliant.

Some are not applicable:
As an example, "name": "ieee802-dot1q-vlan-bridge", "tree-type": 
"not-applicable",
Well, this YANG module is pretty light. See 
https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-vlan-bridge.yang

[
     {
         "name": "dot1q-types",
         "revision": "2015-06-26",
         "organization": "ieee",
         "namespace": "urn:ieee:params:xml:ns:yang:dot1q-types",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf/INTERFACE-VLAN/dot1q-types.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "unknown",
         "compilation-result": 
"https://yangcatalog.org/results/[email-masked]",
         "prefix": "dot1q",
         "yang-version": "1.0",
         "description": "This module contains a collection of generally 
useful YANG types\nthat are specific to 802.1Q VLANs that can be 
usefully shared\nbetween multiple models.\n\nTerms and 
Acronyms\n\n802.1Q: IEEE 802.1Q VLANs\n\nVLAN (vlan): Virtual Local Area 
Network\n",
         "contact": "Robert Wilton - [email-masked]",
         "module-type": "module",
         "tree-type": "not-applicable",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependents": [
             {
                 "name": "flexible-encapsulation",
                 "revision": "2015-06-26",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf/INTERFACE-VLAN/flexible-encapsulation.yang"
             },
             {
                 "name": "ietf-erp",
                 "revision": "2015-07-13",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf/G8032/ietf-erp.yang"
             },
             {
                 "name": "if-l3-vlan",
                 "revision": "2015-06-26",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf/INTERFACE-VLAN/if-l3-vlan.yang"
             }
         ],
         "derived-semantic-version": "1.0.0",
         "index": 0
     },
     {
         "name": "ieee802-dot1ax",
         "revision": "2016-09-09",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1AX:yang:ieee802-dot1ax",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1ax.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "dot1ax",
         "yang-version": "1.0",
         "description": "Link Aggregation allows one or more links to be 
aggregated\ntogether to form a Link Aggregation Group, such that a 
Media\nAccess Control (MAC) Client can treat the Link Aggregation 
Group\nas if it were a single link. To this end, it specifies 
the\nestablishment of data terminal equipment (DTE) to DTE 
logical\nlinks, consisting of N parallel instances of full 
duplex\npoint-to-point links operating at the same data rate.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "iana-if-type",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ieee802-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/draft/ieee802-types.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-dot1q-bridge",
         "revision": "2017-09-07",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-dot1q-bridge",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-bridge.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "dot1q",
         "yang-version": "1.0",
         "description": "This YANG module describes the bridge 
configuration model for\nthe following IEEE 802.1Q Bridges:\n 1. Two 
Port MAC Relay Bridges\n 2. Customer VLAN Bridges\n 3. Provider Bridges.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "nmda-compatible",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "iana-if-type",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ieee802-dot1q-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-types.yang"
             },
             {
                 "name": "ieee802-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/draft/ieee802-types.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "dependents": [
             {
                 "name": "ieee802-dot1q-pb",
                 "revision": "2017-09-07",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-pb.yang"
             },
             {
                 "name": "ieee802-dot1q-sched",
                 "revision": "2017-03-16",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ieee/802.1/ieee802-dot1q-sched.yang"
             },
             {
                 "name": "ieee802-dot1q-tpmr",
                 "revision": "2017-09-07",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-tpmr.yang"
             }
         ],
         "derived-semantic-version": "2.0.0"
     },
     {
         "name": "ieee802-dot1q-lldp",
         "revision": "2017-01-01",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-dot1q-lldp",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ieee/802.1/ieee802-dot1q-lldp.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "lldp",
         "yang-version": "1.1",
         "description": "This module provides for management of IEEE Std 
802.1AB,\nStation and Media Access Control Connectivity Discovery, 
also\nknown as the Link Layer Discovery Protocol (LLDP). This 
module\ncorresponds to the features of the LLDP Version 2 MIB.\n    
\nThis experimental YANG module is an individual contribution, and\ndoes 
not represent a formally sanctioned YANG module of IEEE.\nTherefore, 
this YANG module will change in incompatible ways\nfrom its current 
revision to the formally published YANG\nmodule for IEEE Std 802.1AB-2016.",
         "contact": "Web URL: http://ni.com \nRodney Cummings 
\[email-masked]",
         "module-type": "module",
         "tree-type": "nmda-compatible",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/draft/ieee802-types.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-dot1q-pb",
         "revision": "2017-09-07",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-dot1q-pb",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-pb.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "dot1q-pb",
         "yang-version": "1.0",
         "description": "This YANG module describes the bridge 
configuration model for\nProvider Bridges.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "nmda-compatible",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-dot1q-bridge",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-bridge.yang"
             },
             {
                 "name": "ieee802-dot1q-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-types.yang"
             },
             {
                 "name": "ieee802-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/draft/ieee802-types.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "2.0.0"
     },
     {
         "name": "ieee802-dot1q-sched",
         "revision": "2017-03-16",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-dot1q-sched",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ieee/802.1/ieee802-dot1q-sched.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "sched",
         "yang-version": "1.0",
         "description": "This module provides for management of IEEE Std 
802.1Q Bridges\nthat support Scheduled Traffic Enhancements. \n    
\nThis experimental YANG module is an individual contribution, and\ndoes 
not represent a formally sanctioned YANG module of IEEE.\nTherefore, 
this YANG module will change in incompatible ways\nfrom its current 
revision to the formally published YANG\nmodule for IEEE Std 
802.1Qbv-2015.",
         "contact": "Web URL: http://ni.com \nRodney Cummings 
\[email-masked]",
         "module-type": "module",
         "tree-type": "nmda-compatible",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-dot1q-bridge",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-bridge.yang"
             },
             {
                 "name": "ieee802-dot1q-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-types.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-dot1q-tpmr",
         "revision": "2017-09-07",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-dot1q-tpmr",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-tpmr.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "dot1q-tpmr",
         "yang-version": "1.0",
         "description": "This YANG module describes the bridge 
configuration model for\nthe Two Port MAC Relay Bridges.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "nmda-compatible",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-dot1q-bridge",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-bridge.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "2.0.0"
     },
     {
         "name": "ieee802-dot1q-types",
         "revision": "2017-07-20",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-dot1q-types",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-types.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "dot1q-types",
         "yang-version": "1.0",
         "description": "Common types used within dot1Q-bridge modules.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "not-applicable",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/draft/ieee802-types.yang"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "dependents": [
             {
                 "name": "ieee802-dot1q-bridge",
                 "revision": "2017-09-07",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-bridge.yang"
             },
             {
                 "name": "ieee802-dot1q-pb",
                 "revision": "2017-09-07",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-pb.yang"
             },
             {
                 "name": "ieee802-dot1q-sched",
                 "revision": "2017-03-16",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ieee/802.1/ieee802-dot1q-sched.yang"
             },
             {
                 "name": "ietf-flexible-encapsulation",
                 "revision": "2017-10-30",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             },
             {
                 "name": "ietf-if-l3-vlan",
                 "revision": "2017-10-30",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             }
         ],
         "derived-semantic-version": "2.0.0"
     },
     {
         "name": "ieee802-dot1q-vlan-bridge",
         "revision": "2017-09-07",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-dot1q-vlan-bridge",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-vlan-bridge.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "dot1q-vlan-bridge",
         "yang-version": "1.0",
         "description": "This YANG module describes the bridge 
configuration model for\nCustomer VLAN Bridges.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "not-applicable",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "derived-semantic-version": "2.0.0"
     },
     {
         "name": "ieee802-dot1x",
         "revision": "2017-07-20",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1X:yang:ieee802-dot1x",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1x.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "dot1x",
         "yang-version": "1.0",
         "description": "Port-based network access control allows a 
network administrator\nto restrict the use of IEEE 802 LAN service 
access points (ports)\nto secure communication between authenticated and 
authorized\ndevices. IEEE Std 802.1X specifies an architecture, 
functional\nelements, and protocols that support mutual 
authentication\nbetween the clients of ports attached to the same LAN 
and secure\ncommunication between the ports. The following control 
allows a\nport to be reinitialized, terminating (and 
potentially\nrestarting) authentication exchanges and MKA operation, 
based on\na data model described in a set of YANG modules.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "iana-if-type",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ieee802-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/draft/ieee802-types.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-system",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "2.0.0"
     },
     {
         "name": "ieee802-ethernet-interface",
         "revision": "2017-02-23",
         "organization": "ieee",
         "namespace": 
"urn:ieee:params:xml:ns:yang:ieee802-ethernet-interface",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "eth-if",
         "yang-version": "1.1",
         "description": "This module contains YANG definitions for 
configuring IEEE 802.3\nEthernet Interfaces.\n\nIn this YANG module, 
'Ethernet interface' can be interpretted\nas referring to 'IEEE 802.3 
standard compliant Ethernet\ninterfaces'",
         "contact": "Robert Wilton - [email-masked]",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "iana-if-type",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "dependents": [
             {
                 "name": "ieee802-ethernet-interface-legacy",
                 "revision": "2017-01-20",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-interface-legacy.yang"
             },
             {
                 "name": "ieee802-ethernet-link-oam",
                 "revision": "2017-09-11",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-link-oam.yang"
             },
             {
                 "name": "ieee802-ethernet-pon",
                 "revision": "2017-03-15",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-pon.yang"
             },
             {
                 "name": "ieee802-ethernet-pse",
                 "revision": "2017-09-11",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-pse.yang"
             },
             {
                 "name": "ieee802-pse",
                 "revision": "2017-03-02",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             },
             {
                 "name": "ietf-poe-power-management",
                 "revision": "2017-03-09",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-ethernet-interface-legacy",
         "revision": "2017-01-20",
         "organization": "ieee",
         "namespace": 
"urn:ieee:std:802.3:yang:ieee802-ethernet-interface-legacy",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-interface-legacy.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "failed",
         "compilation-result": 
"https://yangcatalog.org/results/[email-masked]",
         "prefix": "eth-old",
         "yang-version": "1.1",
         "description": "This module contains YANG definitions for 
configuring IEEE Std 802.3\nEthernet interfaces that are deprecated, and 
are no longer\nwidely used in the industry.  The definitions are 
maintained for\nbackwards compatibility purposes, but the general 
expectation is\nthat this module is not anticipated to be widely 
implemented.",
         "contact": "Web URL: http://www.ieee802.org/3/cf/",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "iana-if-type",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ieee802-ethernet-interface",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-interface.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-ethernet-link-oam",
         "revision": "2017-09-11",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.3:yang:ethernet-link-oam",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-link-oam.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "failed",
         "compilation-result": 
"https://yangcatalog.org/results/[email-masked]",
         "prefix": "link-oam",
         "yang-version": "1.0",
         "description": "This module contains a collection of YANG 
definitions\r\nfor managing the Ethernet Link OAM feature defined by 
IEEE\r\n802.3. It provides functionality roughly equivalent to that 
of\r\nthe DOT3-OAM-MIB defined in RFC 4878.\r\n\r\nThis YANG module 
augments the 'ieee802-ethernet-interface' module.",
         "contact": "Web URL: http://www.ieee802.org/3/cf/",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-ethernet-interface",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-interface.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-ethernet-pon",
         "revision": "2017-03-15",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.3:yang:ieee802-ethernet-pon",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-pon.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "failed",
         "compilation-result": 
"https://yangcatalog.org/results/[email-masked]",
         "prefix": "eth-pon",
         "yang-version": "1.1",
         "description": "This module contains a collection of YANG 
definitions for \r\nmanaging the Multi Point Control Protocol for 
Ethernet PON (EPON),\r\nas defined in IEEE Std 802.3, Clause 
64/77\r\n\r\nThis YANG module augments the 'ethernet' module.",
         "contact": "Web URL: http://www.ieee802.org/3/cf/",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-ethernet-interface",
                 "revision": "2017-02-23",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-interface.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             },
             {
                 "name": "ietf-yang-types",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-ethernet-pse",
         "revision": "2017-09-11",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.3:yang:ieee802-ethernet-pse",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-pse.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed-with-warnings",
         "compilation-result": 
"https://yangcatalog.org/results/[email-masked]",
         "prefix": "pse",
         "yang-version": "1.0",
         "description": "This module contains YANG defintions for 
configuring and \r\nmanaging ports with Power Over Ethernet feature 
defined by\r\nIEEE 802.3. It provides functionality roughly equivalent 
to\r\nthat of the POWER-ETHERNET-MIB defined in RFC3621.",
         "contact": "Web URL: http://www.ieee802.org/3/cf/",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-ethernet-interface",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.3/draft/ieee802-ethernet-interface.yang"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ietf/RFC/[email-masked]"
             }
         ],
         "derived-semantic-version": "2.0.0"
     },
     {
         "name": "ieee802-pse",
         "revision": "2017-03-02",
         "organization": "ieee",
         "namespace": "urn:ieee:params:xml:ns:yang:ieee802-pse",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed-with-warnings",
         "compilation-result": 
"https://yangcatalog.org/results/[email-masked]",
         "prefix": "pse",
         "yang-version": "1.0",
         "description": "This module contains YANG defintions for 
confirguring and\nmanaging ports with Power Over Ethernet feature 
defined by\nIEEE 802.3. It provdes funcitonality roughly equivalent 
to\nthat of the POWER-ETHERNET-MIB defined in RFC3621.",
         "contact": "Fei Li - [email-masked]",
         "module-type": "module",
         "tree-type": "split",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependencies": [
             {
                 "name": "ieee802-ethernet-interface",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             },
             {
                 "name": "ietf-interfaces",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             }
         ],
         "dependents": [
             {
                 "name": "ietf-poe-power-management",
                 "revision": "2017-03-09",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ietf-extracted-YANG-modules/[email-masked]"
             }
         ],
         "derived-semantic-version": "1.0.0"
     },
     {
         "name": "ieee802-types",
         "revision": "2017-07-20",
         "organization": "ieee",
         "namespace": "urn:ieee:std:802.1Q:yang:ieee802-types",
         "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/draft/ieee802-types.yang",
         "generated-from": "not-applicable",
         "module-classification": "unknown",
         "compilation-status": "passed",
         "compilation-result": "",
         "prefix": "ieee",
         "yang-version": "1.0",
         "description": "This module contains a collection of generally 
useful derived\ndata types for IEEE YANG models.",
         "contact": "WG-URL: 
http://grouper.ieee.org/groups/802/1/\nWG-EMail: 
[email-masked]\n\nContact: IEEE 802.1 Working Group Chair\nPostal: 
C/O IEEE 802.1 Working Group\n        IEEE Standards 
Association\n        445 Hoes Lane\n        P.O. Box 1331\n        
Piscataway\n        NJ 08855-1331\n        USA\n \t\nE-mail: 
[email-masked]",
         "module-type": "module",
         "tree-type": "not-applicable",
         "yang-tree": 
"https://yangcatalog.org:8443/services/tree/[email-masked]",
         "dependents": [
             {
                 "name": "ieee802-dot1ax",
                 "revision": "2016-09-09",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1ax.yang"
             },
             {
                 "name": "ieee802-dot1q-bridge",
                 "revision": "2017-09-07",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-bridge.yang"
             },
             {
                 "name": "ieee802-dot1q-lldp",
                 "revision": "2017-01-01",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/experimental/ieee/802.1/ieee802-dot1q-lldp.yang"
             },
             {
                 "name": "ieee802-dot1q-pb",
                 "revision": "2017-09-07",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-pb.yang"
             },
             {
                 "name": "ieee802-dot1q-types",
                 "revision": "2017-07-20",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1q-types.yang"
             },
             {
                 "name": "ieee802-dot1x",
                 "revision": "2017-07-20",
                 "schema": 
"https://raw.githubusercontent.com/YangModels/yang/master/standard/ieee/802.1/draft/ieee802-dot1x.yang"
             }
         ],
         "derived-semantic-version": "2.0.0"
     }
]
> Here are my notes from the breakfast meeting at IETF
>
> *NMDA architecture:*
>
> 802.1 and 802.3 projects are using it.
>
> How do we help the other groups in IEEE 802 get started?
>
> Tutorial from 802.1 and 802.3 for 802?
>
> When will the NMDA Datastores architecture draft progress?
>
> In last call, a couple of issues remaining that they hope to resolve 
> this week.
>
> Related protocol drafts – plan to send for last call in December
>
> Interfaces (rfc 7223-bis), IP and routing models updated to NMDA are 
> ready for last call.
>
> Not expecting further churn. Schema mounts are another tool but mainly 
> for large complex models. Possibly applies to more complex bridge 
> instances such as Provider Backplane bridges.
>
> Tool – for converting existing modules to NMDA
>
> *Ethertype*
>
> IEEE can do a model that lists the valid Ethertypes and updates as new 
> ones are assigned.
>
> Concerns about supporting friendly names. Some Ethertypes were 
> registered as private
>
> IETF wants a list with friendly names for most common ones, not all 3500.
>
> *Catalog*
>
> Benoit demonstrated the catalog
>
> URN – should be IEEE
>
> Module name should also be IEEE-<rest of name>, need a hyphen after IEEE.
>
>
>
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 8 Dec 2017 12:01:03 -0800

Pat,

> On Dec 8, 2017, at 6:45 AM, Benoit Claise <[email-masked]> wrote:
> 
>> Ethertype
>> 
>> IEEE can do a model that lists the valid Ethertypes and updates as new ones are assigned.
>> 
>> Concerns about supporting friendly names. Some Ethertypes were registered as private
>> 

The proposed resolution included:

- The current model has a union definition for ethertype which allows for assignments of 16 bit hex values, in addition to friendly names.
- That IETF will take out definitions for 0x9000 and 0x9100 friendly definitions from the model, and republish the ethertype model.

Cheers.
>> Catalog

Mahesh Jethanandani
[email-masked]