Subject: [ieee-ietf-coord] Rough Notes from 2018-03-23 IETF-IEEE 802 Coordination Meeting

From: Cindy Morgan <[email-masked]>
Date: Fri, 23 Mar 2018 12:29:23 +0000

Rough Notes of the 2018-03-23 IETF-IEEE 802 Coordination Meeting, London

Present:

- Amelia Andersdotter
- Deborah Brungard
- Subir Das
- Donald Eastlake
- Janos Farkas
- Eric Gray
- Bob Heile
- Russ Housley
- John Messenger
- Cindy Morgan
- Glenn Parsons
- Charlie Perkins
- Dorothy Stanley
- Pat Thaler
- Pascal Thubert
- Juan Carlos Zuniga

1. Recognition

The group thanked Pat Thaler for her service. Dorothy Stanley will be taking on the role of co-chair of this coordination group.

2. Face-to-Face Meeting in Bangkok

Russ: Our groups will be meeting back-to-back weeks in Bangkok in November. Do we have agenda items for a joint meeting? Have heard suggestions that we should get the 802 chairs together with the IAB and IESG, and given then amount of coordination going on in DetNet, maybe a joint session on those for the other half day.

Pat: In addition to DetNet and 802, we also in 802.1 have a joint project between .1 and IEC to do a profile for DetNet for industrial. I expect they would also join for that half day, or we should at least invite them. They meet together at 802 meetings, or at least they did for initial one, and we expect that to continue. 

John: When would this be?

Russ: It would be the Saturday between IETF and 802.

Pat: One thing we need to do is check with the meeting planners on both sides and ensure that there can be a room available. I expect with the 2 meetings on either side I expect the only cost would be for catering. 

Dorothy: Bob, do you have any information on the meeting rooms?

Bob: It shouldn't be an issue.

3. Coordination List

- 3. IETF NVO3 and IEEE 802.1 DCB

Russ: Alia and Pat were the leads. Alia just stepped down, I don't know if she is still the right person.

Pat: Icy is in sponsor ballot, the final voting on the doc before it goes forward. We shared it with NVO3, so those chairs have the information for anyone in that group who wants to review it. Expect it should be done by July, and Janos will be the new contact because the things that were in the data center have been moved into the TCN group.

- 5. Enabling use of Local Addresses for virtualization and IoT (was: 
Effect of virtualization on IEEE 802 architecture)

Pat: Glenn stays on, and this has been assigned to Max Reigal/OmniRAN. I think that's a good place for it. We do have an I-D that was put up on the addressing as well as using DHCP to assign addresses that was shared to the list. That should be added to the list of relevant docs.

11. IETF and IEEE 802.1 OmniRAN TG

Russ: 802.1cf next month?

Glenn: It's in WG ballot. More like July or later.

- 21. 6tisch

Pascal: Nothing special to report. What is happening now is, we are using the IETF information layer stuff to expose more information [scribe got distracted by people looking for a different meeting]. TO help that we are using the information element from the IETF. 

- 22. CAPWAP extensions in OPSAWG

Russ: The alt-tunnel doc was finished?

Warren: It's with the RFC Editor.

Russ: So is this ready to close?

Dorothy: Yes.

- 24. Coordination between the IETF and IEEE 802 on Pervasive Monitoring

Russ: Looks like we'll share 802E when it's stable?

Juan Carlos: We had a meeting 2 weeks ago and made a lot of advancement after being dormant for most of 2017. We did a big push and the technical editors will incorporate it into a new versions and will be in a better place by Montreal. Related to the MAC address experiment we did in 2015, we were thinking to compile that into some sort of Informational RFC.

Russ: Has a -00 been posted yet?

Juan Carlos: No.

Russ: Please let us know when it is.

- 25. Layer2/Layer 3 Interaction for Time-Sensitive Traffic

Russ: Looking to ensure .1 and DetNEt are aware of each other's docs.

Deborah: DetNet is meeting today, will go until about 2:30PM and hopefully they will get some process done with the data plane.

Pat: Since I am stepping down as DetNet chair, Janos has agreed to take the job as DetNet co-chair so we can maintain that close connection between the groups. 

- 27. Development of YANG models in the IEEE 802

Russ: Are the owners remaining the same?

Pat: That may be worth an email.

Glenn: I'd add Scott Mansfield to the list, he's leading the YANGsters effort in 802. 

Russ: Will there be a YANG module for ethertypes?

Glenn: We had gone down a path with a proposal of what could be generated automatically, and the view from the IEEE RAC side was that we could do a machine-generated YANG module of ethertypes, but it seems like the desire on the IETF side was for a hand-designed name for each ethertype. A list of common ones with some mutually-agreed short friendly names for it. So that is where it is now, and I don't know what the next step is. I haven't talked to Mahesh or Benoit this week so I don't know what the current requirement level is. 

Russ: What I had was that it might be okay, but there are some really common ones like IP that should have a more accessible name. But I think you're right that talking to Benoit is the thing, or finding out if he will be the owner. I'll report back what I hear from Benoit.

- 30. Intelligent Transportation Systems (ITS)

Russ: The IPv6  over 802.11 spec is in WGLC, and the last issue I believe was resolved on Monday, which is whether to use QoS data.

Pascal: The 6LO draft is almost complete now. Going through IESG review and is the draft that does IPv6 level registration. 

Dorothy: The draft, the potential future work is applicable much more broadly than just IETF.

Pascal: Yes, that's true, it's designed to be compatible. One of the properties is each time it moves, it reallocates.

Dorothy: New SG, looking at evolution of the [] to use more modern fi mechanisms. Currently based on 11a, which is almost 20 years old. The work were would be to look at 11n or 11ac mechanisms and adapt those for use in 11p. That work is just starting, the first SG meeting will be in Warsaw in May.

Russ: Is there a URL for that new work?

Dorothy: There is a public document that motivated the formation of the new SG. After the SG finishes its work there will be a PAR. I can send you a link to the motivating document.

Charlie: In the connection of this IP and ITS, but the discussion in the WG has been acrimonious and there was a claim made that there was already review made of this document, and we are not able to determine where IETF work is and where IEEE work is, and this is a super important  topic in that WG.

Russ: Do you have a recommended course of action?

Charlie: The people involved in calling each other names should be aware that we have this coordination committee.

Pat: I didn't quite understand which group?

Charlie: IPWave, between Tony Li and [].

Russ: There has been some private mail between the chairs and the involved individuals to take it down a couple notches.

Pat: Should there be some update of the description of this item? If Pascal and Dorothy could work on that to reflect the related things.

Russ: At least add another sentence about what is going on in .11.

4. New items for coordination list

Pat: This may be early, not chartered in 802 yet, but we did have presentations on congestion isolation that is being discussed in 802.1. It was presented in TSVWG this week. If that does go forward in July it should be coordinated with TSVWG as it would be a control group operating inside the control group for congestion control. There would be an interest in making sure it's coordinated. 

Russ: Spencer Dawkins mentioned this is starting. If there is anything more to add to this now, we should get Spencer.

Deborah: Alvaro in one of his groups had a discussion on routing discovering, LLDP was identified, and the question was if the 1500 byte frame size is really the limit or if it is possible to have a longer one. Someone said the limitation was IPR-related.

Pat: I hear that statement and have no idea what was meant. I have no idea about any intellectual property on that. Messages that would take multiple packets to send. If you're talking 64k there are limitations. The other thing is the protection we count on for our CRC ends at 9K. There has been no interest in 802 in raising the official max frame size. 

John: I would point out that LLDP is not supposed to be used for large data traffic and as far as I'm aware there is no protocol in the LLDP that allows you to link one message to another. There is no stream, just individual announcements. If you start to use if for massive data transfer possibly other things won't work anymore, so don't do this.

Donald: Use the link local flooding ISIS scope for this.

Pat: In context, they had looked at using LLDP and had decided not to because of these limitations. It's good to leverage protocols when you can but this would not be a good instance of that. 

Eric: So this is sorted.

Deborah: Opened and closed.

Juan Carlos: As other business, a quick point of information, in 802 there is an initiative working on a position statement in support of strong encryption.

Russ: Is this in sync with the IAB's statement on this or contradictory?

Juan Carlos: Not contradictory.

Pascal: There was a discussion yesterday in the IOT directorate, so there is a problem of syncing a number of RFCs, there is a question of how to do that. 

Charlie: We have this multicast over wifi draft that was accepted in MBONED, does this need a place on the coordination committee agenda.

Pat: We had something and we closed it.

Charlie: Will it stay closed?

Dorothy: Work had slowed and it appeared that there were no updates. We can add it back now or we can wait and see how it progresses until Montreal.

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 28 Mar 2018 16:42:48 -0400

Hi!

Sorry I couldn’t make it to the meeting last week.

Here’s some more background on the topic of LLDP.

The intended use is for neighbor discovery, not any type of streaming or
large data traffic.  Specifically, the initial use would be to discover
neighbors in a Data Center context using BGP as the routing protocol.  The
discovery would include L3 information (IP addresses) and BGP-specific
details (address families supported and autonomous system numbers).  Just
for reference, most of that information is statically configured and
exchanged in a BGP Open Message, which has a 4k limit.  The intended
information might be a little more because of the potential to carry
multiple IP addresses.

In talking to the proponents, their claim is that there is IPR (IBM’s) on
how to extend LLDP past 1500 bytes.  I guess it has to do with the way
multiple frames would be related to each other…but that is just a guess.

It seems to me that the neighbor discovery application would be something
where LLDP could be used.  And given the 9k size, it sounds like it could
fit.  I see no need in reinventing the wheel if we just can extend what is
already there.

If all the above sounds coherent, maybe an initial step could be to get the
proponents together with an LLDP expert to figure out if what we want to do
is possible…easy…hard…etc..  And then go from there.  Sound reasonable?
Any suggestions on who we can talk to?

Thanks!

Alvaro.

On March 23, 2018 at 8:29:32 AM, Cindy Morgan ([email-masked]) wrote:

Deborah: Alvaro in one of his groups had a discussion on routing
discovering, LLDP was identified, and the question was if the 1500 byte
frame size is really the limit or if it is possible to have a longer one.
Someone said the limitation was IPR-related.

Pat: I hear that statement and have no idea what was meant. I have no idea
about any intellectual property on that. Messages that would take multiple
packets to send. If you're talking 64k there are limitations. The other
thing is the protection we count on for our CRC ends at 9K. There has been
no interest in 802 in raising the official max frame size.

John: I would point out that LLDP is not supposed to be used for large data
traffic and as far as I'm aware there is no protocol in the LLDP that
allows you to link one message to another. There is no stream, just
individual announcements. If you start to use if for massive data transfer
possibly other things won't work anymore, so don't do this.

Pat: In context, they had looked at using LLDP and had decided not to
because of these limitations. It's good to leverage protocols when you can
but this would not be a good instance of that.

Eric: So this is sorted.

---

From: Dan Romascanu <[email-masked]>
Date: Thu, 29 Mar 2018 00:18:25 +0300

Hi,

I would suggest to start with Norm Finn and/or Paul Congdon. There was
great dislike a while ago in the IEEE 802.1 WG at the idea of using LLDP
way beyond it's scope which is exchanging neighbor information at the link
layer. Specifically 'breaking the model' to include L3 information was
considered nocive. However, The Times They Are A Changin' and their
opinions and advice may be different today.

Regards,

Dan

On Wed, Mar 28, 2018 at 11:42 PM, Alvaro Retana <[email-masked]>
wrote:

> If all the above sounds coherent, maybe an initial step could be to get
> the proponents together with an LLDP expert to figure out if what we want
> to do is possible…easy…hard…etc..  And then go from there.  Sound
> reasonable?  Any suggestions on who we can talk to?
>
> Thanks!
>
> Alvaro.
>
> John: I would point out that LLDP is not supposed to be used for large
> data traffic and as far as I'm aware there is no protocol in the LLDP that
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>
>