Subject: [ieee-ietf-coord] ITU-T SG13 / FG NET-2030

From: Russ Housley <[email-masked]>
Date: Fri, 15 Nov 2019 21:59:40 -0500

I was recently told about an effort to take over significant standards work currently being led by the IETF.   The work taking place in ITU-T Study Group 13 / Focus Group on Technologies for Network 2030, lead by Dr. Richard Li as the FG NET-2030 chairman. The group appears to be looking to redesign the layer 3 and 4 protocols to centralize functions that would enable/facilitate data aggregation and surveillance.

Does anyone on this list know if FG NET-2030 is actually gaining ground?

Russ

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Sat, 16 Nov 2019 03:52:31 +0000

Hi Russ,

I cc'd Scott as our ITU liaison - he'll know the latest - I forget if he's on the coordination group list.

I don't recall if we received a liaison on the FG yet, we did get one from TSAG on another IP-related work:
https://datatracker.ietf.org/liaison/1653/

Deborah

-----Original Message-----
From: ieee-ietf-coord <[email-masked]> On Behalf Of Russ Housley
Sent: Friday, November 15, 2019 10:00 PM
To: <[email-masked]> <[email-masked]>
Subject: [ieee-ietf-coord] ITU-T SG13 / FG NET-2030

Russ
_______________________________________________
ieee-ietf-coord mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ieee-2Dietf-2Dcoord&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=4GWxq_0XfF_Bsa06bqwidOdIekeiaI43ulGVHHY5oJc&s=rEOtAYpWuF0kvYvCyjeF6SImWqUi8-lDIe1M62VK7Ek&e=

---

From: Stewart Bryant <[email-masked]>
Date: Sat, 16 Nov 2019 21:12:19 +0800

Russ

RIchard Li, chair of ITU FGnet2030 is at this IETF and will be talking about it at hot RFC and at a side meeting on Wednesday morning.

I have been working on FGnet2030 since it first met, late last year, and do not recognise the centralisation concern. Sure there are some proposals for using AI for control, but no more than will be present in all of the other SDN control systems being proposed. I have not heard the word surveillance in any of the meetings I have attended.

The work is open in that anyone can join the FG without being an ITU member, and the most developed work is that of their SubG2 report which looks at a set of applications that we predict will be needed in about 10 years time. I recommend reading it as a prediction of the future. I do not think these applications can be deployed without developing the network layer, and in some cases without developing a suitable transport protocol. 

Deploying a new network layer protocol is not as daunting as it once was, because the Internet end  to end model seems to be dying in favour of an app to edge computing model (see Geoff Huston's papers on the subject). That is certainly what seems to be happening with the mega OTT providers who are responsible for the lion’s share of the Internet traffic. When you consider that the network path from the customer to the provider is nearly always a multiplexable layer 2 or MPLS service, you can see that there is a potential development path to introduce new, even proprietary, network layer protocols between the app and the edge compute engine. This change of Internet model is both an opportunity and a threat to the IETF, that the IETF needs to take seriously.

I would advice talking to Richard as chair of the FG to get his perspective.

Best regards

Stewart

. 

> On 16 Nov 2019, at 10:59, Russ Housley <[email-masked]> wrote:
> 
> 
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord

---

From: Stewart Bryant <[email-masked]>
Date: Sat, 16 Nov 2019 21:14:14 +0800

Deborah

You need to look at their white paper and the output of SubG2.

Anyone can subscribe to the FG (you do not need to be an ITU-T member) and look at the proposals.

- Stewart

> On 16 Nov 2019, at 11:52, BRUNGARD, DEBORAH A <[email-masked]> wrote:
> 
> Hi Russ,
>

---

From: "Andrew Myles (amyles)" <[email-masked]>
Date: Sun, 17 Nov 2019 20:55:52 +0000

G'day Russ

You may also be interested in some work in ISO/IEC JTC1/SC6/WG7. This WG is generally planning to replace the entire internet protocol stack. :)

More specifically, in recent times a NP Ballot (ISO/IEC NP 4396) has started  (the ballot closes 1 Feb 2020) to standardise RINA. This is a protocol that I understand John Day proposed in the IETF some time ago, but it was not taken up.

The proposed scope is:

This NP will define the Recursive IPC Network Architecture, an architecture that can meet the requirements set out in ISO/IEC TR 29181-1. It can deliver services beyond the limitations of the current Internet by providing security and guaranteeing QoS while maintaining scalability and ease of configuration. This single NP will consist of multiple specifications as follows:

*       Part 1: Architecture

*       Part 2: Common application connection establishment phase

*       Part 3: Common distributed application protocol

*       Part 4: Flow allocator

*       Part 5: Error and flow control protocol

The work to be carried out in this project requires additional protocol specifications for the future work, which support defined architecture. Current proposed specifications are included in this document as drafts for the work to be undertaken.

The purpose and justification is:

There are significant conundrums present in the current Internet architecture. Multi-homing and mobility of hosts are not easily achievable with a standard TCP/IP stack. APIs are not standardised, making the connection between systems a problem. The Internet also has well known issues related to security, Quality of Service (QoS) and multicast. One of the worst problems is the explosion in complexity by the ever growing Internet protocol suite. These issues illustrate the need for well-defined network architectures that encourage networking engineers to apply a disciplined approach towards solving networking problems. This is the right moment to prepare specifications as different companies and governments are backing the deployment of RINA(Recursive Inter-Network Architecture)-enabled networks.

The ballot includes relatively complete drafts, which were written by John Day (Boston University), Eduard Grasa (i2CAT Foundation) & Miquel Tarzan (i2CAT Foundation).

The NP was submitted by the Spanish NB but it has support from at least the US NB and the Belgium NB

Andrew

-----Original Message-----
From: ieee-ietf-coord <[email-masked]> On Behalf Of Russ Housley
Sent: Saturday, 16 November 2019 2:00 PM
To: <[email-masked]> <[email-masked]>
Subject: [ieee-ietf-coord] ITU-T SG13 / FG NET-2030

Russ

[email-masked]<mailto:[email-masked]>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 18 Nov 2019 06:20:45 +0800

RENA was also pushed in ETSI as a solution to 5G backhaul. I am not sure what its standing is there, but it is not a concept that comes up in any of the backhaul discussions that I have been involve in.

To focus on FGnet2030. RENA was presented at one of the FGnet2030 workshops and John Day is an active participant in the work of the FG. However. RENA has not been formally selected and it not called up in the SubG2 work on new applications, nor is it called up in the fledgling SubG3 Architectural framework. Thus, as of today, RENA has no formal standing in FGnet2030. It is entirely legitimate within an open standards process that RENA is advocated by an individual contributor, but RENA is a long way from being selected as a technology to be recommended for development by the FG.

Best regards

Stewart

> On 18 Nov 2019, at 04:55, Andrew Myles (amyles) <[email-masked]> wrote:
> 
> G'day Russ
>  
> You may also be interested in some work in ISO/IEC JTC1/SC6/WG7. This WG is generally planning to replace the entire internet protocol stack. J
>  
> ·       Part 1: Architecture
> ·       Part 2: Common application connection establishment phase
> ·       Part 3: Common distributed application protocol
> ·       Part 4: Flow allocator
> ·       Part 5: Error and flow control protocol
> From: ieee-ietf-coord <[email-masked] <mailto:[email-masked]>> On Behalf Of Russ Housley
> To: <[email-masked] <mailto:[email-masked]>> <[email-masked] <mailto:[email-masked]>>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord <https://www.ietf.org/mailman/listinfo/ieee-ietf-coord>_______________________________________________
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord <https://www.ietf.org/mailman/listinfo/ieee-ietf-coord>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 18 Nov 2019 07:40:06 +0800

I believe this was also presented in HotRFC yesterday:

https://datatracker.ietf.org/meeting/106/materials/slides-106-hotrfc-future-networks-in-2030-00

> On 18. Nov 2019, at 06:20, Stewart Bryant <[email-masked]> wrote:
>