Subject: [ieee-ietf-coord] draft-richardson-anima-ipv6-lldp

From: Russ Housley <[email-masked]>
Date: Thu, 9 Apr 2020 14:47:23 -0400

There was a discussion of draft-richardson-anima-ipv6-lldp on the ANIMA WG virtual interim meeting earlier today.  It would be great if someone familiar with LLDP could take a look at the Internet-Draft and let the group know if there is a better way to proceed.

Russ

---

From: Paul Congdon <[email-masked]>
Date: Thu, 9 Apr 2020 12:24:01 -0700

I've had a brief look at this draft.   My personal belief is that this is a
gross miss-use of the LLDP protocol.  LLDP is NOT a general L2 transport
protocol.   It is intended to exchange a 'relatively' static local database
with neighbors.   When an LLDP agent receives a frame, it is supposed to
compare what it received with what it received the last time and if
anything is different, it will throw away all of the previous information,
replace the database with the most recently received information and
'wake-up' the higher layers to process the changes.  The expectation (and
design center for the protocol) is that things do NOT change frequently.
Assuming the IPv6 packets are intending to implement their own protocol and
will be changing frequently, encapsulating an IPv6 packet inside an LLDP
TLV would signal a change on each transmission and possibly cause an SNMP
TRAP on each packet received by a traditional implementation.   If I
understand the use case correctly, the draft is seriously miss-using the
protocol and I believe others within 802.1 would agree with me.

Paul

On Thu, Apr 9, 2020 at 11:47 AM Russ Housley <[email-masked]> wrote:

> There was a discussion of draft-richardson-anima-ipv6-lldp on the ANIMA WG
> virtual interim meeting earlier today.  It would be great if someone
> familiar with LLDP could take a look at the Internet-Draft and let the
> group know if there is a better way to proceed.
>
> Russ
>
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 15 Apr 2020 13:50:55 +0000

Hi Paul,

Thanks for reviewing the draft.  I hadn’t read it previously (new AD), but having done so, I can certainly understand your concerns!

Would you like to provide the feedback direct to the ANIMA WG and the authors, or would you like me to relay your comments?

Regards,
Rob

From: ieee-ietf-coord <[email-masked]> On Behalf Of Paul Congdon
Sent: 09 April 2020 20:24
To: Russ Housley <[email-masked]>
Cc: <[email-masked]> <[email-masked]>
Subject: Re: [ieee-ietf-coord] draft-richardson-anima-ipv6-lldp

I've had a brief look at this draft.   My personal belief is that this is a gross miss-use of the LLDP protocol.  LLDP is NOT a general L2 transport protocol.   It is intended to exchange a 'relatively' static local database with neighbors.   When an LLDP agent receives a frame, it is supposed to compare what it received with what it received the last time and if anything is different, it will throw away all of the previous information, replace the database with the most recently received information and 'wake-up' the higher layers to process the changes.  The expectation (and design center for the protocol) is that things do NOT change frequently.  Assuming the IPv6 packets are intending to implement their own protocol and will be changing frequently, encapsulating an IPv6 packet inside an LLDP TLV would signal a change on each transmission and possibly cause an SNMP TRAP on each packet received by a traditional implementation.   If I understand the use case correctly, the draft is seriously miss-using the protocol and I believe others within 802.1 would agree with me.

Paul

On Thu, Apr 9, 2020 at 11:47 AM Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:
There was a discussion of draft-richardson-anima-ipv6-lldp on the ANIMA WG virtual interim meeting earlier today.  It would be great if someone familiar with LLDP could take a look at the Internet-Draft and let the group know if there is a better way to proceed.

Russ

_______________________________________________
ieee-ietf-coord mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ieee-ietf-coord

---

From: Paul Congdon <[email-masked]>
Date: Wed, 15 Apr 2020 06:56:15 -0700

You can relay my comments as an individual,  but if we are looking for a
response from IEEE 802.1, I would need to organize that and obtain WG
approval for an official comment.  I'm happy to do that if others feel it
is necessary and appropriate.

Regards
Paul

On Wed, Apr 15, 2020, 6:51 AM Rob Wilton (rwilton) <[email-masked]>
wrote:

> Hi Paul,
>
>
>
> Thanks for reviewing the draft.  I hadn’t read it previously (new AD), but
> having done so, I can certainly understand your concerns!
>
>
>
> Would you like to provide the feedback direct to the ANIMA WG and the
> authors, or would you like me to relay your comments?
>
>
>
> Regards,
>
> Rob
>
>
>
>
>
> *From:* ieee-ietf-coord <[email-masked]> *On Behalf Of *Paul
> Congdon
> *Sent:* 09 April 2020 20:24
> *To:* Russ Housley <[email-masked]>
> *Cc:* <[email-masked]> <[email-masked]>
> *Subject:* Re: [ieee-ietf-coord] draft-richardson-anima-ipv6-lldp
>
>
>
> I've had a brief look at this draft.   My personal belief is that this is
> a gross miss-use of the LLDP protocol.  LLDP is NOT a general L2 transport

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 15 Apr 2020 14:08:21 +0000

Hi Paul,

I would prefer to try and relay them as individual comments for the moment.  If there is strong push back from the authors or the ANIMA working group then we can look at getting a formal IEEE 802.1 response, but I’m hoping that we can avoid the time/effort that would entail …

Regards,
Rob

From: ieee-ietf-coord <[email-masked]> On Behalf Of Paul Congdon
Sent: 15 April 2020 14:56
To: Rob Wilton (rwilton) <[email-masked]>
Cc: Russ Housley <[email-masked]>; <[email-masked]> <[email-masked]>
Subject: Re: [ieee-ietf-coord] draft-richardson-anima-ipv6-lldp

You can relay my comments as an individual,  but if we are looking for a response from IEEE 802.1, I would need to organize that and obtain WG approval for an official comment.  I'm happy to do that if others feel it is necessary and appropriate.

Regards
Paul

On Wed, Apr 15, 2020, 6:51 AM Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Paul,

Regards,
Rob

From: ieee-ietf-coord <[email-masked]<mailto:[email-masked]>> On Behalf Of Paul Congdon
Sent: 09 April 2020 20:24
To: Russ Housley <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ieee-ietf-coord] draft-richardson-anima-ipv6-lldp

I've had a brief look at this draft.   My personal belief is that this is a gross miss-use of the LLDP protocol..  LLDP is NOT a general L2 transport protocol.   It is intended to exchange a 'relatively' static local database with neighbors.   When an LLDP agent receives a frame, it is supposed to compare what it received with what it received the last time and if anything is different, it will throw away all of the previous information, replace the database with the most recently received information and 'wake-up' the higher layers to process the changes.  The expectation (and design center for the protocol) is that things do NOT change frequently.  Assuming the IPv6 packets are intending to implement their own protocol and will be changing frequently, encapsulating an IPv6 packet inside an LLDP TLV would signal a change on each transmission and possibly cause an SNMP TRAP on each packet received by a traditional implementation.   If I understand the use case correctly, the draft is seriously miss-using the protocol and I believe others within 802.1 would agree with me.

Paul

Russ