Subject: [ieee-ietf-coord] update on IEEE 802.1 TSN

From: Janos Farkas <[email-masked]>
Date: Tue, 16 Feb 2021 20:54:17 +0000

Hi,
Please find below an update on recent progress in IEEE 802.1 TSN<https://www.ieee802.org/1/tsn> since the TSN update given at IETF 106<https://datatracker.ietf.org/meeting/106/materials/slides-106-detnet-sessb-tsn-update-01>.
The TSN Task Group (TG) page<https://www.ieee802.org/1/tsn> summarizes TSN standards<https://1.ieee802.org/tsn/#TSN_Standards> and ongoing projects<https://1.ieee802.org/tsn/#Ongoing_TSN_Projects>, and provides a link to the most recent one-page summary: https://www.ieee802.org/1/files/public/docs2021/admin-tsn-summary-0221-v01.pdf.

IEEE Std 802.1CMde-2020<https://standards.ieee.org/standard/802_1CMde-2020.html> TSN for Fronthaul amendment has been published to extend the base standard with enhancements to fronthaul profiles, add support for a new fronthaul interface,  and new synchronization, and syntonization standards.
The TSN profile projects for industrial automation (IEC/IEEE 60802<https://1.ieee802.org/tsn/iec-ieee-60802/>), automotive (P802.1DG<https://1.ieee802.org/tsn/802-1dg/>), and service provider (P802.1DF<https://1.ieee802.org/tsn/802-1df/>) networks are at TG ballot.
The new P802.1DP<https://1.ieee802.org/tsn/802-1dp/> project has been just started to specify TSN profiles for aerospace onboard Ethernet networks. The intent is to develop this standard jointly with SAE Avionics Networks AS-1 A2.

A major milestone has been achieved by publishing the 2020 revision of the IEEE 802.1AS<https://standards.ieee.org/standard/802_1AS-2020.html> standard, which includes the generalized Precision Time Protocol (gPTP) profile of the IEEE Std 1588-2019 Precision Time Protocol. The new features provided by IEEE Std 802.1AS-2020 include: multiple gPTP domains, external port configuration, management support for delay asymmetry measurement, Fine Timing Measurement for IEEE 802.11 transport and more. Two projects amending IEEE Std 802.1AS-2020<https://standards.ieee.org/standard/802_1AS-2020.html> are underway.
The P802.1ASdm<https://1.ieee802.org/tsn/802-1asdm/> project specifies hot standby operations between two gPTP domains in order to improve reliability and availability for time synchronization.
The P802.1ASdn<https://1.ieee802.org/tsn/802-1asdn/> project specifies a YANG data model for the base standard.
Furthermore, a corrigendum<https://1.ieee802.org/maintenance/802-1as-2020-cor1-corrigendum-to-ieee-standard-802-1as-2020/> is underway to correct minor errors in the base standard.
In addition, a new project is being started to replace non-inclusive terms with inclusive terminology wherever possible; see draft Project Authorization Request<https://www.ieee802.org/1/files/public/docs2021/dr-PAR-0221-v01.pdf> (PAR) and Criteria for Standards Development<https://www.ieee802.org/1/files/public/docs2021/dr-CSD-0221-v01.pdf> (CSD).

IEEE Std 802.1AX-2020<https://standards.ieee.org/standard/802_1AX-2020.html> Link Aggregation has been published.

IEEE Std 802.1Qcr-2020<https://standards.ieee.org/standard/802_1Qcr-2020.html> Asynchronous Traffic Shaping (ATS) has been published. This amendment specifies synchronous traffic shaping over full-duplex links with constant data rates.
The P802.1DC<https://1.ieee802.org/tsn/802-1dc/> project, which specifies QoS features for non-bridge network systems is at TG ballot.

IEEE Std 802.1Qcx-2020<https://standards.ieee.org/standard/802_1Qcx-2020.html> YANG for Connectivity Fault Management (CFM) has been published.
The YANG projects for LLDP (P802.1ABcu<https://1.ieee802.org/tsn/802-1abcu/>), FRER (P802.1CBcv<https://1.ieee802.org/tsn/802-1cbcv/>), and an initial set of TSN features (P802.1Qcw<https://1.ieee802.org/tsn/802-1qcw/>) are at WG ballot.
Th P802f<https://1.ieee802.org/tsn/802f/> project to specify YANG data model for EtherTypes including compact and human-readable names is at TG ballot.

The IEEE 802.1CS-2020<https://standards.ieee.org/standard/802_1CS-2020.html> Link-local Registration Protocol (LRP) specification is with the IEEE Editor for publication. LRP is a new base protocol for signaling, which can be used of the distributed configuration model of TSN.
The P802.1CBdb<https://1.ieee802.org/tsn/802-1cbdb/> project, which specifies extended stream identification functions is at WG ballot.
The P802.1ABdh<https://1.ieee802.org/tsn/802-1abdh/> project, which specifies support for multi-frame LLDPDUs is at WG ballot.
The P802.1Qdd<https://1.ieee802.org/tsn/802-1qdd/> Resource Allocation Protocol (RAP) project specifies the first application of 802.1CS LRP<https://standards.ieee.org/standard/802_1CS-2020.html> for distributed resource reservation. P802.1Qdd is at TG ballot.
The P802.1Qdj<https://1.ieee802.org/tsn/802-1qdj/> Configuration Enhancements for Time-Sensitive Networking project is at TG ballot.
The P802.1CQ<https://1.ieee802.org/tsn/802-1cq/> project, which specifies locally-unique assignment of 48-bit and 64-bit addresses in IEEE 802 networks is at TG ballot.

The P802.1Qcj<https://1.ieee802.org/tsn/802-1qcj/> auto-attach project is at WG ballot.
IEEE SA ballot is about to be started on the P802.1Qcz<https://1.ieee802.org/tsn/802-1qcz/> Congestion Isolation project.

Note that the ongoing P802.1Q-Rev<https://1.ieee802.org/maintenance/p802-1q-rev/> project provides a maintenance roll-up of 802.1Q-2018 with the amendments: 802.1Qcc, 802.1Qcp, 802.1Qcr, and 802.1Qcx.

You are welcome to participate. The main 802.1 page: https://www.ieee802.org/1  includes a link to an introductory presentation to IEEE 802.1 including participation. The current version is: https://www.ieee802.org/1/files/public/docs2020/admin-parsons-WG-logistics-orientation-1120.pdf. See also updates on twitter<https://twitter.com/search?q=%40ieee802%20802.1&src=typed_query&f=live>.
Feel free to contact me with further questions.
Best regards,
János

---

From: Warren Kumari <[email-masked]>
Date: Tue, 16 Feb 2021 20:11:26 -0500

Apologies all,

Our driveway is really steep and icy, and our car slid into the ditch on
the side of it.

I’ll be trying to dig it out in the morning, and so may miss the beginning
of the meeting...

W

On Tue, Feb 16, 2021 at 3:54 PM Janos Farkas <Janos.Farkas=
[email-masked]> wrote:

> Hi,
>
> Please find below an update on recent progress in IEEE 802.1 TSN
> <https://www.ieee802.org/1/tsn> since the TSN update given at IETF 106
> <https://datatracker.ietf.org/meeting/106/materials/slides-106-detnet-sessb-tsn-update-01>
> .
>
> The TSN Task Group (TG) page <https://www.ieee802.org/1/tsn> summarizes TSN
> standards <https://1.ieee802.org/tsn/#TSN_Standards> and ongoing projects
> <https://1.ieee802.org/tsn/#Ongoing_TSN_Projects>, and provides a link to
> the most recent one-page summary:
> https://www.ieee802.org/1/files/public/docs2021/admin-tsn-summary-0221-v01.pdf.
>
>
>
>
> IEEE Std 802.1CMde-2020
> <https://standards.ieee.org/standard/802_1CMde-2020.html> TSN for
> Fronthaul amendment has been published to extend the base standard with
> enhancements to fronthaul profiles, add support for a new fronthaul
> interface,  and new synchronization, and syntonization standards.
>
> The TSN profile projects for industrial automation (IEC/IEEE 60802
> <https://1.ieee802.org/tsn/iec-ieee-60802/>), automotive (P802.1DG
> <https://1.ieee802.org/tsn/802-1dg/>), and service provider (P802.1DF
> <https://1.ieee802.org/tsn/802-1df/>) networks are at TG ballot.
>
> The new P802.1DP <https://1.ieee802.org/tsn/802-1dp/> project has been
> just started to specify TSN profiles for aerospace onboard Ethernet
> networks. The intent is to develop this standard jointly with SAE
> Avionics Networks AS-1 A2.
>
>
>
> A major milestone has been achieved by publishing the 2020 revision of the IEEE
> 802.1AS <https://standards.ieee.org/standard/802_1AS-2020.html> standard,
> which includes the generalized Precision Time Protocol (gPTP) profile of
> the IEEE Std 1588-2019 Precision Time Protocol. The new features provided
> by IEEE Std 802.1AS-2020 include: multiple gPTP domains, external port
> configuration, management support for delay asymmetry measurement, Fine
> Timing Measurement for IEEE 802.11 transport and more. Two projects
> amending IEEE Std 802.1AS-2020
> <https://standards.ieee.org/standard/802_1AS-2020.html> are underway.
>
> The P802.1ASdm <https://1.ieee802.org/tsn/802-1asdm/> project specifies
> hot standby operations between two gPTP domains in order to improve
> reliability and availability for time synchronization.
>
> The P802.1ASdn <https://1.ieee802.org/tsn/802-1asdn/> project specifies a
> YANG data model for the base standard.
>
> Furthermore, a corrigendum
> <https://1.ieee802.org/maintenance/802-1as-2020-cor1-corrigendum-to-ieee-standard-802-1as-2020/>
> is underway to correct minor errors in the base standard.
>
> In addition, a new project is being started to replace non-inclusive terms
> with inclusive terminology wherever possible; see draft Project
> Authorization Request
> <https://www.ieee802.org/1/files/public/docs2021/dr-PAR-0221-v01.pdf>
> (PAR) and Criteria for Standards Development
> <https://www.ieee802.org/1/files/public/docs2021/dr-CSD-0221-v01.pdf>
> (CSD).
>
>
>
> IEEE Std 802.1AX-2020
> <https://standards.ieee.org/standard/802_1AX-2020.html> Link Aggregation
> has been published.
>
>
>
> IEEE Std 802.1Qcr-2020
> <https://standards.ieee.org/standard/802_1Qcr-2020.html> Asynchronous
> Traffic Shaping (ATS) has been published. This amendment specifies
> synchronous traffic shaping over full-duplex links with constant data
> rates.
>
> The P802.1DC <https://1.ieee802.org/tsn/802-1dc/> project, which
> specifies QoS features for non-bridge network systems is at TG ballot.
>
>
>
> IEEE Std 802.1Qcx-2020
> <https://standards.ieee.org/standard/802_1Qcx-2020.html> YANG for
> Connectivity Fault Management (CFM) has been published.
>
> The YANG projects for LLDP (P802.1ABcu
> <https://1.ieee802.org/tsn/802-1abcu/>), FRER (P802.1CBcv
> <https://1.ieee802.org/tsn/802-1cbcv/>), and an initial set of TSN
> features (P802.1Qcw <https://1.ieee802.org/tsn/802-1qcw/>) are at WG
> ballot.
>
> Th P802f <https://1.ieee802.org/tsn/802f/> project to specify YANG data
> model for EtherTypes including compact and human-readable names is at TG
> ballot.
>
>
>
> The IEEE 802.1CS-2020
> <https://standards.ieee.org/standard/802_1CS-2020.html> Link-local
> Registration Protocol (LRP) specification is with the IEEE Editor for
> publication. LRP is a new base protocol for signaling, which can be used of
> the distributed configuration model of TSN.
>
> The P802.1CBdb <https://1.ieee802.org/tsn/802-1cbdb/> project, which
> specifies extended stream identification functions is at WG ballot.
>
> The P802.1ABdh <https://1.ieee802.org/tsn/802-1abdh/> project, which
> specifies support for multi-frame LLDPDUs is at WG ballot.
>
> The P802.1Qdd <https://1.ieee802.org/tsn/802-1qdd/> Resource Allocation
> Protocol (RAP) project specifies the first application of 802.1CS LRP
> <https://standards.ieee.org/standard/802_1CS-2020.html> for distributed
> resource reservation. P802.1Qdd is at TG ballot.
>
> The P802.1Qdj <https://1.ieee802.org/tsn/802-1qdj/> Configuration
> Enhancements for Time-Sensitive Networking project is at TG ballot.
>
> The P802.1CQ <https://1.ieee802.org/tsn/802-1cq/> project, which
> specifies locally-unique assignment of 48-bit and 64-bit addresses in IEEE
> 802 networks is at TG ballot.
>
>
>
> The P802.1Qcj <https://1.ieee802.org/tsn/802-1qcj/> auto-attach project
> is at WG ballot.
>
> IEEE SA ballot is about to be started on the P802.1Qcz
> <https://1.ieee802.org/tsn/802-1qcz/> Congestion Isolation project.
>
>
>
> Note that the ongoing P802.1Q-Rev
> <https://1.ieee802.org/maintenance/p802-1q-rev/> project provides a
> maintenance roll-up of 802.1Q-2018 with the amendments: 802.1Qcc, 802.1Qcp,
> 802.1Qcr, and 802.1Qcx.
>
>
>
> You are welcome to participate. The main 802.1 page:
> https://www.ieee802.org/1  includes a link to an introductory
> presentation to IEEE 802.1 including participation. The current version is:
> https://www.ieee802.org/1/files/public/docs2020/admin-parsons-WG-logistics-orientation-1120.pdf.
> See also updates on twitter
> <https://twitter.com/search?q=%40ieee802%20802.1&src=typed_query&f=live>.
>
> _______________________________________________
> ieee-ietf-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ieee-ietf-coord
>
-- 
Perhaps they really do strive for incomprehensibility in their specs.
After all, when the liturgy was in Latin, the laity knew their place.
-- Michael Padlipsky