Subject: [ieee-ietf-coord] RFC8691 and 802.11bd

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 15 Jul 2021 21:24:10 +0200

Hi, participants to the IEEE-IETF coordination,

RFC8691 "IPv6 over OCB" is produced by the IPWAVE WG of IETF.  It 
describes the layering of the IPv6 network protocol on top of the 802.11 
MAC in OCB mode.  This mode is the preferred mode of operation for 
automobile networks that involve 802.11.  This OCB mode is also known as 
802.11p, and will be used in the future 802.11bd to be released by IEEE 
in 2022.

I would like to say that it will be a great idea if the 802.11bd 
document cited RFC8691 whenever the former said 'IPv6'.  It would be a 
perfect match.

How to achieve that goal?

I think there might be a few hurdles in achieving it:

- I do not have regular access to the 802.11bd ongoing developments, and 
the latest documents.  I am not a member of the IEEE respective group.

- some IEEE people often think that _if_ there is a network layer in 
automobile networks, then that would first be the IEEE's networking 
layer for it, which is IEEE 1609.3, and 'WSMP', which is a different 
thing than the IP networking layer.  It might be that IEEE gives 
preference to that networking layer instead of IP.

 From an architecture point of view, I think there is no comparison to 
be made between those two networking layers.  The IP networking layer 
clearly has several advantages, scuh as its addressability capacity and 
the forwarding of datagrams for scalability.

 From an implementation point of view, I did see many implementations of 
this IPv6-over-OCB (802.11p) running in many automobile networks. An 
implementation of IPv6-over-OCB of 802.11bd is only around the corner, 
not posing any significant challenge in realization.

Maybe these worries are not really founded, and maybe it is extremely 
easy to cite RFC8691 in 802.11bd.  But how to do it?

Alex

---

From: "Peter Yee" <[email-masked]>
Date: Thu, 15 Jul 2021 13:39:12 -0700

Hi, Alex,

                I’m the IEEE 802.11 liaison to the IETF. I just checked Draft 2.0 of IEEE 802.11, which was made available to IEEE 802.11 members today. It makes no mention of IPv6 at all. There are no mentions of Internet Protocol either. That’s not surprising given that IEEE 802.11bd focuses on the MAC and PHY layers. If you feel that IEEE 802.11bd ought to have a concrete tie to IPv6 and RFC 8691, you are certainly welcome to pitch the idea to IEEE 802.11 Task Group bd. The task group holds frequent teleconferences and there’s no registration or payment required to participate at that level. The calendar of meetings can be found at https://www.ieee802.org/11/. The next TGbd meeting appears to be 27 July. Unfortunately, you just missed their sessions earlier this week during the IEEE 802 plenary meeting. 

                As for your hurdles below, let me reply by saying:

1.	Please check with Dorothy Stanley (IEEE 802.11 WG chair) and see if she will make a dispensation to grant you access to the latest IEEE 802.11bd draft. The task group working documents (i.e., anything that is not the draft itself) are openly available at https://mentor.ieee.org/802.11/documents?is_dcn=DCN%2C%20Title%2C%20Author%20or%20Affiliation <https://mentor.ieee.org/802.11/documents?is_dcn=DCN%2C%20Title%2C%20Author%20or%20Affiliation&is_group=00bd> &is_group=00bd. 
2.	I don’t believe that IEEE 802.11 explicitly gives preference to IEEE 1609.3. While there is some overlap between the groups, I’m not aware of a required or de facto preference. Many in IEEE 802.11 are also members of the IETF and are quite aware of the strong ties between the protocol families. 

Should you wish to be put on the agenda for an upcoming IEEE 802.11 TGbd teleconference to discuss this topic, please send an email to the task group chair, Bo Sun, at [email-masked] <mailto:[email-masked]> . If you need additional assistance, please feel free to reach out to me directly as well. I will also mention this topic during my liaison report on the IETF during the IEEE 802.11 closing plenary session next Tuesday.

                Kind regards,

                -Peter Yee

From: ieee-ietf-coord <[email-masked]> On Behalf Of Alexandre Petrescu
Sent: Thursday, July 15, 2021 12:24 PM
To: [email-masked]
Cc: Thierry Ernst <[email-masked]>
Subject: [ieee-ietf-coord] RFC8691 and 802.11bd

RFC8691 "IPv6 over OCB" is produced by the IPWAVE WG of IETF.  It describes the layering of the IPv6 network protocol on top of the 802.11 MAC in OCB mode.  This mode is the preferred mode of operation for automobile networks that involve 802.11.  This OCB mode is also known as 802.11p, and will be used in the future 802.11bd to be released by IEEE in 2022.

I would like to say that it will be a great idea if the 802.11bd document cited RFC8691 whenever the former said 'IPv6'.  It would be a perfect match.

- I do not have regular access to the 802.11bd ongoing developments, and the latest documents.  I am not a member of the IEEE respective group.

- some IEEE people often think that _if_ there is a network layer in automobile networks, then that would first be the IEEE's networking layer for it, which is IEEE 1609.3, and 'WSMP', which is a different thing than the IP networking layer.  It might be that IEEE gives preference to that networking layer instead of IP.

>From an architecture point of view, I think there is no comparison to be made between those two networking layers.  The IP networking layer clearly has several advantages, scuh as its addressability capacity and the forwarding of datagrams for scalability.

>From an implementation point of view, I did see many implementations of this IPv6-over-OCB (802.11p) running in many automobile networks.  An implementation of IPv6-over-OCB of 802.11bd is only around the corner, not posing any significant challenge in realization.

Maybe these worries are not really founded, and maybe it is extremely easy to cite RFC8691 in 802.11bd.  But how to do it?

Alex