Subject: [Ieprep] Priority Promotion Scheme (PPS)

From: "Nguyen, An" <[email-masked]>
Date: Thu, 6 Nov 2003 15:35:48 -0500

Priority Promotion Scheme (PPS) may be of interest. 

An

----------------------------------------------

Abstract
    
   The Priority Promotion Scheme (PPS) is a new scheme for traffic 
   control; more specifically, PPS involves applying a kind of admission 
   control to achieve end-to-end QoS for a series of packets on a 
   packet-based network.  The main targets are interactive multimedia 
   services such as VoIP, video chat, and video conferencing.  The 
   scheme is based on end-to-end measurement of network resources by end 
   systems.  Before a session is established or even during a session, 
   the source end system senses, measures, or probes the availability of 
   network resources by sending out packets with priority one level 
   lower than that of normal packets.  The result is modification of the 
   DiffServ Code Point (DSCP) value of the succeeding IP packets: the 
   priority is raised or promoted to firmly establish the session, 
   lowered to leave resources with existing sessions, or otherwise 
   adjusted so that the amount of packets does not exceed the available 
   capacity.  The network, i.e., output links of the routers or L2 
   switches is only assumed to support the per-class form of priority 

-----Original Message-----
From: Geib, Ruediger [mailto:[email-masked]]
Sent: Tuesday, November 04, 2003 10:08 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Tsvwg] Comments on draft-morita-tsvwg-pps-01

Hello Naotaka,

your revised and new PPS related draft are marked 
as TSV WG, but haven't been announced yet (at least I 
couldn't find an announcement in the archive). After 
reading both, I'm having some remarks, following below.

http://www.ietf.org/internet-drafts/draft-morita-tsvwg-pps-01.txt
http://www.ietf.org/internet-drafts/draft-morita-tsvwg-mfverify-00.txt

Remarks related to morita-tsvwg-pps-01:

While the draft is focused on terminals sending with 
variable rates, the edge traffic control seems to assume 
the peak rate as only parameter characterising the 
controlled traffic. Further, section 8.4 demands 
continuous sending of packets. Does that mean that 
terminals sending with variable rates are expected 
to continuosly create traffic at their peak rate if 
they desire to use PPS?

Your third draft "Measurable Forwarding: A New per-Hop 
Behavior (PHB)" wasn't listed in the "individual 
submissions" section. If IETF didn't accept it this time, 
a url to it would be useful as I think it helps 
understanding pps operation.

The framework could put more emphasis on the "stateless 
core" operation. This feature is a clear and very desirable 
benefit of PPS against other signaling modes. It is 
mentioned only once in section 4.2 so far.

I'll stop here and save minor and editorial comments for 
a time when there's a clearer view on the future of PPS 
within IETF.

Regards, Rüdiger

Rüdiger Geib
T-Systems
Systems Integration
Senior Expert, Technologiezentrum
Am Kavalleriesand 3, 64295 Darmstadt
Germany
Fon: +49 6151 832138
http://www.t-systems.com

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: "MORITA, Naotaka" <[email-masked]>
Date: Fri, 07 Nov 2003 09:10:12 +0900

Thank you for your reference, An.

The following three documents are relevant to PPS.
http://www.ietf.org/internet-drafts/draft-morita-tsvwg-pps-01.txt
http://www.ietf.org/internet-drafts/draft-morita-tsvwg-mfphb-00.txt
http://www.ietf.org/internet-drafts/draft-morita-tsvwg-mfverify-00.txt

I am going to make a presentation on Monday morning at TSV WG.

Naotaka

At 15:35 03/11/06 -0500, Nguyen, An wrote:
 >Regards, R$B—E(Biger
 >R$B—E(Biger Geib

----------------------------------
Naotaka MORITA, Senior Research Engineer, Supervisor
Network Service Systems Laboratories
Information Sharing Laboratory Group
NTT
3-9-11, Midori-Cho, Musashino-Shi, Tokyo 180-8585 JAPAN
Tel. +81-422-59-7464, ISDN-Fax +81-422-60-4012
E-mail: [email-masked]
MSN messenger: [email-masked]
NTT home page: http://www.ntt.co.jp/about/e/index.html