Subject: [Ieprep] MLPPoIP effort?

From: "Eagan, Christopher" <[email-masked]>
Date: Wed, 19 Nov 2003 09:54:48 -0500

Thanks Ken,

Yes, those are some of the drafts I was thinking of.  In addition, there is the traits-based-authorization* effort in the sipping wg and the mlef phb** draft that are applicable.  I guess the issue is, can we somehow unify, and invigorate some of these efforts under a common goal of MLPPoIP?  Is IEPREP the place to do it or should it be an additional working group?  The reason I wonder about a separate working group is that it appears IEPREP is focused on the Internet whereas the private networks deal with a more configurable environment (chairs?).

When I said "specification of protocols for MLPPoIP" I meant specifying a required behavior using existing protocols where possible, and specifying required extensions to protocols if necessary.

Chris

*http://www.ietf.org/internet-drafts/draft-peterson-sipping-role-authz-01.txt

**http://www.ietf.org/internet-drafts/draft-silverman-diffserv-mlefphb-02.txt

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Ken Carlberg
> Sent: Tuesday, November 18, 2003 10:49 AM
> To: Eagan, Christopher; [email-masked]
> Subject: RE: [Ieprep] MLPPoIP effort?
> 
> 
>  
> > There are several documents in the IETF related to various issues
> > important to MLPP, but there does not seem to be a visible effort on
> > building the 'whole system'.  Is there a possibility of unifying or
> co-
> > parenting some of these efforts under the IEPREP umbrella?
> 
> I assume you've read the following drafts.  These are individual
> contributions, but they provide a starting point for what you may be
> looking for.  The drafts will have the author's address, so 
> feel free to
> contact them directly.
> 
> 	draft-pierce-ieprep-assured-service-req-01.txt
> 	draft-pierce-ieprep-assured-service-arch-01.txt
> 	draft-pierce-ieprep-pref-treat-examples-01.txt
> 	draft-polk-sipping-mlpp-reqs-01.txt
> 
> Of the items you mentioned below...
> 
> 	- Requirements Document for MLPP over IP
> 	- Identification of technologies to be used or any necessary 
> 	  protocol extensions
> 	- Specification of protocols to use in MLPPoIP
> 	- Specification of gateways between MLPP IP netwowks and other 
> 	  MLPP networks
> 
> ...the first two would seem to fall within the current the current
> charter of IEPREP -- however, the ieprep chairs are a more definitive
> authority on that issue.  For the last two, if by "specification" you
> mean the definition of new protocols, then that would be out of the
> current IEPREP charter and I would suggest speaking with an Area
> Director for further advice.
> 
> My personal view is that if there is something specific that 
> you feel is
> missing or not addressed, its very helpful to put things in 
> writing and
> in the form of a draft-rfc.  That provides a tangible point for others
> to examine and comment on (if they feel so inclined :-).  Note that
> comments can be quite blunt and they generally arise on 3 
> occasions: the
> introduction of a new draft, the request to make an individual
> contribution into a working group item, and last call.  Its 
> usually the
> latter two that wake people up.
> 
> Regards,
> 
> -ken
> 
> 
> 
> _______________________________________________
> Ieprep mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ieprep
> 

_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: "Ken Carlberg" <[email-masked]>
Date: Wed, 19 Nov 2003 10:39:12 -0500

> I guess the issue is, can we somehow
> unify, and invigorate some of these efforts under a common goal of
> MLPPoIP?  Is IEPREP the place to do it or should it be an additional
> working group?  The reason I wonder about a separate working group is
that
> it appears IEPREP is focused on the Internet whereas the private
networks
> deal with a more configurable environment (chairs?).

personally, I'm not thrilled about the formation of another somewhat
related working group if a significant measure of its work involves
requirements.  Charters of existing working groups can be modified
within reason to take on new and related work, and I'd have a preference
for you trying to pursue that direction first with IEPREP and seeing the
reaction.  The decision on that request is predominantly one advocated
by the group as a whole, and the worst thing that happens is that the
answer is no.

However, the group (and I assume ADs as well) will find it very
difficult to make a decision without a draft-RFC to look at.  So I'll
just reiterate the request for you to put together a draft.  Drafts can
be quite informal, so perhaps you may want to add a temporary annex that
states where other drafts are a bit lacking.

> When I said "specification of protocols for MLPPoIP" I meant
specifying a
> required behavior using existing protocols where possible, and
specifying
> required extensions to protocols if necessary.

Its that latter item that will probably receive a lot of pushback within
IEPREP.  So if you want to add an extension to SIP, as an example,
you'll be redirected to take that to the SIPPING/SIP working group.

my 2 cents,

-ken

---

From: [email-masked] (Scott Bradner)
Date: Wed, 19 Nov 2003 10:41:03 -0500 (EST)

> The reason I wonder about a separate working group is that it
> appears IEPREP is focused on the Internet whereas the private networks deal
> with a more configurable environment

it is a different environment, though I would not agree that it is 
"more configurable"

in any case - the ieprep WG decided to work on within-enterprise
ieprep (i.e. not between enterprise ) issues ("enterprice" includes ISP)
so the basic topic seems reasonable to think about in ieprep but we
need to look at the charter to see if such work is already in-charter
or if we need to talk to the ADs about changing the charter if the
WG thinks this is useful work

Scott (chair hat on)