Subject: Re: [ietf-822] Update to RFC 5322 to allow "group" syntax in the "from" header

From: Barry Leiba <[email-masked]>
Date: Sun, 9 Sep 2012 17:09:48 -0400

I have just posted draft-leiba-5322upd-from-group-04:
   http://datatracker.ietf.org/doc/draft-leiba-5322upd-from-group/

That changes the definition of Sender as well as From, and also adds a
new "Applicability Statement" section that has an edited version of
some text suggested by John Klensin (thanks, John).  I like the
result, and I hope others do as well: it makes it clearer that we're
not recommending the general use of group syntax in From and Sender,
but are enabling it for limited use in certain situations (of which
the EAI use case is so far the only one).

Further comments before I ask Pete to run a formal last call on this?

Barry

---

From: Ned Freed <[email-masked]>
Date: Sun, 09 Sep 2012 23:17:02 -0700 (PDT)

> Further comments before I ask Pete to run a formal last call on this?

It occurs to me that now that sender has changed from

    sender = mailbox

to

    sender = address

Since address can be a group, and a group can contain multiple addresses, we've
left a crack through which the syntax allows multiple address to slip into a
sender field.

I suppose we could define sender as something like this:

    sender = mailbox / (display-name ":" (mailbox / CFWS) ";" [CFWS])

But this seems kinda ugly to me. I think a note to the effect that at most one
address can appear in a sender group construct would suffice.

Aside from that, this document looks spot on to me.

				Ned

---

From: Barry Leiba <[email-masked]>
Date: Mon, 10 Sep 2012 15:26:03 -0400

> left a crack through which the syntax allows multiple address to slip into a
...
> I think a note to the effect that at most one

I have this change queued up:

OLD
   If the from field contains more than one address (mailbox or group) in the
   address-list, then the sender field, containing the field name "Sender" and a
   single mailbox or group specification, MUST appear in the message.

NEW
   If the from field contains more than one address (mailbox or group) in the
   address-list, then the sender field, containing the field name "Sender" and a
   single mailbox or group specification that refers to no more than
one mailbox,
   MUST appear in the message.

Barry

---

From: Ned Freed <[email-masked]>
Date: Mon, 10 Sep 2012 13:12:23 -0700 (PDT)

>    MUST appear in the message.

<pedant>

This only covers the case where the from: contains more than one address. What
about the case where the from is a single address but different from the
sender?

</pedant>

				Ned

---

From: Barry Leiba <[email-masked]>
Date: Mon, 10 Sep 2012 16:21:26 -0400

>>    one mailbox, MUST appear in the message.
>
> <pedant>
>

He-he-he.

Yes, so I'll also add that to the end of the paragraph after the grammar:

OLD
   Otherwise, both fields SHOULD appear.

NEW
   Otherwise, both fields SHOULD appear.  If the "Sender:" field
   specifies a group, that group SHOULD NOT refer to more than
   one mailbox.

(Q: "SHOULD NOT", or "MUST NOT"?)

Barry

---

From: Ned Freed <[email-masked]>
Date: Mon, 10 Sep 2012 13:47:43 -0700 (PDT)

> (Q: "SHOULD NOT", or "MUST NOT"?)

I think MUST NOT is appropriate here.

				Ned

---

From: Bill McQuillan <[email-masked]>
Date: Mon, 10 Sep 2012 14:34:19 -0700

>    MUST appear in the message.

Does this mean that an empty group counts as one "addr-spec" for 
the purposes of requiring a Sender: field?

If not, it sounds to me as if an IMAP or POP server downgrading for a 
legacy client will have to "violate" this rule since a downgraded 
From: field will normally have only an empty group with the 
UTF8 addr-spec hidden in the name of the group. If that triggers 
the requirement for the server to create a Sender: field, the only 
thing available to put into it is the same empty group in the 
From: field.

My belief is that the downgrading process in this case can just 
leave the From: field with an empty group and presume that the 
client will not crash on the missing Sender: field.

Note that the damage will not likely propagate since the message
is unreplyable!

-- 
Bill McQuillan <[email-masked]>

---

From: Ned Freed <[email-masked]>
Date: Mon, 10 Sep 2012 14:30:07 -0700 (PDT)

I should also add that I believe this change addresses the remaining issue.

				Ned

> 				Ned
> _______________________________________________
> ietf-822 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-822

---

From: Ned Freed <[email-masked]>
Date: Mon, 10 Sep 2012 14:50:14 -0700 (PDT)

> the purposes of requiring a Sender: field?

No.

> UTF8 addr-spec hidden in the name of the group.

Correct.

> If that triggers
> the requirement for the server to create a Sender: field,

Unless I'm missing something, it doesn't trigger. The rule is "more than one",
not "other than one".

> the only

I don't see why this would be required by this language.

				Ned

---

From: Bill McQuillan <[email-masked]>
Date: Tue, 11 Sep 2012 01:37:07 -0700

> Unless I'm missing something, it doesn't trigger. The rule is "more than one",

Re-reading 5322, you're right. I'm not sure why I thought that it
was "other than one".