Subject: Proposed Statement on "HTTPS everywhere for the IETF"

From: The IESG <[email-masked]>
Date: Mon, 01 Jun 2015 09:43:59 -0700

Hi All,

The IESG are planning to agree an IESG statement on "HTTPS Everywhere
for the IETF," please see [1] for the current text.

We are seeking community feedback on this and welcome assistance
from the community in identifying any cases where a change or
additional guidance is needed to put this into effect.

The IESG plans to finalise this statement just after IETF-93 in Prague.

* Please send general feedback intended for discussion to [email-masked]

* Comments about specific issues arising can be sent to [email-masked]
or [email-masked] as appropriate (use [email-masked] if not sure)

Regards,
Terry & Stephen (for the IESG)

[1] https://trac.tools.ietf.org/group/iesg/trac/wiki/HttpsEverywhere

---

From: Ted Lemon <[email-masked]>
Date: Tue, 2 Jun 2015 14:02:27 -0400

On Jun 2, 2015, at 12:59 PM, Joe Touch <[email-masked]> wrote:
> Leaving out the have-nots - or those whose access is blocked by others
> when content cannot be scanned - isn't moving forward.

That would certainly be a problem if the consensus were not to provide both a secure and an, as you call it, "open" version of all IETF documents.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 2 Jun 2015 14:13:48 -0400

On Jun 2, 2015, at 2:05 PM, Joe Touch <[email-masked]> wrote:
>> On 6/2/2015 11:02 AM, Ted Lemon wrote:
>> That would certainly be a problem if the consensus were not to
>> provide both a secure and an, as you call it, "open" version of all IETF documents.
> 
> The IETF is more than just the documents.
> All IETF content should be accessible via non-secure means.

Yes, I agree, and as I said I think that's the consensus.   What I mean by "IETF documents" is what you mean by "IETF content," and I apologize for my lack of clarity—I was not merely referring to RFCs and internet drafts.

That said, there's clearly some reason why you responded, I think to something that I said, by raising the concern that some public IETF content might not be accessible in this way.   So probably the right thing to do is figure out if you still think that someone is proposing a solution which would have that as its result, and if so, explain why you think that, since it likely means that some technical problem was overlooked either in what I said or what was said previously.