Subject: IETF 100 Registration Opening Delayed Until Wednesday, 26 July at 07:00 PDT (14:00 UTC)

From: IETF Secretariat <[email-masked]>
Date: Fri, 21 Jul 2017 02:26:46 -0700

Registration for IETF 100 in Singapore has been postponed until Wednesday of next week due to issues with the main venue hotel reservation system that are beyond our control. 

New date: Wednesday, 26 July 
New time: 07:00 PDT (14:00 UTC)

Worldwide times at https://timeanddate.com/s/37rk. An announcement opening registration and hotel reservations will be made at 07:00 PDT on 26 July.

Letters of Invitation may be requested during registration.

- IETF Secretariat

---

From: Alexa Morris <[email-masked]>
Date: Fri, 21 Jul 2017 11:47:05 +0200

The time and date link was incorrect in the message below. Correct link is: https://timeanddate.com/s/3ax6.

Alexa

> On Jul 21, 2017, at 11:26 AM, IETF Secretariat <[email-masked]> wrote:
>