Subject: [Ietf-community-india] Virtual #RFCsWeLove on 2nd May 2020

From: Dhruv Dhody <[email-masked]>
Date: Fri, 24 Apr 2020 22:23:54 +0530

Hi Folks,

We are planning to have our very first Virtual #RFCsWeLove -

Date: 2nd May 2020 (Saturday)
Time: 10:00 AM to 1:00 PM
Venue: Google Meet - https://meet.google.com/trj-pyhx-eca
Agenda:
- Discuss on the virtual IETF 107
- Minimizing suffering due to extra buffering: the PIE way by Mohit P. Tahiliani
- Current state of DNS & Introduction to DoH by Swapneel Patnekar
- TBD
- Feedback on organizing more virtual events

Please register and let us know if you have a topic in mind for this
or a future meetup - https://forms.gle/bYdKzr1ZT9FAU1hc9

Thanks! Stay Safe!

Dhruv
For IIESoc

---

From: Fred Baker <[email-masked]>
Date: Fri, 24 Apr 2020 11:10:53 -0700

It might be worthwhile to also mention Codel, and explain the differences. I'd offer to do it, but the time isn't exactly conducive.

> On Apr 24, 2020, at 9:53 AM, Dhruv Dhody <[email-masked]> wrote:
> 
> Hi Folks,
> 
> _______________________________________________
> Ietf-community-india mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-community-india

---

From: "Mohit P. Tahiliani" <[email-masked]>
Date: Sat, 25 Apr 2020 17:12:12 +0530

Hi Fred,

Thanks for the suggestion.

Yes, I can add an introduction to CoDel and explain the differences.

But it would be great to listen to your talk on queue disciplines. Either
way works for me!

Regards,
Mohit P. Tahiliani

On Fri, Apr 24, 2020 at 11:40 PM Fred Baker <[email-masked]>
wrote:

> It might be worthwhile to also mention Codel, and explain the differences.
> I'd offer to do it, but the time isn't exactly conducive.
>

---

From: Fred Baker <[email-masked]>
Date: Sun, 26 Apr 2020 22:36:29 -0700

Mohit has offered to include something on Codel in his talk. It might be best to let him talk about it.

FYI, I'm the author of Cisco WRED circa 1996, and one to the authors of RFC 8333 (PIE). I was working on the topic of bufferbloat before it was cool to do so - I implemented WFQ in 1991 at ACC and in 1994 at Cisco. I'm not sure PIE has deployment outside Cable Labs and Cable Modem. What's out there is Codel, primarily in Linux (RFC 8290).

I assume that when you state a time without a time zone, it's India Standard Time (not UTC), right?

I'll try to pull together a few slides on the history of AQM technologies, and the AQM working group, for Saturday night.

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 27 Apr 2020 13:05:17 +0530

Hi Fred,

> I assume that when you state a time without a time zone, it's India Standard Time (not UTC), right?

yes!

> I'll try to pull together a few slides on the history of AQM technologies, and the AQM working group, for Saturday night.

and, that would be Friday Night for you!

India Standard Time, IST    Sat, 2 May 2020 at 10:00 IST
Pacific Time, PT            Fri, 1 May 2020 at 21:30 PDT

Thanks!
Dhruv

---

From: Fred Baker <[email-masked]>
Date: Mon, 27 Apr 2020 07:52:16 -0700

> On Apr 27, 2020, at 12:35 AM, Dhruv Dhody <[email-masked]> wrote:
> 
> Hi Fred,
> 

Yes, apologies for the error.

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 29 Apr 2020 12:08:22 +0530

Hi Folks,

Here are the updated details -

Date: 2nd May 2020 (Saturday)
Time: 10:00 AM to 1:00 PM
Venue: Google Meet - https://meet.google.com/trj-pyhx-eca
Agenda:
- Discussion on the virtual IETF 107
- History of AQM technologies by Fred Baker
- Minimizing suffering due to extra buffering: the PIE way by Mohit P. Tahiliani
- Current state of DNS & Introduction to DoH by Swapneel Patnekar
- Web Payment APIs by Nemo
- Feedback on organizing more virtual events

Register at - https://forms.gle/bYdKzr1ZT9FAU1hc9

Read more at - https://www.iiesoc.in/post/virtual-rfcs-we-love-may-2020

Stay Safe and see you there!

Thanks!
Dhruv
For IIESoc

---

From: Fred Baker <[email-masked]>
Date: Wed, 29 Apr 2020 15:50:08 -0700

See attached. I'm especially interested in Mohit's comments, as I presume I'll essentially be introducing his topic.

BTW, I thought he started out wanting to talk about CoDel, and decided to discuss both PIE and CoDel? This only mentions PIE.

> On Apr 28, 2020, at 11:38 PM, Dhruv Dhody <[email-masked]> wrote:
> 
> Hi Folks,
>

---

From: "Mohit P. Tahiliani" <[email-masked]>
Date: Thu, 30 Apr 2020 12:34:18 +0530

Hello Fred,

On Thu, Apr 30, 2020 at 4:20 AM Fred Baker <[email-masked]> wrote:

> See attached. I'm especially interested in Mohit's comments, as I presume
> I'll essentially be introducing his topic.
>

It looks good to me. Thanks! I'm glad you'll be introducing this topic.

You might want to introduce the FQ-AQM approach in the last slide?

BTW, I thought he started out wanting to talk about CoDel, and decided to
> discuss both PIE and CoDel? This only mentions PIE.
>

I wanted to talk about PIE, and decided to add CoDel afterwards based on
our discussion.

This abstract was prepared before we decided to add CoDel in the talk, so
it does not reflect that part. I'll send the revised abstract.

Thanks and Regards,
Mohit P. Tahiliani

---

From: Fred Baker <[email-masked]>
Date: Thu, 30 Apr 2020 06:55:50 -0700

> On Apr 30, 2020, at 12:04 AM, Mohit P. Tahiliani <[email-masked]> wrote:
> 
> Hello Fred,
> 
> I wanted to talk about PIE, and decided to add CoDel afterwards based on our discussion.
> 
> This abstract was prepared before we decided to add CoDel in the talk, so it does not reflect that part. I'll send the revised abstract.
> 
> Thanks and Regards,
> Mohit P. Tahiliani

In any event, you will be discussing both PIE and CoDel, I believe. If not, I'll come up with some slides to discuss CoDel.

But yes, I'll add a slide or two about the FQ-AQM model.

---

From: "Mohit P. Tahiliani" <[email-masked]>
Date: Fri, 1 May 2020 03:57:29 +0530

Yes, I'll be discussing both PIE and CoDel.

Thanks,
Mohit P. Tahiliani

On Thu, Apr 30, 2020, 19:25 Fred Baker <[email-masked]> wrote:

> > See attached. I'm especially interested in Mohit's comments, as I
> presume I'll essentially be introducing his topic.
> >
> > BTW, I thought he started out wanting to talk about CoDel, and decided
> to discuss both PIE and CoDel? This only mentions PIE.
> >
> > This abstract was prepared before we decided to add CoDel in the talk,
> so it does not reflect that part. I'll send the revised abstract.
> >
> > Thanks and Regards,
> > Mohit P. Tahiliani
>
> In any event, you will be discussing both PIE and CoDel, I believe. If
> not, I'll come up with some slides to discuss CoDel.
>