Subject: [Ietf-community-india] Fw: Free Webcasts: Message Layer Security / RFCsWeLove

From: Nalini J Elkins <[email-masked]>
Date: Mon, 13 Jul 2020 14:11:17 +0000 (UTC)

All,

You may be interested in these upcoming free webinars.

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

----- Forwarded Message -----

From: Nalini Elkins <[email-masked]>
To: "[email-masked]" <[email-masked]>
Sent: Monday, July 13, 2020, 06:59:56 AM PDT
Subject: Free Webcasts: Message Layer Security / RFCsWeLove

  

Free Webcast: Message Layer Security (MLS)

This webinar is presented by the Industry Network Technology Council.  You may go to this website to see future webinars and to download foils and recordings (when available) of past webinars.

Name: Asynchronous Group Message Security

Area: Message Layer Security (MLS)

Date: July 23, 2020

Time: 9:00am Pacific (11am Central, 12pm Eastern)

By: Dr. Britta Hale

Register HERE

The current protocols used for texting applications such as Facebook Messenger, WhatsApp, Signal, etc. are being revised.  One of the essential problem is that number of people in a group in such applications can only grow to be in the 200 - 300 person range.  With the new security protocol being developed at the IETF,  Message Layer Security (MLS),  this number can grow to be in the 50,000 or even 100,000 range in a group.

This will change the kind of new applications which are possible in the coming years.  The essence of MLS is secure group keying.  We may well see MLS used together with other protocols in the future.

Dr. Britta Hale has been very involved in the development of this new protocol.

Webinar Description:

Peer-to-peer group communication has long been a necessity for usability in team coordination. However, the security of such systems has not been well understood or investigated in comparison to one-to-one secure messaging options (such as Signal or even TLS). Based on an ongoing IETF standardization initiative, this presentation will introduce participants to the basic concepts of group messaging security, end-goals, and threat models – including “self-healing” security – and will prepare them to ask critical questions regarding group communication security and implementations.

Britta Hale is an Assistant Professor of Computer Science at the Naval Postgraduate School working in cryptography and cybersecurity. Her specialization areas include analysis and design of cryptographic key exchange and authentication protocols. Hale is currently active in the design and IETF standardization of the MLS group messaging protocol, user-mediated protocol analysis, and hybrid post-quantum cryptography.

Recent papers include the first public research on detection of man-in-the-middle attackers in messaging protocols. Hale holds a PhD from the Norwegian University of Science and Technology and a Master’s in Mathematics of Cryptography and Communications from Royal Holloway, Univ. of London.

RFCsWeLove: Pre-IETF 108 Discussion

Date: 17th July Friday
Time in India: 18:30 to 20:00 IST

Time in US: 6:00am pacific (9:00am eastern)

Registration: HERE

This meetup is in coordination with the India Internet Engineering Society (IIESOC) and ISOC Rural Development Special Interest Group.

All attendees from around the world are welcome and encouraged to attend.  The next IETF meeting, IETF 108, will be virtual.  You may attend all sessions remotely.  Click HERE for more information.  

MEETUP AGENDA

    * Introduction to IETF & IETF participation from India by Michael Richardson and Vinayak Hegde
    
    * Tips for attending IETF 108 online by Dhruv Dhody
    
    * Panel discussion on “How to increase participation in IETF from India?
    
    * Moderator: Nalini Elkins
    
    * Panelist: Shwetha Bhandari, T Santosh, Shraddha Hegde, Tirumaleswar Reddy Konda, and Mohit P. Tahiliani

For more details, click HERE.

This RFCsWeLove focuses on introducing the IETF just before the online IETF 108 meeting (27-31 July 2020).

Nalini Elkins

Inside Products, Inc.  

www.insidethestack.com

    

Inside Products 
  
Inside Products offers innovative solutions for managing TCP/IP networks. Our focus is to improve the productivity of the systems programming staff who maintain the data processing infrastructure for large corporations, educational institutions, and government agencies. We are technical people who write products for other technical people. For more information, please go to: 

http://www.insidethestack.com

 

  Manage Your Subscription  

This message was sent to [email-masked] from [email-masked]

Nalini Elkins
Inside Products
36A Upper Circle
Carmel Valley, CA 93924

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

---

From: Rahul Jadhav <[email-masked]>
Date: Tue, 14 Jul 2020 09:32:04 +0530

Thanks Nalini for the information.

The listed webinars links are not shown up in the mail. Can you please send
the registration link for MLS webinar?

Thanks,
Rahul

On Mon, 13 Jul 2020 at 19:41, Nalini J Elkins <
[email-masked]> wrote:

> This webinar is presented by the Industry Network Technology Council.  You
> may go to this website to see future webinars and to download foils and
> recordings (when available) of past webinars.
>
>
>
> The current protocols used for texting applications such as Facebook
> Messenger, WhatsApp, Signal, etc. are being revised.  One of the essential
> problem is that number of people in a group in such applications can only
> grow to be in the 200 - 300 person range.  With the new security protocol
> being developed at the IETF,  Message Layer Security (MLS),  this number
> can grow to be in the 50,000 or even 100,000 range in a group.
>
> This will change the kind of new applications which are possible in the
> coming years.  The essence of MLS is secure group keying.  We may well see
> MLS used together with other protocols in the future.
>
> Peer-to-peer group communication has long been a necessity for usability
> in team coordination. However, the security of such systems has not been
> well understood or investigated in comparison to one-to-one secure
> messaging options (such as Signal or even TLS). Based on an ongoing IETF
> standardization initiative, this presentation will introduce participants
> to the basic concepts of group messaging security, end-goals, and threat
> models – including “self-healing” security – and will prepare them to ask
> critical questions regarding group communication security and
> implementations.
>
> Britta Hale is an Assistant Professor of Computer Science at the Naval
> Postgraduate School working in cryptography and cybersecurity. Her
> specialization areas include analysis and design of cryptographic key
> exchange and authentication protocols. Hale is currently active in the
> design and IETF standardization of the MLS group messaging protocol,
> user-mediated protocol analysis, and hybrid post-quantum cryptography.
>
> Recent papers include the first public research on detection of
> man-in-the-middle attackers in messaging protocols. Hale holds a PhD from
> the Norwegian University of Science and Technology and a Master’s in
> Mathematics of Cryptography and Communications from Royal Holloway, Univ.
> of London.
>
>
>
> This meetup is in coordination with the India Internet Engineering Society
> (IIESOC) and ISOC Rural Development Special Interest Group.
>
> All attendees from around the world are welcome and encouraged to attend.
> The next IETF meeting, IETF 108, will be virtual.  You may attend all
> sessions remotely.  Click HERE for more information.
>
> MEETUP AGENDA
>
>
> Inside Products offers innovative solutions for managing TCP/IP networks.
> Our focus is to improve the productivity of the systems programming staff
> who maintain the data processing infrastructure for large corporations,
> educational institutions, and government agencies. We are technical people
> who write products for other technical people. For more information, please
> go to:
>
>
>
> _______________________________________________
> Ietf-community-india mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-community-india
>

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 14 Jul 2020 09:40:33 +0530

Hi Rahul,

Looks like the HTML was stripped in Nalini's email, you can find the
webinar link at - https://industrynetcouncil.org/webinars

Thanks!
Dhruv

On Tue, Jul 14, 2020 at 9:32 AM Rahul Jadhav <[email-masked]> wrote:
> The listed webinars links are not shown up in the mail. Can you please send the registration link for MLS webinar?
>
> Thanks,
> Rahul
>
> On Mon, 13 Jul 2020 at 19:41, Nalini J Elkins <[email-masked]> wrote:
>>
>> All,
>>
>> To: "[email-masked]" <nalini_elkins@insidethestack..com>

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 14 Jul 2020 12:33:49 +0000 (UTC)

Thanks, Dhruv!

Rahul, I see that you have registered for the webinar.

Next time, I will send along the links in text also.

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

On Monday, July 13, 2020, 09:11:18 PM PDT, Dhruv Dhody <[email-masked]> wrote: 

Hi Rahul,

Thanks!
Dhruv