Subject: RE: [ietf-dkim] 1193 considered harmful

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 24 Mar 2006 08:55:53 -0800

I am not really bothered by the direct mail use case. They have
infrastructure support. 

But mailing lists are a different matter. Mailing lists are typically run on
pensioned off hardware. Delays can already be an issue. The issue is not so
much signature time, it is messaging architecture. Most code deals with the
head and the body separately. This creates a dependency I would like to
avoid.  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Hector Santos
> Sent: Friday, March 24, 2006 8:01 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [ietf-dkim] 1193 considered harmful
> 
> ----- Original Message -----
> From: "Arvel Hathcock" <[email-masked]>
> 
> 
> >> and the question is left at whether same-body/different-header 
> >> messages are actually sent.  I am saying that they are.
> >
> > Right, it's very common isn't it?  Doesn't this mailing list do it?
> 
> But the irony, DKIM is being supported by the DMA as their 
> ticket to legitimacy and their wishes can be very costly.  If 
> it wasn't obvious, the reference is when you have a message 
> body template like so:
> 
>    Dear  %FIRST.NAME%
> 
>    Do you suffer from %PROBLEM%?   If so, then we have %SOLUTION%
>    at a cost of %COST% designed just for you!
> 
> Template variables %PROBLEM%, %SOLUTION% and %COST% is 
> common. But %FIRST.NAME% is not requiring each message to be 
> individualized.
> 
> This means if you have 1,000,000 target addresses, you need either:
> 
>     1) 1,000,000 individual storage files, or
>     2) A smart MTA that performs template macro substitution 
> dynamically
>        at the SMTP session.
> 
> Most models exist,  DKIM caters to #1.  #2 will require DKIM 
> hashing at the SMTP stage.
> 
> --
> Hector Santos, Santronics Software, Inc.
> http://www.santronics.com
> 
> 
> _______________________________________________
> NOTE WELL: This list operates according to 
> http://mipassoc.org/dkim/ietf-list-rules.html
> 
> 
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Michael Thomas <[email-masked]>
Date: Fri, 24 Mar 2006 09:01:56 -0800

> head and the body separately. This creates a dependency I would like to

I'm having a real hard time understanding this. I run a few mailing
lists, and as far as I can tell DKIM as in -allman-01 works fine,
and wouldn't be helped at all by this proposal.

		Mike