Subject: [ietf-dkim] Re: draft-ietf-dkim-base-01 submitted

From: Mircea Purdea <[email-masked]>
Date: Thu, 13 Apr 2006 11:59:49 -0700 (PDT)

Two questions:

 1. Is this to be considered the 'current' DKIM
specification? That is, should new implementations
follow this?

 2. Shouldn't this new draft recommend a signature
'Version' value? The new bh/b hashing scheme does not
seem to be compatible with that in 'draft-allman-dkim-base-01'...

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 13 Apr 2006 20:12:08 +0100

> specification? That is, should new implementations

This is the current working draft. You should expect
more new drafts of base over the next month or two
when we're scheduled to have a working group last
call. At that point the specification will be more
stable. The most recent is always the current one.

Different people will decide differently about when
to start coding. But the more people coding up the
spec the better the result hopefully.

> seem to be compatible with that in 'draft-allman-dkim-base-01'...

That was suggested, but we didn't bottom out on whether
or not its warranted. We should do that.

Stephen.

---

From: Dave Crocker <[email-masked]>
Date: Thu, 13 Apr 2006 12:41:36 -0700

>> specification? That is, should new implementations
...
 > spec the better the result hopefully.

During IETF working group development, implementations of drafts are useful for 
exposing problems.  As noted, however, the drafts change.  Therefore a 
non-trivial issue with implementing a draft -- even for experimentation -- is 
who you will test it with.

If you are seeking to implement a production version of DKIM, the version 
submitted to the IETF is the current stable reference.

Please see <http://mipassoc.org/dkim/#production>.

/d