Subject: [ietf-dkim] Proposal for v= tag

From: Mircea Purdea <[email-masked]>
Date: Sat, 22 Apr 2006 18:39:33 +0300

>
> While it may be sensible to start using v= now, or when an RFC
> issues, or in some other way, I don't think that having a
> different v= for each Internet-draft is a good idea really.
>
> Perhaps you are expecting too much of each version of the I-D
> in terms of stability/compatibility. These are working documents,
> clearly labeled as such and expecting a clear interoperability
> story between -xx and -yy for all xx,yy is not reasonable IMO.
>   

 Perhaps I am expecting too much, but still, I don't see why it would be 
unreasonale to identify drafts.
 If we have the tag, why not use it?

 Mircea

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 22 Apr 2006 16:49:06 +0100

> If we have the tag, why not use it?

I guess my concern would be that it might encourage people not to
update their code to be RFC compliant.

Stephen.

---

From: Mircea Purdea <[email-masked]>
Date: Sat, 22 Apr 2006 18:56:14 +0300

> update their code to be RFC compliant.
 
 That might be so, but on the other hand, I think that before commiting 
to a RFC, live testing of draft implementations SHOULD be done, and 
currently, given the v= situation, this is nigh impossible...

 Mircea

---

From: Michael Thomas <[email-masked]>
Date: Sat, 22 Apr 2006 09:14:52 -0700

> currently, given the v= situation, this is nigh impossible...

Well, I just went and implemented -01 yesterday and I'm not having a 
problem supporting
the previous versions. We may yet have a situation where we can't do 
that, but thus far
we haven't. Considering that the draft seems to be converging, I'd say 
that waiting for
it to track rfc's seems like a reasonable thing to do.

       Mike