Subject: Re: [ietf-dkim] dkim-base-01: ABNF discrepancies

From: Eric Allman <[email-masked]>
Date: Mon, 01 May 2006 11:36:08 -0700

> I noticed a few discrepancies on dkim-base-01. Sorry if someone
> already  pointed out.

Nope, you're the first.  Thanks.

> Section 3.5, the ABNF for selector conflicts between section 3.1
> and 3.5. I think
>
>    sig-s-tag    = %x73 [FWS] "=" [FWS] Domain
>
> should be
>
>    sig-s-tag    = %x73 [FWS] "=" [FWS] sub-domain *( "." sub-domain 
)

Yes, you're right.  Thanks.

> Section 3.6.1, the ABNF for "s=" tag of key doesn't represent
> "a colon-separated list" as described. So I think
>
>    key-s-tag        = %x73 [FWS] "=" [FWS] key-s-tag-type
>
> should be
>
>    key-s-tag        = %x73 [FWS] "=" [FWS] key-s-tag-type
>                       0*( [FWS] ":" [FWS] key-s-tag-type )

True.  Question for the list: should this actually be:

  key-s-tag   = %x73 [FWS] "=" [FWS] ( "*" / key-s-tag-type-list )

with key-s-tag-type-list defined as the colon separated list?  Put 
another way, should "*" be a special qualifier, or just another type 
in the list?

eric
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Tony Hansen <[email-masked]>
Date: Mon, 01 May 2006 15:13:59 -0400

> another way, should "*" be a special qualifier, or just another type

Syntactically, "*" should be just another type in the list.

	Tony Hansen
	[email-masked]