Subject: RE: [ietf-dkim] Are verifiers expected to query SSP on a successfulverify?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 2 Aug 2006 11:06:44 -0700

> From: Stephen Farrell [mailto:[email-masked]] 

> Phill,
> 
> Hallam-Baker, Phillip wrote:
>  > That does not allow for algorithm agility which I believe 
> is either  > an explicit security area requirement now or 
> soon will be after the  > SHA-1 issue is addressed.
> 
> Don't we already have alg. agility between signers and 
> verifiers, via the h= and k= fields of the key record?

No.

There are two agility issues, first can you use the new algorithms. The key record can answer that one fine

The second is which algorithms should I expect? The key record does not answer that as far as I can see and it is the wrong place to do that.

The key record should allow verification of the signature, the policy record the sufficiency of the signature.

> If so, then is what you're suggesting only of use when the 
> signer is different from the rfc2822.From domain?

No.

> If so, do we expect that domains like that, that don't sign 
> for themselves, will find it useful to be specifying the 
> acceptable algorithms for their signed mail?

No, the scheme useful for two cases. The principle one being for when a domain is in the process of a transition and wishes to support legacy signature algorithms without opening up a downgrade attack vulnerabilty.

The use of remote selectors in the policy record is not the principle intended use, but it is useful to some certainly and I don't see a good reason to block it.

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 02 Aug 2006 19:16:50 +0100

> The key record can answer that one fine

That's why I thought we were agile enough already:-)

> The second is which algorithms should I expect? The key record does 
 > not answer that as far as I can see and it is the wrong place to
 > do that.

Why? Surely all that can happen is stripping of the stronger
sig and we already decided that that wasn't a bother for base,
so why is it a problem now? (Maybe I mis-remember but I think
we decided it was a non-problem, not that it was a problem
to punt to SSP.)

S.