Subject: [ietf-dkim] Delegated signatures in real life

From: John L <[email-masked]>
Date: Tue, 29 Aug 2006 18:10:09 -0400 (EDT)

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Information Superhighwayman wanna-be, http://johnlevine.com, Mayor
"I dropped the toothpaste", said Tom, crestfallenly.
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 30 Aug 2006 7:18 -0400

On Tue, 29 Aug 2006 18:17:51 -0400 (EDT) John L <[email-masked]> wrote:

>Senders already use NS delegation to let third parties put on first party 
>DK signatures.  It works.  It's popular.  There is no need to invent 
>another way to solve this solved problem.

For small domain owners with outsourced DNS this isn't necessarily going to 
be available.  So it depends on how broadly you care to have DKIM 
available/deployable.

I don't have broad statistics for this, but based on the providers I use 
that provide DNS services:

Two registrars: neither support
One dedicated DNS provider: Does not support
One domain host: Does support

Based on my limited sampling, I'm not optimistic the NS delegation is THE 
answer.  This doesn't point to any particular DNS or policy approach as an 
alternative.  I do think it exemplifies that SOME alternative is needed.

Scott K

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 30 Aug 2006 11:52:53 -0700

Oddly enough end user signatures are easy precisely because of the reasons John states.

You have to implement key management and the key management can talk to the dns.

XKMS solves these problems wonderfully. The corner cases are the ones in between. There is just enough effort required to be a PITA but not enough to justify a new infrastructure.

On the admin side where I depart from many in this group is the level of tollerance I have for convoluted admin procedures. First as a security specialist my experience is they screw up in insecure ways. Second not being a paid consultant I see no reason to tolerate high admin overhead.

The deployment scenarios that interest me these days are deployments in areas like afghanistan or iraq, places I have no intention of making site visits to, I am out of that sort of thing these days.

Sent from my GoodLink Wireless Handheld (www.good.com)

 -----Original Message-----
From: 	John Levine [mailto:[email-masked]]
Sent:	Wednesday, August 30, 2006 07:37 AM Pacific Standard Time
To:	[email-masked]
Cc:	[email-masked]
Subject:	Re: [ietf-dkim] Delegated signatures in real life

>In addition, I would also note that it is extremely easy in a group like 
>this to lose track of how non-technical many domain owners are today. 

Right, and that means that they use someone else to provide their
mail service.

Keep in mind that DKIM, unlike SPF, requires the active participation
of whoever runs your outgoing mail server to apply signatures, unless
you are enough of a weenie to run a signing engine in your MUA and do
your own key management.  For the vast majority of non-technical
users, their ISP or hosting company's MTA will apply its own
signature, and that will be good enough.  Indeed, it will probably be
better than a tiny domain's own signature, since whatever formal or
informal reputation systems recipients use are much more likely to
have entries for the ISP than for a tiny domain that sends 12 messages
a week.

I suppose it is hypothetically possible that providers will upgrade
their MTAs to support per-domain DKIM signing and out of perverse
hostility won't offer the DNS support for it.  That has never
impressed me as a scenario likely enough to be worth inventing a new
mechanism with unknown security problems that has to be implemented by
all DKIM recipients.

R's,
John

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 30 Aug 2006 12:03:37 -0700

First the example john gives is real, but an incomplete description. VeriSign is an ESP, the point is that this high trust case is not th most general case, it is much more common to outsource bulk mailing and this is done today to low trust providers precisely because there is no authentication in email.

We should not rely on an expectation of low security that we are trying to change.

Security by analogy and security by comparison fail for well known reasons. 

It is always a mistake to use implementation considerations to filter requirements gathering. Gather the requirements then filter.

I know people think they have code to protect. But at this stage I don't think ssp will survive unchanged. So why not simplify it while we have the chance? Especially when we can do so and meet more requirements by doing so.

 -----Original Message-----
From: 	John L [mailto:[email-masked]]
Sent:	Tuesday, August 29, 2006 05:52 PM Pacific Standard Time
To:	Hallam-Baker, Phillip
Cc:	DKIM List
Subject:	RE: [ietf-dkim] Delegated signatures in real life

> Orbitz might not care about the security issues raised by allowing 
> doubleclick to sign messages on behalf of their CEO and other 
> executives. Many others will.

Actually, Doubleclick signs for email.orbitz.com, which is not the domain 
where the execs have their addresses.  If there is some security problem 
here, you'll have to explain more clearly what it is.

> This is a security area spec, least privilege must apply wherever possible.

Sure, but don't forget that the D in DKIM stands for Domain.  The 
granularity is domains, not mailboxes.  If you want per-mailbox 
signatures, DKIM isn't what you're looking for.

Regards,

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 30 Aug 2006 16:32 -0400

On 30 Aug 2006 19:38:58 -0000 John Levine <[email-masked]> wrote:
>>That sounds to me like you are saying that DKIM first party signing is 
only 
>>for big domains.
>
>No, I'm saying that the anyone who wants to sign their mail with their
>own domain can do so.  If you want to delegate that to a service
>bureau, we have working examples today of domains using NS delegation
>to outsource their mail including DK signing.  Even if you are too
>cheap to use a DNS service that lets you put in NS records, your can
>get much the same effect by having your mail service make up your
>keys, send you CNAME or TXT records, and you cut and paste them into
>your zone, not unlike the way that you help people to put in SPF
>records.
>
OK.  Sorry I was reading to much into what you wrote.  I think that list of 
options does include choices that are suitable for nearly everyone.  

I'm waiting for some time to seriously think about if I think it's adequate 
or if a policy mechansim is require too.  I'm now undecided on the matter.

>>"You're little, third party is good enough for you" is not the right 
answer.
>
>Actually, what I was saying is "you're little, your ISP's signature is
>the one that matters."  I host a bunch of little domains, and I expect
>to sign all of their mail with my own somewhat better known domain.  I
>should be able to sign the mail of people who want with their own
>domain, probably at modest extra cost, but I doubt many will ask.
>
Fair enough.  As long as the mechanisms are in place to allow either 
approach in a reasonable way, I think that's a question the market can 
decide.

>>At this point I'm not suggesting an alternative.  My point is that NS 
>>subdomain delegation is not sufficient by itself.
>
>If I understand your position, you are positing that someone will pay
>between $20 and $50/mo for Internet access, probably some extra amount
>per month for a DKIM-capable mail service, but they use a crummy DNS
>service where they don't know how to put in NS records, and the $2/mo
>it would cost to switch to a DNS service that does support them is an
>insurmountable barrier.  Maybe I'm getting hard hearted in my old age,
>but pleas of selective ineptness or selective poverty do not make a
>compelling argument for anything.

It's not a matter of money, but a matter of the complexity of dealing with 
an audience that the first step in the process is you have to explain what 
a DNS service IS and they have very limited time or interest in 
understanding.

Scott K

---

From: Arvel Hathcock <[email-masked]>
Date: Wed, 30 Aug 2006 21:13:00 -0500

> a DNS service IS and they have very limited time or interest in 

Believe me, I can sympathize with that experience.  However, DKIM-BASE already requires the use of DNS so we've crossed this bridge already haven't we?

-- 
Arvel