Subject: [ietf-dkim] New Requirements: SSP must offer Highest Protection Possible

From: "Hector Santos" <[email-masked]>
Date: Tue, 1 Aug 2006 13:39:58 -0400

I suggest a new requirement:

- SSP must offer Highest Protection possible for Responsible
  Originating domains (High Value or not) who desire 100%
  exclusivity in their mail digital signatures which includes

    - no expectation for tampering, and
    - no expectation for 3rd party signatures, and
    - an expectation that verifiers will follow
      and honor this policy.

Even if one feels "it probably won't be used", there is no evidence
that it won't, therefore, the highest protection possible for
a mail digital signature must be made available, not excluded as a
possibility for usage.

---
HLS

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 01 Aug 2006 18:50:38 +0100

> a mail digital signature must be made available, not excluded as a

"highest protection" (with or without caps:-) is a simple assertion
that there is a benefit.

I still don't see what that benefit is. What message (that should) gets
delivered that wouldn't otherwise, or gets dropped (that should)
that would otherwise get through?

Sorry for being dumb about this, but I just don't see the benefit,
and I do see potential for at least accidental DoS when someone tries
to help by countersigning.

S.

---

From: <[email-masked]>
Date: Tue, 1 Aug 2006 14:00:43 -0400

Benefit,
Assertion by the signer to affect the policy of the receiver. Agreed
accidental DOS possibility by a (un)helpful relayer.

Bill Oxley 
Messaging Engineer 
Cox Communications, Inc. 
Alpharetta GA 
404-847-6397 
[email-masked] 

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Stephen Farrell
Sent: Tuesday, August 01, 2006 1:51 PM
To: Hector Santos
Cc: IETF-DKIM
Subject: Re: [ietf-dkim] New Requirements: SSP must offer Highest
ProtectionPossible

S.

---

From: "Hector Santos" <[email-masked]>
Date: Tue, 1 Aug 2006 14:22:21 -0400

----- Original Message -----
From: "Stephen Farrell" <[email-masked]>
To: "Hector Santos" <[email-masked]>
Cc: "IETF-DKIM" <[email-masked]>
Sent: Tuesday, August 01, 2006 1:50 PM
Subject: Re: [ietf-dkim] New Requirements: SSP must offer Highest Protection
Possible

> "highest protection" (with or without caps:-) is a simple assertion

Correct, but I would suggest it is based on the hypothesis that the
shortest, interrupted path between A and B theoritically offers the highest
protection (less troublesome, less opportunity for change).

So this policy basically becomes an emulation of the direct 1 to 1 mail
transaction "no change" expectation.  It would not be used where there might
be an expectation of mailing list servers in involved.

> that would otherwise get through?

I'm not suggesting that a 2nd (3rd party ) valid signature added would not
be a valid transaction, but I think you should leave it up to the domain if
he wishes to allow this:

     OP=ALWAYS; 3P=NEVER;      Highest protection
     OP=ALWAYS; 3P=OPTIONAL;   "high" protection

All I saying is lets not exclude the highest potential.

> I do see potential for at least accidental DoS when someone tries

Right, thats possible. But isn't that a bug and applies to all policies <g>
and doesn't it still serve the purpose at the final destination that there
was a middle man doing unexpected things to the message?

All I am noting is that we should not exclude this possible policy. I don't
see the reason for excluding it.  The domains don't have to use it and there
is no harm created by it.

--
Hector Santos, Santronics Software, Inc.
http://www.santronics.com

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 01 Aug 2006 20:37:05 +0100

Evening Hector,

> be an expectation of mailing list servers in involved.

Now that sounds *very* complicated, or else, very marginal
(in terms of places it could be used).

> All I saying is lets not exclude the highest potential.

Ok, I'll stop asking now, but I have not seen anything to
convince me of a benefit here, never mind that this is
"highest" in any interesting sense. I can understand the
apparent attractiveness of being able to represent what
senders/domain-owners would like to say, but that doesn't
mean that ssp is the right protocol to use to make all
such statements.

> Right, thats possible. But isn't that a bug and applies to all policies <g>

No. If a mailing list, or forwarder, wanted to start
signing, are they first supposed to check all of their
subscribers policies to determine which senders will be
disadvantaged by their signing?

That makes no sense at all to me and is a straight
consequence of the addition of a signature having a
negative effect.

> is no harm created by it.

There is harm there - we'd at least be creating a new
DoS opportunity where none would exist otherwise, and
that I definitely dislike.

Stephen.

---

From: "Hector Santos" <[email-masked]>
Date: Tue, 1 Aug 2006 21:00:26 -0400

> (in terms of places it could be used).

A bank?  Maybe with the growing "e-Medical" market, a doctor? or in general
any high-value domain who will most likely have a Donald Trump "HUGE"
expectation for direct 1 to 1 like exclusivity with no middle ware
tampering.

I am not sure if you (speaking in general of course <g>) is questioning the
value of this or whether its possible to work or simply no one will want to
use it.

> that I definitely dislike.

How would this Exclusive (I am the only one to sign) SSP policy DoS work and
if so, why would not there be a defense?

Or more general, where is the DoS where it would not be otherwise today?  I
just don't see how we are not defensive minded on DoS across the board, but
for this one, we are?

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 02 Aug 2006 12:14:40 +0100

> expectation for direct 1 to 1 like exclusivity with no middle ware

Ah - fair enough - you could always set aside or setup a subdomain for
this kind of thing to lessen the impact.

> if so, why would not there be a defense?

Right now, I'd mostly be concerned about the accidental DoS
where some intermediary also signs. However, I guess if
someone could control mail routing from one of the outbound
(untrusted) MTAs then they could send the mail via an innocent
signer in order to affect the mail, without being easily blamed.
I guess if you could bring down some connection then you
might be able to get mail re-routed from outside.

I believe I've demonstrated a case where this is harmful. I've
yet to see an equivalent demonstration that its useful!

> just don't see how we are not defensive minded on DoS across the board, but

I hope we consider DoS all the time,
S.
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Michael Thomas <[email-masked]>
Date: Wed, 02 Aug 2006 08:06:00 -0700

> might be able to get mail re-routed from outside.

I don't think this is an entirely far-fetched scenario either: suppose
that the receiving domain as a matter of course signed everything
incoming as sort of an authenticated received header function. In
that case it would always fail even in a supposed "point-to-point"
mode. I'm guessing that's probably not what the sender had in mind.

       Mike

---

From: "william(at)elan.net" <[email-masked]>
Date: Fri, 4 Aug 2006 13:54:07 -0700 (PDT)

> mean that ssp is the right protocol to use to make all

What do you mean by it not being "right protocol", in fact
what in your view makes protocol somehow "right" or "wrong"?

In any case the above scenario ("OP=ALWAYS; 3P=NEVER") is
probably going to be used by financial organizations that
want to protect use of their domains by phishers. Many of
these organizations only want to communicate directly with
end-users and do not allow their employers to even signup
for public mail list (or they allow but require users to
use address in some type of "corporate" domain as opposed
to their primary domain known to users), there is nothing
wrong with allowing them to publish this in the policy
and if it turns out not to be useful, I'm sure they will
not public it and remove 3P=NEVER policy record.

> disadvantaged by their signing?

Hopefully these lists will check which the existing signature
first. If this signature would get broken after normal list
processing than its good idea for mail list to check policies
of original sender and to accomdate those cases (i.e. different
type of list processed which would not break the signature).
If they are going to check on these cases anyway I see nothing
wrong with mail list not adding their own signature for those
same cases if user/domain asked not to do it.

> consequence of the addition of a signature having a

I was on the linux conference recently in the security-area where
presenter said SELinux extensions would always make security of the
system greater. In couple minutes an example was found where they make 
security of overall system weaker when the policy gets applied to
file having to do with another security mechanism. The point is that
new security mechanisms do always bring greater security for all the
cases they can be used with - in fact I'd not be surprised if there
is a theorem that said it is impossible.

-- 
William Leibzon
Elan Networks
[email-masked]

---

From: "william(at)elan.net" <[email-masked]>
Date: Fri, 4 Aug 2006 15:47:28 -0700 (PDT)

> is a theorem that said it is impossible.

In the last sentense it should have been that "new security mechanisms
DO NOT always bring greater security"...