Subject: [ietf-dkim] Feature matrix

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 5 Sep 2006 08:42:50 -0700

One of the considerations people should keep in mind when proposing policy architectures is the fact that we will have to construct a feature implementation matrix to move from proposed standard to draft standard.
 
People who suggest per-user policy mechanisms should bear in mind the need to demonstrate two independent implementations of each feature.

If you want to do anything complex it would be better to look at ways of re-using existing mechanism in the key records than attempt to develop parallel mechanism in the policy record.
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 06 Sep 2006 04:50:39 +0200

Hallam-Baker, Phillip wrote:

> If you want to do anything complex

Not really, "per user" is unnecessary.  If domain owners with
addresses [email-masked] want to offer this feature, they
can create [email-masked], ready.  No SASLprep
or Punycode nightmares, please.

For an example how simple that is look at the LHS of my "From".

It's okay if senders do interesting things with local parts,
let them add "!", "%", and what else as they see fit.  But no
other party should be bothered by such schemes.  The %l in SPF
is dubious, I can only hope that it survives whatever EAI does.

Frank