Subject: [ietf-dkim] Policy vs Practices

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 5 Sep 2006 08:48:28 -0700

Both terms are bad, the term practices is much worse.

Policy is the term of art used to describe what the SSP record is intended to do. It is directly analogous to WS-Policy.

Practices in the context of PKI refers to the legal side of the problem.

There is certainly a history of deprecating the role of policy mechanisms in the IETF. Hence my attempt to create a policy language that is absolutely minimal without constraining utility.

Using the term 'practices' instead of policy is not going to fool anyone, the objection is to the idea, not the name. The term practices is higly loaded and has its own meaning and will cause even more people to shudder.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Stephen Farrell
> Sent: Tuesday, September 05, 2006 2:48 AM
> To: Frank Ellermann
> Cc: [email-masked]
> Subject: Re: [ietf-dkim] Re: Additional per user policy requirments
> 
> 
> 
> Frank Ellermann wrote:
> >  What is the precise
> > Message-ID where one of the Chairs stated that it's the 
> consensus of 
> > this WG to rename "policy" to "practises" ?
> 
> There isn't one afaik. As Doug said that predates the WG.
> 
> But once reqs-01 is out, we're planning to move back into 
> using the issue tracker, so you can of course raise this as 
> an issue if you like, and it'll get resolved that way.
> 
> S.
> _______________________________________________
> NOTE WELL: This list operates according to 
> http://mipassoc.org/dkim/ietf-list-rules.html
> 
> 

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Hector Santos" <[email-masked]>
Date: Tue, 5 Sep 2006 12:09:46 -0400

+1.  

----- Original Message ----- 
From: "Hallam-Baker, Phillip" <[email-masked]>
Sent: Tuesday, September 05, 2006 11:48 AM
Subject: [ietf-dkim] Policy vs Practices

> Policy is the term of art used to describe what the SSP 
> record is intended to do. It is directly analogous to 
> WS-Policy.
> 
> There is certainly a history of deprecating the role of 
> policy mechanisms in the IETF. Hence my attempt to create a 
> policy language that is absolutely minimal without 
> constraining utility.
> 
> Using the term 'practices' instead of policy is not going to 
> fool anyone, the objection is to the idea, not the name. The 
> term practices is higly loaded and has its own meaning and 
> will cause even more people to shudder.

---

From: Douglas Otis <[email-masked]>
Date: Tue, 5 Sep 2006 10:09:22 -0700

On Sep 5, 2006, at 8:48 AM, Hallam-Baker, Phillip wrote:

>
> Using the term 'practices' instead of policy is not going to fool  
> anyone, the objection is to the idea, not the name. The term  
> practices is highly loaded and has its own meaning and will cause  
> even more people to shudder.

The term "practice" over "policy" acknowledges information conveyed  
is not action related instruction for the verifier.  This information  
instead offers assurances regarding an initial state of the message.   
While DKIM is a good mechanism for safe message annotation (provided  
other assurances are made), signature requirements for acceptance  
will disrupt many common email services.  Within the current DKIM  
limitations, rigid verifier instructions would not be compatible with  
email in general.  The term "practice" better conveys this design  
limitation, and better clarifies how this mechanism might be used.

-Doug