Subject: RE: [ietf-dkim] user level ssp

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 6 Sep 2006 14:12:56 -0700

> [mailto:[email-masked]] On Behalf Of J.D. Falk

> On 2006-09-06 10:45, Hallam-Baker, Phillip wrote:
> 
> > The main value I see in user level policy is easing phased 
> deployment. 
> > If you are a bank with 100,000 employees with email and you want to 
> > deploy DKIM you probably want some form of hook that lets 
> you do it in 
> > stages.
> 
> So they'll have 100,000 SSP records?
> 
> Perhaps there's an easier, more flexible, more scalable 
> hook...like "we don't sign all mail."

We don't sign all mail is utterly useless as a policy record. There are only two usefull policy positions ALWAYS SIGN and MIGHT SIGN. There is no value in distinguishing MIGHT SIGN and NEVER SIGN.

Since you can wildcard the most common case one would need 50,000 SSP records at most. It is likely that they would be generated automatically as individual mail servers were configured to use DKIM.

BITs are cheap. I see no problem in deploying 100,000 DKIM records in such a situation. 

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "J.D. Falk" <[email-masked]>
Date: Wed, 06 Sep 2006 14:18:19 -0700

On 2006-09-06 14:12, Hallam-Baker, Phillip wrote:

> Since you can wildcard the most common case one would need 50,000 SSP
> records at most. It is likely that they would be generated
> automatically as individual mail servers were configured to use DKIM.
> 

How will that scale to the 219,000,000 users that comScore thought 
Yahoo! Mail had about a year ago?

(The actual number is a trade secret, but comScore's close enough for 
this conversation.)

And, have any actual banks actually asked for this, or is it still 
entirely theoretical?

-- 
J.D. Falk, Anti-Spam Product Manager
Yahoo! Communications Platform Team
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Douglas Otis <[email-masked]>
Date: Wed, 6 Sep 2006 14:36:49 -0700

> And, have any actual banks actually asked for this, or is it still  

Yes, there have been requests, and not just from banks.

-Doug

---

From: <[email-masked]>
Date: Wed, 6 Sep 2006 18:02:01 -0400

My problem (although much smaller in scale at this time) exactly

Bill Oxley 
Messaging Engineer 
Cox Communications, Inc. 
Alpharetta GA 
404-847-6397 
[email-masked] 

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of J.D. Falk
Sent: Wednesday, September 06, 2006 5:18 PM
To: IETF-DKIM
Subject: Re: [ietf-dkim] user level ssp