Subject: Re: [ietf-dkim] Re: Additional per user policy requirments

From: Scott Kitterman <[email-masked]>
Date: Wed, 06 Sep 2006 10:23 -0400

On Wed, 6 Sep 2006 10:08:42 -0400 Damon <[email-masked]> wrote:

>... Only because people insist that it 
>*must* work in every scheme they can make up.
>I believe that we could implement what we have discussed and the fact
>that it won't work for everybody should be an asterisk. It will work
>for most systems and I am comfortable with that. Implementation is not
>a requirement.
>
+1

Scott K
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 6 Sep 2006 09:51:28 -0700

> From: Douglas Otis [mailto:[email-masked]] 
 
> On Wed, 2006-09-06 at 08:46 -0700, Hallam-Baker, Phillip wrote:
> > 
> > I don't see why any authentication policy would require 
> more than four 
> > terms, six at the absolute maximum. It is not necessary to 
> implement 
> > braces, merely specify whether AND or OR has higher precedence.
> 
> While I agree that this is solvable using rather simple 
> syntax, it is yet to be determined whether even determining 
> precedence is needed.
> This might be accomplished by their listed order.

I don't like depending on list ordering and it does not allow for as much flexibility. 

It is possible to convert any boolean expression in the form a.b.c + d.e + ... Or a+b+c . d+e . ...