Subject: RE: [ietf-dkim] Policy vs Practices

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 5 Sep 2006 10:19:24 -0700

> From: Douglas Otis [mailto:[email-masked]] 

> On Sep 5, 2006, at 8:48 AM, Hallam-Baker, Phillip wrote:
> 
> >
> > Using the term 'practices' instead of policy is not going to fool 
> > anyone, the objection is to the idea, not the name. The 
> term practices 
> > is highly loaded and has its own meaning and will cause even more 
> > people to shudder.
> 
> The term "practice" over "policy" acknowledges information 
> conveyed is not action related instruction for the verifier.  
> This information  
> instead offers assurances regarding an initial state of the 
> message.   
> While DKIM is a good mechanism for safe message annotation 
> (provided other assurances are made), signature requirements 
> for acceptance will disrupt many common email services.  
> Within the current DKIM limitations, rigid verifier 
> instructions would not be compatible with email in general.  
> The term "practice" better conveys this design limitation, 
> and better clarifies how this mechanism might be used.

I agree that the record ONLY contains a statement by the sender that is descriptive of sender actions.

However the record is not bound by protocol to the actual actions of the sender and so the term 'practices' cannot be used with accuracy. What the record specifies is in fact the intended practice.

The English term for an intended practice is 'policy'.

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 5 Sep 2006 13:39:21 -0400

> > > is highly loaded and has its own meaning and will cause even more
...
> However the record is not bound by protocol to the actual actions of the
> sender and so the term 'practices' cannot be used with accuracy. What the
> record specifies is in fact the intended practice.
>
+1

Scott K