Subject: RE: [ietf-dkim] New IANA considerations: standards track or just RFC?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 24 Jan 2007 13:54:19 -0800

+1

I think that people need to take a look at the past ten years and finaly conclude that if the crazies haven't wrecked the Internet already they are not going to. The idea of the IETF or IANA as some sort of gatekeeper protecting the Internet is bogus. The only people who are going to listen are the people who are least likely to cause a problem.

I would like to see the number of IANA registries for text strings reduced to one. There is no reason why the term XYZ should be used in two different specs with entirely different semantics. There is no shortage of terms to use. The only thing that matters is that there is no collision.

We want DKIM to use the same tags for crypto algorithms as everything else.

> [mailto:[email-masked]] On Behalf Of John Levine

> >I generally agree with "RFC only", but haven't thought about 
> all eight 
> >of the registries that -base asks to have created.  It's not 
> clear that 
> >we want to do this with all of them.  For example, we might 
> want to set 
> >a higher bar for the signature or hash algorithm than for 
> creation of a 
> >new signature tag.
> 
> Remember that the point of the registry is primarily to 
> prevent namespace collisions.  Registering a name for a new 
> algorithm doesn't change the DKIM spec, it just tells people 
> that if they want to fool around with that particular 
> algorithm, that's the name to use to be compatible with other 
> people doing the same.  It'd take another standards track RFC 
> to promote a particular algorithm into the spec.
> 
> The main reason to limit registration is to avoid namespace 
> exhaustion, but since these are all variable length text 
> strings. that's not a problem.  In general, the bar to IANA 
> registration has been set too high, which is why there's way 
> too many protocol parameters documented only in the folklore.

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Douglas Otis <[email-masked]>
Date: Wed, 24 Jan 2007 14:39:10 -0800

> We want DKIM to use the same tags for crypto algorithms as  

Isn't that water under the bridge?  DKIM could have utilized an  
existing index or mnemonic scheme.  As it is now, there is a  
signature and key context for the same thing, where hash is expressed  
together or separately.  Most protocols ensure pairing by using an  
index approach.

-Doug