Subject: [ietf-dkim] Policy

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 21 Feb 2007 12:40:30 -0800

I think that there is plenty on policy to keep us busy.

I see three (related) questions:

1) What is the range of policy statements that should be supported?
	PHB: [DKIM[=keyselector]? ] *
		(signing is all or nothing, multiple signatures may be specified).
	Others: ?
		(does anyone argue for DKIM-Somethines as an actionable policy)

2) What syntax should be supported?
	PHB: Tag-value pairs, DKIM is a tag
		Other possible extension tags are for other protocols: SPF,
		PHISHED, DKIM-TEST, SMIME, PGP, etc. 
	Others: ?
		(This answer depends on the andswer to 1, if you have a great deal
		of expression in your policy language then a DKIM language might 
		be appropriate).

3) What should the discovery mechanism be?
	PHB: Finese the wildcard issue with a pointer record
		Reuse of PTR prefered but a new RR is acceptable
	Others: ?

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Stephen Farrell
> Sent: Wednesday, February 21, 2007 10:01 AM
> To: Barry Leiba
> Cc: IETF DKIM WG
> Subject: Re: [ietf-dkim] draft-ietf-dkim-base-10 submitted
> 
> 
> 
> Barry Leiba wrote:
> >> The DKIM base draft has been updated and submitted.  The 
> changes are 
> >> minimal, comprising response to IESG review and some XML updates 
> >> intended to smooth the rfc-editor review.
> > 
> > And the -base-10 draft is now on its way to the RFC editor 
> queue,[1] 
> > having passed IESG review.  Many thanks to everyone who 
> worked to get 
> > this done.  And now we just wait for the RFC editor 
> process, and the 
> > RFC number for the Proposed Standard.
> 
> And get active on SSP again. (Or should I cancel the Prague 
> meeting slot? So far we've little to discuss it seems.)
> 
> S.
> _______________________________________________
> NOTE WELL: This list operates according to 
> http://mipassoc.org/dkim/ietf-list-rules.html
> 

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 21 Feb 2007 20:54:28 +0000

> I think that there is plenty on policy to keep us busy.

I agree, but list members are being uncharacteristically
shy on the topic recently;-)

> I see three (related) questions:

Should those be addressed in ssp-reqs? If so, (and they're
not currently), then how?

We agreed in San Diego to finalise ssp-reqs first (via a
WGLC) before deciding SSP protocol issues, but we've made
no progress recently (to be fair, a number of folks were
busy with dealing with IESG comments to base, so its not
a criticism, just a fact). I'd like us to have that WGLC
started around Prague if we can.

Stephen.

---

From: Damon <[email-masked]>
Date: Wed, 21 Feb 2007 16:14:37 -0500

I keep getting left off the acknowledgements section :-P. Guess I have
to try harder not to cause the authors to get too upset at me ;-)

OK, I will jump in with both feet--
In as far as signing, I think we had discussed before that an
intermediary (I sign SOME mail) would be worthless without being able
to communicate the cases in which the email MUST be signed.

Regards,
Damon Sauer

---

From: Douglas Otis <[email-masked]>
Date: Wed, 21 Feb 2007 13:32:01 -0800

On Feb 21, 2007, at 1:14 PM, Damon wrote:

> intermediary (I sign SOME mail) would be worthless without being  
> able to communicate the cases in which the email MUST be signed.

Why would some email being signed be worthless?  This assumes the  
recipient recognizes the email-address while also being unaware the  
email is signed.  A rather simple DDoS on the DNS server hosting the  
policy and keys might be a rather simple way to bypass such attempts  
at protection.  Policy should also consider what happens with the  
email address is in two forms and uses UTF8.

-Doug