Subject: [ietf-dkim] Wording in draft-ietf-dkim-overview-09

From: Eric Allman <[email-masked]>
Date: Mon, 10 Mar 2008 14:33:07 -0700

In reviewing the documents prior to the meeting today, I noticed an 
oddity in draft-ietf-dkim-overview-09.  The intro to section 5 says 
"The MSA signs the message..." and "The MDA verifies the 
signature...".  However, this isn't necessarily true, and in fact 
conflicts with 3.1.2 (Implementation Locality), 5.2 (Signing), 5.3 
(Verifying), and 5.6 (DKIM Placement within an ADMD).

If those words are intended to be relative to just the DKIM service 
then I suggest other wording such as "DKIM Signing Agent (DSA)" and 
"DKIM Verification Agent (DVA)".

eric
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Dave Crocker <[email-masked]>
Date: Mon, 10 Mar 2008 19:28:34 -0400

As much as I fear we are becoming awash in email functional module names, I 
suspect your suggestion is the only reasonable choice here.

I've come to view this example as "a function that can be placed within any 
module that is part of a particular Adminstrative Domain (trust domain)."

So, signing is expected to be done somewhere inside the Originating ADMD and 
validation within the Receiving ADMD.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Dave Crocker <[email-masked]>
Date: Sun, 23 Mar 2008 14:18:21 -0700

Eric,

Thanks for noting this.  The details in that portion of the draft are painfully 
vestigal and needs to solidly embrace the trust arena of an ADMD, rather than 
just focus on particular modules within the ADMD.

d/

-- 

   Dave Crocker