Subject: [ietf-dkim] RFC 4871 errata

From: Stephen Farrell <[email-masked]>
Date: Mon, 29 Sep 2008 10:43:31 +0100

Hi all,

We need to give Pasi guidance on the WG's opinion of the
various errata [1] that've been posted for RFC 4871.

Most of these were generated as a result of the good interop
work done earlier, so this should hopefully be easy.

We need to tell Pasi if we think the errata as posted
should be accepted and if so, whether the proposed
change and accompanying notes are ok or not. If the
text needs changing then we need to generate the new
text required. (Since this could take some time, please
don't try to e.g. polish the notes text so that its
totally nice and shiny:-)

If there are ones we need to discuss, please start
a new thread for each. Once that's settled down, I'll
send out a mail looking for some +1's on the entire set.
(If no-one comments on any of them in two weeks, i.e.
by 2008-10-13, then I'll send out that message
anyway.)

After that's all done, we'll want to think about whether
to do a 4871bis with the changes or a delta or whatever,
but that's for later.

Thanks,
Stephen.

[1] http://www.rfc-editor.org/errata_search.php?rfc=4871&eid=
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "MH Michael Hammer (5304)" <[email-masked]>
Date: Mon, 29 Sep 2008 09:39:36 -0400

I reviewed each of the errata items and didn't see any issues with the
changes indicated.

> -----Original Message-----
> From: [email-masked] [mailto:ietf-dkim-
> [email-masked]] On Behalf Of Stephen Farrell
> Sent: Monday, September 29, 2008 5:44 AM
> To: ietf-dkim
> Subject: [ietf-dkim] RFC 4871 errata
> 
> 
> Hi all,
>

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 30 Sep 2008 13:17:23 +0300

In particular, my earlier email (two months ago) identified 
two errata (1383 and 1378) that deserve a closer look:

http://mipassoc.org/pipermail/ietf-dkim/2008q3/010664.html

(For these two, I'd be hesitant to assume that silence 
means everyone's OK with them.)

Best regards,
Pasi

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of ext 
> Stephen Farrell
> Sent: 29 September, 2008 12:44
> To: ietf-dkim

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 30 Sep 2008 15:38:00 +0100

Thanks Pasi,

Tony - you generated both of those from the interop, so
could you take a peek and let us know what you recall
and/or think? (e.g. for 1378 do you prefer optional or
REQUIRED?, for 1383 I guess if the interop showed that
folks implement more generic wildcarding then the erratum
is ok as-is).

Ta,
S.

---

From: Jeff Macdonald <[email-masked]>
Date: Tue, 30 Sep 2008 10:34:33 -0400

> various errata [1] that've been posted for RFC 4871.

I agree with the proposed changes. I do find it interesting that the
interop event hasn't happened yet. :)

-- 
Jeff Macdonald <[email-masked]>
e-Dialog

---

From: Tony Hansen <[email-masked]>
Date: Tue, 30 Sep 2008 10:32:00 -0400

Pasi's note today prompted me to look back at his previous note on the
errata. And what do you know, I already had it marked "I need to respond
to this". :-) Better late than never.

Look for the response separately.

	Tony Hansen
	[email-masked]