Subject: Re: [ietf-dkim] DKIM adoption

From: Franck Martin <[email-masked]>
Date: Sat, 1 Aug 2009 16:17:59 +1200 (FJT)

I was curious by Scott comment re SPF. 

Is there a class of spam that cannot get a DKIM signature? 

I would think botnets would be that class, as they usually infect computers and not sure they could DKIM sign as it would require them to set a DNS entry too. Knowing that botnets are 70% of spam, if DKIM could solve this one it would be great. 

so my question to add to your question "Does the presence of a signature provide any objective data about the goodness or badness of the signer?" is: 
is there a class of spam that cannot get a DKIM signature? 

----- Original Message ----- 
From: "Dave CROCKER" <[email-masked]> 
To: "Franck Martin" <[email-masked]> 
Cc: "DKIM WG" <[email-masked]> 
Sent: Saturday, 1 August, 2009 4:04:28 PM GMT +12:00 Fiji 
Subject: Re: [ietf-dkim] DKIM adoption 

Franck Martin wrote: 
> Yes the reputation of the domain override things, but what happens when 
> it is the first time a domain is seen? Does DKIM help or not? 

Does the presence of a signature provide any objective data about the goodness 
or badness of the signer? 

If the claim is that it does, there needs to be an explanation of the basis, 
because I don't see it. 

d/ 
-- 

Dave Crocker 
Brandenburg InternetWorking 
bbiw.net 
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Steve Atkins <[email-masked]>
Date: Fri, 31 Jul 2009 22:02:25 -0700

On Jul 31, 2009, at 9:17 PM, Franck Martin wrote:

> I would think botnets would be that class, as they usually infect  
> computers and not sure they could DKIM sign as it would require them  
> to set a DNS entry too. Knowing that botnets are 70% of spam, if  
> DKIM could solve this one it would be great.

This is trivial for botnets to do. Apart from the obvious ways, many  
botnets already run DNS.

>
> so my question to add to your question "Does the presence of a  
> signature provide any objective data about the goodness or badness  
> of the signer?" is:

It says that the software generating the email was written at some  
point after 2007. Which is a data point, but not a terribly useful one.

Cheers,
   Steve