Subject: [ietf-dkim] DKIM adoption

From: Franck Martin <[email-masked]>
Date: Sat, 1 Aug 2009 10:22:39 +1200 (FJT)

Looking at DKIM adoption. I have seen statements that some mailers will do DKIM based reputation if available, but I have yet to see a statement as either: 
-an email not signed with DKIM will have its reputation lowered (less likely to pass filters) 
-an email signed with DKIM will have its reputation increased (more likely to pass filters) 

I think if there were some postmasters making such statement it would boost the adoption of DKIM. 

I think stating that some postmasters are moving to domain based reputation is just encouraging the status quo of not DKIM signing to stay in IP based reputation. 
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Steve Atkins <[email-masked]>
Date: Fri, 31 Jul 2009 16:17:29 -0700

On Jul 31, 2009, at 3:22 PM, Franck Martin wrote:

> Looking at DKIM adoption. I have seen statements that some mailers  
> will do DKIM based reputation if available, but I have yet to see a  
> statement as either:

I doubt that either is true, though. A DKIM signature allows you to  
acquire increased or decreased reputation based on the history of that  
signing token.

If I've never seen that token before, or I've seen bad behaviour  
associated with that token, it's not going to increase the reputation  
of the email (not in any sane mail filtering system anyway).

Conversely, if I see unsigned mail coming in from an IP address that's  
sent great mail forever, I'm not going to decimate the mail stream  
just to encourage DKIM adoption.

Might there be a grey area where the existence of a DKIM signature  
just pushes it over the edge? Maybe, but it's going to be a pretty  
small grey area.

> I think stating that some postmasters are moving to domain based  
> reputation is just encouraging the status quo of not DKIM signing to  
> stay in IP based reputation.

And there's nothing wrong with that. People should be moving to DKIM  
because of the actual advantages, not because of that sort of  
artificial pressure on them, I think.

Requiring DKIM before setting up an FBL or a red carpet seems a more  
reasonable sort of pressure for an ISP to apply, should they feel so  
inclined.

Cheers,
   Steve

---

From: Franck Martin <[email-masked]>
Date: Sat, 1 Aug 2009 12:51:01 +1200 (FJT)

Yes the reputation of the domain override things, but what happens when it is the first time a domain is seen? Does DKIM help or not? 

Also, I'm thinking in terms of points like for spammassin. Seeing some patterns in the email increase or lower the points. I don't think a whole reputation judgement would be done on DKIM alone, unless the email is proven forged by DKIM but we are not there yet as ADSP is not widely spread nor adopted. 

----- Original Message ----- 
From: "Steve Atkins" <[email-masked]> 
To: "DKIM WG" <[email-masked]> 
Sent: Saturday, 1 August, 2009 11:17:29 AM GMT +12:00 Fiji 
Subject: Re: [ietf-dkim] DKIM adoption 

Cheers, 
Steve

---

From: Steve Atkins <[email-masked]>
Date: Fri, 31 Jul 2009 18:18:58 -0700

On Jul 31, 2009, at 5:51 PM, Franck Martin wrote:

> Yes the reputation of the domain override things, but what happens  
> when it is the first time a domain is seen? Does DKIM help or not?

If there's no DKIM, then there's not really any obvious domain to be  
talking
about when it comes to reputation, so I don't think that's a question  
that
makes sense (at least not without more details as to what you mean
by seeing a domain).

>
> Also, I'm thinking in terms of points like for spammassin. Seeing  
> some patterns in the email increase or lower the points. I don't  
> think a whole reputation judgement would be done on DKIM alone,

Not all the time, no. But if the domain token attached to the message
via DKIM is on a whitelist, or if there's a significant positive  
history,
then it's quite likely that the DKIM based reputation would override
other measures (and would likely be used to short circuit analysis
to avoid expensive content-based work).

> unless the email is proven forged by DKIM but we are not there yet  
> as ADSP is not widely spread nor adopted.
>

Yup. That's probably out of scope for this discussion, anyway.

Cheers,
   Steve

---

From: Scott Kitterman <[email-masked]>
Date: Fri, 31 Jul 2009 22:12:41 -0400

On Sat, 1 Aug 2009 12:51:01 +1200 (FJT) Franck Martin <[email-masked]> 
wrote:
>Yes the reputation of the domain override things, but what happens when it 
is the first time a domain is seen? Does DKIM help or not? 
It can't.

>Also, I'm thinking in terms of points like for spammassin. Seeing some 
patterns in the email increase or lower the points.
Some of the people involved early in the SPF project had the same idea.  It 
did encourage spaammer to adopt it, but it also had a big backlash after 
people noticed spammers could publish SPF record just fine and the positive 
points were just helping spammers.

I don't suggest a repeat.

Scott K

---

From: Dave CROCKER <[email-masked]>
Date: Sat, 01 Aug 2009 06:04:28 +0200

Franck Martin wrote:
> Yes the reputation of the domain override things, but what happens when 
> it is the first time a domain is seen? Does DKIM help or not?

Does the presence of a signature provide any objective data about the goodness 
or badness of the signer?

If the claim is that it does, there needs to be an explanation of the basis, 
because I don't see it.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html