Subject: Re: [ietf-dkim] [Fwd: New Version Notification - draft-ietf-dkim-rfc4871-errata-07.txt]

From: Jim Fenton <[email-masked]>
Date: Thu, 02 Jul 2009 12:27:37 -0700

Lest anyone interpret silence as agreement, I'm OK (not enthusiastic,
but OK) with most of the added text in this revision, but I have a
problem with the last two paragraphs.

> This does not state what the implicit value of "i=" is, relative to    
> "d=". In this context, that fact is irrelevant.

I'm not sure what point is being made, but RFC 4871 does explicitly
define the default value of "i=" (an empty Local-part followed by an "@"
followed by the domain from the "d=" tag).  It isn't clear what "this"
context is, and the paragraph is likely to introduce confusion as to
whether the default value in RFC 4871 no longer exists.

> Another example is the difference between the socket interface to TCP    
> versus the TCP protocol itself. There is the activity within the    
> protocol stack, and then there is the activity within in the software    
> libraries that are actually used.

This analogy isn't clearly stated, and in any case is discussion that is
irrelevant in the context of a protocol specification.

Both of these paragraphs should be removed.

-Jim

Dave CROCKER wrote:
> -------- Original Message --------
> Subject: New Version Notification - draft-ietf-dkim-rfc4871-errata-07.txt
> Date: Fri, 26 Jun 2009 19:30:01 -0700 (PDT)
> From: [email-masked]
> To: [email-masked], [email-masked], 
>        [email-masked]
>
> New version (-07) has been submitted for draft-ietf-dkim-rfc4871-errata-07.txt.
> http://www.ietf.org/internet-drafts/draft-ietf-dkim-rfc4871-errata-07.txt
>
>
> Diff from previous version:
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-dkim-rfc4871-errata-07
>
> IETF Secretariat.
>
>
>   
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 02 Jul 2009 20:21:50 -0700

> whether the default value in RFC 4871 no longer exists.

The text needs to be taken in the context in which it occurs.  So, for example, 
the "This" parallels the "This Update" in the preceding paragraph.  Equally, the 
reference to implicit value is within the Update, not to RFC 4871.

> Both of these paragraphs should be removed.

The concerned area director(s) found the added text helpful.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net