Subject: [ietf-dkim] DKIM V 2.4.O - SSP and timeout

From: kim d <[email-masked]>
Date: Mon, 17 Aug 2009 15:38:33 +0200

Hi 

(Hope i am at the right place - it is the first time i use this list)

I have Postfix/DKIM version V 2.4.0 installed.

My server configuration is: 
On-DNSError             tempfail
DNSTimeout              10

SSP policy: 
_ssp._domainkey.spam3.gm.transpac.fr. 900 IN TXT "dkim=all \;
handling=deny \; t=s")

Test = sending a non internal unsigned message with a faked from header
=> result expected = message rejected as per SSP policy in place

When my DNS server is responding within DNSTimeout then I have 2 log
lines including the SSP  reject log line
unknown-jobid) external host be-1-data attempted to send as
spam3.gm.transpac.fr
rejected per sender domain policy
=> result is ok 

When my DNS server is NOT responding within DNSTimeout I have not the
SSP log line (ok) but the message passes tru the system.
(unknown-jobid) external host be-1-data attempted to send as
spam3.gm.transpac.fr
=> I expected to have a tempfail 

Is it a bug or something I do not understand ?
Nb: I would prefer not to migrate to a new version.

Thank you for your help.
Rgds
Alain

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 17 Aug 2009 08:48:20 -0700

> -----Original Message-----
> From: [email-masked] [mailto:ietf-dkim-
> [email-masked]] On Behalf Of kim d
> Sent: Monday, August 17, 2009 6:39 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [ietf-dkim] DKIM V 2.4.O - SSP and timeout
> 
> Hi
> 

Nope, wrong place. This list is for discussing DKIM-related work of the Internet Engineering Task Force, which is about setting standards and not producing software.

You should repost your question to the mailing list that supports the DKIM software you're trying to use.