Subject: [ietf-dkim] Mailing list reality check

From: John Levine <[email-masked]>
Date: 4 Aug 2010 16:51:10 -0000

I'd like to back up a minute and try to understand better what (if any)
problem we're trying to solve here.  So here is a straw poll.

Assuming you do any sorting of inbound mail at all, how do you treat
mail from lists to which you have subscribed?

A) Use the From: address (or something that identifies the contributor)
as the primary sort criterion

B) Use the List-ID: (or something that identifies the list) as the
primiary sort criterion

C) Something else

It is my impression that everyone does B, but maybe I'm wrong.

R's,
John
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 4 Aug 2010 10:02:25 -0700

> -----Original Message-----
> From: [email-masked] [mailto:ietf-dkim-
> [email-masked]] On Behalf Of John Levine
> Sent: Wednesday, August 04, 2010 9:51 AM
> To: [email-masked]
> Subject: [ietf-dkim] Mailing list reality check
> 

I use Outlook at work whose filtering interface keys off the contents of To:/Cc:.  So I'm in the (C) camp for your poll.

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 04 Aug 2010 10:09:42 -0700

> B) Use the List-ID: (or something that identifies the list) as the

My thunderbird filters vary.  Mostly they use to:/cc:, like Murray.  Sometimes 
I've set them to use a List-ID.

I typically reserve filters on the From: field for other types of mail that do 
not circumnavigate a mailing list.

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Martijn Grooten <[email-masked]>
Date: Wed, 4 Aug 2010 18:23:31 +0100

> It is my impression that everyone does B, but maybe I'm wrong.

I mostly use B (I think I've used all of MAIL FROM, To:/Cc:, Subject: and List-ID: to identify a mailing list), but in GMail I also have filters that add a certain tag for certain From: addresses. I've found that useful for lists I don't want to check daily, unless a friend sends a post.

Martijn.

Virus Bulletin Ltd, The Pentagon, Abingdon, OX14 3YP, England.
Company Reg No: 2388295. VAT Reg No: GB 532 5598 33.

---

From: Steve Atkins <[email-masked]>
Date: Wed, 4 Aug 2010 11:36:04 -0700

> It is my impression that everyone does B, but maybe I'm wrong.

C).

List-ID is a great thing to sort on, but I also sort (and, more to the
point, filter) based on From address both before and after looking
at the List-ID.

So the sorting criteria is From address, followed by List-ID,
followed by From address.

I can sort with perfectly acceptable accuracy on all these things
without any sort of authentication needed. If the MLM were to DKIM
sign the List-ID: and From: fields that would be nice, but it's not
essential.

Cheers,
  Steve

---

From: <[email-masked]>
Date: Wed, 4 Aug 2010 12:54:33 -0400

B

---

From: Jeff Macdonald <[email-masked]>
Date: Thu, 5 Aug 2010 09:53:46 -0400

> B) Use the List-ID: (or something that identifies the list) as the

Via Gmail, B when provided.
Via Outlook, C, Subject line.

-- 
Jeff Macdonald
Ayer, MA

---

From: "John R. Levine" <[email-masked]>
Date: 6 Aug 2010 19:55:41 -0400

>> primary sort criterion
> Actually, "Any recipient" but it's what you mean by B, even if it's not what you said.

Several other people said they sort on To: but I get the impression that's 
also used as a list identifier.

R's,
John

---

From: Jon Callas <[email-masked]>
Date: Fri, 6 Aug 2010 16:15:23 -0700

Jon

---

From: Ian Eiloart <[email-masked]>
Date: Mon, 09 Aug 2010 12:18:37 +0100

> mail from lists to which you have subscribed?

B. I use the List-ID: to sort list traffic into separate mail folders, so 
that I can prioritise other stuff. Where there's no List-ID, I try to use 
some proxy for it, like a Subject line tag.

-- 
Ian Eiloart
IT Services, University of Sussex
01273-873148 x3148
For new support requests, see http://www.sussex.ac.uk/its/help/

---

From: "J.D. Falk" <[email-masked]>
Date: Tue, 10 Aug 2010 15:32:53 -0700

> It is my impression that everyone does B, but maybe I'm wrong.

B when I can, or occasionally whatever's in procmail's venerable ^TO macro.

However, when talking to average user types, they'll most often:

1. wish they knew how to filter
2. /visually/ filter based on subject tags
3. sort alphabetically by subject
4. create MUA filters based on subject
5. create MUA filters based on To/Cc

Perhaps if the List-Id header were visible, they'd consider using that instead.